Subject: [LilyPond] Accord inverser la position des notes proches (droite gauche)

From: MartialR via LilyPond <[email-masked]>
Date: Fri, 30 Jan 2026 21:44:04 +0000

Bonsoir
je cale ... dans un accord  inverser la position des notes proches.
Comment mettre le do à gauche du si  !
Cordialement ,

```
\version "2.24"

{ 
<c'' b'>4 
}
```
![image|40x63](upload://3axGHf87fl55zDRQtrYrQFfLVxi.png)

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/accord-inverser-la-position-des-notes-proches-droite-gauche/6090/1).

Pour créer un nouveau sujet, écrivez à [[email-masked]](mailto:[email-masked]) ou visitez la [page d'accueil de lilypond.community](https://lilypond.community).

---

From: xavier via LilyPond <[email-masked]>
Date: Fri, 30 Jan 2026 22:11:54 +0000

Il y a peut-être moyen de faire quelque chose avec [ce snippet](https://wiki.lilypond.community/wiki/Re-positioning_note_heads_on_the_opposite_side_of_the_stem).

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/accord-inverser-la-position-des-notes-proches-droite-gauche/6090/2).

---

From: MartialR via LilyPond <[email-masked]>
Date: Fri, 30 Jan 2026 22:12:18 +0000

Hé ben voilà 

```
{
  <c'' b'>
  s4
  <
  \tweak X-extent #'(0.85 . 0 )
  \tweak Accidental.X-offset -1.2 cis''
  \tweak X-extent #'(0 . 0) b'>4
  s4
}
```
![image|145x66](upload://nrwfQvmXeashAfOFTjIQP0MzWMs.png)

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/accord-inverser-la-position-des-notes-proches-droite-gauche/6090/3).

---

From: MartialR via LilyPond <[email-masked]>
Date: Fri, 30 Jan 2026 22:23:00 +0000

Merci, pour   [ce snippet](https://wiki.lilypond.community/wiki/Re-positioning_note_heads_on_the_opposite_side_of_the_stem).
mais c'est un gros morceau pour juste une fois !

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/accord-inverser-la-position-des-notes-proches-droite-gauche/6090/4).

---

From: MartialR via LilyPond <[email-masked]>
Date: Fri, 30 Jan 2026 22:24:37 +0000

ça fonctionne bein aussi ! 
```
#(define ((shift offsets) grob)
"Defines how NoteHeads should be moved according to the given list of offsets."
 (let* (
 ;; NoteHeads
        ;; Get the NoteHeads of the NoteColumn
        (note-heads (ly:grob-array->list (ly:grob-object grob 'note-heads)))
        ;; Get their durations
        (nh-duration-log
          (map
            (lambda (note-head-grobs)
              (ly:grob-property note-head-grobs 'duration-log))
            note-heads))
        ;; Get their length in X-axis-direction
        (stencils-x-lengths
          (map
            (lambda (x)
                (let* ((grob-x-ext (ly:grob-extent x grob X)))
                  (if (interval-sane? grob-x-ext)
                      (interval-length grob-x-ext)
                      0)))
             note-heads))
 ;; Stem
        (stem (ly:grob-object grob 'stem))
        (stem-thick (ly:grob-property stem 'thickness 1.3))
        (stem-x-width (if (ly:grob? stem)
                          (let ((stem-x-ext (ly:grob-extent stem grob X)))
                            (if (interval-sane? stem-x-ext)
                                (interval-length stem-x-ext)
                                (/ stem-thick 10)))
                          ;; Fall back
                          ;; TODO is it ever used?
                          (/ stem-thick 10)))
        (stem-dir (ly:grob-property stem 'direction))
        ;; Calculate a value to compensate the stem-extension
        (stem-x-corr
          (map
            (lambda (q)
               ;; TODO better coding if (<= log 0)
               (cond ((and (= q 0) (= stem-dir 1))
                      (* -1 (+ 2  (* -4 stem-x-width))))
                     ((and (< q 0) (= stem-dir 1))
                      (* -1 (+ 2  (* -1 stem-x-width))))
                     ((< q 0)
                      (* 2 stem-x-width))
                     (else (/ stem-x-width 2))))
             nh-duration-log)))
 ;; Final Calculation for moving the NoteHeads
   (for-each
     (lambda (nh nh-x-length off x-corr)
         (if (= off 0)
           #f
           (ly:grob-translate-axis! nh (* off (- nh-x-length x-corr)) X)))
     note-heads stencils-x-lengths offsets stem-x-corr)))

displaceHeads =
#(define-music-function (offsets) (list?)
"
 Moves the NoteHeads, using (shift offsets)
"
 #{
   \once \override NoteColumn.before-line-breaking = #(shift offsets)
 #})
 
adjustStem =
#(define-music-function (val)(pair?)
"
 Adjust 'stem-attachment via 
 adding multiples of the stem-width to the x-default (car val)
 and multiplying the y-default with (cdr val).
"
#{
   \once \override NoteHead.before-line-breaking = 
   #(lambda (grob)
     (let* ((stem-at (ly:grob-property grob 'stem-attachment))
            (stem (ly:grob-object grob 'stem))
            (stem-x-width (interval-length (ly:grob-property stem 'X-extent))))
     (ly:grob-set-property! 
       grob
       'stem-attachment 
       (cons (+ (car stem-at) (* stem-x-width (car val))) (* (cdr val) (cdr stem-at))) 
       )))
#})

{ 

<c'' b'>
\displaceHeads #'(-0.8 1 1) 
<c'' b'>
}
```
![image|127x63](upload://n7tgIh3lgeBa0vEjt7g0hH6PUxu.png)

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/accord-inverser-la-position-des-notes-proches-droite-gauche/6090/5).

---

From: MartialR via LilyPond <[email-masked]>
Date: Fri, 30 Jan 2026 23:06:50 +0000

mais ça ne marche pas bien avec mon accord à 5 notes 
obligé de ruser  

``` 
\version "2.24"
\language "english"

\relative c'{ 
    <<
    { 
      \set fingeringOrientations = #'(right)
      \stemDown
      \tweak Stem.stencil ##f
      
      <\tweak X-extent #'(1.2 . 0 )
      \tweak Accidental.X-offset -2 cs'
      \tweak X-extent #'(0 . 0) b \tweak X-offset 3 -3 >4
    }
    \\
    { \set fingeringOrientations = #'(right)
      \oneVoice
      <a, e' a'-4>4^"½II"  }
}
```
trop content mis en place !
!![image|169x242](upload://3Fi4hZAyRfMI6z5xTziNZa45t4H.png)

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/accord-inverser-la-position-des-notes-proches-droite-gauche/6090/6).

---

From: FabFlam via LilyPond <[email-masked]>
Date: Sat, 31 Jan 2026 10:32:11 +0000

Bonjour @MartialR,

Je le fais souvent avec:
```
\override NoteColumn.force-hshift = 1. (ou le nombre qu'on veut)
```
Ca décale la note vers la droite on met un signe moins si on veut décaler dans l'autre sens.
Est-ce que ça peut marcher dans ton cas ? Ca m'a l'air trop simple :smiley:

Fab

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/accord-inverser-la-position-des-notes-proches-droite-gauche/6090/7).

---

From: Bernard Meylan via LilyPond <[email-masked]>
Date: Sat, 31 Jan 2026 13:21:47 +0000

Question totalement inutile (!): pourquoi veux-tu inverser ces notes d'accord?

Bernard

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/accord-inverser-la-position-des-notes-proches-droite-gauche/6090/8).

---

From: MartialR via LilyPond <[email-masked]>
Date: Sat, 31 Jan 2026 13:41:34 +0000

parce que... 
le doigté à droite pour le Si  ce n'est pas clair. 
mais je suis revenu comme par défaut. 
![image|152x208](upload://VqJriyGyM4VnDXZxWhGmBWvcrO.png)

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/accord-inverser-la-position-des-notes-proches-droite-gauche/6090/9).

---

From: xavier via LilyPond <[email-masked]>
Date: Sat, 31 Jan 2026 14:00:20 +0000

[quote="MartialR, post:9, topic:6090"]
le doigté à droite pour le Si ce n'est pas clair.
[/quote]

Et pourquoi ne pas le mettre à gauche ? À cause de l'arpège ?

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/accord-inverser-la-position-des-notes-proches-droite-gauche/6090/10).

---

From: Bernard Meylan via LilyPond <[email-masked]>
Date: Sat, 31 Jan 2026 16:09:41 +0000

C'est vrai que le 3 fait référence au si, mais dans ce cas le 4 devrait être vis-à-vis du do# et pour le la aigu, ce serait le 5… Si je reprends les règles que j'ai apprises en gravure, en cas de collision, la plus grave doit (devrait…) se situer à gauche de la hampe, et l'aigüe à droite… Scott Ross dit la même chose…

Cordialement.

Bernard

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/accord-inverser-la-position-des-notes-proches-droite-gauche/6090/11).

---

From: MartialR via LilyPond <[email-masked]>
Date: Sat, 31 Jan 2026 16:38:54 +0000

partition duo guitares les doigtés sont bon ! 
Je laisse  ainsi doigté à droite si à gauche.

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/accord-inverser-la-position-des-notes-proches-droite-gauche/6090/12).