Subject: [LilyPond] Erreur inexpliquée

From: Vincent Gay via LilyPond <[email-masked]>
Date: Tue, 22 Apr 2025 19:34:10 +0000

Bonsoir la communauté,

Cela fait des mois que je travaille sur les mêmes fichiers et tout ce passe bien. Mais aujourd'hui nouveau projet et ...

\version "2.24.4" \relative c'' { \repeat unfold 4 { a4 } }

Avertissement : « (gs -q -dNODISPLAY -dNOSAFER -dNOPAUSE -dBATCH -dAutoRotatePages=/None -dPrinted=false /tmp/lilypond-tmp-350007) » a échoué (256)

init.ly: Erreur : Guile a signalé une erreur pour l'expression débutant ici

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/erreur-inexpliquee/5896/1).

Pour créer un nouveau sujet, écrivez à [[email-masked]](mailto:[email-masked]) ou visitez la [page d'accueil de lilypond.community](https://lilypond.community).

---

From: Vincent Gay via LilyPond <[email-masked]>
Date: Tue, 22 Apr 2025 19:51:01 +0000

Pfff... problème de html par mail
je recommence ici

\version "2.24.4"

\relative c'' {
  \repeat unfold 4 { a4 }
}

#

 (let ((book-handler (if (defined? 'default-toplevel-book-handler)

Throw to key `ly-file-failed' with args `()'.

Arrêté avec le code de retour 1.

Hum, j'essaie à nouveau les vieux fichiers, ça passe

je vois la référence à book-handler , j'essaie donc 

tenorSax = \relative c'' {
  \key c \major
  \time 4/4   \repeat unfold 4 { a4 }
}

\book {
  \bookpart { 
    \score {
      <<
        \new Staff  \tenorSax
    }
  }
}

Avertissement : « (gs -q -dNODISPLAY -dNOSAFER -dNOPAUSE -dBATCH -dAutoRotatePages=/None -dPrinted=false /tmp/lilypond-tmp-1714804) » a échoué (256)

erreur fatale : erreur sur les fichiers "/tmp/frescobaldi-7i5c98if/tmpmpz_v9p2/Essai.ly"

Arrêté avec le code de retour 1.

J'essaie de comprendre la différence avec les anciens fichiers qui comprennent tous une fonction que m'avait tricoté Jean pour les sources embarquée (et qui à priori n'ont rien à voir avec la choucroute !)

j'essaie à nouveau et là ça passe. Y'a quand même un truc non ?

\version "2.24.0"
#(set-global-staff-size 20)

tenorSax = \relative c'' {
  \key c \major
  \time 4/4   \repeat unfold 4 { a4 }
}

% la fonction de Jean AVANT le book
#(define embed-source-code
   (if (ly:get-option 'embed-source-code)
       (begin
        (ly:set-option 'embed-source-code #f)
        #t)
       #f))

\book {
  \bookpart { 
    \score {
      <<
        \new Staff  \tenorSax
    }
  }
}

Naturellement si je désactive l'embarquement du code source dans les préférences de Frescobaldi ça marche aussi 

Mon environnement : Archlinux à jour, lilypond -2.24.4-5, frescobaldi 4.0.2 guile 3.0.10-1

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/erreur-inexpliquee/5896/2).

---

From: Jean Abou Samra via LilyPond <[email-masked]>
Date: Tue, 22 Apr 2025 22:40:32 +0000

Que dit LilyPond avec `--verbose` ?

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/erreur-inexpliquee/5896/3).

---

From: Vincent Gay via LilyPond <[email-masked]>
Date: Wed, 23 Apr 2025 05:47:55 +0000

Salut Jean,

Démarrage lilypond 2.24.4 [Seven_Days_Sting-1.ly]...
Niveau de journalisation fixé à 287

Relocalisation
  Le binaire LilyPond a un chemin absolu :
    /usr/bin/lilypond
  Setting de INSTALLER_PREFIX à /usr
  Utilisation de la valeur run-time pour datadir,
    déterminée à « /usr/share/lilypond/2.24.4 »
  Utilisation de la valeur run-time pour libdir,
    déterminée à « /usr/lib/lilypond/2.24.4 »
  Utilisation de la valeur run-time pour localedir,
    déterminée à « /usr/share/locale »
  Utilisation de la valeur compile-time pour relocdir,
    déterminée à «  »
  Ajout de « /usr/bin »  à PATH
  Setting de PATH à /usr/bin:/usr/local/sbin:/usr/local/bin:/usr/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl
Setting de GUILE_AUTO_COMPILE à 0
Setting de GUILE_WARN_DEPRECATED à detailed
Setting de XDG_CACHE_HOME à /usr/share/lilypond/2.24.4
Setting de GC_INITIAL_HEAP_SIZE à 40M
Setting de GC_NPROCS à 1
Setting de GC_FREE_SPACE_DIVISOR à 1

Préfixe effectif : « /usr/share/lilypond/2.24.4 »
PATH="/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl"

[]
[/usr/share/lilypond/2.24.4/scm/lily/lily-library.scm]
[/usr/share/lilypond/2.24.4/scm/lily/output-lib.scm]
[/usr/share/lilypond/2.24.4/scm/lily/markup-macros.scm]
[/usr/share/lilypond/2.24.4/scm/lily/parser-ly-from-scheme.scm]
[/usr/share/lilypond/2.24.4/scm/lily/file-cache.scm]
[/usr/share/lilypond/2.24.4/scm/lily/define-event-classes.scm]
[/usr/share/lilypond/2.24.4/scm/lily/define-music-callbacks.scm]
[/usr/share/lilypond/2.24.4/scm/lily/define-music-types.scm]
[/usr/share/lilypond/2.24.4/scm/lily/define-note-names.scm]
[/usr/share/lilypond/2.24.4/scm/lily/c++.scm]
[/usr/share/lilypond/2.24.4/scm/lily/chord-entry.scm]
[/usr/share/lilypond/2.24.4/scm/lily/skyline.scm]
[/usr/share/lilypond/2.24.4/scm/lily/markup.scm]
[/usr/share/lilypond/2.24.4/scm/lily/define-markup-commands.scm]
[/usr/share/lilypond/2.24.4/scm/lily/stencil.scm]
[/usr/share/lilypond/2.24.4/scm/lily/modal-transforms.scm]
[/usr/share/lilypond/2.24.4/scm/lily/chord-ignatzek-names.scm]
[/usr/share/lilypond/2.24.4/scm/lily/music-functions.scm
[/usr/share/lilypond/2.24.4/scm/lily/define-music-display-methods.scm]
]
[/usr/share/lilypond/2.24.4/scm/lily/part-combiner.scm]
[/usr/share/lilypond/2.24.4/scm/lily/autochange.scm]
[/usr/share/lilypond/2.24.4/scm/lily/define-music-properties.scm]
[/usr/share/lilypond/2.24.4/scm/lily/time-signature.scm]
[/usr/share/lilypond/2.24.4/scm/lily/time-signature-settings.scm]
[/usr/share/lilypond/2.24.4/scm/lily/auto-beam.scm]
[/usr/share/lilypond/2.24.4/scm/lily/chord-name.scm]
[/usr/share/lilypond/2.24.4/scm/lily/define-context-properties.scm]
[/usr/share/lilypond/2.24.4/scm/lily/translation-functions.scm]
[/usr/share/lilypond/2.24.4/scm/lily/breath.scm]
[/usr/share/lilypond/2.24.4/scm/lily/script.scm]
[/usr/share/lilypond/2.24.4/scm/lily/midi.scm]
[/usr/share/lilypond/2.24.4/scm/lily/layout-beam.scm]
[/usr/share/lilypond/2.24.4/scm/lily/parser-clef.scm]
[/usr/share/lilypond/2.24.4/scm/lily/layout-slur.scm]
[/usr/share/lilypond/2.24.4/scm/lily/font.scm]
[/usr/share/lilypond/2.24.4/scm/lily/font-encodings.scm]
[/usr/share/lilypond/2.24.4/scm/lily/bar-line.scm]
[/usr/share/lilypond/2.24.4/scm/lily/flag-styles.scm]
[/usr/share/lilypond/2.24.4/scm/lily/fret-diagrams.scm]
[/usr/share/lilypond/2.24.4/scm/lily/tablature.scm]
[/usr/share/lilypond/2.24.4/scm/lily/harp-pedals.scm]
[/usr/share/lilypond/2.24.4/scm/lily/define-woodwind-diagrams.scm]
[/usr/share/lilypond/2.24.4/scm/lily/display-woodwind-diagrams.scm]
[/usr/share/lilypond/2.24.4/scm/lily/predefined-fretboards.scm]
[/usr/share/lilypond/2.24.4/scm/lily/define-grob-properties.scm]
[/usr/share/lilypond/2.24.4/scm/lily/define-grobs.scm]
[/usr/share/lilypond/2.24.4/scm/lily/define-grob-interfaces.scm]
[/usr/share/lilypond/2.24.4/scm/lily/define-stencil-commands.scm]
[/usr/share/lilypond/2.24.4/scm/lily/scheme-engravers.scm]
[/usr/share/lilypond/2.24.4/scm/lily/scheme-performers.scm]
[/usr/share/lilypond/2.24.4/scm/lily/titling.scm]
[/usr/share/lilypond/2.24.4/scm/lily/paper.scm]
[/usr/share/lilypond/2.24.4/scm/lily/backend-library.scm]
[/usr/share/lilypond/2.24.4/scm/lily/color.scm]
(primitive-load-path lily) : 0.08 secondes
Initialisation de FontConfig...
Ajout du fichier de configuration de fontconfig : « /usr/share/lilypond/2.24.4/fonts/00-lilypond-fonts.conf »
Ajout du fichier de configuration de fontconfig : « /etc/fonts/fonts.conf »
Ajout du fichier de configuration de fontconfig : « /usr/share/lilypond/2.24.4/fonts/99-lilypond-fonts.conf »
Ajout d'un répertoire de fontes : « /usr/share/lilypond/2.24.4/fonts/otf »
Construction de la base de donnée des fontes...

[/usr/share/lilypond/2.24.4/ly/declarations-init.ly[/usr/share/lilypond/2.24.4/ly/music-functions-init.ly][/usr/share/lilypond/2.24.4/ly/toc-init.ly]
Utilisation de « nederlands » pour le nom des notes...[/usr/share/lilypond/2.24.4/ly/drumpitch-init.ly][/usr/share/lilypond/2.24.4/ly/chord-modifiers-init.ly][/usr/share/lilypond/2.24.4/ly/script-init.ly][/usr/share/lilypond/2.24.4/ly/chord-repetition-init.ly][/usr/share/lilypond/2.24.4/ly/scale-definitions-init.ly][/usr/share/lilypond/2.24.4/ly/dynamic-scripts-init.ly][/usr/share/lilypond/2.24.4/ly/spanners-init.ly][/usr/share/lilypond/2.24.4/ly/predefined-fretboards-init.ly][/usr/share/lilypond/2.24.4/ly/string-tunings-init.ly][/usr/share/lilypond/2.24.4/ly/property-init.ly][/usr/share/lilypond/2.24.4/ly/grace-init.ly][/usr/share/lilypond/2.24.4/ly/midi-init.ly[/usr/share/lilypond/2.24.4/ly/performer-init.ly]][/usr/share/lilypond/2.24.4/ly/paper-defaults-init.ly[/usr/share/lilypond/2.24.4/ly/titling-init.ly][/usr/share/lilypond/2.24.4/ly/text-replacements.ly]][/usr/share/lilypond/2.24.4/ly/context-mods-init.ly][/usr/share/lilypond/2.24.4/ly/engraver-init.ly]]
Traitement de « /tmp/frescobaldi-7i5c98if/tmpjg0k8qsg/Seven_Days_Sting-1.ly »
Analyse...[/usr/share/lilypond/2.24.4/ly/init.ly
Utilisation de « nederlands » pour le nom des notes...[/tmp/frescobaldi-7i5c98if/tmpjg0k8qsg/Seven_Days_Sting-1.ly]
Interprétation en cours de la musique...
[/usr/share/lilypond/2.24.4/fonts/otf/emmentaler-20.otf
nom CFF de la fonte Emmentaler-20 identique.]
temps écoulé : 0.03 secondes
55 éléments dénombrés (6 extensions)
Pré-traitement des éléments graphiques...
103 objets graphiques (grob) dénombrés.
[/usr/share/lilypond/2.24.4/fonts/otf/emmentaler-11.otf
nom CFF de la fonte Emmentaler-11 identique.]
[/usr/share/lilypond/2.24.4/fonts/otf/emmentaler-13.otf
nom CFF de la fonte Emmentaler-13 identique.]
[/usr/share/lilypond/2.24.4/fonts/otf/emmentaler-14.otf
nom CFF de la fonte Emmentaler-14 identique.]
[/usr/share/lilypond/2.24.4/fonts/otf/emmentaler-16.otf
nom CFF de la fonte Emmentaler-16 identique.]
[/usr/share/lilypond/2.24.4/fonts/otf/emmentaler-18.otf
nom CFF de la fonte Emmentaler-18 identique.]
[/usr/share/lilypond/2.24.4/fonts/otf/emmentaler-23.otf
nom CFF de la fonte Emmentaler-23 identique.]
Détermination du nombre optimal de pages...
[lilypond_serif_3.866]
nom CFF de la fonte C059-Roman identique.
Répartition de la musique sur une page...
Dessin des systèmes...
109 éléments dénombrés.
Initialisation de la liste des fontes CFF à empaqueter.
Embarquement de la fonte « C059-Roman ».
[/usr/share/fonts/gsfonts/C059-Roman.otf]
[/usr/share/lilypond/2.24.4/ps/music-drawing-routines.ps]
[/usr/share/lilypond/2.24.4/ps/lilyponddefs.ps]
[/tmp/frescobaldi-7i5c98if/tmpjg0k8qsg/Seven_Days_Sting-1.ly]
temps d'activité de Paper_outputter : 0.02 secondes
Conversion à « Seven_Days_Sting-1.pdf »...
Préparation de la commande GhostScript pour « /tmp/lilypond-tmp-7356602 » :
  << /OutputFile (./lilypond-tmp-8347925.pdf) /CompatibilityLevel 1.4 /PageSize [595.28 841.89] /OutputDevice /pdfwrite >> setpagedevice /.setdefaultscreen where { pop .setdefaultscreen } { (Warning: .setdefaultscreen not available) print } ifelse newpath fill (/tmp/lilypond-tmp-8347925) (r) file .setsafe run
Appel de « gs -dNODISPLAY -dNOSAFER -dNOPAUSE -dBATCH -dAutoRotatePages=/None -dPrinted=false /tmp/lilypond-tmp-7356602 »...

GPL Ghostscript 10.05.0 (2025-03-12)
Copyright (C) 2025 Artifex Software, Inc.  All rights reserved.
This software is supplied under the GNU AGPLv3 and comes with NO WARRANTY:
see the file COPYING for details.
Error: /rangecheck in --pdfmark--
Operand stack:
   --nostringval--   Name   (LilyPond source file 0)   FS   --dict:3/3(L)--   EMBED
Execution stack:
   %interp_exit   .runexec2   --nostringval--   pdfmark   --nostringval--   2   %stopped_push   --nostringval--   pdfmark   pdfmark   false   1   %stopped_push   1949   1   3   %oparray_pop   1948   1   3   %oparray_pop   1933   1   3   %oparray_pop   1803   1   3   %oparray_pop   --nostringval--   %errorexec_pop   .runexec2   --nostringval--   pdfmark   --nostringval--   2   %stopped_push   --nostringval--   1949   1   3   %oparray_pop   1948   1   3   %oparray_pop   1933   1   3   %oparray_pop   1803   1   3   %oparray_pop   --nostringval--   %errorexec_pop   .runexec2   --nostringval--   pdfmark   --nostringval--   2   %stopped_push   --nostringval--   1950   6   3   %oparray_pop   pdfmark
Dictionary stack:
   --dict:749/1123(ro)(G)--   --dict:0/20(G)--   --dict:116/200(L)--
Current allocation mode is local
Current file position is 157504
GPL Ghostscript 10.05.0: Unrecoverable error, exit code 1
Avertissement : « (gs -dNODISPLAY -dNOSAFER -dNOPAUSE -dBATCH -dAutoRotatePages=/None -dPrinted=false /tmp/lilypond-tmp-7356602) » a échoué (256)

init.ly: Erreur : Guile a signalé une erreur pour l'expression débutant ici
#
 (let ((book-handler (if (defined? 'default-toplevel-book-handler)
/usr/share/lilypond/2.24.4/scm/lily/lily.scm
In ice-9/boot-9.scm:
  1755:12 16 (with-exception-handler _ _ #:unwind? _ #:unwind-for-type _)
In unknown file:
          15 (apply-smob/0 #<thunk 753774315300>)
In /usr/src/debug/lilypond/lilypond-2.24.4/out/share/lilypond/current/scm/lily/lily.scm:
   873:16 14 (lilypond-main _)
    902:4 13 (lilypond-all ("/tmp/frescobaldi-7i5c98if/tmpjg0k8qsg/Seven_Days_Sting-1.ly"))
In srfi/srfi-1.scm:
lily.scm:5 (x)> ("/tmp/frescobaldi-7i5c98if/tmpjg0k8qsg/Seven_Days_Sting-1.ly"))
In /usr/src/debug/lilypond/lilypond-2.24.4/out/share/lilypond/current/scm/lily/lily.scm:
    912:9 11 (_ "/tmp/frescobaldi-7i5c98if/tmpjg0k8qsg/Seven_Days_Sting-1.ly")
In ice-9/boot-9.scm:
boot-9.scm:7 (exn)> _ #:unwind? _ #:unwind-for-type _)
In unknown file:
           9 (ly:parse-file "/tmp/frescobaldi-7i5c98if/tmpjg0k8qsg/Seven_Days_Sting-1.ly")
In ice-9/boot-9.scm:
  1755:12  8 (with-exception-handler _ _ #:unwind? _ #:unwind-for-type _)
In unknown file:
           7 (apply-smob/0 #<thunk 753774cf2960>)
           6 (ly:book-process #<Book> #< Output_def> #< Output_def> "Seven_Days_Sting-1")
In /usr/src/debug/lilypond/lilypond-2.24.4/out/share/lilypond/current/scm/lily/backend-library.scm:
    335:4  5 (postprocess-output #< Output_def> #<directory (lily framework-ps) 753774e46460> ("pdf") "Seven_Days_Sting-1" "/tmp/lilypond-tmp-8347925" #f)
In srfi/srfi-1.scm:
backend-library.scm:14 (f)> ("pdf"))
In /usr/src/debug/lilypond/lilypond-2.24.4/out/share/lilypond/current/scm/lily/backend-library.scm:
    150:4  3 (postscript->pdf 595.2755905511812 841.8897637795277 "Seven_Days_Sting-1" "/tmp/lilypond-tmp-8347925" #f)
     57:4  2 (ly:gs-cli _ "<< /OutputFile (./lilypond-tmp-8347925.pdf) /CompatibilityLevel 1.4 /PageSize [595.28 841.89] /OutputDevice /pdfwrite >> setpagedevice /.setdefaultscreen where { pop .setdefaultscreen } { (Warning: .setdefaultscreen not available) print } ifelse newpath fill (/tmp/lilypond-tmp-8347925) (r) file .setsafe run")
In ice-9/boot-9.scm:
  1676:22  1 (raise-exception _ #:continuable? _)
In unknown file:
           0 (apply-smob/1 #<exception-handler 753774cf2920> #<&compound-exception components: (#<&error> #<&irritants irritants: ()> #<&exception-with-kind-and-args kind: ly-file-failed args: ()>)>)
Throw to key `ly-file-failed' with args `()'.
Arrêté avec le code de retour 1.

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/erreur-inexpliquee/5896/4).

---

From: xavier via LilyPond <[email-masked]>
Date: Wed, 23 Apr 2025 06:39:23 +0000

Salut,

Tu utilises lilypond fourni par Fedora ?
[Il semblerait qu'il y ait une erreur Ghostscript (probablement la même) avec lilypond (devel) de Fedora 42](https://lists.gnu.org/archive/html/lilypond-user/2025-04/msg00106.html). Je suppose que cela doit être pareil pour le lilypond stable de Fedora.
Solution : utiliser les binaires officiels de lilypond.org

Cordialement,
Xavier

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/erreur-inexpliquee/5896/5).

---

From: Vincent Gay via LilyPond <[email-masked]>
Date: Wed, 23 Apr 2025 07:41:57 +0000

> Tu utilises lilypond fourni par Fedora ?

Nop, Archlinux

-- 
Vincent Gay
Envoyé depuis mon saxo-phone

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/erreur-inexpliquee/5896/6).