Subject: [LilyPond] partition Batterie

From: christianleBars via LilyPond <[email-masked]>
Date: Mon, 03 Mar 2025 07:15:59 +0000

Bonjour a tous.
Comme il n'est pmas possible d'écriçre une batterie avec la police "lilyjazz"
j'aimerai seulement ecrire la clé en" lilyjazz" . Quelqu'un a peut etre une idée ?
Par avance merci.
Bonne journée

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/partition-batterie/5867/1).

Pour créer un nouveau sujet, écrivez à [[email-masked]](mailto:[email-masked]) ou visitez la [page d'accueil de lilypond.community](https://lilypond.community).

---

From: xavier via LilyPond <[email-masked]>
Date: Sun, 09 Mar 2025 19:12:03 +0000

Bonjour,

Grâce à @jeanas c'est possible en utilisant la version de développement.

```
\version "2.25.24"

\paper {
  % property-defaults.fonts.music = "lilyjazz"
}

\layout {
  \context {
    \Staff
    \override Clef.fonts.music = "lilyjazz" 
  }
}

\score {
  <<
    \new Staff {
      c'1
    }
}
```

Cordialement,
Xavier

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/partition-batterie/5867/2).

---

From: xavier via LilyPond <[email-masked]>
Date: Sun, 09 Mar 2025 19:15:05 +0000

Ou pour une batterie (`DrumStaff`) :

```
\version "2.25.24"

\paper {

\layout {
  \context {
    \DrumStaff

\score {
  <<
    \new DrumStaff \drummode {
       hihat4 hh bassdrum bd
    }
}
```

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/partition-batterie/5867/3).

---

From: christianleBars via LilyPond <[email-masked]>
Date: Mon, 10 Mar 2025 07:51:19 +0000

Merci pour votre réponse.
voici le programme:

\version "2.24.4"
\include "lilyjazz.ily" 
\paper 
{
   property-defaults.fonts.music = "lilyjazz"
}
nam = 
 \lyricmode 
  {
  cymc cyms 
  cymr hh hhc 
  hho hhho
  hhp
  cb hc 
  bd sn ss tomh tommh tomml toml tomfh tomfl }
mus = \drummode {
  cymc 
 cyms
  cymr hh
  hhc 
  hho hhho 
  hhp \break
  cb hc 
  bd sn ss tomh tommh tomml toml tomfh tomfl s16
crashcymbal4 
hihat8 
halfopenhihat 
hh hh hh 
openhihat
}
\score
{
  <<
    \new DrumStaff 
    \with
     {
       \remove Bar_engraver
       \remove Time_signature_engraver
       \hide Stem
       \override Stem.Y-extent = ##f
       drumStyleTable = #agostini-drums-style
      \override Clef.fonts.music = "lilyjazz" 
       \override LyricText.font-family = "lilyjazz"
       \override Staff.NoteHead.style = #'diamond
        \override Staff.NoteHead.style = #'cross
       \override Staff.NoteHead.style = #'xcircle
  }
 \mus
     \new Lyrics \nam
  \layout {
  \context {
    \DrumStaff

  }
}

hélas toutes les tetes de notes ne sont pas reconnue.
bonne journée
Cordialement

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/partition-batterie/5867/4).