Subject: [LilyPond] Violons divisi

From: Christophe via LilyPond <[email-masked]>
Date: Tue, 08 Oct 2024 20:30:38 +0000

Bonjour,
Pour un conducteur de cordes seules, j'ai besoin de créer deux parties de violon 1 et deux de violons 2. Dans l'assistant de Frescolbaldi, les violons sont numérotés de 1 à 4.
Je souhaiterais que chaque violon ait sa portée propre et que chaque partie soit regroupée par catégorie en une seule fois : violons 1 sur 2 portées et idem pour les violons 2.
Je trouve un post sur le forum, mais qui ne m'éclaire pas vraiment : je n'ai pas besoin de lignes d'ossia.
Voici ce que j'ai pour l'instant :
```
\version "2.24.1"

\header {
  title = "Mélodie"
  
}

\paper {
  #(set-paper-size "a4")
}

global = {
  \key g \major
  \numericTimeSignature
  \time 2/4
  \partial 8
}

scoreAViolinI = \relative c'' {
  \global
  % En avant la musique !
  d8
  e8. d16 d8 c
}

scoreAViolinII = \relative c'' {
  \global
  % En avant la musique !
r8
  b2 b
}

scoreAViolinIII = \relative c'' {
  \global
  % En avant la musique !
r8
  g2 g2
}

scoreAViolinIV = \relative c'' {
  \global
  % En avant la musique !
  d2 d
  
}

scoreAViola = \relative c' {
  \global
  % En avant la musique !
  
}

scoreACello = \relative c {
  \global
  % En avant la musique !
  
}

scoreAContrabass = \relative c {
  \global
  % En avant la musique !
  
}

scoreAViolinIPart = \new Staff \with {
  instrumentName = "Violon I"
  midiInstrument = "violin"
} \scoreAViolinI

scoreAViolinIIPart = \new Staff \with {
  instrumentName = "Violon II"
  midiInstrument = "violin"
} \scoreAViolinII

scoreAViolinIIIPart = \new Staff \with {
  instrumentName = "Violon III"
  midiInstrument = "violin"
} \scoreAViolinIII

scoreAViolinIVPart = \new Staff \with {
  instrumentName = "Violon IV"
  midiInstrument = "violin"
} \scoreAViolinIV

scoreAViolaPart = \new Staff \with {
  instrumentName = "Alto"
  midiInstrument = "viola"
} { \clef alto \scoreAViola }

scoreACelloPart = \new Staff \with {
  instrumentName = "Violoncelle"
  midiInstrument = "cello"
} { \clef bass \scoreACello }

scoreAContrabassPart = \new Staff \with {
  instrumentName = "Contrebasse"
  midiInstrument = "contrabass"
} { \clef bass \scoreAContrabass }

\score {
  <<
    \new StaffGroup <<
    \new Staff \with { instrumentName = "Violin 1" }
  \global  \scoreAViolinIPart
    
    \new StaffGroup <<
      \new Staff \with { instrumentName = "Violin 1" }
  \global  \scoreAViolinIIIPart

    \scoreAViolaPart
    \scoreACelloPart
    \scoreAContrabassPart
  \layout { }
  \midi {
    \tempo 4=92
  }
}

```
Merci pour vos conseils et références.
Christophe

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/violons-divisi/5758/1).

Pour créer un nouveau sujet, écrivez à [[email-masked]](mailto:[email-masked]) ou visitez la [page d'accueil de lilypond.community](https://lilypond.community).

---

From: MartialR via LilyPond <[email-masked]>
Date: Tue, 08 Oct 2024 21:23:02 +0000

Bonsoir,

si vous créer  des Portée (Staff)  en premier  "scoreACelloPart"
il ne faut pas les répéter  avec \new Staff \with ... 

Est-ce ceci que vous cherchez : 
```
\version "2.24.1"

\header {
  title = "Mélodie"
  
}

\paper {
  #(set-paper-size "a4")
}

global = {
  \key g \major
  \numericTimeSignature
  \time 2/4
  \partial 8
}

  
}

}

}

}

scoreAViolinIPart = \new Staff \with {
%  instrumentName = "Violon I"
  midiInstrument = "violin"
} \scoreAViolinI

scoreAViolinIIPart = \new Staff \with {
 % instrumentName = "Violon II"
  midiInstrument = "violin"
} \scoreAViolinII

scoreAViolinIIIPart = \new Staff \with {
  %instrumentName = "Violon III"
  midiInstrument = "violin"
} \scoreAViolinIII

scoreAViolinIVPart = \new Staff \with {
 % instrumentName = "Violon IV"
  midiInstrument = "violin"
} \scoreAViolinIV

\score {
% \new StaffGroup % tout
  << 
     \new StaffGroup \with { instrumentName =  "VIOLiN" } % Violon
     <<
     \new StaffGroup \with { instrumentName = "Vl I" } % Violon I
     <<
      \scoreAViolinIPart
      \scoreAViolinIPart
   \new StaffGroup \with {  instrumentName = "Vl 2" }
   <<
    \scoreAViolinIIPart
     \scoreAViolinIIPart
     \new StaffGroup  \with { instrumentName = "Vl 3" }
    <<
    \scoreAViolinIIIPart
    \scoreAViolinIIIPart
    %% etc. 
  \new StaffGroup   \with { instrumentName = "Vl 4" }
  <<
    \scoreAViolinIVPart
     \scoreAViolinIVPart

   \scoreAViolaPart
    \scoreACelloPart
   \scoreAContrabassPart
  \layout { indent = 30 }
  \midi {
    \tempo 4=92
  }
}
```
Cordialement

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/violons-divisi/5758/2).

---

From: Jean-Julien Fleck via LilyPond <[email-masked]>
Date: Wed, 09 Oct 2024 09:10:43 +0000

Voici ce à quoi je suis arrivé si j'ai bien compris la demande. J'ai un peu modifié les noms. Il y avait effectivement des staffs en trop.
```
\version "2.24.1"

\header {
  title = "Mélodie"
  
}

\paper {
  #(set-paper-size "a4")
}

global = {
  \key g \major
  \numericTimeSignature
  \time 2/4
  \partial 8
}

scoreAViolinI_I = \relative c'' {
  \global
  % En avant la musique !
  d8
  e8. d16 d8 c
}

scoreAViolinI_II = \relative c'' {
  \global
  % En avant la musique !
r8
  b2 b
}

scoreAViolinII_I = \relative c'' {
  \global
  % En avant la musique !
r8
  g2 g2
}

scoreAViolinII_II = \relative c'' {
  \global
  % En avant la musique !
  d2 d
  
}

}

}

}

scoreAViolinI_IPart = \new Staff \with {
  instrumentName = "Violon I"
  midiInstrument = "violin"
} \scoreAViolinI_I

scoreAViolinI_IIPart = \new Staff \with {
  instrumentName = "Violon I"
  midiInstrument = "violin"
} \scoreAViolinI_II

scoreAViolinII_IPart = \new Staff \with {
  instrumentName = "Violon II"
  midiInstrument = "violin"
} \scoreAViolinII_I

scoreAViolinII_IIPart = \new Staff \with {
  instrumentName = "Violon II"
  midiInstrument = "violin"
} \scoreAViolinII_II

\score {
  <<
    \new StaffGroup <<
        \scoreAViolinI_IPart
        \scoreAViolinI_IIPart

    \new StaffGroup <<
        \scoreAViolinII_IPart
        \scoreAViolinII_IIPart
    
%    \new StaffGroup <<
%     >>

    \scoreAViolaPart
    \scoreACelloPart
    \scoreAContrabassPart
  \layout { }
  \midi {
    \tempo 4=92
  }
}
```

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/violons-divisi/5758/3).

---

From: Christophe via LilyPond <[email-masked]>
Date: Wed, 09 Oct 2024 14:45:56 +0000

Bonjour et grand merci à vous deux, Martial et jjfPCSI1.
C'est bien ce que je cherchais.
C'est résolu.
Bien cordialement.
Christophe

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/violons-divisi/5758/4).