Subject: [LilyPond] Problème d'installation sur linux

From: Moebius1 via LilyPond <[email-masked]>
Date: Tue, 08 Oct 2024 18:53:51 +0000

Bonjour,
J'essaye d'installer la dernière version de développement ; je la mets dans /usr/local/ ; je sais, ce n'est pas du tout obligatoire mais j'aime bien que les programmes soient localisés là où il y a des programmes locaux. 
Bref, je lance lily en ligne de commande avec le fichier de test indiqué sur le site pour être certain que ce n'est pas frescobaldi qui déraisonne et j'obtiens ceci :
GNU LilyPond 2.25.20 (running Guile 3.0)
;;; note: source file /usr/local/lilypond-2.25.20/share/guile/3.0/ice-9/eval.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/guile/3.0/ccache/ice-9/eval.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/lily.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/lily.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/clip-region.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/clip-region.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/curried-definitions.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/curried-definitions.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/operators.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/operators.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/lily-library.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/lily-library.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/output-lib.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/output-lib.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/markup-macros.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/markup-macros.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/parser-ly-from-scheme.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/parser-ly-from-scheme.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/file-cache.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/file-cache.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/define-event-classes.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/define-event-classes.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/define-music-callbacks.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/define-music-callbacks.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/define-music-types.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/define-music-types.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/define-note-names.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/define-note-names.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/c++.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/c++.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/chord-entry.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/chord-entry.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/skyline.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/skyline.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/markup.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/markup.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/define-markup-commands.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/define-markup-commands.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/qr-code.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/qr-code.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/stencil.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/stencil.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/modal-transforms.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/modal-transforms.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/chord-ignatzek-names.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/chord-ignatzek-names.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/music-functions.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/music-functions.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/display-lily.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/display-lily.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/define-music-display-methods.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/define-music-display-methods.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/part-combiner.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/part-combiner.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/autochange.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/autochange.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/define-music-properties.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/define-music-properties.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/time-signature.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/time-signature.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/time-signature-settings.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/time-signature-settings.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/auto-beam.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/auto-beam.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/chord-name.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/chord-name.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/define-context-properties.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/define-context-properties.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/translation-functions.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/translation-functions.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/breath.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/breath.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/script.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/script.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/midi.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/midi.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/layout-beam.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/layout-beam.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/parser-clef.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/parser-clef.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/layout-slur.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/layout-slur.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/font-encodings.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/font-encodings.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/bar-line.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/bar-line.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/flag-styles.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/flag-styles.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/fret-diagrams.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/fret-diagrams.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/tablature.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/tablature.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/harp-pedals.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/harp-pedals.go
;;; note: source file /usr/local/lilypond-2.25.20/share/lilypond/2.25.20/scm/lily/define-woodwind-diagrams.scm
;;;       newer than compiled /usr/local/lilypond-2.25.20/lib/lilypond/2.25.20/ccache/lily/define-woodwind-diagrams.go
ERROR: In procedure apply-smob/1:
Wrong number of arguments to #<boot-closure 7f62e1305be0 (_ . _)>

Franchement, je n'y comprends pas grand chose (ça, c'est normal) mais surtout, j'aimerais bien pouvoir me servir de cette version.
Curieusement, je n'ai rien vu sur la liste qui ressemble à ce problème.
Je suis en debian12 et l'installation se borne à décompresser le fichier lilypond-2.25.20-linux-x86_64.tar.gz et à mettre le dossier créé à l'endroit indiqué
Voili voilou, c'est sans doute un truc tout bête et je sollicite votre aide pour résoudre ce problème. 
Remerciements anticipés.

PS : la dernière version dont j'ai pu me servir est la 2.25.12, toutes les suivantes ont le même problème.

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/probleme-dinstallation-sur-linux/5757/1).

Pour créer un nouveau sujet, écrivez à [[email-masked]](mailto:[email-masked]) ou visitez la [page d'accueil de lilypond.community](https://lilypond.community).

---

From: MartialR via LilyPond <[email-masked]>
Date: Wed, 09 Oct 2024 08:56:19 +0000

Bonjour, 
je pose la question par précaution : avez vous indiqué dans frescobaldi le chemin de l'exécutable lilypond ? 
/usr/local/lilypond-2.25.20/bin/lilypond
Essayez en l'installant  ailleurs  dans opt par exemple  (ce que je fais)
/opt/lilypond-2.25.20/bin/lilypond 

Cordialement

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/probleme-dinstallation-sur-linux/5757/2).

---

From: Moebius1 via LilyPond <[email-masked]>
Date: Wed, 09 Oct 2024 10:22:45 +0000

Bonjour,
En fait, comme je le disais, voyant que j'avais des erreurs avec 
frescobaldi, j'ai directement utilisé la ligne de commande dans un 
terminal pour n'utiliser que lilypond et j'ai tapé :
/usr/local/lilypond-2.25.20/bin/lilypond Bureau/test.ly
test.ly étant un fichier tout simple ne contenant que :
\version "2.25.20"

{ c' }
J'avoue, c'est bizarre...
cordialement,
Le 09/10/2024 à 10:56, MartialR via LilyPond a écrit :
> [MartialR] 	MartialR
> Octobre 9
>
> Bonjour,
> je pose la question par précaution : avez vous indiqué dans 
> frescobaldi le chemin de l'exécutable lilypond ?
> ------------------------------------------------------------------------
>
> Pour poster dans ce sujet, visitez la page du 
> sujet 
> <https://lilypond.community/t/probleme-dinstallation-sur-linux/5757/2>.
>
> Pour créer un nouveau sujet, écrivez à [email-masked] ou 
> visitez la page d'accueil de lilypond.community 
> <https://lilypond.community>.
>
> 
>
> Pour vous désabonner de ces e-mails, cliquez ici 
> <https://lilypond.community/email/unsubscribe/bde99df2a58373ee506b6aaf98ae0e43bbe7e2f79cf0f9bc95b48cae83c4f5d7>.
>

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/probleme-dinstallation-sur-linux/5757/3).

---

From: MartialR via LilyPond <[email-masked]>
Date: Wed, 09 Oct 2024 12:51:01 +0000

sous ubuntu 
/opt/lilypond-2.25.20/bin/lilypond Bureau/ test.ly 
chez moi ça fonctionne 
Je ne saurai donner une explication au problème. 
Testez une installation dans un autre répertoire. 
et/ou installez une 2.24.4 pour tester si le problème existe en 2.24.  
Cordialement

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/probleme-dinstallation-sur-linux/5757/4).

---

From: Moebius1 via LilyPond <[email-masked]>
Date: Wed, 09 Oct 2024 13:40:18 +0000

Merci, ça m'a mis sur la voie !
En fait, ce n'est pas exactement cela, cela arrive parce que je copie 
avec cp sans l'option --preserve ; avec l'option -a qui la contient, ça 
roule sans problème !
Merci encore !

Le 09/10/2024 à 15:11, Jean Abou Samra via LilyPond a écrit :
> tar -xvf

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/probleme-dinstallation-sur-linux/5757/6).