Subject: [LilyPond] [Général] Segno et Coda de LilyJazz dans un DrumStaff

From: Sébastien Richard via LilyPond <[email-masked]>
Date: Fri, 05 Jan 2024 16:15:39 +0000

Bonsoir,

Comment puis je faire pour que lilypond utilise les Segno & Coda de LilyJazz dans l'exemple ci-dessous ?

```
\version "2.24.2"

drum = \drummode {
  sn4 sn sn sn
  \segnoMark 1
  sn4 sn sn sn
  \codaMark 1
  sn4 sn sn sn  
}

\score {
  \new DrumStaff \with {} \drum
  \layout { }
}
```
Bien évidemment j'ai installé LilyJazz et graver les exemples avec succès.

Bonne soirée à tous

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/segno-et-coda-de-lilyjazz-dans-un-drumstaff/5598/1).

Pour créer un nouveau sujet, écrivez à [[email-masked]](mailto:[email-masked]) ou visitez la [page d'accueil de lilypond.community](https://lilypond.community).

---

From: Sébastien Richard via LilyPond <[email-masked]>
Date: Mon, 15 Jan 2024 21:01:50 +0000

Je poste ici la réponse de Michael de la liste anglophone. Un grand Merci à lui.

Hi Sebastien,

On Sat, Jan 13, 2024 at 11:17 AM Sebastien Richard <[[email-masked]](mailto:[email-masked])> wrote:

> Hi all,
>
>
>
>
> I've been struggling with this for a long time without getting close to any solution.
>
>
>
>
> How can I use the Segno & Coda from LilyJazz in the example below ?

To clarify, you want just the segno and coda marks in the LilyJazz font, while the rest of the notation remains in the default music font? If so, I'm not completely sure but I don't think that can be done with the 2.24 series. However ...

As the 2.25 series has been developed, the arrival of 2.25.6 brought along a significantly redone font handling system. One of the new features is that font selection is now just another property, and can be modified on a per-grob basis. Which makes what you want fairly simple and straight forward. Once the LilyJazz font files have been placed as needed, it's just a matter of modifying the properties of the SegnoMark and CodaMark grobs. Like this:

```
\version "2.25.12"

drum = \drummode {
   sn4 sn sn sn
   \segnoMark 1
   sn4 sn sn sn
   \codaMark 1
   sn4 sn sn sn
}

\score {
   \new DrumStaff { \drum }
}
\layout {
   \context {
      \Score
      \override CodaMark.fonts.music = "lilyjazz"
      \override SegnoMark.fonts.music = "lilyjazz"
   }
}
```

This will mean that you would have to make the jump to the development series, so you'll have to decide for yourself if that's something you're willing to do. I can say that I've been using the development versions for a while and generally they're working just fine. The only real issue I've encountered was when the newer versions switched to Guile 3 one of the third-party packages I'm using didn't like that, but I've managed to get through that. Other than that all has been well. So if Guile 3 isn't for you, something between 2.25.6 and 2.25.10 (I think it was .11 where Guile 3 came in) should be safe.

--
Michael

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/segno-et-coda-de-lilyjazz-dans-un-drumstaff/5598/2).