Subject: [LilyPond] [Général] Problème de liaison dans un repeat volta

From: Sébastien Richard via LilyPond <[email-masked]>
Date: Fri, 08 Dec 2023 18:19:18 +0000

Bonsoir à tous,

J'ai un problème de liaison dans un repeat volta : 

```
\version "2.24.2"

up = \drummode {
  <hh sn>8 <hh bd> <hh sn>8. bd16 sn8 <cymc bd>4 <cymc bd>8~
  \repeat volta 2 {
    {
      cymc <hh bd> <hh sn> hh <hh bd> <hh bd> <hh sn> hh
    }
    \alternative {
      \volta 1 {
        <hh bd> hh <hh sn> hh sn8 <tomh tomml> <tomh tomml> <cymc bd>\laissezVibrer
      }
      \volta 2 {
        <hh bd> <hh bd> <hh sn> hh16 bd sn8 <cymc bd> <cymc bd> <cymc bd>~
      }
    }
  }
  cymc <hh bd> <hh sn> hh <hh bd> <hh bd> <hh sn> hh
}

\score {
  \new DrumStaff
  <<
  \new DrumVoice { \voiceOne \up }
  \layout { }
}
```
Ce qui me donne :

![Screenshot at 2023-12-08 18-48-04|690x78](upload://qHpIah3Uwn9zzNeeEtAVhgVMXAz.png)

Comment faire pour enlever la liaison sur la dernière grosse caisse du bloc de répétition 1 (entourée en rouge)?

Merci

@+

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/probleme-de-liaison-dans-un-repeat-volta/5563/1).

Pour créer un nouveau sujet, écrivez à [[email-masked]](mailto:[email-masked]) ou visitez la [page d'accueil de lilypond.community](https://lilypond.community).

---

From: MartialR via LilyPond <[email-masked]>
Date: Fri, 08 Dec 2023 18:48:37 +0000

Bonsoir,
Il faut en le ver les volta 1 volta 2
```
\version "2.24.2"

up = \drummode {
  <hh sn>8 <hh bd> <hh sn>8. bd16 sn8 <cymc bd>4 <cymc bd>8~
  \repeat volta 2 {
    {
      cymc <hh bd> <hh sn> hh <hh bd> <hh bd> <hh sn> hh
    }
    \alternative {
      {
        <hh bd> hh <hh sn> hh sn8 <tomh tomml> <tomh tomml> <cymc bd>~
      }
       {
        <hh bd> <hh bd> <hh sn> hh16 bd sn8 <cymc bd> <cymc bd> <cymc bd>~
      }
    }
  }
  cymc <hh bd> <hh sn> hh <hh bd> <hh bd> <hh sn> hh
}

\score {
  \new DrumStaff
  <<
  \layout { }
}

```
Bonne soirée

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/probleme-de-liaison-dans-un-repeat-volta/5563/2).

---

From: Sébastien Richard via LilyPond <[email-masked]>
Date: Fri, 08 Dec 2023 19:11:57 +0000

Merci Martial,

Ma question devait être mal posée. Le résultat n'est pas celui que je recherchais *mais* cela m'a permis de trouver comment faire :

```
up = \drummode {
  <hh sn>8 <hh bd> <hh sn>8. bd16 sn8 <cymc bd>4 <cymc~ bd>8
  \repeat volta 2 {
    {
      cymc <hh bd> <hh sn> hh <hh bd> <hh bd> <hh sn> hh
    }
    \alternative {
      \volta 1 {
        <hh bd> hh <hh sn> hh sn8 <tomh tomml> <tomh tomml> <cymc\laissezVibrer bd>
      }
      \volta 2 {
        <hh bd> <hh bd> <hh sn> hh16 bd sn8 <cymc bd> <cymc bd> <cymc bd>~
      }
    }
  }
  cymc <hh bd> <hh sn> hh <hh bd> <hh bd> <hh sn> hh
}

\score {
  \new DrumStaff
  <<
  \layout { }
}
```

Ce qui donne : 

![Screenshot at 2023-12-08 20-05-17|690x80](upload://o98L02Mg8jU6LhBrm3BBr6d6Sty.png)

Je n'avais pas réaliser que l'on pouvais bouger les liaisons comme cela :grin:

Merci !!

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/probleme-de-liaison-dans-un-repeat-volta/5563/3).