Subject: [LilyPond] [Général] Problèmes avec macport et homebrew

From: Ben via LilyPond <[email-masked]>
Date: Wed, 13 Dec 2023 18:44:28 +0000

Bonsoir, 

Jusqu'à présent, j'utilisais les versions macport de frescobaldi et lilypond 2.25.1 sur mac os 13.6.3 Apple M1 sans trop de problèmes. 

Puis, n'arrivant pas à mettre à jour via la routine de macport, j'ai eu la mauvaise idée de supprimer macport pour tout réinstaller. J'y ai passé ma journée sans succès. 

- lilypond arm 2.25.11 s'installe via macport, mais il met d'autres polices que la même version en intel, c'est donc inutilisable

- frescobaldi plante à l'installation, à cause de python-popper-qt5, c'est d'autant plus regrettable que c'était la seule solution que j'avais trouvée pour lancer frescobaldi depuis les sources, ne désespérant pas de pouvoir corriger un jour le bug assez pénibles des menus sous macos, mais tant pis. 

J'ai essayé avec homebrew: 

- frescobaldi s'installe avec succès

- lilypond arm 2.24.3 s'installe, mais impossible de compiler, il manque le module gs

Bref, je n'ai plus que la version directement téléchargeable de lilypond qui heureusement fonctionne! Par contre, elle n'est pas compilée Apple, mais Intel, ce qui est un peu dommage, mais je peux vivre avec. 

Au plaisir, 

Ben

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/problemes-avec-macport-et-homebrew/5573/1).

Pour créer un nouveau sujet, écrivez à [[email-masked]](mailto:[email-masked]) ou visitez la [page d'accueil de lilypond.community](https://lilypond.community).

---

From: Jean Abou Samra via LilyPond <[email-masked]>
Date: Wed, 13 Dec 2023 18:56:36 +0000

[quote="Ben, post:1, topic:5573"]
lilypond arm 2.25.11 s'installe via macport, mais il met d'autres polices que la même version en intel, c'est donc inutilisable
[/quote]

On dirait qu'il n'ont pas réglé https://trac.macports.org/ticket/67026 *soupir...*

[quote="Ben, post:1, topic:5573"]
frescobaldi plante à l'installation, à cause de python-popper-qt5
[/quote]

Vous l'avez fait avec `pip install python-poppler-qt5` ? Normal que ça ne marche pas, ça va le compiler et c'est compliqué™.

[quote="Ben, post:1, topic:5573"]
lilypond arm 2.24.3 s'installe, mais impossible de compiler, il manque le module gs
[/quote]

Quelle est l'erreur ?

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/problemes-avec-macport-et-homebrew/5573/2).

---

From: Ben via LilyPond <[email-masked]>
Date: Wed, 13 Dec 2023 19:39:09 +0000

> Le 13 déc. 2023 à 19:56, Jean Abou Samra via LilyPond <[email-masked]> a écrit :
> 
> 	Jean Abou Samra <https://lilypond.community/u/jeanas> jeanas
> Décembre 13
>  Ben:
> On dirait qu'il n'ont pas réglé https://trac.macports.org/ticket/67026 soupir...
> 
On peut aussi écrire r4…

>  Ben:
> Vous l'avez fait avec pip install python-poppler-qt5 ? Normal que ça ne marche pas, ça va le compiler et c'est compliqué™.
> 
Alors avec macport, je fais sudo port install frescobaldi et la routine plante au niveau de python-poppler-qt5, alors que la dernière fois (qui date un peu), tout s'était installé correctement. 

 J'ai aussi essayé de recréer l'environnement python de frescobaldi avec pip. J'arrive enfin à installer pyqt5, mais pip install python-poppler-qt5 ne passe pas. Si je comprends bien, il faut que j'essaye de comprendre le fonctionnement de sip et de poppler pour résoudre le problème, j'ai l'impression que cela ne sera pas demain la veille.

>  Ben:
warning: g_spawn_sync failed (-1): gs: Failed to execute child process “gs” (No such file or directory)
warning: `(gs -q -dNODISPLAY -dNOSAFER -dNOPAUSE -dBATCH -dAutoRotatePages=/None -dPrinted=false /var/folders/nh/rtfxzmdn3gx18fwg6lbw4dfc0000gn/T//lilypond-tmp-8887710)' failed (-1)

/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/ly/init.ly:65:2: error: Guile signaled an error for the expression beginning here
#
 (let ((book-handler (if (defined? 'default-toplevel-book-handler)
Throw to key `ly-file-failed' with args `()'.
Arrêté avec le code de retour 1.

> 
> Pour poster dans ce sujet, visitez la page du sujet <https://lilypond.community/t/problemes-avec-macport-et-homebrew/5573/2>.
> 
> Pour créer un nouveau sujet, écrivez à [email-masked] <mailto:[email-masked]> ou visitez la page d'accueil de lilypond.community <https://lilypond.community/>.
> 
> Réponses précédentes
> 
> 	Ben <https://lilypond.community/u/ben> Ben 
> Décembre 13
> Bonsoir,
> 
> frescobaldi plante à l'installation, à cause de python-popper-qt5, c'est d'autant plus regrettable que c'était la seule solution que j'avais trouvée pour lancer frescobaldi depuis les sources, ne désespérant pas de pouvoir corriger un jour le bug assez pénibles des menus sous macos, mais tant pis.
> 
> frescobaldi s'installe avec succès
> 
> Pour poster dans ce sujet, visitez la page du sujet <https://lilypond.community/t/problemes-avec-macport-et-homebrew/5573/2>.
> 
> Pour créer un nouveau sujet, écrivez à [email-masked] <mailto:[email-masked]> ou visitez la page d'accueil de lilypond.community <https://lilypond.community/>.
> 
> 
> 
> Pour vous désabonner de ces e-mails, cliquez ici <https://lilypond.community/email/unsubscribe/c6f9f19458c132f472e07a70d04e6a009411421fb9ba5abf91b1e78f8ca7c0b0>.
>

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/problemes-avec-macport-et-homebrew/5573/3).

---

From: Jean Abou Samra via LilyPond <[email-masked]>
Date: Wed, 13 Dec 2023 19:45:00 +0000

[quote="Ben, post:3, topic:5573"]
warning: g_spawn_sync failed (-1): gs: Failed to execute child process “gs” (No such file or directory)
warning: `(gs -q -dNODISPLAY -dNOSAFER -dNOPAUSE -dBATCH -dAutoRotatePages=/None -dPrinted=false /var/folders/nh/rtfxzmdn3gx18fwg6lbw4dfc0000gn/T//lilypond-tmp-8887710)' failed (-1)

Et avec `--verbose`, qu'est-ce que ça donne ?

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/problemes-avec-macport-et-homebrew/5573/4).

---

From: Ben via LilyPond <[email-masked]>
Date: Wed, 13 Dec 2023 20:06:54 +0000

Voilà:

Démarrage lilypond 2.24.3 [Test.ly]...
Log level set to 287

Relocation
  LilyPond binary has absolute file name:
    /opt/homebrew/Cellar/lilypond/2.24.3/bin/lilypond
  Setting INSTALLER_PREFIX to '/opt/homebrew/Cellar/lilypond/2.24.3'
  Using run-time value for datadir,
    setting it to '/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3'
  Using run-time value for libdir,
    setting it to '/opt/homebrew/Cellar/lilypond/2.24.3/lib/lilypond/2.24.3'
  Using run-time value for localedir,
    setting it to '/opt/homebrew/Cellar/lilypond/2.24.3/share/locale'
  Using compile-time value for relocdir,
    setting it to ''
  Prepending '/opt/homebrew/Cellar/lilypond/2.24.3/bin' to PATH
  Setting PATH to '/opt/homebrew/Cellar/lilypond/2.24.3/bin:/opt/homebrew/Cellar/lilypond/2.24.3/bin:/opt/homebrew/Cellar/lilypond/2.24.3/bin:/opt/homebrew/Cellar/lilypond/2.24.3/bin:/opt/homebrew/Cellar/lilypond/2.24.3/bin:/Users/ben/lilypond-2.25.11/bin:/usr/bin:/bin:/usr/sbin:/sbin'
Setting GUILE_AUTO_COMPILE to '0'
Setting GUILE_WARN_DEPRECATED to 'detailed'
Setting XDG_CACHE_HOME to '/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3'
Setting GC_INITIAL_HEAP_SIZE to '40M'
Setting GC_NPROCS to '1'
Setting GC_FREE_SPACE_DIVISOR to '1'

Effective prefix: '/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3'
PATH="/opt/homebrew/Cellar/lilypond/2.24.3/bin:/opt/homebrew/Cellar/lilypond/2.24.3/bin:/opt/homebrew/Cellar/lilypond/2.24.3/bin:/opt/homebrew/Cellar/lilypond/2.24.3/bin:/opt/homebrew/Cellar/lilypond/2.24.3/bin:/Users/ben/lilypond-2.25.11/bin:/usr/bin:/bin:/usr/sbin:/sbin"

[]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/lily-library.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/output-lib.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/markup-macros.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/parser-ly-from-scheme.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/file-cache.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/define-event-classes.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/define-music-callbacks.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/define-music-types.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/define-note-names.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/c++.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/chord-entry.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/skyline.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/markup.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/define-markup-commands.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/stencil.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/modal-transforms.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/chord-ignatzek-names.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/music-functions.scm
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/define-music-display-methods.scm]
]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/part-combiner.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/autochange.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/define-music-properties.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/time-signature.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/time-signature-settings.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/auto-beam.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/chord-name.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/define-context-properties.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/translation-functions.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/breath.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/script.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/midi.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/layout-beam.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/parser-clef.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/layout-slur.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/font.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/font-encodings.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/bar-line.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/flag-styles.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/fret-diagrams.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/tablature.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/harp-pedals.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/define-woodwind-diagrams.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/display-woodwind-diagrams.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/predefined-fretboards.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/define-grob-properties.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/define-grobs.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/define-grob-interfaces.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/define-stencil-commands.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/scheme-engravers.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/scheme-performers.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/titling.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/paper.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/backend-library.scm]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/color.scm]
(primitive-load-path lily): 0.07 seconds
Initializing FontConfig...
Adding fontconfig configuration file: /opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/fonts/00-lilypond-fonts.conf
Adding fontconfig configuration file: /opt/homebrew/etc/fonts/fonts.conf
Adding fontconfig configuration file: /opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/fonts/99-lilypond-fonts.conf
Adding font directory: /opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/fonts/otf
Building font database...

[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/ly/declarations-init.ly[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/ly/music-functions-init.ly][/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/ly/toc-init.ly]
Using `nederlands' note names...[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/ly/drumpitch-init.ly][/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/ly/chord-modifiers-init.ly][/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/ly/script-init.ly][/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/ly/chord-repetition-init.ly][/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/ly/scale-definitions-init.ly][/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/ly/dynamic-scripts-init.ly][/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/ly/spanners-init.ly][/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/ly/predefined-fretboards-init.ly][/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/ly/string-tunings-init.ly][/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/ly/property-init.ly][/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/ly/grace-init.ly][/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/ly/midi-init.ly[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/ly/performer-init.ly]][/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/ly/paper-defaults-init.ly[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/ly/titling-init.ly][/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/ly/text-replacements.ly]][/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/ly/context-mods-init.ly][/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/ly/engraver-init.ly]]
Processing `/Users/ben/Desktop/Test.ly'
Parsing...[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/ly/init.ly
Using `nederlands' note names...[/Users/ben/Desktop/Test.ly]
Interpreting music...
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/fonts/otf/emmentaler-20.otf
CFF name for font Emmentaler-20 is the same.]
elapsed time: 0.02 seconds
Element count 55 (spanners 6) 
Preprocessing graphical objects...
Grob count 103
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/fonts/otf/emmentaler-11.otf
CFF name for font Emmentaler-11 is the same.]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/fonts/otf/emmentaler-13.otf
CFF name for font Emmentaler-13 is the same.]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/fonts/otf/emmentaler-14.otf
CFF name for font Emmentaler-14 is the same.]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/fonts/otf/emmentaler-16.otf
CFF name for font Emmentaler-16 is the same.]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/fonts/otf/emmentaler-18.otf
CFF name for font Emmentaler-18 is the same.]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/fonts/otf/emmentaler-23.otf
CFF name for font Emmentaler-23 is the same.]
Finding the ideal number of pages...
[lilypond_serif_3.8662109375]
CFF name for font C059-Roman is the same.
Fitting music on 1 page...
Drawing systems...
Element count 109
Initializing embedded CFF font list.
Embedding CFF font `C059-Roman'.
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/fonts/otf/C059-Roman.otf]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/ps/music-drawing-routines.ps]
[/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/ps/lilyponddefs.ps]
Paper_outputter elapsed time: 0.01 seconds
Converting to `Test.pdf'...
Preparing Ghostscript command to `/var/folders/nh/rtfxzmdn3gx18fwg6lbw4dfc0000gn/T//lilypond-tmp-592332': << /OutputFile (./lilypond-tmp-1592284.pdf) /CompatibilityLevel 1.4 /PageSize [595.28 841.89] /OutputDevice /pdfwrite >> setpagedevice /.setdefaultscreen where { pop .setdefaultscreen } { (Warning: .setdefaultscreen not available) print } ifelse newpath fill (/var/folders/nh/rtfxzmdn3gx18fwg6lbw4dfc0000gn/T//lilypond-tmp-1592284) (r) file .setsafe run
Invoking `gs -dNODISPLAY -dNOSAFER -dNOPAUSE -dBATCH -dAutoRotatePages=/None -dPrinted=false /var/folders/nh/rtfxzmdn3gx18fwg6lbw4dfc0000gn/T//lilypond-tmp-592332'...
warning: g_spawn_sync failed (-1): gs: Failed to execute child process “gs” (No such file or directory)
warning: `(gs -dNODISPLAY -dNOSAFER -dNOPAUSE -dBATCH -dAutoRotatePages=/None -dPrinted=false /var/folders/nh/rtfxzmdn3gx18fwg6lbw4dfc0000gn/T//lilypond-tmp-592332)' failed (-1)

/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/ly/init.ly:65:2: error: Guile signaled an error for the expression beginning here
#
 (let ((book-handler (if (defined? 'default-toplevel-book-handler)
/opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/scm/lily/lily.scm
In ice-9/boot-9.scm:
  1752:10 16 (with-exception-handler _ _ #:unwind? _ # _)
In unknown file:
          15 (apply-smob/0 #<thunk 105e4b2a0>)
In /private/tmp/lilypond-20231119-11127-7plyz7/lilypond-2.24.3/out/share/lilypond/current/scm/lily/lily.scm:
   873:16 14 (lilypond-main _)
    902:4 13 (lilypond-all ("/Users/ben/Desktop/Test.ly"))
In srfi/srfi-1.scm:
    634:9 12 (for-each #<procedure 10615a690 at /private/tmp/lilypo…> …)
In /private/tmp/lilypond-20231119-11127-7plyz7/lilypond-2.24.3/out/share/lilypond/current/scm/lily/lily.scm:
    912:9 11 (_ "/Users/ben/Desktop/Test.ly")
In ice-9/boot-9.scm:
  1747:15 10 (with-exception-handler #<procedure 10615a660 at ice-9…> …)
In unknown file:
           9 (ly:parse-file "/Users/ben/Desktop/Test.ly")
In ice-9/boot-9.scm:
  1752:10  8 (with-exception-handler _ _ #:unwind? _ # _)
In unknown file:
           7 (apply-smob/0 #<thunk 1068ed520>)
           6 (ly:book-process #<Book> #< Output_def> #< Output_def> #)
In /private/tmp/lilypond-20231119-11127-7plyz7/lilypond-2.24.3/out/share/lilypond/current/scm/lily/backend-library.scm:
    335:4  5 (postprocess-output #< Output_def> #<directory (lily f…> …)
In srfi/srfi-1.scm:
    634:9  4 (for-each #<procedure 1064ac180 at /private/tmp/lilypo…> …)
In /private/tmp/lilypond-20231119-11127-7plyz7/lilypond-2.24.3/out/share/lilypond/current/scm/lily/backend-library.scm:
    150:4  3 (postscript->pdf 595.2755905511812 841.8897637795277 "…" …)
     57:4  2 (ly:gs-cli _ "<< /OutputFile (./lilypond-tmp-1592284.pd…")
In ice-9/boot-9.scm:
  1685:16  1 (raise-exception _ #:continuable? _)
In unknown file:
           0 (apply-smob/1 #<exception-handler 1068ed3e0> #<&compoun…>)
Throw to key `ly-file-failed' with args `()'.
Arrêté avec le code de retour 1.

> Le 13 déc. 2023 à 20:44, Jean Abou Samra via LilyPond <[email-masked]> a écrit :
> 
> /opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/ly/init.ly:65 <http://init.ly:65/>:2: error: Guile signaled an error for the expression beginning here
> 
> Throw to key ly-file-failed' with args ()'.
> Et avec --verbose, qu'est-ce que ça donne ?
> 
> Pour poster dans ce sujet, visitez la page du sujet <https://lilypond.community/t/problemes-avec-macport-et-homebrew/5573/4>.
> 
> Le 13 déc. 2023 à 19:56, Jean Abou Samra via LilyPond [email-masked] <mailto:[email-masked]>a écrit :
> 
> Jean Abou Samra https://lilypond.community/u/jeanas jeanas
> Décembre 13
> Ben:
> On dirait qu'il n'ont pas réglé #67026 (LilyPond: installation of text fonts probably broken) – MacPorts <https://trac.macports.org/ticket/67026>soupir...
> On peut aussi écrire r4…
> 
> Ben:
> /opt/homebrew/Cellar/lilypond/2.24.3/share/lilypond/2.24.3/ly/init.ly:65 <http://init.ly:65/>:2: error: Guile signaled an error for the expression beginning here
> 
>  <https://lilypond.community/#h-1>
> Throw to key ly-file-failed' with args ()'.
> On dirait qu'il n'ont pas réglé #67026 (LilyPond: installation of text fonts probably broken) – MacPorts <https://trac.macports.org/ticket/67026> soupir...
> 
>  Ben:
> Pour poster dans ce sujet, visitez la page du sujet <https://lilypond.community/t/problemes-avec-macport-et-homebrew/5573/4>.
> 
> Pour vous désabonner de ces e-mails, cliquez ici <https://lilypond.community/email/unsubscribe/a2ec0050d3e7e62ee2b1b29e140a8c8275626772940579cc4265cbc152232b69>.
>

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/problemes-avec-macport-et-homebrew/5573/5).

---

From: Ben via LilyPond <[email-masked]>
Date: Thu, 14 Dec 2023 10:05:44 +0000

>> CVous l'avez fait avec pip install python-poppler-qt5 ? Normal que ça ne marche pas, ça va le compiler et c'est compliqué™.
>> 
Cher Jean, 

J'ai vu que vous aviez fait des modifications pour rendre python-poppler-qt5 disponible sous Linux, est-ce que cela vous serait compliqué de m'indiquer les commandes que vous avez utilisées pour y parvenir, afin que je puisse essayer de les reproduire sous mac os x? Cela me ferait gagner beaucoup de temps… 

Au plaisir, 

Ben

>> Pour vous désabonner de ces e-mails, cliquez ici <https://lilypond.community/email/unsubscribe/c6f9f19458c132f472e07a70d04e6a009411421fb9ba5abf91b1e78f8ca7c0b0>.

---
Pour poster dans ce sujet, visitez la [page du sujet](https://lilypond.community/t/problemes-avec-macport-et-homebrew/5573/6).