Subject: Dessins de manches de Guitare sous Lily

From: Jean-Loups <[email-masked]>
Date: Wed, 4 Oct 2023 22:24:09 +0200

Salut,
Y a-t-il une fonction pour dessiner le manche de la guitare sous Lilypond ?
Et toi, avec des couleurs, les notes en format américain ou italien 

Sincèremen,
Jean-loups
Envoyé de mon iPhone

---

From: Martial R <[email-masked]>
Date: Wed, 4 Oct 2023 23:51:28 +0200

B'soir

comme ceci ?

%-------------------------------------------------------
\version "2.24.2"

\score {
  % \new StaffGroup
  <<
    \new ChordNames {
      \chordmode {  b  }
    }
    \new Staff {
      \clef "treble_8"
      \override Voice.TextScript.fret-diagram-details.finger-code =
      #'below-string

      \override Voice.TextScript.size = 1.5
      <b, fis b dis' fis'>1^\markup
      \override #'(fret-diagram-details . ((finger-code . in-dot)))
      \fret-diagram-verbose #`(
                                (place-fret 5 2 1)
                                (place-fret 4 4 "fis" red)
                                (place-fret 3 4 "b" red)
                                (place-fret
                                 2 4
                                 ,#{ \markup
                                     \concat {
                                       \vcenter "d"
                                       \fontsize #-5
                                       \musicglyph "accidentals.sharp"
                                 } #}
                                 red)
                                (place-fret 1 2 1)
                                )
    }
 \layout {  }
}
%--------------------------------------

tout ici fretboard
http://lilypond.org/doc/v2.24/Documentation/notation/common-notation-for-fretted-strings#index-FretBoards

Cordialement

Le mer. 4 oct. 2023 à 22:24, Jean-Loups <[email-masked]> a

-- 
Martial Rameaux

---

From: Martial R <[email-masked]>
Date: Thu, 5 Oct 2023 09:40:22 +0200

Désolé pour les doublons, ça "merdouille" sur mon clavier :-)
voici :
https://lsr.di.unimi.it/LSR/Snippet?id=790

\language "english"

% Helper function to invert first elements of scales
#(define (inverted num mod)
   (if (zero? (modulo num mod))
         (list '1 'inverted)
         (list (1+ (modulo num mod)))))

% Expand the (string fret) pairs to valid lilypond syntax
#(define (fret-from-list l1 l2 n1)
   (if  (null? l1)
        l2
        (fret-from-list (cdr l1) (append l2 (list (append '(place-fret)
(car l1) (inverted (length l2) n1)))) n1)))

% arg1 is the list of (string fret) pairs making up the scale
% arg2 is the number of unique tones in the scale (i.e. 7 for major scale,
5 for pentatonic)
% arg3 is a scale factor used to enlarge the fret diagram
#(define-markup-command (scale-diagramm layout props arg1 arg2 arg3) (list?
integer? number?)
   (interpret-markup layout props
    (markup
     (#:override (cons 'size arg3 )
      (#:override '(fret-diagram-details
                    . (
                       (finger-code . in-dot)
                       (number-type . arabic)
                       (label-dir   . -1)
                       (orientation . landscape)
                       (dot-radius  . 0.4)
                       (fret-count  . 8)
                       (top-fret-thickness . 7)))
        #:fret-diagram-verbose
          (fret-from-list arg1 '() arg2)))) ))

#(define-markup-command (verbose-diagramm layout props arg1 arg2 arg3)
(list? integer? number?)
   (interpret-markup layout props
    (markup
     (#:override (cons 'size arg3 )
      (#:override '(fret-diagram-details
                    . (
                       (finger-code . in-dot)
                       (number-type . arabic)
                       (label-dir   . -1)
                       (orientation . landscape)
                       (dot-radius  . 0.4)
                       (fret-count  . 8)
                       (top-fret-thickness . 7)))
        #:fret-diagram-verbose
          (fret-from-list arg1 '() arg3))))))

eclapC=\markup\bold\scale-diagramm #'((6 9)(6 11)
                                          (5 9)(5 11)
                                          (4 9)(4 11)
                                     (3 8)(3 9)(3 11)
                                     (2 9) (2 10) (2 12)
                                     (1 9)(1 10)(1 12)
                                          ) #9 #5

eclapV=\markup\bold\verbose-diagramm #'((6 9 "cs")(6 11 "ds")(6 13 "e")
                                          (5 9 "fs")(5 11 "gs") (5 13 "a")
                                          (4 9 "b")(4 11 "cs")
                                     (3 8 "ds")(3 9 "e")(3 11 "fs")
                                     (2 9 "gs") (2 10 "a") (2 13 "b")
                                     (1 9 "cs")(1 10 "ds")(1 13 "e")
                                          ) #9 #5

\relative c' {
 %<>^\eclapC^"Eric Clapton" cs, ds fs gs b cs ds e fs gs a cs ds e
 <>^\eclapV cs ds fs gs b cs ds e fs gs a cs ds e
}

%---------------------------------------------------

---

From: Martial R <[email-masked]>
Date: Thu, 5 Oct 2023 13:39:19 +0200

Bonjour,
c'est mieux d'envoyer les messages aussi sur la liste,
plus on est
plus on peut répondre mieux :- )

%------------------------La couleur
troisnotes=\markup\bold\verbose-diagramm #'((6 9 "cs")(6 11 "ds" orange)(6
12 "e" red)) #9 #5

\relative c' {
 <>^\troisnotes cs ds e
}
%-------------------------------------------

liste des couleurs
http://lilypond.org/doc/v2.24/Documentation/notation/list-of-colors

-- 
Martial Rameaux

---

From: Jean-Loups <[email-masked]>
Date: Fri, 06 Oct 2023 01:26:51 +0200

https://www.youtube.com/watch?v=YLP6TPzfEnE

Le vendredi 06 octobre 2023 à 01:18 +0200, Jean-Loups a écrit :
> j'ai aussi toutes les phrases blues à mettre au propre
> 
> Le vendredi 06 octobre 2023 à 01:13 +0200, Jean-Loups a écrit :
> > \version "2.22.1"
> > % arg2 is the number of unique tones in the scale (i.e. 7 for major
> > scale, 5 for pentatonic)
> > #(define-markup-command (scale-diagramm layout props arg1 arg2
> > arg3) (list? integer? number?)
> > #(define-markup-command (verbose-diagramm layout props arg1 arg2
> > arg3) (list? integer? number?)
> > eclapV=\markup\bold\verbose-diagramm #'((6 9 "cs")(6 11 "ds")(6 12
> > "e" red) 
> > (5 9 "fs")(5 11 "gs" geen) (5 12 "a")
> > (4 9 "b" green)(4 11 "cs")
> > (3 8 "ds")(3 9 "e" red)(3 11 "fs") 
> > (2 9 "gs"green) (2 10 "a") (2 12 "b" green)
> > (1 9 "cs")(1 11 "ds")(1 12 "e" red) 
> > ) #9 #5
> > 
> > \relative c' {
> > %<>^\eclapC^"Eric Clapton" cs ds e fs gs a b cs ds e fs gs a b cs
> > ds e 
> > <>^\eclapV cs ds e fs gs a b cs ds e fs gs a b cs ds e 
> > }
> > 
> > reste plus qu'a mettre en couleur sur la partition et le tittre et
> > l'auteur et le nom de la gamme
> > jl
> > 
> > Le jeudi 05 octobre 2023 à 13:39 +0200, Martial R a écrit :
> > > 
> > > Bonjour, 
> > > troisnotes=\markup\bold\verbose-diagramm #'((6 9 "cs")(6 11 "ds"
> > > orange)(6 12 "e" red)) #9 #5                                    
> > >     
> > >                                          
> > > \relative c' {
> > >  <>^\troisnotes cs ds e 
> > > }

---

From: Jean-Loups <[email-masked]>
Date: Fri, 06 Oct 2023 22:58:28 +0200

salut,
j'ai encore toutes les phrases blues à écrire
https://images.franceserv.fr/image/E29
ça avance ça avance...

Le vendredi 06 octobre 2023 à 01:26 +0200, Jean-Loups a écrit :
> > > % arg2 is the number of unique tones in the scale (i.e. 7 for
> > > major scale, 5 for pentatonic)
> > > eclapV=\markup\bold\verbose-diagramm #'((6 9 "cs")(6 11 "ds")(6
> > > 12 "e" red) 
> > > reste plus qu'a mettre en couleur sur la partition et le tittre
> > > et l'auteur et le nom de la gamme
> > > jl
> > > 
> > > > troisnotes=\markup\bold\verbose-diagramm #'((6 9 "cs")(6 11
> > > > "ds" orange)(6 12 "e" red)) #9 #5                              
> > > >           
> > > >                                          
> > > > \relative c' {
> > > >  <>^\troisnotes cs ds e 
> > > > }