Subject: Accords jazz notés différemment en ChordNames et en ChordGrid

From: Denis Bitouzé <[email-masked]>
Date: Mon, 10 Apr 2023 12:05:16 +0200

Bonjour,

quelqu'un sait-il pourquoi les accords jazz sont notés différemment en
`ChordNames` et en `ChordGrid`, ainsi qu'en atteste l'ECM suivant, et
surtout comment faire pour qu'ils soient notés en `ChordGrid` comme en
`ChordNames` ?

Merci d'avance.

--8<---------------cut here---------------start------------->8---
\version "2.24.1"
\include "jazzchords.ily"
\paper {
  #(define fonts
    (set-global-fonts
      #:sans "lilyjazz-chord"
  ))
}

theChords = \chordmode { c1:maj }

\score {
  <<
    \new ChordNames \theChords
  \layout { }
}

\new ChordGrid \theChords
--8<---------------cut here---------------end--------------->8---
-- 
Denis

---

From: Jean Abou Samra <[email-masked]>
Date: Mon, 10 Apr 2023 18:44:47 +0200

> surtout comment faire pour qu'ils soient notés en `ChordGrid` comme en  

Dans le jazzchords.ily d'[ici](https://github.com/OpenLilyPondFonts/lilyjazz/tree/master/stylesheet), je trouve

```
\layout {
  \context {
    \ChordNames
    chordRootNamer = #JazzChordNames	% update the chord names
    chordNameExceptions = #JazzChords	% update the chord exceptions
    \override ChordName.font-name = #"lilyjazz-chord"  % use the custom font for displaying the chords
  }
}
```

Il faudrait remettre la même chose dans un bloc pour `ChordGrid`, c'est à dire :

```
\layout {
  \context {
    \ChordNames
    chordRootNamer = #JazzChordNames	% update the chord names
    chordNameExceptions = #JazzChords	% update the chord exceptions
    \override ChordName.font-name = #"lilyjazz-chord"  % use the custom font for displaying the chords
  }
  \context {
    \ChordGrid
    chordRootNamer = #JazzChordNames	% update the chord names
    chordNameExceptions = #JazzChords	% update the chord exceptions
    \override ChordName.font-name = #"lilyjazz-chord"  % use the custom font for displaying the chords
  }
}
```

(à faire de préférence dans un nouveau fichier inclus pour éviter d'écraser ceci à la prochaine mise à jour de Lilyjazz).

Cordialement,

Jean

---

From: Denis Bitouzé <[email-masked]>
Date: Mon, 10 Apr 2023 22:15:22 +0200

Le 10/04/23 à 18h44, Jean Abou Samra a écrit :

> [...]

Avec Jean, les oignons sont toujours petits :) Merci bien !

Cordialement.
-- 
Denis