Subject: Lilypond sous macos M1

From: Ben <[email-masked]>
Date: Wed, 1 Mar 2023 20:13:03 +0100

Bonjour, 

Les diverses réflexions sur frescobaldi m'ont amené à essayer de mieux comprendre ce qui se passe avec lilypond version macos:

D'abord, le lien du site https://lilypond.org/doc/v2.25/Documentation/changes.fr.pdf <https://lilypond.org/doc/v2.25/Documentation/changes.fr.pdf> est actuellement mort.

Ensuite, pourquoi est-ce que lilypond n'est fourni pour macos qu'en Intel et pas en M1? Y-a-t-il là aussi des problèmes de compilation?

Enfin, j'ai essayé d'installer lilypond-devel via macport: 

Déjà, seule la version 25.5.1 est disponible, et pas la 25.5.2, puis elle est bien en M1, comme pour frescobaldi

Mais lorsque j'ajoute /opt/local/bin/lilypond dans frescobaldi et que je compile, j'obtiens cette erreur:

 warning: g_spawn_sync failed (-1): gs: Failed to execute child process “gs” (No such file or directory)
warning: `(gs -q -dNODISPLAY -dNOSAFER -dNOPAUSE -dBATCH -dAutoRotatePages=/None -dPrinted=false /var/folders/nh/rtfxzmdn3gx18fwg6lbw4dfc0000gn/T//lilypond-tmp-7030529)' failed (-1)

/opt/local/share/lilypond/2.25.1/ly/init.ly:64:2: error: Guile signaled an error for the expression beginning here
#
 (let ((book-handler (if (defined? 'default-toplevel-book-handler)
Throw to key `ly-file-failed' with args `()'.
Arrêté avec le code de retour 1.

Est-ce que vous auriez une idée du problème?

Au plaisir, 

Ben

---

From: Jean Abou Samra <[email-masked]>
Date: Wed, 01 Mar 2023 21:55:59 +0100

Le mercredi 01 mars 2023 à 20:13 +0100, Ben a écrit :
> D'abord, le lien du site [https://lilypond.org/doc/v2.25/Documentation/changes.fr.pdf](https://lilypond.org/doc/v2.25/Documentation/changes.fr.pdf) est actuellement mort.

C'est normal, la liste des changements est habituellement traduite en français, mais en 2.25.2 elle ne l'était pas encore. C'est déjà fait par Jean-Charles, cela apparaîtra dans la 2.25.3. En attendant, vous pouvez lire la version originale en anglais (remplacer `.fr.pdf` par `.pdf` dans l'URL).

> Ensuite, pourquoi est-ce que lilypond n'est fourni pour macos qu'en Intel et pas en M1? Y-a-t-il là aussi des problèmes de compilation?

Plutôt des problèmes d'infrastructure, car à ma connaissance la compilation ne pose pas de souci particulier, mais la seule machine macOS à laquelle Jonas Hahnfeld (le responsable de la parution des nouvelles versions) ait accès est la même machine que moi jusqu'ici, celle louée à distance qui tourne sous macOS 10.15 et processeur Intel. Je ne sais pas s'il a envisagé d'utiliser les GitHub actions (notez que c'est un choix un peu moins naturel pour LilyPond que pour Frescobaldi, car le projet LilyPond est hébergé sous GitLab, pas GitHub). Si vous voulez poser la question, c'est à la liste [lilypond-devel](https://lists.gnu.org/mailman/listinfo/lilypond-devel) qu'il faut écrire.

> Déjà, seule la version 25.5.1 est disponible, et pas la 25.5.2, puis elle est bien en M1, comme pour frescobaldi

La 2.25.2 a moins de deux semaines, c'est normal qu'il faille un peu de temps aux redistributeurs pour intégrer les nouvelles versions.

Au passage, LilyPond peut aussi s'installer via Homebrew, avec a priori des binaires natives M1 et une installation plus rapide. Par contre c'est la 2.24.1, j'imagine qu'il va essayer de compiler si vous installez avec `--HEAD`.

> /opt/local/share/lilypond/2.25.1/ly/[init.ly:64](http://init.ly:64):2: error: Guile signaled an error for the expression beginning here  
> #  

Quelques questions :

- Est-ce que la même chose se produit en ligne de commande si vous faites `/opt/local/bin/lilypond fichier.ly` ?

- Est-ce que vous pouvez donner la sortie avec l'option `--verbose`, en ligne de commande comme depuis Frescobaldi ? Dans le premier cas, faire `/opt/local/bin/lilypond --verbose fichier.ly`, et dans le second, menu LilyPond > Graver (personnalisé) et rajouter « --verbose » dans les options supplémentaires.

- Qu'est-ce qui s'affiche dans le log en compilant (en ligne de commande comme dans Frescobaldi) le fichier suivant ?

  ```
  \version "2.25.2"
  
  #(ly:message "LD_LIBRARY_PATH=~s" (getenv "LD_LIBRARY_PATH"))
  ```

Cordialement,

Jean

---

From: Ben <[email-masked]>
Date: Wed, 1 Mar 2023 22:35:02 +0100

> Le 1 mars 2023 à 21:55, Jean Abou Samra <[email-masked]> a écrit :
> 
> C'est normal, la liste des changements est habituellement traduite en français, mais en 2.25.2 elle ne l'était pas encore. C'est déjà fait par Jean-Charles, cela apparaîtra dans la 2.25.3. En attendant, vous pouvez lire la version originale en anglais (remplacer .fr.pdf par .pdf dans l'URL).
> 
D'accord.
> Plutôt des problèmes d'infrastructure, car à ma connaissance la compilation ne pose pas de souci particulier, mais la seule machine macOS à laquelle Jonas Hahnfeld (le responsable de la parution des nouvelles versions) ait accès est la même machine que moi jusqu'ici, celle louée à distance qui tourne sous macOS 10.15 et processeur Intel. Je ne sais pas s'il a envisagé d'utiliser les GitHub actions (notez que c'est un choix un peu moins naturel pour LilyPond que pour Frescobaldi, car le projet LilyPond est hébergé sous GitLab, pas GitHub). Si vous voulez poser la question, c'est à la liste lilypond-devel <https://lists.gnu.org/mailman/listinfo/lilypond-devel> qu'il faut écrire.
> 
> 
Si ce n'est pas très compliqué, et qu'il y a une marche à suivre, je peux volontiers le faire sur mon M1, il faut pour cela que je repose la question en anglais sur la liste lilypond-devel?
> Au passage, LilyPond peut aussi s'installer via Homebrew, avec a priori des binaires natives M1 et une installation plus rapide. Par contre c'est la 2.24.1, j'imagine qu'il va essayer de compiler si vous installez avec --HEAD.
> 
> 
Ce serait étonnant, car homebrew nécessite que l'on envoie des dmg, donc si la version M1 existait en dmg pour homebrew, il l'aurait forcément aussi mise sur le site.

>> /opt/local/share/lilypond/2.25.1/ly/init.ly:64 <http://init.ly:64/>:2: error: Guile signaled an error for the expression beginning here
>> 
>> Throw to key ly-file-failed' with args ()'.
> Est-ce que la même chose se produit en ligne de commande si vous faites /opt/local/bin/lilypond fichier.ly ?
> 
> 
Non, là cela fonctionne correctement.
> 
> Est-ce que vous pouvez donner la sortie avec l'option --verbose, en ligne de commande comme depuis Frescobaldi ? Dans le premier cas, faire /opt/local/bin/lilypond --verbose fichier.ly, et dans le second, menu LilyPond > Graver (personnalisé) et rajouter « --verbose » dans les options supplémentaires.
> 
> 
Voir ci-dessous.
> 
> Qu'est-ce qui s'affiche dans le log en compilant (en ligne de commande comme dans Frescobaldi) le fichier suivant ?
> 
> \version "2.25.2"
> 

J'ai changé version à 2.25.1:

Frescobaldi: 
 Démarrage lilypond 2.25.1 [Test.ly]...
Processing `/Users/benedikt/Desktop/Test.ly'
Parsing...
LD_LIBRARY_PATH="/opt/local/lib"
Success: compilation successfully completed
Terminé avec succès en 0.3".

Terminal:
GNU LilyPond 2.25.1 (exécution de Guile 2.2)
Traitement de « /Users/benedikt/Desktop/Test.ly »
Analyse...
LD_LIBRARY_PATH=#f
Compilation menée à son terme, avec succès.

Au plaisir, 

Ben

__________________________________________________________________
Verbose frescobaldi:

 Démarrage lilypond 2.25.1 [Test.ly]...
Log level set to 287

Relocation
  LilyPond binary has absolute file name:
    /opt/local/libexec/lilypond-bin
  Setting INSTALLER_PREFIX to '/opt/local'
  Using run-time value for datadir,
    setting it to '/opt/local/share/lilypond/2.25.1'
  Using run-time value for libdir,
    setting it to '/opt/local/lib/lilypond/2.25.1'
  Using run-time value for localedir,
    setting it to '/opt/local/share/locale'
  Using compile-time value for relocdir,
    setting it to ''
  Prepending '/opt/local/libexec' to PATH
  Setting PATH to '/opt/local/libexec:/usr/bin:/bin:/usr/sbin:/sbin'
Setting GUILE_AUTO_COMPILE to '0'
Setting GUILE_WARN_DEPRECATED to 'detailed'
Setting XDG_CACHE_HOME to '/opt/local/share/lilypond/2.25.1'
Setting GC_INITIAL_HEAP_SIZE to '40M'
Setting GC_NPROCS to '1'
Setting GC_FREE_SPACE_DIVISOR to '1'

Effective prefix: '/opt/local/share/lilypond/2.25.1'
PATH="/opt/local/libexec:/usr/bin:/bin:/usr/sbin:/sbin"

[]
[/opt/local/share/lilypond/2.25.1/scm/lily/lily-library.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/output-lib.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/markup-macros.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/parser-ly-from-scheme.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/file-cache.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/define-event-classes.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/define-music-callbacks.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/define-music-types.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/define-note-names.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/c++.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/chord-entry.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/skyline.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/markup.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/define-markup-commands.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/stencil.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/modal-transforms.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/chord-ignatzek-names.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/music-functions.scm
[/opt/local/share/lilypond/2.25.1/scm/lily/define-music-display-methods.scm]
]
[/opt/local/share/lilypond/2.25.1/scm/lily/part-combiner.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/autochange.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/define-music-properties.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/time-signature.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/time-signature-settings.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/auto-beam.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/chord-name.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/define-context-properties.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/translation-functions.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/breath.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/script.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/midi.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/layout-beam.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/parser-clef.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/layout-slur.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/font.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/font-encodings.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/bar-line.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/flag-styles.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/fret-diagrams.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/tablature.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/harp-pedals.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/define-woodwind-diagrams.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/display-woodwind-diagrams.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/predefined-fretboards.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/define-grob-properties.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/define-grobs.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/define-grob-interfaces.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/define-stencil-commands.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/scheme-engravers.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/scheme-performers.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/titling.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/paper.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/backend-library.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/color.scm]
(primitive-load-path lily): 0.05 seconds
Initializing FontConfig...
Adding fontconfig configuration file: /opt/local/share/lilypond/2.25.1/fonts/00-lilypond-fonts.conf
Adding fontconfig configuration file: /opt/local/etc/fonts/fonts.conf
Adding fontconfig configuration file: /opt/local/share/lilypond/2.25.1/fonts/99-lilypond-fonts.conf
Adding font directory: /opt/local/share/lilypond/2.25.1/fonts/otf
Building font database...

[/opt/local/share/lilypond/2.25.1/ly/declarations-init.ly[/opt/local/share/lilypond/2.25.1/ly/music-functions-init.ly][/opt/local/share/lilypond/2.25.1/ly/toc-init.ly]
Using `nederlands' note names...[/opt/local/share/lilypond/2.25.1/ly/drumpitch-init.ly][/opt/local/share/lilypond/2.25.1/ly/chord-modifiers-init.ly][/opt/local/share/lilypond/2.25.1/ly/script-init.ly][/opt/local/share/lilypond/2.25.1/ly/chord-repetition-init.ly][/opt/local/share/lilypond/2.25.1/ly/scale-definitions-init.ly][/opt/local/share/lilypond/2.25.1/ly/dynamic-scripts-init.ly][/opt/local/share/lilypond/2.25.1/ly/spanners-init.ly][/opt/local/share/lilypond/2.25.1/ly/predefined-fretboards-init.ly][/opt/local/share/lilypond/2.25.1/ly/string-tunings-init.ly][/opt/local/share/lilypond/2.25.1/ly/property-init.ly][/opt/local/share/lilypond/2.25.1/ly/grace-init.ly][/opt/local/share/lilypond/2.25.1/ly/midi-init.ly[/opt/local/share/lilypond/2.25.1/ly/performer-init.ly]][/opt/local/share/lilypond/2.25.1/ly/paper-defaults-init.ly[/opt/local/share/lilypond/2.25.1/ly/titling-init.ly][/opt/local/share/lilypond/2.25.1/ly/text-replacements.ly]][/opt/local/share/lilypond/2.25.1/ly/context-mods-init.ly][/opt/local/share/lilypond/2.25.1/ly/engraver-init.ly]]
Processing `/Users/benedikt/Desktop/Test.ly'
Parsing...[/opt/local/share/lilypond/2.25.1/ly/init.ly
Using `nederlands' note names...[/Users/benedikt/Desktop/Test.ly]
Interpreting music...
elapsed time: 0.00 seconds
Element count 55 (spanners 6) 
Preprocessing graphical objects...
Grob count 103
[/opt/local/share/lilypond/2.25.1/fonts/otf/emmentaler-11.otf
CFF name for font Emmentaler-11 is the same.]
[/opt/local/share/lilypond/2.25.1/fonts/otf/emmentaler-13.otf
CFF name for font Emmentaler-13 is the same.]
[/opt/local/share/lilypond/2.25.1/fonts/otf/emmentaler-14.otf
CFF name for font Emmentaler-14 is the same.]
[/opt/local/share/lilypond/2.25.1/fonts/otf/emmentaler-16.otf
CFF name for font Emmentaler-16 is the same.]
[/opt/local/share/lilypond/2.25.1/fonts/otf/emmentaler-18.otf
CFF name for font Emmentaler-18 is the same.]
[/opt/local/share/lilypond/2.25.1/fonts/otf/emmentaler-20.otf
CFF name for font Emmentaler-20 is the same.]
[/opt/local/share/lilypond/2.25.1/fonts/otf/emmentaler-23.otf
CFF name for font Emmentaler-23 is the same.]
Finding the ideal number of pages...
[lilypond_serif_3.8662109375]
CFF name for font C059-Roman is the same.
Fitting music on 1 page...
Drawing systems...
Element count 109
Initializing embedded CFF font list.
Found file in search path: /opt/local/share/fonts/urw-core35-fonts/C059-Roman.otf -> /opt/local/share/fonts/urw-core35-fonts/C059-Roman.otf
Embedding CFF font `C059-Roman'.
[/opt/local/share/fonts/urw-core35-fonts/C059-Roman.otf]
Found file in search path: music-drawing-routines.ps -> /opt/local/share/lilypond/2.25.1/ps/music-drawing-routines.ps
Found file in search path: lilyponddefs.ps -> /opt/local/share/lilypond/2.25.1/ps/lilyponddefs.ps
Paper_outputter elapsed time: 0.01 seconds
Converting to `Test.pdf'...
Preparing Ghostscript command to `/var/folders/nh/rtfxzmdn3gx18fwg6lbw4dfc0000gn/T//lilypond-tmp-2745269': mark /OutputFile (./lilypond-tmp-6566008.pdf) /CompatibilityLevel 1.4 /PageSize [595.28 841.89] (pdfwrite) finddevice putdeviceprops pop (pdfwrite) selectdevice newpath fill (/var/folders/nh/rtfxzmdn3gx18fwg6lbw4dfc0000gn/T//lilypond-tmp-6566008) (r) file .setsafe run
Invoking `gs -dNODISPLAY -dNOSAFER -dNOPAUSE -dBATCH -dAutoRotatePages=/None -dPrinted=false /var/folders/nh/rtfxzmdn3gx18fwg6lbw4dfc0000gn/T//lilypond-tmp-2745269'...
warning: g_spawn_sync failed (-1): gs: Failed to execute child process “gs” (No such file or directory)
warning: `(gs -dNODISPLAY -dNOSAFER -dNOPAUSE -dBATCH -dAutoRotatePages=/None -dPrinted=false /var/folders/nh/rtfxzmdn3gx18fwg6lbw4dfc0000gn/T//lilypond-tmp-2745269)' failed (-1)

/opt/local/share/lilypond/2.25.1/ly/init.ly:64:2: error: Guile signaled an error for the expression beginning here
#
 (let ((book-handler (if (defined? 'default-toplevel-book-handler)
/opt/local/share/lilypond/2.25.1/scm/lily/lily.scm          14 (# #<?>)
In /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_textproc_lilypond/lilypond-devel/work/lilypond-2.25.1/out/share/lilypond/current/scm/lily/lily.scm:
   902:16 13 (lilypond-main _)
    931:4 12 (lilypond-all _)
In srfi/srfi-1.scm:
    640:9 11 (for-each #<procedure 104f1ecf0 at /opt/local/var/macp?> ?)
In /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_textproc_lilypond/lilypond-devel/work/lilypond-2.25.1/out/share/lilypond/current/scm/lily/lily.scm:
    941:9 10 (_ _)
In ice-9/boot-9.scm:
    829:9  9 (catch _ _ #<procedure 104f09000 at /opt/local/var/mac?> ?)
In unknown file:
           8 (ly:parse-file "/Users/benedikt/Desktop/Test.ly")
           7 (apply-smob/1 #<catch-closure 10549cca0>)
           6 (ly:book-process #<Book> #< Output_def> #< Output_def> #)
In /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_textproc_lilypond/lilypond-devel/work/lilypond-2.25.1/out/share/lilypond/current/scm/lily/backend-library.scm:
    319:4  5 (postprocess-output #< Output_def> #<directory (lily f?> ?)
In srfi/srfi-1.scm:
    640:9  4 (for-each #<procedure 104f72980 at /opt/local/var/macp?> ?)
In /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_textproc_lilypond/lilypond-devel/work/lilypond-2.25.1/out/share/lilypond/current/scm/lily/backend-library.scm:
    139:4  3 (postscript->pdf _ _ _ _ #f)
     57:4  2 (ly:gs-cli _ _)
In ice-9/boot-9.scm:
   751:25  1 (dispatch-exception 0 ly-file-failed ())
In unknown file:
           0 (apply-smob/1 #<catch-closure 10549cc60> ly-file-failed)
Throw to key `ly-file-failed' with args `()'.
Arrêté avec le code de retour 1.

_________________________________________________________________________
Verbose terminal: 

Niveau de journalisation fixé à 287
GNU LilyPond 2.25.1 (exécution de Guile 2.2)

Relocalisation
  Le binaire LilyPond a un chemin absolu :
    /opt/local/libexec/lilypond-bin
  Setting de INSTALLER_PREFIX à /opt/local
  Utilisation de la valeur run-time pour datadir,
    déterminée à « /opt/local/share/lilypond/2.25.1 »
  Utilisation de la valeur run-time pour libdir,
    déterminée à « /opt/local/lib/lilypond/2.25.1 »
  Utilisation de la valeur run-time pour localedir,
    déterminée à « /opt/local/share/locale »
  Utilisation de la valeur compile-time pour relocdir,
    déterminée à «  »
  Ajout de « /opt/local/libexec »  à PATH
  Setting de PATH à /opt/local/libexec:/opt/local/bin:/opt/local/sbin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/Library/Apple/usr/bin
Setting de GUILE_AUTO_COMPILE à 0
Setting de GUILE_WARN_DEPRECATED à detailed
Setting de XDG_CACHE_HOME à /opt/local/share/lilypond/2.25.1
Setting de GC_INITIAL_HEAP_SIZE à 40M
Setting de GC_NPROCS à 1
Setting de GC_FREE_SPACE_DIVISOR à 1

Préfixe effectif : « /opt/local/share/lilypond/2.25.1 »
PATH="/opt/local/libexec:/opt/local/bin:/opt/local/sbin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/Library/Apple/usr/bin"

[/opt/local/share/lilypond/2.25.1/scm/lily/lily.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/lily-library.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/output-lib.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/markup-macros.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/parser-ly-from-scheme.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/file-cache.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/define-event-classes.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/define-music-callbacks.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/define-music-types.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/define-note-names.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/c++.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/chord-entry.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/skyline.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/markup.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/define-markup-commands.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/stencil.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/modal-transforms.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/chord-ignatzek-names.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/music-functions.scm
[/opt/local/share/lilypond/2.25.1/scm/lily/define-music-display-methods.scm]
]
[/opt/local/share/lilypond/2.25.1/scm/lily/part-combiner.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/autochange.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/define-music-properties.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/time-signature.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/time-signature-settings.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/auto-beam.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/chord-name.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/define-context-properties.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/translation-functions.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/breath.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/script.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/midi.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/layout-beam.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/parser-clef.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/layout-slur.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/font.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/font-encodings.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/bar-line.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/flag-styles.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/fret-diagrams.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/tablature.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/harp-pedals.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/define-woodwind-diagrams.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/display-woodwind-diagrams.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/predefined-fretboards.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/define-grob-properties.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/define-grobs.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/define-grob-interfaces.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/define-stencil-commands.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/scheme-engravers.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/scheme-performers.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/titling.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/paper.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/backend-library.scm]
[/opt/local/share/lilypond/2.25.1/scm/lily/color.scm]
(primitive-load-path lily) : 0.05 secondes
Initialisation de FontConfig...
Ajout du fichier de configuration de fontconfig : « /opt/local/share/lilypond/2.25.1/fonts/00-lilypond-fonts.conf »
Ajout du fichier de configuration de fontconfig : « /opt/local/etc/fonts/fonts.conf »
Ajout du fichier de configuration de fontconfig : « /opt/local/share/lilypond/2.25.1/fonts/99-lilypond-fonts.conf »
Ajout d'un répertoire de fontes : « /opt/local/share/lilypond/2.25.1/fonts/otf »
Construction de la base de donnée des fontes...

[/opt/local/share/lilypond/2.25.1/ly/declarations-init.ly[/opt/local/share/lilypond/2.25.1/ly/music-functions-init.ly][/opt/local/share/lilypond/2.25.1/ly/toc-init.ly]
Utilisation de « nederlands » pour le nom des notes...[/opt/local/share/lilypond/2.25.1/ly/drumpitch-init.ly][/opt/local/share/lilypond/2.25.1/ly/chord-modifiers-init.ly][/opt/local/share/lilypond/2.25.1/ly/script-init.ly][/opt/local/share/lilypond/2.25.1/ly/chord-repetition-init.ly][/opt/local/share/lilypond/2.25.1/ly/scale-definitions-init.ly][/opt/local/share/lilypond/2.25.1/ly/dynamic-scripts-init.ly][/opt/local/share/lilypond/2.25.1/ly/spanners-init.ly][/opt/local/share/lilypond/2.25.1/ly/predefined-fretboards-init.ly][/opt/local/share/lilypond/2.25.1/ly/string-tunings-init.ly][/opt/local/share/lilypond/2.25.1/ly/property-init.ly][/opt/local/share/lilypond/2.25.1/ly/grace-init.ly][/opt/local/share/lilypond/2.25.1/ly/midi-init.ly[/opt/local/share/lilypond/2.25.1/ly/performer-init.ly]][/opt/local/share/lilypond/2.25.1/ly/paper-defaults-init.ly[/opt/local/share/lilypond/2.25.1/ly/titling-init.ly][/opt/local/share/lilypond/2.25.1/ly/text-replacements.ly]][/opt/local/share/lilypond/2.25.1/ly/context-mods-init.ly][/opt/local/share/lilypond/2.25.1/ly/engraver-init.ly]]
Traitement de « /Users/benedikt/Desktop/Test.ly »
Analyse...[/opt/local/share/lilypond/2.25.1/ly/init.ly
Utilisation de « nederlands » pour le nom des notes...[/Users/benedikt/Desktop/Test.ly]
Interprétation en cours de la musique...
temps écoulé : 0.00 secondes
55 éléments dénombrés (6 extensions)
Pré-traitement des éléments graphiques...
103 objets graphiques (grob) dénombrés.
[/opt/local/share/lilypond/2.25.1/fonts/otf/emmentaler-11.otf
nom CFF de la fonte Emmentaler-11 identique.]
[/opt/local/share/lilypond/2.25.1/fonts/otf/emmentaler-13.otf
nom CFF de la fonte Emmentaler-13 identique.]
[/opt/local/share/lilypond/2.25.1/fonts/otf/emmentaler-14.otf
nom CFF de la fonte Emmentaler-14 identique.]
[/opt/local/share/lilypond/2.25.1/fonts/otf/emmentaler-16.otf
nom CFF de la fonte Emmentaler-16 identique.]
[/opt/local/share/lilypond/2.25.1/fonts/otf/emmentaler-18.otf
nom CFF de la fonte Emmentaler-18 identique.]
[/opt/local/share/lilypond/2.25.1/fonts/otf/emmentaler-20.otf
nom CFF de la fonte Emmentaler-20 identique.]
[/opt/local/share/lilypond/2.25.1/fonts/otf/emmentaler-23.otf
nom CFF de la fonte Emmentaler-23 identique.]
Détermination du nombre optimal de pages...
[lilypond_serif_3.8662109375]
nom CFF de la fonte C059-Roman identique.
Répartition de la musique sur une page...
Dessin des systèmes...
109 éléments dénombrés.
Initialisation de la liste des fontes CFF à empaqueter.
Found file in search path: /opt/local/share/fonts/urw-core35-fonts/C059-Roman.otf -> /opt/local/share/fonts/urw-core35-fonts/C059-Roman.otf
Embarquement de la fonte « C059-Roman ».
[/opt/local/share/fonts/urw-core35-fonts/C059-Roman.otf]
Found file in search path: music-drawing-routines.ps -> /opt/local/share/lilypond/2.25.1/ps/music-drawing-routines.ps
Found file in search path: lilyponddefs.ps -> /opt/local/share/lilypond/2.25.1/ps/lilyponddefs.ps
temps d'activité de Paper_outputter : 0.01 secondes
Conversion à « Test.pdf »...
Préparation de la commande GhostScript pour « /var/folders/nh/rtfxzmdn3gx18fwg6lbw4dfc0000gn/T//lilypond-tmp-3394622 » :
  mark /OutputFile (./lilypond-tmp-5723017.pdf) /CompatibilityLevel 1.4 /PageSize [595.28 841.89] (pdfwrite) finddevice putdeviceprops pop (pdfwrite) selectdevice newpath fill (/var/folders/nh/rtfxzmdn3gx18fwg6lbw4dfc0000gn/T//lilypond-tmp-5723017) (r) file .setsafe run
Appel de « gs -dNODISPLAY -dNOSAFER -dNOPAUSE -dBATCH -dAutoRotatePages=/None -dPrinted=false /var/folders/nh/rtfxzmdn3gx18fwg6lbw4dfc0000gn/T//lilypond-tmp-3394622 »...

GPL Ghostscript 9.56.1 (2022-04-04)
Copyright (C) 2022 Artifex Software, Inc.  All rights reserved.
This software is supplied under the GNU AGPLv3 and comes with NO WARRANTY:
see the file COPYING for details.
gc time taken: 0.13261
]
Compilation menée à son terme, avec succès.

---

From: Jean Abou Samra <[email-masked]>
Date: Thu, 02 Mar 2023 01:37:17 +0100

> Si ce n'est pas très compliqué, et qu'il y a une marche à suivre, je peux volontiers le faire sur mon M1, il faut pour cela que je repose la question en anglais sur la liste lilypond-devel?  

Ce n'est pas très compliqué, mais c'est une responsabilité importante, il faut vraiment que vous soyiez disponible pour faire ça à chaque fois qu'une nouvelle version sort. Enfin, mieux vaut qu'on en discute sur lilypond-devel.

> Ce serait étonnant, car homebrew nécessite que l'on envoie des dmg, donc si la version M1 existait en dmg pour homebrew, il l'aurait forcément aussi mise sur le site.

Je ne comprends pas trop ce que vous voulez dire.

À ma connaissance, le système de “brew cask” installe des applications graphiques, mais le reste, non.

(Je regarde le reste plus tard.)

---

From: Jean Abou Samra <[email-masked]>
Date: Thu, 02 Mar 2023 02:01:39 +0100

Je vois ce que c'est, mais je ne sais pas trop s'il faut le considérer comme un bug de MacPorts ou de Frescobaldi.

Le log du terminal indique qu'au départ, la variable PATH est mise à

```
/opt/local/bin:/opt/local/sbin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/Library/Apple/usr/bin
```

alors que dans Frescobaldi, c'est

```
/usr/bin:/bin:/usr/sbin:/sbin
```

Or le Ghostscript installé par MacPorts se trouve probablement dans `/opt/local/bin` (essayez `/opt/local/bin/gs --help`, je pense que cette commande doit exister).

À ce que je lis de [cette page](https://guide.macports.org/chunked/installing.shell.html), MacPorts change les fichiers de configuration du shell pour ajouter ses dossiers au `PATH`. C'est bien joli, mais ça ne marche qu'en lançant LilyPond depuis un shell.

Frescobaldi pourrait sans doute détecter une configuration MacPorts et ajouter les bons dossiers au `PATH`, mais ce n'est pas génial d'avoir du code pour chaque méthode d'installation possible de LilyPond dans chaque environnement d'édition comme Frescobaldi.

Je pense que MacPorts pourrait utiliser un [fichier de réadressage](https://lilypond.org/doc/v2.24/Documentation/usage/command_002dline-usage#relocation) pour régler le problème. Je n'en suis pas complètement sûr.

Je pense que ça devrait aller mieux si vous ouvrez Frescobaldi depuis un terminal.

Au passage, ça me surprend que vous soyiez le premier à faire part de ce problème. Je pensais qu'il y aurait plus de gens qui installeraient LilyPond depuis MacPorts.

---

From: Ben <[email-masked]>
Date: Thu, 2 Mar 2023 02:32:03 +0100

> Le 2 mars 2023 à 01:37, Jean Abou Samra <[email-masked]> a écrit :
> 
Je me suis inscrit et j'ai posté.

> (Je regarde le reste plus tard.)
De ce que j'ai compris de homebrew, c'est que l'on créé le cask à partir d'une application déjà compilée, contrairement à MacPort qui s'occupe de compiler tout par lui-même. 

Si donc l'équipe dev de lilypond n'a pas de version compilée M1, celle sur homebrew ne sera pas non plus compilée M1.

---

From: Jean Abou Samra <[email-masked]>
Date: Thu, 02 Mar 2023 02:38:38 +0100

> De ce que j'ai compris de homebrew, c'est que l'on créé le cask à partir d'une application déjà compilée, contrairement à MacPort qui s'occupe de compiler tout par lui-même.   

Justement, c'est ce qui se passe quand on crée un cask, mais LilyPond n'est pas distribuée par Homebrew sous forme de cask. Cf.

https://github.com/Homebrew/homebrew-core/issues/119476#issuecomment-1368278021

D'ailleurs, en repensant à ce bug de Homebrew, je me suis rendu compte que MacPorts a le même bug *soupir*...

https://trac.macports.org/ticket/67026#ticket

---

From: Ben <[email-masked]>
Date: Thu, 2 Mar 2023 03:05:02 +0100

En fait, je lançais frescobaldi par un script pour contourner le problème du bug des menus au démarrage…

Mais là, je l'ai lancé depuis le lien officiel de macport et cette fois, cela fonctionne. 

Je vais donc arrêter d'utiliser ce script et repasser par l'ancienne astuce qui consiste à ouvrir un fichier .ly depuis le finder quand le bug se produit.

Merci pour votre aide!

Ben

> Le 2 mars 2023 à 02:01, Jean Abou Samra <[email-masked]> a écrit :
> 
> Or le Ghostscript installé par MacPorts se trouve probablement dans /opt/local/bin (essayez /opt/local/bin/gs --help, je pense que cette commande doit exister).
> 
> À ce que je lis de cette page <https://guide.macports.org/chunked/installing.shell.html>, MacPorts change les fichiers de configuration du shell pour ajouter ses dossiers au PATH. C'est bien joli, mais ça ne marche qu'en lançant LilyPond depuis un shell.
> 
> Frescobaldi pourrait sans doute détecter une configuration MacPorts et ajouter les bons dossiers au PATH, mais ce n'est pas génial d'avoir du code pour chaque méthode d'installation possible de LilyPond dans chaque environnement d'édition comme Frescobaldi.
> 
> Je pense que MacPorts pourrait utiliser un fichier de réadressage <https://lilypond.org/doc/v2.24/Documentation/usage/command_002dline-usage#relocation> pour régler le problème. Je n'en suis pas complètement sûr.
>

---

From: Ben <[email-masked]>
Date: Thu, 2 Mar 2023 03:24:57 +0100

> Le 2 mars 2023 à 02:38, Jean Abou Samra <[email-masked]> a écrit :
> 
>>> Je ne comprends pas trop ce que vous voulez dire. À ma connaissance, le système de “brew cask” installe des applications graphiques, mais le reste, non. (Je regarde le reste plus tard.)
>>> 
D'accord, merci. 
> D'ailleurs, en repensant à ce bug de Homebrew, je me suis rendu compte que MacPorts a le même bug soupir...
> 
Ah bon? J'ai pourtant compilé avec la dernière version lilypond-devel de macport et les fonts sorties sont bien les C059. 

Au plaisir, 

Ben

---

From: Jean Abou Samra <[email-masked]>
Date: Thu, 02 Mar 2023 11:15:21 +0100

> Ah bon? J'ai pourtant compilé avec la dernière version lilypond-devel de macport et les fonts sorties sont bien les C059.

Mais d'où vient la police ? Que renvoie

```
#(ly:message "C059 file: ~a" (ly:font-config-get-font-file "C059"))
```

?

---

From: Ben <[email-masked]>
Date: Thu, 2 Mar 2023 11:27:08 +0100

De macport visiblement…

 Démarrage lilypond 2.25.1 [Sans titre]...
Processing `/var/folders/nh/rtfxzmdn3gx18fwg6lbw4dfc0000gn/T/frescobaldi-tjlintod/tmp2lf8z2xc/document.ly'
Parsing...
C059 file: /opt/local/share/fonts/urw-core35-fonts/C059-Roman.otf
Success: compilation successfully completed
Terminé avec succès en 0.4".

> Le 2 mars 2023 à 11:15, Jean Abou Samra <[email-masked]> a écrit :
>

---

From: Jean Abou Samra <[email-masked]>
Date: Thu, 02 Mar 2023 11:35:48 +0100

Le jeudi 02 mars 2023 à 11:27 +0100, Ben a écrit :
> Processing `/var/folders/nh/rtfxzmdn3gx18fwg6lbw4dfc0000gn/T/frescobaldi-tjlintod/tmp2lf8z2xc/[document.ly](http://document.ly)'  
> Parsing...  

Je vois que le Portfile installe le paquet urw-core35-fonts au moment de la compilation. Peut-être qu'il a tout simplement laissé ce paquet installé par la suite ?

Par contre, pour les polices TeX Gyre, la situation a l'air différente. Qu'est-ce que vous obtenez avec

```
#(ly:message "TeX Gyre file: ~a" (ly:font-config-get-font-file "TeX Gyre Schola"))
```

?

---

From: Ben <[email-masked]>
Date: Thu, 2 Mar 2023 11:42:35 +0100

Oui, en effet, mais là, la différence est seulement de style.

Quels paquets macport faudrait-il installer pour avoir également les polices TeX Gyre?

 Démarrage lilypond 2.25.1 [Sans titre]...
Processing `/var/folders/nh/rtfxzmdn3gx18fwg6lbw4dfc0000gn/T/frescobaldi-tjlintod/tmp2lf8z2xc/document.ly'
Parsing...
TeX Gyre file: /System/Library/Fonts/Supplemental/Kokonor.ttf
Success: compilation successfully completed
Terminé avec succès en 0.5".

> Le 2 mars 2023 à 11:35, Jean Abou Samra <[email-masked]> a écrit :
> 
>> Processing `/var/folders/nh/rtfxzmdn3gx18fwg6lbw4dfc0000gn/T/frescobaldi-tjlintod/tmp2lf8z2xc/document.ly <http://document.ly/>'
>> Parsing...

---

From: Jean Abou Samra <[email-masked]>
Date: Thu, 02 Mar 2023 11:53:39 +0100

> Oui, en effet, mais là, la différence est seulement de style.

Ouf, je ne suis pas complètement fou :-)

Par contre, je ne saisis pas ce que vous entendez par « différence de style ». LilyPond fait la promesse à ses utilisateurs que les police TeX Gyre Cursor/Heros/Schola sont disponibles, et cette promesse n'est pas tenue dans le paquet MacPorts puisque l'on obtient du Kokonor au lieu du TeX Gyre Schola. (C'est notamment important pour les caractères qui ne se trouvent pas dans les polices URW++, soit C059 et compagnie, comme, de mémoire, l'alphabet vietnamien.)

> Quels paquets macport faudrait-il installer pour avoir également les polices TeX Gyre?

Justement, c'est tout le problème : il n'y a pas de paquet MacPorts qui les fournisse. Comme indiqué dans les notes du port, au moment de l'installation, MacPorts cherche ces polices dans une distribution TeX externe à MacPorts, pointe LilyPond vers ces polices, et s'attend à ce que LilyPond installe ces polices en même temps que ses exécutables — ce que LilyPond ne fait plus depuis la 2.23.11. Donc les mainteneurs de MacPorts vont devoir créer un paqet pour ces polices.

Cordialement,

Jean

---

From: Ben <[email-masked]>
Date: Thu, 2 Mar 2023 12:10:19 +0100

> Le 2 mars 2023 à 11:53, Jean Abou Samra <[email-masked]> a écrit :
> 
Dans l'exemple donné, le caractère retourné était carrément faux (I au lieu de N). Dans l'exemple de compilation que j'ai essayé, seul l'aspect changeait. De ce fait, comme je n'utilise pas l'alphabet vietnamien, je n'aurais pas remarqué le bug. 

Mais du coup, le bug est rédhibitoire, car j'imagine quand même que certains caractères de musique vont être impactés!?

> Justement, c'est tout le problème : il n'y a pas de paquet MacPorts qui les fournisse. Comme indiqué dans les notes du port, au moment de l'installation, MacPorts cherche ces polices dans une distr…
Et en attendant cela, il aurait peut-être été judicieux de ne pas recommander l'installation lilypond sur macos autre que par le paquet intel…

Bon, ce n'est pas trop grave, j'imagine quand même que la plupart des utilisateurs macs installe lilypond avec les paquets intel, car ils ne sauraient de toute manière pas comment configurer frescobaldi avec le lilypond de brew ou de macport…

Au plaisir, 

Ben

---

From: Jean Abou Samra <[email-masked]>
Date: Thu, 02 Mar 2023 12:18:30 +0100

> Dans l'exemple donné, le caractère retourné était carrément faux (I au lieu de N). Dans l'exemple de compilation que j'ai essayé, seul l'aspect changeait. De ce fait, comme je n'utilise pas l'alpha…

La police par défaut sur les systèmes où un I sortait au lieu d'un N était différente de la vôtre, et buguée (rien à voir avec LilyPond pour le coup).

> Mais du coup, le bug est rédhibitoire, car j'imagine quand même que certains caractères de musique vont être impactés!?

Non, je ne dirais pas rédhibitoire, il ne se manifeste que si vous utilisez explicitement une police TeX Gyre (par exemple avec `\markup \override #'(font-name . "TeX Gyre Schola") "ABC"`), ou bien si vous utilisez le vietnamien. Vous n'aurez pas la police TeX Gyre Schola mais une police trouvée dans le système (en l'occurrence Kokonor).

Ça reste un bug quand même.

> Et en attendant cela, il aurait peut-être été judicieux de ne pas recommander l'installation lilypond sur macos autre que par le paquet intel…

En général, un bug, ça ne se prévoit pas...

Cordialement,

Jean

---

From: Ben <[email-masked]>
Date: Thu, 2 Mar 2023 12:30:06 +0100

> Le 2 mars 2023 à 12:18, Jean Abou Samra <[email-masked]> a écrit :
> 

D'accord.

> Non, je ne dirais pas rédhibitoire, il ne se manifeste que si vous utilisez explicitement une police TeX Gyre (par exemple avec \markup \override #'(font-name . "TeX Gyre Schola") "ABC"), ou bien si vous utilisez le vietnamien. Vous n'aurez pas la police TeX Gyre Schola mais une police trouvée dans le système (en l'occurrence Kokonor).
> 

D'accord, ce qui veut dire que le bug est au moins repérable, car ceux qui utilisent la TeX Gyre verront la différence, et les autres utilisateurs ne sont pas concernés. 
> En général, un bug, ça ne se prévoit pas...

Oui, c'était dans le cas où le bug était critique, là on peut estimer qu'il ne concernera qu'une petite minorité d'utilisateurs. 

Mais de manière plus générale, une page web détaillant l'installation de macport, frescobaldi et lilypond avec la manière de contourner les gros bugs ne serait pas de trop…

Au plaisir, 

Ben

---

From: Jean Abou Samra <[email-masked]>
Date: Thu, 02 Mar 2023 12:52:23 +0100

> Mais de manière plus générale, une page web détaillant l'installation de macport, frescobaldi et lilypond avec la manière de contourner les gros bugs ne serait pas de trop…

Écrire une telle page prend du temps et de l'énergie. À mon humble avis, ces ressources sont mieux dépensées à corriger les problèmes :)

---

From: Ben <[email-masked]>
Date: Thu, 2 Mar 2023 13:34:54 +0100

> Le 2 mars 2023 à 12:52, Jean Abou Samra <[email-masked]> a écrit :
> 
En effet, mais je mettrais au moins une seule ligne:

Mac ARM: la version x86_64 fonctionne via Rosetta, pour une version native, passez par macports (qui installera lilypond ici: /opt/local/bin/lilypond) ou par homebrew.