Subject: Spanners

From: "K. Blum" <[email-masked]>
Date: Wed, 8 Feb 2023 16:24:55 +0100

Bonjour Vincent,

> les extenseurs de lignes d'octavation se termine par un petit crochet
> genre ---------¬
> Ce n'est pas le cas des indication textuelle avec extension

peut-être comme ça?

% -------------------------------------------------
\version "2.24.0"
\relative c' {
   \override TextSpanner.bound-details.left.text = "Break"
   c1\startTextSpan
   c c\stopTextSpan
   r
   \override TextSpanner.dash-period = #1
   \override TextSpanner.dash-fraction = #0.5
   \override TextSpanner.bound-details.right.text = \markup { \draw-line
#'(0 . -1) }
   \once \override TextSpanner.bound-details.left.stencil-align-dir-y =
#CENTER

   c\startTextSpan
   c c\stopTextSpan
   r
}
% -------------------------------------------------

Il y a beaucoup d'inspiration içi:

https://lsr.di.unimi.it/LSR/Item?id=271

---

From: Martial R <[email-masked]>
Date: Wed, 8 Feb 2023 17:05:44 +0100

Bonjour,

j'ai cette fonction sous le coude
%--------------------------------------------
stop = \stopTextSpan}
textSp = #(define-event-function (str)(markup?)
           #{
            \tweak bound-details.left.text \markup $str
           % \tweak bound-details.left.text \markup \normal-text $str
            \tweak style #'line % mettre en commentaire pour des pointillés
            \tweak dash-period #0.8
            \tweak bound-details.left.stencil-align-dir-y #0
            \tweak bound-details.left-broken.attach-dir -1 % pos y du trait
            \tweak bound-details.left-broken.padding 1.5
            \tweak bound-details.left-broken.text ##f
            \tweak bound-details.right.padding -1.5 %pos x du trait vertical
            \tweak bound-details.right-broken.text ##f %pas de trait au
break-ligne
            \tweak bound-details.right.text
           \markup
           \with-dimensions #'(0 . 0) #'(-.3 . 0)
           \draw-line #'(0 . -1)
           \startTextSpan
           #})

\relative { c' e\textSp"Grr jusqu'au bout" \break e e c1 c c c c1\stop  }
%--------------------------------------------------------------------------------

-- 
Martial Rameaux

---

From: Vincent Gay <[email-masked]>
Date: Thu, 9 Feb 2023 00:37:50 +0100

Merci à vous deux, en personnalisant les paramètres j'arrive exactement 
à ce que je veux. Dans la mesure où ce sera le réglage par défaut 
j’intégrerai les override dans un layout.

Le 08/02/2023 à 17:05, Martial R a écrit :
>             \tweak bound-details.right-broken.text ##f %pas de trait 
> au break-ligne
>        \once \override
>     TextSpanner.bound-details.left.stencil-align-dir-y =
>     #CENTER
>
>        c\startTextSpan
>        c c\stopTextSpan
>        r
>     }

-- 
Vincent Gay
Envoyé depuis mon saxo-phone :)
https://myrealbook.vintherine.org/  -http://photos.vintherine.org/

---

From: Vincent Gay <[email-masked]>
Date: Thu, 9 Feb 2023 00:42:38 +0100

Le 09/02/2023 à 00:37, Vincent Gay a écrit :

Dans la mesure où ce sera le réglage par défaut j’intégrerai les override dans un layout.

Quoique... le TextSpanner.bound-details.right.text dépend de la direction du spanner...

--
Vincent Gay
Envoyé depuis mon saxo-phone :)
https://myrealbook.vintherine.org/ - http://photos.vintherine.org/

---

From: Jean Abou Samra <[email-masked]>
Date: Thu, 09 Feb 2023 13:45:33 +0100

>     Quoique... le TextSpanner.bound-details.right.text dépend de la     direction du spanner...  

Quelque chose comme ça, peut-être ?

```
\version "2.24.0"

#(use-modules (srfi srfi-2))

stop = \stopTextSpan
textSp = #(define-event-function (str)(markup?)
           #{
            \tweak bound-details.left.text \markup $str
            \tweak bound-details.left.text \markup \normal-text $str
            \tweak style #'line % mettre en commentaire pour des pointillés
            \tweak dash-period #0.8
            \tweak bound-details.left.stencil-align-dir-y #0
            \tweak bound-details.left-broken.attach-dir -1 % pos y du trait
            \tweak bound-details.left-broken.padding 1.5
            \tweak bound-details.left-broken.text ##f
            \tweak bound-details.right.padding -1.5 %pos x du trait vertical
            \tweak bound-details.right-broken.text ##f %pas de trait au break-ligne
            \tweak bound-details.right.text
           \markup
           \draw-line #'(0 . -1)
            \tweak right-bound-info
              #(grob-transformer
                'right-bound-info
                (lambda (grob orig)
                  (or (and-let* ((stencil (assq-ref orig 'stencil))
                                 ((eqv? DOWN (ly:grob-property grob 'direction))))
                        (let ((upside-down (ly:stencil-scale stencil 1 -1)))
                          (acons 'stencil upside-down orig)))
                      orig)))
           \startTextSpan
           #})

\relative { c' e\textSp"Grr jusqu'au bout" \break e e c1 c c c c1\stop  }
\relative { \textSpannerDown c' e\textSp"Grr jusqu'au bout" \break e e c1 c c c c1\stop  }
```

Au passage : Klaus, je ne savais pas que tu parlais français :-) (Klaus
est un contributeur de longue date sur la liste anglophone.)

Cordialement,

Jean