Subject: notation sur une tablature

From: Christian LE BARS <[email-masked]>
Date: Sun, 16 Oct 2022 17:05:44 +0200

Bonjour à tous.

Ma question du jours:

J'aimerai noter dans une tablature guitare le doigts utilisé je pensais 
que cela devrait convenir:

lesTablatures =
\new TabStaff
{
  \tabFullNotation
  \numericTimeSignature
   <c\rightHandFinger#1 c'>4  g8 c' e  e' g4
}

Hélas cela fonctionne sur un accord mais pas sur une tablature.

Par avance merci.

Passer un bon dimanche

chnristian

---

From: Pierre Perol-Schneider <[email-masked]>
Date: Sun, 16 Oct 2022 17:27:55 +0200

Bonjour Christian,
Avec une option *whiteout* et sans :

\new TabStaff \with {
  \consists New_fingering_engraver
%% optional:
  \override StrokeFinger.whiteout = ##t
}
{
  \tabFullNotation
  \numericTimeSignature
   <c\rightHandFinger#1 c'>4  g8 c' e  e' g4
   %% ou peut-être
   <c_\rightHandFinger#1 c'>4  g8 c' e  e' g4
}

Cordialement,
Pierre

Le dim. 16 oct. 2022 à 17:14, Christian LE BARS <[email-masked]> a

---

From: Christian LE BARS <[email-masked]>
Date: Sun, 16 Oct 2022 18:10:20 +0200

Bonsoir Pierre

Merci pour ta réponse, cependant c'est presque ça, voila mon code:

lesTablatures \new TabStaff \with { \consists New_fingering_engraver 
\override StrokeFinger.whiteout = ##t } { \tabFullNotation 
\numericTimeSignature <c\rightHandFinger#1 c'\rightHandFinger#3 >4 
g8\rightHandFinger#2 c'\rightHandFinger#3 e\rightHandFinger#1 
e'\rightHandFinger#4 g4\rightHandFinger#2 } Apparemment le fait de 
l'écrire pour les notes dans les chevrons il aime pas, pour les notes 
isolées c'est ok.

Pourtant j'ai l'affichage correct, mais j'ai l'erreur:

/tmp/frescobaldi-u6to5vl9/tmplyzbqzew/Bonsoir les Amis.ly:123:6: erreur 
de programmation : absence de réglage du « side-axis » pour l'objet 
StrokeFinger.

De plus si je pouvais effacer le numéro des notes seul les noms des 
doigts m’intéresse.

A+

---

From: Pierre Perol-Schneider <[email-masked]>
Date: Sun, 16 Oct 2022 18:41:26 +0200

On peut faire :

 \new TabStaff
 \with {
   %% option
   %\omit TabNoteHead
   \override TabNoteHead.transparent = ##t
   \consists New_fingering_engraver
   \override StrokeFinger.whiteout = ##t
 } {
   \tabFullNotation
   \numericTimeSignature
   <c\rightHandFinger#1 c'\rightHandFinger#3 >4
   g8\rightHandFinger#2 c'\rightHandFinger#3 e
   \rightHandFinger#1 e'\rightHandFinger#4
   g4\rightHandFinger#2
 }

Mais la sortie est à arranger
Pour le message d'erreur, c'est juste un message et c'est normal vu le
\context.
Tu peux aussi essayer de définir le contexte qui te convient au mieux :
https://lilypond.org/doc/v2.23/Documentation/notation/defining-new-contexts
HTH, cordialement,
Pierre

Le dim. 16 oct. 2022 à 18:10, Christian LE BARS <[email-masked]> a
écrit :

> e'\rightHandFinger#4 g4\rightHandFinger#2 } Apparemment le fait de l'écrire
> pour les notes dans les chevrons il aime pas, pour les notes isolées c'est
> ok.
>
> De plus si je pouvais effacer le numéro des notes seul les noms des doigts
> m’intéresse.
>
> A+
>

---

From: Pierre Perol-Schneider <[email-masked]>
Date: Sun, 16 Oct 2022 18:45:23 +0200

PS. Ou peu-être mieux :
 \new TabStaff
 \with {
   %% option
   %\omit TabNoteHead
   \override TabNoteHead.transparent = ##t
   \consists New_fingering_engraver
   \override StrokeFinger.whiteout = ##t
   strokeFingerOrientations = #'(down)
 } {
   \tabFullNotation
   \numericTimeSignature
   <c\rightHandFinger#1 c'^\rightHandFinger#3 >4
   g8\rightHandFinger#2 c'\rightHandFinger#3 e
   \rightHandFinger#1 e'\rightHandFinger#4
   g4\rightHandFinger#2
 }

---

From: Pierre Perol-Schneider <[email-masked]>
Date: Sun, 16 Oct 2022 18:49:15 +0200

PS2, perso j'enlèverai le \tabFullNotation ;)

Le dim. 16 oct. 2022 à 18:45, Pierre Perol-Schneider <
[email-masked]> a écrit :

>> Le dim. 16 oct. 2022 à 18:10, Christian LE BARS <[email-masked]>
>> a écrit :
>>
>>> Bonsoir Pierre
>>>

---

From: Pierre Perol-Schneider <[email-masked]>
Date: Sun, 16 Oct 2022 18:54:51 +0200

PS3... mais un simple \override StrokeFinger.extra-offset = #'(-1 . 0) fait
très bien l'affaire...
 \new TabStaff
 \with {
   \override TabNoteHead.transparent = ##t
   \consists New_fingering_engraver
   \override StrokeFinger.whiteout = ##t
   \override StrokeFinger.extra-offset = #'(-1 . 0)
 } {
   \tabFullNotation
   \numericTimeSignature
   <c\rightHandFinger#1 c'\rightHandFinger#3 >4
   g8\rightHandFinger#2 c'\rightHandFinger#3
   e\rightHandFinger#1 e'\rightHandFinger#4
   g4\rightHandFinger#2
 }

Le dim. 16 oct. 2022 à 18:49, Pierre Perol-Schneider <
[email-masked]> a écrit :

>>>> /tmp/frescobaldi-u6to5vl9/tmplyzbqzew/Bonsoir les Amis.ly:123:6:
>>>> erreur de programmation : absence de réglage du « side-axis » pour l'objet
>>>> StrokeFinger.
>>>>

---

From: Christian LE BARS <[email-masked]>
Date: Sun, 16 Oct 2022 20:50:45 +0200

Bonsoir Pierre.

Cela me convient tout a fait.

Merci beaucoup

Cordialement