Subject: notation dans tablature

From: Christian LE BARS <[email-masked]>
Date: Sat, 29 Oct 2022 18:01:10 +0200

Bonjour a tous.

j'aimerai inscrire un side-axis dans mon code , je n'ai pas su trouver 
la syntaxe dans la doc!

Quelqu'un peut-il m'éclairer?

voici mon code:

\version "2.22.2" %-------------------------------- lesTablatures = \new 
TabStaff \with { \override TabNoteHead.transparent = ##t \consists 
New_fingering_engraver \override StrokeFinger.whiteout = ##t \override 
StrokeFinger.extra-offset = #'(-1 . 0) } { \tabFullNotation 
\numericTimeSignature < c'\rightHandFinger#3 c\rightHandFinger#1 >4 
g8\rightHandFinger#2 c'\rightHandFinger#3 e\rightHandFinger#1 
e'\rightHandFinger#4 g4\rightHandFinger#2 } 
%---------------------------- \score { \lesTablatures \layout { 
#(layout-set-staff-size 30) } }

Je voudrais que ce side-axis concernent les 2 do entre les chevrons.

Par avance merci

---

From: Jean Abou Samra <[email-masked]>
Date: Sun, 30 Oct 2022 09:52:43 +0100

Le 29/10/2022 à 18:01, Christian LE BARS a écrit :
> [...]

Bonjour Christian,

Une solution :

\version "2.22.2"

%--------------------------------
lesTablatures =
  \new TabStaff
   \with
    {
     \override TabNoteHead.transparent = ##t
     \consists New_fingering_engraver
     \override StrokeFinger.whiteout = ##t
     \override StrokeFinger.side-axis = #X
     \override StrokeFinger.X-offset = 
#ly:self-alignment-interface::centered-on-x-parent
     }
   {
    \tabFullNotation
    \numericTimeSignature

    < c'\rightHandFinger#3
    c\rightHandFinger#1  >4

    g8\rightHandFinger#2 c'\rightHandFinger#3
    e\rightHandFinger#1 e'\rightHandFinger#4
    g4\rightHandFinger#2
   }
%----------------------------
\score
{
  \lesTablatures
   \layout
    {
     #(layout-set-staff-size 30)

   }
}

Cordialement,
Jean

---

From: Christian LE BARS <[email-masked]>
Date: Sun, 30 Oct 2022 10:21:16 +0100

Bonjour Jean, bonjour a tous.

Encore une fois le grand chef savait!

merci