Subject: Harmoniques en guitare

From: <[email-masked]>
Date: Sun, 24 Jul 2022 09:55:30 +0200

Bonjour,

Le code suivant affiche correctement l’harmonique naturelle du mi (1ère corde en 12ème position) :

\language "catalan"

harmonics = {

<\parenthesize mi' mi''\harmonic>

}

frettedStrings = {

\harmonicByFret #12 mi'\3

}

\score {

<<

\new Staff {

\clef "treble_8"

\harmonics

}

\new TabStaff {

\frettedStrings

}

}

Il oblige cependant à considérer séparément les 2 portées avec leur notation respective. Est-il possible d’unifier cela par une condition qui testerait le contexte de ses 2 portées ?

Cela donnerait en pseudocode :

musique = {

SI contexte = Staff ALORS

<\parenthesize mi' mi''\harmonic>

SINON SI contexte = TabStaff ALORS

\harmonicByFret #12 mi'\3

FINSI

}

\score {

<<

\new Staff {

\clef "treble_8"

\musique

}

\new TabStaff {

\musique

}

}

Bonne journée,

Olivier

---

From: Martial R <[email-masked]>
Date: Sun, 24 Jul 2022 12:14:48 +0200

Bonjour,

Pour une ou deux harmonique j'utiliserai   la commande \tag #'
https://lilypond.org/doc/v2.22/Documentation/notation/different-editions-from-one-source.fr.html
https://lilypond.org/doc/v2.23/Documentation/notation/different-editions-from-one-source.fr.html#using-tags

%------------------------------------------
 \language "catalan"

harmonics = {
\tag #'TabFret { \harmonicByFret #12 mi'\3 }
\tag #'Harm  <\parenthesize mi' mi''\harmonic>
}

frettedStrings = {

\score {
    <<
        \new Staff {
            \clef "treble_8"
         \removeWithTag #'TabFret \harmonics
        }
        \new TabStaff {
       \keepWithTag #'TabFret \harmonics

      %\frettedStrings
        }
}
%---------------------------------------

-- 
Martial Rameaux