Subject: 2.23.8 et musicxml2ly

From: "F. Moinard" <[email-masked]>
Date: Tue, 26 Apr 2022 13:14:54 +0400

Bonjour,

J'ai tout récemment changé de système pour Linux Mint 20.3, je n'ai pas 
encore tous les repères peut-être...

La version de Lilypond distribuée est la 2.20.0-1.

Concernant musicxml2ly avec la version distribuée, pas de surprises :

~$ /usr/bin/musicxml2ly -l "italiano" -a --nd --nrp --npl --nsd --no-beaming Lalo-Symphonie-Espagnole_2_Trb123_EXPORT.musicxml
musicxml2ly: Lecture du fichier MusicXML « Lalo-Symphonie-Espagnole_2_Trb123_EXPORT.musicxml »...
musicxml2ly: Conversion en expressions LilyPond...
musicxml2ly: Conversion en expressions LilyPond...
musicxml2ly: Conversion en expressions LilyPond...
musicxml2ly: Conversion en expressions LilyPond...
musicxml2ly: Conversion en expressions LilyPond...
musicxml2ly: Conversion en expressions LilyPond...
musicxml2ly: Fichier de sortie : « Lalo-Symphonie-Espagnole_2_Trb123_EXPORT.ly »
musicxml2ly: Converting to current version (2.23.8) notations ...
~$

Mais cela ne va plus avec la nouvelle version de lilypond :

~$ ~/bin/lilypond-2.23.8/bin/musicxml2ly -l "italiano" -a --nd --nrp --npl --nsd --no-beaming Lalo-Symphonie-Espagnole_2_Trb123_EXPORT.musicxml
musicxml2ly: Reading MusicXML from Lalo-Symphonie-Espagnole_2_Trb123_EXPORT.musicxml ...
Traceback (most recent call last):
   File "/home/fcj/bin/lilypond-2.23.8/bin/../libexec/musicxml2ly", line 3478, in <module>
     main()
   File "/home/fcj/bin/lilypond-2.23.8/bin/../libexec/musicxml2ly", line 3471, in main
     voices = convert(filename, options)
   File "/home/fcj/bin/lilypond-2.23.8/bin/../libexec/musicxml2ly", line 3327, in convert
     tree = read_musicxml(filename, options.compressed, options.use_lxml)
   File "/home/fcj/bin/lilypond-2.23.8/bin/../libexec/musicxml2ly", line 3318, in read_musicxml
     return read_xml(io_object, use_lxml)
   File "/home/fcj/bin/lilypond-2.23.8/bin/../libexec/musicxml2ly", line 3268, in read_xml
     doc = minidom.parse(io_object)
   File "/home/fcj/bin/lilypond-2.23.8/lib/python3.10/xml/dom/minidom.py", line 1987, in parse
     from xml.dom import expatbuilder
   File "/home/fcj/bin/lilypond-2.23.8/lib/python3.10/xml/dom/expatbuilder.py", line 32, in <module>
     from xml.parsers import expat
   File "/home/fcj/bin/lilypond-2.23.8/lib/python3.10/xml/parsers/expat.py", line 4, in <module>
     from pyexpat import *
ModuleNotFoundError: No module named 'pyexpat'
~$

J'avais eu un précédent message d'erreur, il manquait le paquet 
python3-numcodecs (message d'erreur au sujet de zlib). Là, 
l'installation du paquet python3-xmltodict ne résout pas le problème.

Cette erreur n'est pas très gênante dans la mesure où la version de la 
distribution fonctionne... mais comment la réparer ?

Bonne journée,
Frédéric Moinard

---

From: Jean Abou Samra <[email-masked]>
Date: Tue, 26 Apr 2022 12:30:46 +0200 (CEST)

> Le 26/04/2022 11:14, F. Moinard <[email-masked]> a écrit :
> 
> 
> Bonjour,
> J'ai tout récemment changé de système pour Linux Mint 20.3, je n'ai pas encore tous les repères peut-être...
> J'avais eu un précédent message d'erreur, il manquait le paquet python3-numcodecs (message d'erreur au sujet de zlib). Là, l'installation du paquet python3-xmltodict ne résout pas le problème.
> Cette erreur n'est pas très gênante dans la mesure où la version de la distribution fonctionne... mais comment la réparer ?
> Bonne journée,
> Frédéric Moinard

Bonjour Frédéric,

C'est un sérieux problème, effectivement. Merci beaucoup de l'avoir
signalé. Je ne crois pas qu'il soit possible d'y faire quelque chose
en attendant un correctif (je peux me tromper). J'ai ouvert la page
de bug

https://gitlab.com/lilypond/lilypond/-/issues/6334

Cordialement,
Jean

---

From: "F. Moinard" <[email-masked]>
Date: Tue, 26 Apr 2022 16:47:44 +0400

Bonjour,

Le 26/04/2022 à 14:30, Jean Abou Samra a écrit :
> (...)

Merci pour ton intervention !

Cordialement,
Frédéric