Subject: debug export tuxguitar to lilypond

From: Jean-Christophe <[email-masked]>
Date: Tue, 04 Jan 2022 21:22:22 +0100

#(define (tie::tab-clear-tied-fret-numbers grob)
   (let* ((tied-fret-nr (ly:spanner-bound grob RIGHT)))
      (ly:grob-set-property! tied-fret-nr 'transparent #t)))

\version "2.22.0"
\paper {
   indent = #0
   printallheaders = ##t
   print-all-headers = ##t
   ragged-right = ##f
   ragged-bottom = ##t
}
\layout {
   \context { \Score
      \override MetronomeMark #'padding = #'5
   }
   \context { \Staff
      \override TimeSignature #'style = #'numbered
      \override StringNumber #'transparent = ##t
   }
   \context { \TabStaff
      \override TimeSignature #'style = #'numbered
      \override Stem #'transparent = ##t
      \override Beam #'transparent = ##t
      \override Tie  #'after-line-breaking = #tie::tab-clear-tied-fret-
numbers
   }
   \context { \TabVoice
      \override Tie #'stencil = ##f
   }
   \context { \StaffGroup
      \consists "Instrument_name_engraver"
   }
}
deadNote = #(define-music-function (parser location note) (ly:music?)
   (set! (ly:music-property note 'tweaks)
      (acons 'stencil ly:note-head::print
         (acons 'glyph-name "2cross"
            (acons 'style 'special
               (ly:music-property note 'tweaks)))))
   note)

palmMute = #(define-music-function (parser location note) (ly:music?)
   (set! (ly:music-property note 'tweaks)
      (acons 'style 'do (ly:music-property note 'tweaks)))
   note)

TrackAVoiceAMusic = #(define-music-function (parser location inTab)
(boolean?)
#{
   \tempo 4=80
   \clef #(if $inTab "tab" "treble_8")
   \key c \major
   \time 4/4
   \oneVoice
   \repeat volta 2 {
      <e\4 g\3 >8 <c\5>8 <e\4 g\3 >8 <c\5>8 <e\4 g\3 >8 <c\5>8 <g\3 b\2
>8 <c\5>8 
   }
   \alternative {
   {
      <f\4 a\3 >8 <c\5>8 <f\4 a\3 >8 <c\5>8 <f\4 a\3 >8 <c\5>8 <f\4 a\3
>16 <ais\3>16 <b\3>16 r16 
   }
   {
      <f\4 a\3 >8 <c\5>8 <f\4 a\3 >8 <c\5>8 <f\4 a\3 >8 <c\5>8 <f\4 a\3
>8 <c\5>8 
   }
   }
   <a\3 f\4 >8 <c\5>8 <a\3 f\4 >8 <c\5>8 <a\3 e\4 >8 <c\5>8 <a\3 e\4 >8
<c\5>8 
   <a\3 f\4 >8 <d\5>8 <f\4 a\3 >8 <d\5>8 <a\3 f\4 >8 <c\5>8 <a\3 f\4 >8
<c\5>8 
   <b\3 g\4 >8 <d\5>8 <g\4 b\3 >8 <d\5>8 <g\4 b\3 >8 <d\5>8 <a\4 c'\3
>8 <d\5>8 
   <d'\3 b\4 >1 
   \repeat volta 2 {
      <e\4 g\3 >8 <c\5>8 <e\4 g\3 >8 <c\5>8 <e\4 g\3 >8 <c\5>8 <g\3 b\2
>8 <c\5>8 
   }
   \alternative {
   {
      <f\4 a\3 >8 <c\5>8 <f\4 a\3 >8 <c\5>8 <f\4 a\3 >8 <c\5>8 <f\4 a\3
>16 <ais\3>16 <b\3>16 r16 
   }
   {
      <f\4 a\3 >8 <c\5>8 <f\4 a\3 >8 <c\5>8 <f\4 a\3 >8 <c\5>8 <f\4 a\3
>8 <c\5>8 
   }
   }
   <a\3 f\4 >8 <c\5>8 <a\3 f\4 >8 <c\5>8 <a\3 e\4 >8 <c\5>8 <a\3 e\4 >8
<c\5>8 
   <a\3 f\4 >8 <d\5>8 <f\4 a\3 >8 <d\5>8 <a\3 f\4 >8 <c\5>8 <a\3 f\4 >8
<c\5>8 
   <b\3 g\4 >8 <d\5>8 <g\4 b\3 >8 <d\5>8 <g\4 b\3 >8 <d\5>8 <a\4 c'\3
>8 <d\5>8 
   <d'\3 b\4 >1 
   \repeat volta 2 {
      <f'\1 a\3 >8 <f\4>8 <a\3 f'\1 >8 <f\4>8 <g\3 g'\1 >8 <d\4>8 <g\3
g'\1 >8 <d\4>8 
   }
   \alternative {
   {
      <e'\1 g\3 >8 <e\4>8 <b\2 g\3 >8 <g\3 c'\2 >8 <e'\1 gis\3 >8
<d\4>8 <d'\2 gis\3 >4 
   }
   {
      <c\5>8 <e\4 g\3 c'\2 >8 <g,\6>8 <c'\2>8 <a,\5>8 <c'\2>8 <b,\5>8
<c'\2>8 
   }
   }
   \repeat volta 2 {
      <e\4 g\3 >8 <c\5>8 <e\4 g\3 >8 <c\5>8 <e\4 g\3 >8 <c\5>8 <g\3 b\2
>8 <c\5>8 
   }
   \alternative {
   {
      <a\3 f\4 >8 <c\5>8 <a\3 f\4 >8 <c\5>8 <a\3 f\4 >8 <c\5>8 <a\3 f\4
>16 <ais\3>16 <b\3>16 r16 
   }
   {
      <f\4 a\3 >8 <c\5>8 <f\4 a\3 >8 <c\5>8 <f\4 a\3 >8 <c\5>8 <f\4 a\3
>8 <c\5>8 
   }
   }
   <a\3 f\4 >8 <c\5>8 <a\3 f\4 >8 <c\5>8 <a\3 e\4 >8 <c\5>8 <a\3 e\4 >8
<c\5>8 
   <a\3 f\4 >8 <d\5>8 <f\4 a\3 >8 <d\5>8 <a\3 f\4 >8 <c\5>8 <a\3 f\4 >8
<c\5>8 
   <b\3 g\4 >8 <d\5>8 <g\4 b\3 >8 <d\5>8 <g\4 b\3 >8 <d\5>8 <a\4 c'\3
>8 <d\5>8 
   <d'\3 b\4 >1 
   \repeat volta 2 {
      <f'\1 a\3 >8 <f\4>8 <a\3 f'\1 >8 <f\4>8 <g\3 g'\1 >8 <d\4>8 <g\3
g'\1 >8 <d\4>8 
   }
   \alternative {
   {
      <e'\1 g\3 >8 <e\4>8 <b\2 g\3 >8 <g\3 c'\2 >8 <e'\1 gis\3 >8
<d\4>8 <d'\2 gis\3 >4 
   }
   {
      <e\4 g\3 c'\2 >1 
   }
   }
   \bar "|."
   \pageBreak
#})
TrackAVoiceBMusic = #(define-music-function (parser location inTab)
(boolean?)
#{
#})
TrackALyrics = \lyricmode {
   \set ignoreMelismata = ##t
   
   \unset ignoreMelismata
}
TrackAStaff = \new Staff <<
   \context Voice = "TrackAVoiceAMusic" {
      \TrackAVoiceAMusic ##f
   }
   \context Voice = "TrackAVoiceBMusic" {
      \TrackAVoiceBMusic ##f
   }
TrackATabStaff = \new TabStaff \with { stringTunings = #'( 4 -1 -5 -10
-15 -20 ) } <<
   \context TabVoice = "TrackAVoiceAMusic" {
      \removeWithTag #'chords
      \removeWithTag #'texts
      \TrackAVoiceAMusic ##t
   }
   \context TabVoice = "TrackAVoiceBMusic" {
      \removeWithTag #'chords
      \removeWithTag #'texts
      \TrackAVoiceBMusic ##t
   }
TrackAStaffGroup = \new StaffGroup <<
   \TrackAStaff
   \TrackATabStaff
TrackBVoiceAMusic = #(define-music-function (parser location inTab)
(boolean?)
#{
   \tempo 4=80
   \clef #(if $inTab "tab" "bass_8")
   \key c \major
   \time 4/4
   \oneVoice
   \repeat volta 2 {
      <c,\3 g,\1 >2. <b,\1 c,~\3 >8 <c\1 c,\3 >8 
   }
   \alternative {
   {
      <a,\1 f,\2 >2. <f,\2 a,\1 >4 
   }
   {
      <f,,\4 c,\3 f,\2 >2. <c,\3 f,\2 f,,\4 >4 
   }
   }
   <f,\2>2 <e,\2>8 <e,\2>4. 
   <d,\2>2 <c,\3>8 <c,\3>4. 
   <g,,\4>2 <g,,\4>8 <g,,\4>4. 
   <g,,\4>1 
   \repeat volta 2 {
      <c,\3 g,\1 >2. <b,\1 c,~\3 >8 <c\1 c,\3 >8 
   }
   \alternative {
   {
      <a,\1 f,\2 >2. <f,\2 a,\1 >4 
   }
   {
      <f,,\4 c,\3 f,\2 >2. <c,\3 f,\2 f,,\4 >4 
   }
   }
   <f,\2>2 <e,\2>8 <e,\2>4. 
   <d,\2>2 <c,\3>8 <c,\3>4. 
   <g,,\4>2 <g,,\4>8 <g,,\4>4. 
   <g,,\4>1 
   \repeat volta 2 {
      <f,,\4>4 <f,,\4>4 <g,,\4>8 <g,,~\4>8 <g,,\4>8. <g,,\4>16 
   }
   \alternative {
   {
      <c,\3>4 <c,\3>4 <e,,\4>8 <e,,~\4>8 <e,,\4>8. <e,,\4>16 
   }
   {
      <c,\3>4 <g,,\4>4 <a,,\3>4 <b,,\3>4 
   }
   }
   \repeat volta 2 {
      <c,\3 g,\1 >2. <b,\1 c,~\3 >8 <c\1 c,\3 >8 
   }
   \alternative {
   {
      <a,\1 f,\2 >2. <f,\2 a,\1 >4 
   }
   {
      <f,,\4 c,\3 f,\2 >2. <c,\3 f,\2 f,,\4 >4 
   }
   }
   <f,\2>2 <e,\2>8 <e,\2>4. 
   <d,\2>2 <c,\3>8 <c,\3>4. 
   <g,,\4>2 <g,,\4>8 <g,,\4>4. 
   <g,,\4>1 
   \repeat volta 2 {
      <f,,\4>4 <f,,\4>4 <g,,\4>8 <g,,~\4>8 <g,,\4>8. <g,,\4>16 
   }
   \alternative {
   {
      <c,\3>4 <c,\3>4 <e,,\4>8 <e,,~\4>8 <e,,\4>8. <e,,\4>16 
   }
   {
      <c,\3>1 
   }
   }
   \bar "|."
   \pageBreak
#})
TrackBVoiceBMusic = #(define-music-function (parser location inTab)
(boolean?)
#{
#})
TrackBLyrics = \lyricmode {
   \set ignoreMelismata = ##t
   
   \unset ignoreMelismata
}
TrackBStaff = \new Staff <<
   \context Voice = "TrackBVoiceAMusic" {
      \TrackBVoiceAMusic ##f
   }
   \context Voice = "TrackBVoiceBMusic" {
      \TrackBVoiceBMusic ##f
   }
TrackBTabStaff = \new TabStaff \with { stringTunings = #'( -17 -22 -27
-32 ) } <<
   \context TabVoice = "TrackBVoiceAMusic" {
      \removeWithTag #'chords
      \removeWithTag #'texts
      \TrackBVoiceAMusic ##t
   }
   \context TabVoice = "TrackBVoiceBMusic" {
      \removeWithTag #'chords
      \removeWithTag #'texts
      \TrackBVoiceBMusic ##t
   }
TrackBStaffGroup = \new StaffGroup <<
   \TrackBStaff
   \TrackBTabStaff
TrackCVoiceAMusic = #(define-music-function (parser location inTab)
(boolean?)
#{
   \tempo 4=80
   \clef #(if $inTab "tab" "treble_8")
   \key c \major
   \time 4/4
   \oneVoice
   \repeat volta 2 {
      <g,\6 c\5 e\4 g\3 c'\2 e'\1 >4. <g,\6 c\5 e\4 >8 <g,\6 c\5 e\4
g\3 c'\2 e'\1 >2 
   }
   \alternative {
   {
      <f'\1 c'\2 a\3 f\4 c\5 f,\6 >4. <f\4 c\5 f,\6 >8 <f'\1 c'\2 a\3
f\4 c\5 f,\6 >2 
   }
   {
      <f\4 a\3 c\5 f,\6 >8\arpeggio <c\5 f,\6 f\4 a\3 >8\arpeggio <f\4
a\3 c\5 f,\6 >8\arpeggio <c\5 f\4 a\3 f,\6 >8\arpeggio <f\4 a\3 c\5
c'\2 >8\arpeggio <c\5 a\3 f\4 c'\2 >8\arpeggio <f\4 a\3 c\5 c'\2 f'\1
>8\arpeggio <c\5 f\4 a\3 f'\1 c'\2 >8\arpeggio 
   }
   }
   <c'\2 a\3 f\4 >4 <c'\2 a\3 f\4 >8 <f\4>8 <c'\2 a\3 e\4 >4 <c'\2 a\3
e\4 >8 <e\4>8 
   <c'\2 a\3 d\4 >4 <d\4 a\3 c'\2 >8 <d\4>8 <c'\2 a\3 c\5 >4 <c\5 a\3
c'\2 >8 <c\5>8 
   <b\2 g\3 d\4 >8 <d\4>8 <d\4 g\3 b\2 >8 <d\4>8 <d\4 g\3 b\2 >8 <d\4>8
<c'\2 g\3 e\4 >8 <f\4>8 
   <f\4 g\3 d'\2 >1 
   \repeat volta 2 {
      <g,\6 c\5 e\4 g\3 c'\2 e'\1 >4. <g,\6 c\5 e\4 >8 <g,\6 c\5 e\4
g\3 c'\2 e'\1 >2 
   }
   \alternative {
   {
      <f'\1 c'\2 a\3 f\4 c\5 f,\6 >4. <f\4 c\5 f,\6 >8 <f'\1 c'\2 a\3
f\4 c\5 f,\6 >2 
   }
   {
      <f\4 a\3 c\5 f,\6 >8\arpeggio <c\5 f,\6 f\4 a\3 >8\arpeggio <f\4
a\3 c\5 f,\6 >8\arpeggio <c\5 f\4 a\3 f,\6 >8\arpeggio <f\4 a\3 c\5
c'\2 >8\arpeggio <c\5 a\3 f\4 c'\2 >8\arpeggio <f\4 a\3 c\5 c'\2 f'\1
>8\arpeggio <c\5 f\4 a\3 f'\1 c'\2 >8\arpeggio 
   }
   }
   <c'\2 a\3 f\4 >4 <c'\2 a\3 f\4 >8 <f\4>8 <c'\2 a\3 e\4 >4 <c'\2 a\3
e\4 >8 <e\4>8 
   <d\4 a\3 c'\2 >4 <d\4 c'\2 a\3 >8 <d\4>8 <c\5 c'\2 a\3 >4 <c\5 a\3
c'\2 >8 <c\5>8 
   <b\2 g\3 d\4 >8 <d\4>8 <d\4 g\3 b\2 >8 <d\4>8 <b\2 g\3 d\4 >8 <d\4>8
<e\4 c'\2 g\3 >8 <f\4>8 
   <f\4 g\3 d'\2 >1 
   \repeat volta 2 {
      <f'\1 c'\2 a\3 f\4 c\5 >8\arpeggio <f\4 c\5 a\3 c'\2 f'\1
>8\arpeggio <c\5 f\4 a\3 c'\2 f'\1 >8\arpeggio <f\4 f'\1 c'\2 a\3 c\5
>8\arpeggio <g,\6 b,\5 d\4 g\3 d'\2 g'\1 >8\arpeggio <d\4 b,\5 g,\6 g\3
d'\2 g'\1 >8\arpeggio <d\4 g\3 d'\2 g'\1 b,\5 g,\6 >8\arpeggio <d\4
g'\1 d'\2 g\3 b,\5 g,\6 >8\arpeggio 
   }
   \alternative {
   {
      <e'\1 c'\2 g\3 e\4 c\5 e,\6 >8\arpeggio <e\4 c\5 e,\6 >8\arpeggio
<b\2 g\3 e\4 c\5 e,\6 >8\arpeggio <c\5 e\4 g\3 c'\2 e,\6 >8\arpeggio
<e'\1 d'\2 gis\3 d\4 b,\5 e,\6 >8\arpeggio <d\4 b,\5 >8\arpeggio <d'\2
gis\3 d\4 b,\5 e,\6 >4\arpeggio 
   }
   {
      <c\5 g,\6 e\4 g\3 c'\2 e'\1 >1\arpeggio 
   }
   }
   \repeat volta 2 {
      <g,\6 c\5 e\4 g\3 c'\2 e'\1 >4. <g,\6 c\5 e\4 >8 <g,\6 c\5 e\4
g\3 c'\2 e'\1 >2 
   }
   \alternative {
   {
      <f'\1 c'\2 a\3 f\4 c\5 f,\6 >4. <f\4 c\5 f,\6 >8 <f'\1 c'\2 a\3
f\4 c\5 f,\6 >2 
   }
   {
      <f\4 a\3 c\5 f,\6 >8\arpeggio <c\5 f,\6 f\4 a\3 >8\arpeggio <f\4
a\3 c\5 f,\6 >8\arpeggio <c\5 f\4 a\3 f,\6 >8\arpeggio <f\4 a\3 c\5
c'\2 >8\arpeggio <c\5 a\3 f\4 c'\2 >8\arpeggio <f\4 a\3 c\5 c'\2 f'\1
>8\arpeggio <c\5 f\4 a\3 f'\1 c'\2 >8\arpeggio 
   }
   }
   <c'\2 a\3 f\4 >4 <f\4 a\3 c'\2 >8 <f\4>8 <c'\2 a\3 e\4 >4 <e\4 a\3
c'\2 >8 <e\4>8 
   <c'\2 a\3 d\4 >4 <d\4 a\3 c'\2 >8 <d\4>8 <c'\2 a\3 c\5 >4 <c\5 a\3
c'\2 >8 <c\5>8 
   <b\2 g\3 d\4 >8 <d\4>8 <d\4 g\3 b\2 >8 <d\4>8 <d\4 g\3 b\2 >8 <d\4>8
<e\4 c'\2 g\3 >8 <f\4>8 
   <f\4 g\3 d'\2 >1 
   \repeat volta 2 {
      <f'\1 c'\2 a\3 f\4 c\5 >8\arpeggio <f\4 c\5 a\3 c'\2 f'\1
>8\arpeggio <c\5 f\4 a\3 c'\2 f'\1 >8\arpeggio <f\4 f'\1 c'\2 a\3 c\5
>8\arpeggio <g,\6 b,\5 d\4 g\3 d'\2 g'\1 >8\arpeggio <d\4 b,\5 g,\6 g\3
d'\2 g'\1 >8\arpeggio <d\4 g\3 d'\2 g'\1 b,\5 g,\6 >8\arpeggio <d\4
g'\1 d'\2 g\3 b,\5 g,\6 >8\arpeggio 
   }
   \alternative {
   {
      <e'\1 c'\2 g\3 e\4 c\5 e,\6 >8\arpeggio <e\4 c\5 e,\6 >8\arpeggio
<b\2 g\3 e\4 c\5 e,\6 >8\arpeggio <c\5 e\4 g\3 c'\2 e,\6 >8\arpeggio
<e'\1 d'\2 gis\3 d\4 b,\5 e,\6 >8\arpeggio <d\4 b,\5 >8\arpeggio <d'\2
gis\3 d\4 b,\5 e,\6 >4\arpeggio 
   }
   {
      <g,\6 c\5 e\4 g\3 c'\2 e'\1 >1\arpeggio 
   }
   }
   \bar "|."
   \pageBreak
#})
TrackCVoiceBMusic = #(define-music-function (parser location inTab)
(boolean?)
#{
#})
TrackCLyrics = \lyricmode {
   \set ignoreMelismata = ##t
   
   \unset ignoreMelismata
}
TrackCStaff = \new Staff <<
   \context Voice = "TrackCVoiceAMusic" {
      \TrackCVoiceAMusic ##f
   }
   \context Voice = "TrackCVoiceBMusic" {
      \TrackCVoiceBMusic ##f
   }
TrackCTabStaff = \new TabStaff \with { stringTunings = #'( 4 -1 -5 -10
-15 -20 ) } <<
   \context TabVoice = "TrackCVoiceAMusic" {
      \removeWithTag #'chords
      \removeWithTag #'texts
      \TrackCVoiceAMusic ##t
   }
   \context TabVoice = "TrackCVoiceBMusic" {
      \removeWithTag #'chords
      \removeWithTag #'texts
      \TrackCVoiceBMusic ##t
   }
TrackCStaffGroup = \new StaffGroup <<
   \TrackCStaff
   \TrackCTabStaff
\score {
   \TrackAStaffGroup
   \header {
      title = "Imagine" 
      composer = "" 
      instrument = "Piano - Right Hand" 
   }
}
\score {
   \TrackBStaffGroup
   \header {
      title = "Imagine" 
      composer = "" 
      instrument = "Piano - Left Hand" 
   }
}
\score {
   \TrackCStaffGroup
   \header {
      title = "Imagine" 
      composer = "" 
      instrument = "Guitar" 
   }
}

---

From: Christian LE BARS <[email-masked]>
Date: Wed, 5 Jan 2022 11:59:33 +0100

Bonjour a tous.

Sans vouloir être méchant, mais voulant comprend, c'est quoi ce machin!

un message de présentation serait je pense nécessaire. Merci

---

From: Jean-Christophe <[email-masked]>
Date: Wed, 05 Jan 2022 12:34:07 +0100

c'est une partition tuxguitar que j'ai exporté vers lilypond mais ça
bug. je ne sais pas du tous ce qu'il ne va pas...

---

From: Pierre Perol-Schneider <[email-masked]>
Date: Wed, 5 Jan 2022 13:20:08 +0100

Bonjour Jean-Christophe,

Il se passe que l'exportation vers LilyPond n'est visiblement pas au point...

Ci-joint un fichier nettoyé de -- presque -- toutes les lignes inutiles.

Meilleurs vœux à tous,

Pierre

Le 05/01/2022 à 12:34, Jean-Christophe a écrit :

Bonjour a tous.

Sans vouloir être méchant, mais voulant comprend, c'est quoi ce
machin!

---

From: Jean-Christophe <[email-masked]>
Date: Thu, 06 Jan 2022 15:54:05 +0100

salut,

j'ai ça comme bug a la compile :

$ lilypond father-and-son.ly 
GNU LilyPond 2.22.1
Traitement de « father-and-son.ly »
Analyse...
father-and-son.ly:50:11: Erreur : GUILE a signalé une erreur pour
l'expression débutant ici
\clef #
(if $inTab "tab" "treble_8")
Unbound variable: $inTab
father-and-son.ly:124:7: Erreur : type d'argument erroné pour 1.
Attendait string, #<unspecified> trouvé.
\TrackAVoiceAMusic ##f
father-and-son.ly:124:7: Erreur : erreur dans #{ ... #}
\TrackAVoiceAMusic ##f
father-and-son.ly:85:11: Erreur : GUILE a signalé une erreur pour
l'expression débutant ici
\clef #
(if $inTab "tab" "treble_8")
Unbound variable: $inTab
father-and-son.ly:127:7: Erreur : type d'argument erroné pour 1.
Attendait string, #<unspecified> trouvé.
\TrackAVoiceBMusic ##f
father-and-son.ly:127:7: Erreur : erreur dans #{ ... #}
\TrackAVoiceBMusic ##f
father-and-son.ly:50:11: Erreur : GUILE a signalé une erreur pour
l'expression débutant ici
\clef #
(if $inTab "tab" "treble_8")
Unbound variable: $inTab
father-and-son.ly:134:7: Erreur : type d'argument erroné pour 1.
Attendait string, #<unspecified> trouvé.
\TrackAVoiceAMusic ##t
father-and-son.ly:134:7: Erreur : erreur dans #{ ... #}
\TrackAVoiceAMusic ##t
father-and-son.ly:85:11: Erreur : GUILE a signalé une erreur pour
l'expression débutant ici
\clef #
(if $inTab "tab" "treble_8")
Unbound variable: $inTab
father-and-son.ly:139:7: Erreur : type d'argument erroné pour 1.
Attendait string, #<unspecified> trouvé.
\TrackAVoiceBMusic ##t
father-and-son.ly:139:7: Erreur : erreur dans #{ ... #}
\TrackAVoiceBMusic ##t
Interprétation en cours de la
musique.../usr/share/lilypond/2.22.1/scm/translation-
functions.scm:381:39: In procedure ly:pitch-tones in expression
(ly:pitch-tones (list-ref tuning #)):
/usr/share/lilypond/2.22.1/scm/translation-functions.scm:381:39: Wrong
type argument in position 1 (expecting Pitch): 4
white-wolf@Music-Station:~/Organisation/Musiques$ 

Le mercredi 05 janvier 2022 à 13:20 +0100, Pierre Perol-Schneider a

---

From: Pierre Perol-Schneider <[email-masked]>
Date: Fri, 7 Jan 2022 08:36:02 +0100

... perseverare diabolicum...

Le 06/01/2022 à 15:54, Jean-Christophe a écrit :

salut,

GNU LilyPond 2.22.1

Analyse...

father-and-son.ly:50:11: Erreur : GUILE a signalé une erreur pour l'expression débutant ici

\clef #

Unbound variable: $inTab

\TrackAVoiceAMusic ##f

\TrackAVoiceAMusic ##f

father-and-son.ly:85:11: Erreur : GUILE a signalé une erreur pour l'expression débutant ici

\clef #

Unbound variable: $inTab

\TrackAVoiceBMusic ##f

\TrackAVoiceBMusic ##f

father-and-son.ly:50:11: Erreur : GUILE a signalé une erreur pour l'expression débutant ici

\clef #

Unbound variable: $inTab

\TrackAVoiceAMusic ##t

\TrackAVoiceAMusic ##t

father-and-son.ly:85:11: Erreur : GUILE a signalé une erreur pour l'expression débutant ici

\clef #

Unbound variable: $inTab

\TrackAVoiceBMusic ##t

\TrackAVoiceBMusic ##t

Interprétation en cours de la musique.../usr/share/lilypond/2.22.1/scm/translation-functions.scm:381:39: In procedure ly:pitch-tones in expression (ly:pitch-tones (list-ref tuning #)):

/usr/share/lilypond/2.22.1/scm/translation-functions.scm:381:39: Wrong type argument in position 1 (expecting Pitch): 4

Le mercredi 05 janvier 2022 à 13:20 +0100, Pierre Perol-Schneider a écrit :

Bonjour Jean-Christophe,

Meilleurs vœux à tous,

Pierre

Bonjour a tous.

machin!

---

From: Jean-Christophe <[email-masked]>
Date: Fri, 07 Jan 2022 20:42:54 +0100

c'est bon je n'utilisais pas le bon fichier .ly

Le vendredi 07 janvier 2022 à 08:36 +0100, Pierre Perol-Schneider a
écrit :
> > /usr/share/lilypond/2.22.1/scm/translation-functions.scm:381:39:
> > Wrong type argument in position 1 (expecting Pitch): 4

---

From: Pierre Perol-Schneider <[email-masked]>
Date: Sat, 8 Jan 2022 09:18:15 +0100

Après relecture je pense m'être trompé d'une octave au piano main gauche.

Voici un layout corrigé :

\paper {
ragged-bottom = ##f
ragged-last-bottom = ##f
}

\header { title = "Imagine" }

\bookpart {
\header { instrument = "Piano" }
\score {
\new PianoStaff \with { \omit StringNumber } <<
\new Staff \fixed c'' \TrackAVoiceAMusic
\new Staff \fixed c' { \clef F \TrackBVoiceAMusic }
\layout {}
\midi {}
}
}

\bookpart {
\header { instrument = "Guitar" }
\score {
\new StaffGroup \with { \omit StringNumber } <<
\new Staff { \clef "G_8" \TrackCVoiceAMusic }
\new TabStaff { \clef "moderntab" \TrackCVoiceAMusic }
\layout {}
\midi {}
}
}

Cordialement,

Pierre

Le 07/01/2022 à 20:42, Jean-Christophe a écrit :

Le vendredi 07 janvier 2022 à 08:36 +0100, Pierre Perol-Schneider a écrit :

salut,

GNU LilyPond 2.22.1

Analyse...

\clef #

Unbound variable: $inTab

\TrackAVoiceAMusic ##f

\TrackAVoiceAMusic ##f

\clef #

Unbound variable: $inTab

\TrackAVoiceBMusic ##f

\TrackAVoiceBMusic ##f

\clef #

Unbound variable: $inTab

\TrackAVoiceAMusic ##t

\TrackAVoiceAMusic ##t

\clef #

Unbound variable: $inTab

\TrackAVoiceBMusic ##t

\TrackAVoiceBMusic ##t

Bonjour Jean-Christophe,

Meilleurs vœux à tous,

Pierre

Bonjour a tous.

machin!