Subject: changement de rythmique 7/8 - 4/4

From: jean-christophe <[email-masked]>
Date: Thu, 11 Nov 2021 15:28:55 +0100

http://lilybin.com/a6uxba/13

bonjour, j'essai d'écrire :
\version "2.18.2"

up = \upbow
do = \downbow

%{
Antisèche (uniquement pour ceux qui connaissent mal leur manche) :
    0    1    2    3    4    etc.
1   e'   f'  fis'  g'  gis'
2   b    c'  cis'  d'  dis'
3   g   gis   a   ais   b
4   d   dis   e    f   fis
5   a,  ais,  b,   c   cis
6   e,   f,  fis,  g,  gis,
%}

global = {
  \time 7/8
  % option :
  \numericTimeSignature
  \key c\major %% <= à préciser pour d'éventuelles transpositions
futures
  \tempo "70"
%  \mark\markup\small "Capo. VI"
%  \partial 2. %% <= anacrouse
}

maMusiqueVoixUn =
  {
    \repeat volta 4
    {
      \repeat volta 2
      {
         % mes.0
        |  c8 c c c c c4
        |  c8 c c c c c4
        |  c8 c c c c c4
        |  c8 c c c c c4
         % mes.1
        |  c8 c c c c c4
        |  c8 c c c c c4
        |  c8 c c c c c4
        |  c8 c c c c c4
         % mes.2
        |  r8 c\up c\do c\up (c4.)^"x2"
 /time 4/4    
          % mes.0
         |  c c c c c c c c
         |  c c c c c c c c
         |  c c c c c c c c
         |  c c c c c c c c
          % mes.1

     % mes.0
    |  c8 c c c c c4
    |  c8 c c c c c4
    |  c8 c c c c c4
    |  c8 c c c c c4
     % mes.1
    |  c8 c c c c c4
    |  c8 c c c c c4
    |  c8 c c c c c4
    |  c8 c c c c c4
     % mes.2
    |  c2.\bar "|."
  }
}

%maMusiqueVoixDeux = {
%  % mes.0
%    c4 c c c
%  | % mes.1
%    c c c c
%    % etc.
%}

mesAccords = \chordmode {
    % mes.0
     e2..:m
    % mes.1
     c:7
    % mes.2
     a:m9
    % mes.3
     g:6
    % mes.4
     e2..:m
    % mes.5
     c:7
    % mes.6
     a:m9
    % mes.7
     g:6
    % mes.8
     g:6
    % partie deux
    % mes.0
     e2..:m
    % mes.1
     c:7
    % mes.2
     a:m9
    % mes.3
     g:6
    % mes.4
     e2..:m
    % mes.5
     c:7
    % mes.6
     a:m9
    % mes.7
     g:6
    % mes.8
     g:6
    % etc.
}

%%% Partition :

\paper {
  ragged-right = ##f
}

\header {
  title = "Exercice rythmique"
  subtitle = \markup\normal-text "Rythme en 7/8"
  composer = "Jean-Christophe White"
}
%
%%\markup\italic "Tablature avec accords :"
%\score {
%  <<
%    \new ChordNames \mesAccords
%    \new TabStaff <<
%      \global
%      \clef "moderntab"
%      \tabFullNotation
%      << \maMusiqueVoixUn \\ \maMusiqueVoixDeux >>
%    >>
%  >>
%  \layout {
%    \context {
%      \TabStaff
%      instrumentName = "Guitare"
%    }
%  }
%}
%
\markup\italic "portée standard :"
\score {
  \new Staff <<
    \clef "G_8"
    \new Voice { \global \voiceOne \maMusiqueVoixUn }
    \new Voice { \global \voiceTwo \maMusiqueVoixDeux }
  \layout {
    \context {
      \Staff
      instrumentName = "Guitare"
    }
  }
}

%\markup\italic "portée standard avec accords :"
%\score {
%  <<
%    \new ChordNames \mesAccords
%    \new Staff <<
%      \clef "G_8"
%      \new Voice { \global \voiceOne \maMusiqueVoixUn }
%      \new Voice { \global \voiceTwo \maMusiqueVoixDeux }
%    >>
%  >>
%  \layout {
%    \context {
%      \Staff
%      instrumentName = "Guitare"
%    }
%  }
%}

\markup\italic "portée rythmique avec accords :"
\score {
  <<
    \new ChordNames \mesAccords
    \new Staff <<
      \clef "G_8"
      \new Voice { \improvisationOn \global\maMusiqueVoixUn }
  \layout {
    \context {
      \Voice
      \consists Pitch_squash_engraver
    }
    \context {
      \Staff
      instrumentName = "Guitare"
    }
  }
}

mais ca ne veux pas compile.
un coups de mains serai bien venu.

cdlt,
jean-christophe white

---

From: Vincent Gay <[email-masked]>
Date: Thu, 11 Nov 2021 16:49:46 +0100

Le 11/11/2021 à 15:28, jean-christophe a écrit :
> ../..

Houla... effectivement pas mal d'erreur
- manque un } quelque part (mais je ne me souviens plus où)
- un slash au lieu d'un anti-slash (/time 4/4 au lieu de \time 4/4)
- des mesures écrite en 7/8 alors que tu as déjà fait le changement en 4/4
- ta voix maMusiqueVoixDeux écrite en 4/4 mais qui s'insère en début de 
partition quand tu es en 7/8
- cette dernière était commentée mais appelée dans les scores qui du 
coup ne la trouvait pas

bon, à part ta voix 2 dont je ne sais ce que tu veux en faire voilà la 
correction

P.S. 2.18 c'est un peu vieux comme version, non ?

%%%%%%%%%%%%%%%%%%%%%%%

\version "2.18"

up = \upbow
do = \downbow

%{

global = {
   \time 7/8
   % option :
   \numericTimeSignature
   \key c\major %% <= à préciser pour d'éventuelles transpositions futures
   \tempo "70"
   %  \mark\markup\small "Capo. VI"
   %  \partial 2. %% <= anacrouse
}

maMusiqueVoixUn =
{
     \repeat volta 2
     {
       % mes.0
       |  c8 c c c c c4
       |  c8 c c c c c4
       |  c8 c c c c c4
       |  c8 c c c c c4
       % mes.1
       |  c8 c c c c c4
       |  c8 c c c c c4
       |  c8 c c c c c4
       |  c8 c c c c c4
       % mes.2
       \time 4/4
       % mes.0
       |  c c c c c c c c
       |  c c c c c c c c
       |  c c c c c c c c
       |  c c c c c c c c
       % mes.1

       % mes.0
       |  c8 c c c c c c4
       |  c8 c c c c c c4
       |  c8 c c c c c c4
       |  c8 c c c c c c4
       % mes.1
       |  c8 c c c c c c4
       |  c8 c c c c c c4
       |  c8 c c c c c c4
       |  c8 c c c c c c4
       % mes.2
       |  c2.
    }
}

maMusiqueVoixDeux = {
  % mes.0
    c4 c c c
  | % mes.1
    c c c c
    % etc.
}

%%% Partition :

\paper {
   ragged-right = ##f
}

\header {
\markup \italic "portée standard :"
     %\new Voice { \global \voiceTwo \maMusiqueVoixDeux }
   >>

\markup\italic "portée standard avec accords :"
\score {
  <<
    \new ChordNames \mesAccords
    \new Staff <<
      \clef "G_8"
      \new Voice { \global \voiceOne \maMusiqueVoixUn }
      %\new Voice { \global \voiceTwo \maMusiqueVoixDeux }
    >>
  >>
  \layout {
    \context {
      \Staff
      instrumentName = "Guitare"
    }
  }
}

     >>
   >>

-- 
Vincent Gay
Envoyé depuis mon saxo-phone :)
https://myrealbook.vintherine.org/ - http://photos.vintherine.org/

---

From: jean-christophe <[email-masked]>
Date: Fri, 12 Nov 2021 19:19:08 +0100

j'ai fait ça mais j'ai le nom des accord qui se décale, comment les
aligner ?

http://lilybin.com/a6uxba/19
%%%%%%%%%%%%%%%%%%%%%%%

\version "2.22.1"

up = \upbow
do = \downbow

%{

global = {
   \time 7/8
   % option :
   \numericTimeSignature

maMusiqueVoixUn =
{
     \repeat volta 2
     {
       % mes.0
       |  c8 c c c c c4
       |  c8 c c c c c4
       |  c8 c c c c c4
       |  c8 c c c c c4
       % mes.1
       |  c8 c c c c c4
       |  c8 c c c c c4
       |  c8 c c c c c4
       |  c8 c c c c c4
       % mes.2
       |  r8 c\up c\do c\up (c4.)^"x2"
       \time 4/4
       % mes.0
         c8 c c c c c c4
         c8 c c c c c c4
         c8 c c c c c c4
         c8 c c c c c c4
         c8 c c c c c c4
         c8 c c c c c c4
         c8 c c c c c c4
         c8 c c c c2
       \time 7/8
       % mes.0
       |  c8 c c c c c4
       |  c8 c c c c c4
       |  c8 c c c c c4
       |  c8 c c c c c4
       % mes.1
       |  c8 c c c c c4
       |  c8 c c c c c4
       |  c8 c c c c c4
       |  c8 c c c c c4
       % mes.2
       %|  r8 c\up c\do c\up (c4.)^"x2"
       | c2.

    }
}

maMusiqueVoixDeux = {
    % mes.0
   | c4 c c c
    % mes.1
   | c c c c
    % etc.
}

   % mes.9
   c:7
   % mes.10
   a:m9
   % mes.11
   g:6
   % mes.12
   e2..:m
   % mes.13
   c:7
   % mes.14
   a:m9
   % mes.15
   g:6
   % mes.16
   g:6
   % etc.
}

%%% Partition :

\paper {
   ragged-right = ##f
}

\header {
%\markup \italic "portée standard :"
%     %\new Voice { \global \voiceTwo \maMusiqueVoixDeux }

%      %\new Voice { \global \voiceTwo \maMusiqueVoixDeux }

\markup\italic "portée rythmique avec accords :"
\score {
   <<
     \new ChordNames \mesAccords
     \new Staff <<
       \clef "G_8"
       \new Voice { \improvisationOn \global\maMusiqueVoixUn }
 %      \new Voice { \improvisationOn \global\maMusiqueVoixDeux }
   \layout {
     \context {
       \Voice

---

From: "F. Moinard" <[email-masked]>
Date: Sat, 13 Nov 2021 00:16:06 +0400

Bonjour,

À partir du 4/4 ("/% partie deux/"), les durées des accords sont 
peut-être fautives. Remplacer "2.." par "1" ?

hth,
Frédéric

---

From: Vincent Gay <[email-masked]>
Date: Fri, 12 Nov 2021 21:34:03 +0100

> peut-être fautives. Remplacer "2.." par "1" ?
C'est exactement ça, avec un g6 de trop à la fin et une dernière mesure 
bizarre à 6 temps au lieux de 7 (devrait être c2..)

le code corrigé ci-dessous

%%%%%%%%%%%%%%

\version "2.18.2"
%%%%%%%%%%%%%%%%%%%%%%%

%\version "2.22.1"

up = \upbow
do = \downbow

%{

global = {
    \time 7/8
    % option :
    \numericTimeSignature

maMusiqueVoixUn =
{
      \repeat volta 2
      {
        % mes.0
        |  c8 c c c c c4
        |  c8 c c c c c4
        |  c8 c c c c c4
        |  c8 c c c c c4
        % mes.1
        |  c8 c c c c c4
        |  c8 c c c c c4
        |  c8 c c c c c4
        |  c8 c c c c c4
        % mes.2
        | c2..

     }
}

maMusiqueVoixDeux = {
     % mes.0
    | c4 c c c
     % mes.1
    | c c c c
     % etc.
}

    e1:m
    % mes.1
    c:7
    % mes.2
    a:m9
    % mes.3
    g:6
    % mes.4
    e:m
    % mes.5
    c:7
    % mes.6
    a:m9
    % mes.7
    g:6
    % mes.8
    g2..:6
    e:m
    % mes.9
    c:7
    % mes.10
    a:m9
    % mes.11
    g:6
    % mes.12
    e2..:m
    % mes.13
    c:7
    % mes.14
    a:m9
    % mes.15
    g:6
    % mes.16
    %g:6
    % etc.
}

%%% Partition :

\paper {
    ragged-right = ##f
}

\header {

-- 
Vincent Gay
Envoyé depuis mon saxo-phone :)
https://myrealbook.vintherine.org/  -http://photos.vintherine.org/