Subject: Re: Chiffrage des accords de jazz

From: xtof pno <[email-masked]>
Date: Thu, 11 Nov 2021 20:11:15 +0000 (UTC)

Bonjour,Je ne suis pas sûr de bien comprendre la démarche pour personnaliser le chiffrage des accords, notamment inscrire les extensionsde l'accord entre parenthèses pour un gain de place et de lisibilité.Je crois avoir compris qu'il est nécessaire de noter d'abord les accords dont on souhaite modifier le chiffrage sous chExceptionMusic = {... }.En fait, on les écrit deux fois.
Je suis gêné, car j'écris les notes constituant l'accord sur deux portées de piano et je ne vois pas comment les noter commedans l'exemple donné qu'en clef de sol : <c e ges bes des'>1 et  c1:7.5-.9-   .

Pour être plus clair, je joins le code. On pourrait s'intéresser pour commencer au seul accord de la 3e mesure 2e temps : G7 b9 add b13.
\version "2.18.2"
globalC = {
  \key c \major
  \numericTimeSignature
  \time 4/4 }
chordNames = \chordmode {
  \globalC
  % Ajouter ici des chiffrages.
   \set additionalPitchPrefix = "add"
  c2:maj7 13
  a:m7 11
 f4:min7.5- 
   \set chordNameSeparator = \markup { "/" }
   aes4/b 
   \set additionalPitchPrefix = "add"
   e:min7 9  
   \set chordNameSeparator = \markup { "/" } 
   es4/a
   
  d4:min7          g:9-.13-        e:min7  a: 7
rightC = \relative c' {
  % En avant la musique !
<c e g a c>4 c' <g c d g> <g g'>
<a c e fis a>8 b' <es, aes c> b'16 a! <g, d' f a>8 g' <bes, es g> e!
<a, c f>8 g' <b,! es aes> g'16 f <g, b e>8 d' <cis, f! a! c!> e' |
}

leftC = \relative c {
  % En avant la musique !
<c, c'>4. <c c'>16 <b b'> <a a'>4 <b'' c e>
<fis e'>4 <b dis a'> <e, d'> <a cis g'>
<d, c'>4 <g f'!> <e d'> <a, g'> |
\bar".."}

chordsPart = \new ChordNames \chordNames

pianoPart = \new PianoStaff \with {
  instrumentName = "Piano"
} <<
  \new Staff = "right" \with {
    midiInstrument = "acoustic grand"}  
  { << \globalC \rightC >> }
  \new Staff = "left" \with {
    midiInstrument = "acoustic grand"
  }  { \clef bass << \globalC \leftC>> }

\score {
  <<
   
    \chordsPart
    \pianoPart
       >>
  
  \header {
    title = "Tensions"
  %  subtitle = ""
  }
  \layout { }
  \midi {
    \tempo 4=80
  }
}
Merci pour vos éclairages.Christophe Julien
    Le dimanche 24 octobre 2021 à 09:17:24 UTC+2, Martial R <[email-masked]> a écrit :  
 
 merci

mais ce qui est demandé c'est un double chiffrage entre parenthèse

j'ai simplifié avec raise..
http://lilybin.com/m6hagr/4

%-----
chExceptionMusic = {
  %accord 7 add5add9
  <c e ges bes des'>1-\markup {
    \super "7"
    \fontsize #1 "(" \super {
    \fontsize #-1
  \column  {
        "b5"
        \raise #1  "b9"
      }
    } \fontsize #1 ")"
  }
}
%---------

Le dim. 24 oct. 2021 à 08:46, Jacques Menu <[email-masked]> a écrit :
>
> Salut Martial,
>
> Un exemple :
>
>
>
> JM
>
> > Le 24 oct. 2021 à 08:41, Martial R <[email-masked]> a écrit :
> >
> > j'aime bien fignoler
> > supprimer \concat (corie de mes essais )
> >
> > à remplacer ; chExceptionMusic = {...}
> > %------------------------------
> > chExceptionMusic = {
> >  %accord 7 add5add9
> >  <c e ges bes des'>1-\markup {
> >    \super "7"
> >    \fontsize #2 "(" \super {
> >    \fontsize #-1
> >  \translate #'(0 . 0.8)
> >  \column  {
> >    \translate #'(0 . -0.5) "b5"
> >    \translate #'(0 . 0.5)  "b9"
> >      }
> >    } \fontsize #2 ")"
> >  }
> > }
> > %-------------------------
> >
> > http://lilybin.com/m6hagr/3
> >
> > --
> > Martial Rameaux
> >
>

-- 
Martial Rameaux

---

From: Martial R <[email-masked]>
Date: Fri, 12 Nov 2021 10:40:00 +0100

Bonjour,,

voici une version avec de vrais bémols  dans les accords
http://lilybin.com/m6hagr/11
%%%%%%%%%%%%%%%%%%%ù

chExceptionMusic = {
  %mesModelesAccords
  %accord 7 add5-add9-

  <c e ges bes des'>1-\markup {
    \super "7"
    \fontsize #1 "(" \super {
      \fontsize #-1
      \column{
        \concat { \flat "5" }
        \raise #1  \concat { \flat "9" }
      }
    } \fontsize #1 ")"
  }

 <c e ges bes aes'>1-\markup {
    \super "7"
    \fontsize #1 "(" \super {
      \fontsize #-1
      \column{
        \concat { \flat "5" }
        \raise #1  \concat { \flat "13" }
      }
    } \fontsize #1 ")"
  }
}

% Convert music to list and prepend to existing exceptions.
%specialAccord
chExceptions = #(append
                 (sequential-music-to-chord-exceptions chExceptionMusic #t)
                 ignatzekExceptions)

theMusic = \chordmode {
  \set chordNameExceptions = #chExceptions
  c1:7.5-.9-
  a:7.5-.9-
  c:7.5-13-
  f,:7.5-13-
  \unset chordNameExceptions
  e:7.5-.9-
  c:7.5-13-
}

<<
  \new ChordNames{
    \theMusic
  }
  \new Voice \theMusic
%%%%%%%%%%%%%%%%%%%%%%%

Le sam. 23 oct. 2021 à 22:34, xtof pno <[email-masked]> a écrit :
>
> Bonjour,
> Je souhaiterais noter des accords comme pièce jointe "modèle".
> Que les extensions de l'accord se superposent dans une parenthèse.
>
> Mais j'obtiens pièce jointe "résultat" (avec g:9-.13-). Ce n'est pas très lisible et cela prend beaucoup de place.
> Comment ajuster la commande ?
>
> 2° : comment supprimer l'ajout "add" : \set additionalPitchPrefix = "add"
> pour qu'il n'apparaisse qu'à la demande et non pas systématiquement ?
>
> Merci pour vos conseils.
> Cordialement.
> Christophe Julien.

-- 
Martial Rameaux

---

From: xtof pno <[email-masked]>
Date: Fri, 12 Nov 2021 16:41:42 +0000 (UTC)

Bonjour Martial,Merci beaucoup pour tes réponses.Cependant, je n'arrive toujours pas au résultat escompté.Je pense qu'il y a un problème au niveau de l'exception.Mes accords sont écrits pour piano, deux portées donc. Tes exemples ne le sont qu'en clef de sol.Je suppose que la cause est là.Comment écrire les notes de l'accord de l'exception, qui se trouvent sur 2 portées ?Merci pour vos conseils concernant cet ajustement.CJ

    Le vendredi 12 novembre 2021 à 10:40:18 UTC+1, Martial R <[email-masked]> a écrit :  
 
 Bonjour,,

chExceptionMusic = {
  %mesModelesAccords
  %accord 7 add5-add9-

theMusic = \chordmode {

<<
  \new ChordNames{
    \theMusic
  }
  \new Voice \theMusic
%%%%%%%%%%%%%%%%%%%%%%%

-- 
Martial Rameaux

---

From: Martial R <[email-masked]>
Date: Fri, 12 Nov 2021 17:59:33 +0100

Bonjour,

Sans exemple minimal j'ai du mal à comprendre en plus je suis un peu bourin !
est-ce que ceci vous parle :
http://lilybin.com/m6hagr/12
%%%%%%%%%%%%%%%%%
\version "2.18.2"
chExceptionMusic = {
  %mesModelesAccords
  %accord 7 add5-add9-

chExceptions = #(append

theMusic = \chordmode {

global = {
  \key c \major
  \time 4/4
}

right = \relative c'' {
  \global
  % En avant la musique !
  ges1 ees  a' d,
}

left = \relative c' {
  \global
  % En avant la musique !
  c,1 a' c, f,
}

\score {
  <<
    \new ChordNames{
      \theMusic
    }
    \new PianoStaff \with {
      instrumentName = "Piano"
    } <<
      \new Staff = "right" \right
      \new Staff = "left" { \clef bass \left }
  \layout { }
}
%%%%%%%%%%%%%%%%%%%ù

Le ven. 12 nov. 2021 à 17:42, xtof pno <[email-masked]> a écrit :
>
> Bonjour Martial,
> Merci beaucoup pour tes réponses.
> Cependant, je n'arrive toujours pas au résultat escompté.
> Je pense qu'il y a un problème au niveau de l'exception.
> Mes accords sont écrits pour piano, deux portées donc. Tes exemples ne le sont qu'en clef de sol.
> Je suppose que la cause est là.
> Comment écrire les notes de l'accord de l'exception, qui se trouvent sur 2 portées ?
> Merci pour vos conseils concernant cet ajustement.
> CJ
>

-- 
Martial Rameaux

---

From: xtof pno <[email-masked]>
Date: Fri, 12 Nov 2021 18:17:28 +0000 (UTC)

Merci Martial,L'exemple me parle effectivement, mais je n'arrive pas à ce résultat.
Un truc qui bloque :

\version "2.18.2"
globalC = {
  \key c \major
  \numericTimeSignature
  \time 4/4 }
  
   chExceptionMusic = {
  %accord 7 b9 b13
 < g f' a b es aes > 1-\markup {
    \super "7"
    \fontsize #2 "(" \super {
    \fontsize #-1
  \translate #'(0 . 0.8)
  \column  {
    \translate #'(0 . -0.5) "b9"
    \translate #'(0 . 0.5)  "b13"
      }
    } \fontsize #2 ")"
  }
}  

  d4:min7  

  g:9-.13-
e:min7  a: 7}
<d, c'>4 <g f'!> <e d'> <a, g'> |}

\score {
  <<
    \chordsPart
    \pianoPart
       >>
  \header {
    title = "Niveau 3"
  }
  \layout { }
  \midi {
    \tempo 4=80
  } }

Ecrire b5 ou "flat 5" sont équivalents.Merci pour votre aide.CJ

    Le vendredi 12 novembre 2021 à 17:59:49 UTC+1, Martial R <[email-masked]> a écrit :  
 
 Bonjour,

chExceptions = #(append

theMusic = \chordmode {

global = {
  \key c \major
  \time 4/4
}

right = \relative c'' {
  \global
  % En avant la musique !
  ges1 ees  a' d,
}

left = \relative c' {
  \global
  % En avant la musique !
  c,1 a' c, f,
}

\score {
  <<
    \new ChordNames{
      \theMusic
    }
    \new PianoStaff \with {
      instrumentName = "Piano"
    } <<

-- 
Martial Rameaux

---

From: Vincent Gay <[email-masked]>
Date: Fri, 12 Nov 2021 21:23:56 +0100

Le 12/11/2021 à 19:17, xtof pno a écrit :
> Merci Martial,
> L'exemple me parle effectivement, mais je n'arrive pas à ce résultat.
> Un truc qui bloque :
>
>
> \version ""
>

est-ce que ceci correspond à tes attentes ? Si oui te reporter à ma 
première réponse, sinon je ne comprends pas ce sue tu cherche

%%%%%%%%%%%%%%%%%%

\version "2.18.2"

globalC = {
   \key c \major
   \numericTimeSignature
   \time 4/4 }

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
% Creating jazz-style chords
% Borrowed from Jean-Pierre's good work at:
% https://sites.google.com/site/jpgzic/home
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

% modification of the procedure "chordRootNamer"
%---- Definition of chord alterations -------
#(define (JazzChordNames pitch majmin)    ;majmin is a required argument 
for "chordNamer", but not used here
   (let* ((alt (ly:pitch-alteration pitch)))
     (make-line-markup
       (list
     (make-simple-markup
       (vector-ref #("C" "D" "E" "F" "G" "A" "B")
         (ly:pitch-notename pitch)))
     (if (= alt 0)            ; alteration ?
       (markup "")        ; do nothing
       (if (= alt FLAT)    ; flat or sharp
         (markup "♭")
         (markup "♯")
       )
     )
       )
     )
   )
)

%----- markup commands to make it easier to write chords -----
%----- this section can be adapted as desired (I don't like "MI" and 
"MA", for example)
% for minor chords, use "acMin" to print a small "m"
#(define-markup-command (acMin layout props extension) (string?)
   (interpret-markup layout props
     (markup #:small "m" #:super extension)))

% for major chords, use "acMaj" to print a small "M"
#(define-markup-command (acMaj layout props extension) (string?)
   (interpret-markup layout props
     (markup #:super "^" #:super extension)))

% for chords with up to three alterations, stacked on top of each other
#(define-markup-command (acAlt layout props strA strB strC) (string? 
string? string?)
   (interpret-markup layout props
     (markup
       #:super strA
       #:fontsize 1.5 "["
       #:fontsize -4
       #:raise 2
       #:center-column (strB strC)
       #:fontsize 1.5 "]"
     )
   )
)

% modify the built-in "chordNameExceptions"
%----- change chord exceptions for jazz notation -----
%
%    degrés             markup                % écriture
JazzChordsList = {

% minor third chords - 3 notes
   <c es ges>1-\markup { \raise #0.7 "°" } % :dim
   <c es g>-\markup { \acMin #"" } % :m

% minor third chords - 4 notes
   <c es ges beses>-\markup { \raise #0.7 "°7" } % :dim7
   <c es gis>-\markup { \acMin #"aug" } % :m5+ (Ab/C)
   <c es g a>-\markup { \acMin #"6" } % :m6
   <c es g as>-\markup { \acMin #">6" } % :m6
   <c es ges bes>-\markup { Ø } % :m7.5-
   <c es g bes>-\markup { \acMin #"7" } % :m7
   <c es gis bes>-\markup { \acMin #"7 <5" } % :m7.5+
   <c es g b>-\markup { \acMin #"^" } % :m7+
   <c es g d'>-\markup { \acMin #"add9" } % :m5.9

% minor third chords - 5+ notes
   <c es g a d'>-\markup { \acMin #"6/9" } % :m6.9
   <c es g bes des'>-\markup { \acMin #"7(>9)" } % :m7.9-
   <c es g bes d'>-\markup { \acMin #"9" } % :m9
   <c es ges bes d'>-\markup { \acMin #"9(>5)" } % :m9.5-
   <c es g b d'>-\markup { \acMin #"^9" } % :m9.7+
   <c es g bes dis'>-\markup { \acMin #"7(<9)" } % :m7.9+
   <c es g bes f'>-\markup { \acMin #"7(add 11)" } % :m7.11
   <c es ges bes f'>-\markup { @ \super #"(11)" } % :m7.11
   <c es g bes a'>-\markup { \acMin #"7(add 13)" } % :m7.13
   <c es g bes d' f'>-\markup { \acMin #"11" } % :m11
   <c es ges bes d' f'>-\markup { \acMin #"11(>5)" } % :m11.5-
   <c es g bes d' f' a'>-\markup { \acMin #"13" } % :m13

% major third chords - 3 notes
   <c e ges>-\markup { \super ">5" } % :5-
   <c e gis>-\markup { \super "aug" } % :aug

% major third chords - 4 notes
   <c e g a d'>-\markup {
       \super "6"
       \hspace #-0.5 \raise #0.7 \tiny "/"
       \hspace #-0.5 \tiny "9"
       }    % :6.9
% special chords
   <c> -\markup { \small \super "bass" } % :c:1
   <c g> -\markup { \small \super "power" } % :c:1.5
   <c e g bes c'>-\markup { \super "7alt" } % :c:8
%  <c e g b>-\markup { ^ } % :maj
   <c e g b>-\markup { \acMaj #""} % :maj
   <c e ges b>-\markup { \acMaj #">5" } % :maj.5-
   <c e gis b>-\markup { \acMaj #"<5" } % :maj.5+

   <c e ges bes>-\markup { \super "7(>5)" } % :7.5-
   <c e gis bes>-\markup { \super "7+" } % :7.5+
   <c e g d'>-\markup { \super "add9" } % :1.3.5.9

% major third chords - 5+ notes
   <c e g b d'>-\markup { \acMaj #"9" } % :maj9
   <c e g bes des'>-\markup { \super "7(>9)" } % :9-
   <c e g bes d' fis'>-\markup { \super "9(<11)" } % :9.11+
   <c e g bes dis'>-\markup { \super "7(<9)" } % :9+
   <c e g bes fis'>-\markup { \super "7(<11)" } % :7.11+
   <c e g b fis'>1-\markup { \acMaj "(<11)"}
   <c e g b d' fis'>1-\markup { \acMaj #"9" \super "(<11)"}
   <c e g bes aes'>-\markup { \super "7(>13)" } % :7.13-
   <c e g b d' f'>-\markup { \acMaj #"11" } % :maj11
   <c e g b d' a' >-\markup { \acMaj #"13" } % :maj13
   <c e g bes d' a' >-\markup { \super "13" } % :13
   <c e g b d' aes' >-\markup { \acMaj #"9(>13)" } % :13
   %<c e g bes des' a' >-\markup { \super "13(>9)" } % :13.9-
   <c e g bes des' a' >-\markup { \override #'(baseline-skip . 2) \acAlt 
#"7" #">9" #"13" } % :13.9-
   <c e g bes dis' aes'>-\markup { \override #'(baseline-skip . 2) 
\acAlt #"7" #"<9" #">13" } % :9+.13-
   <c e g bes d' fis' a'>-\markup { \override #'(baseline-skip . 2) 
\acAlt #"7" #"<11" #"13" } % :11+.13
   <c e g bes des' fis'>-\markup { \override #'(baseline-skip . 2) 
\acAlt #"7" #">9" #"<11" } % :9-11+

   %<c e ges bes des'>-\markup { \override #'(baseline-skip . 2) \acAlt 
#"7" #">5" #">9" } % :5-9-
   <c e ges bes d' a'>-\markup { \override #'(baseline-skip . 2) \acAlt 
#"7" #"13" #">5" } % :13.5-
   <c e g bes des' as'>-\markup { \override #'(baseline-skip . 2) \acAlt 
#"7" #">13" #">9" } % :9-13-

%   <c e ges bes des'>-\markup { \override #'(baseline-skip . 2) \acAlt 
#"7" #">9" #">5" } % :5-9-
%    <c e gis bes des'>-\markup { \override #'(baseline-skip . 2) \acAlt 
#"7" #">9" #"<5" } % :5+9-
%   <c e ges bes dis'>-\markup { \override #'(baseline-skip . 2) \acAlt 
#"7" #"<9" #">5" } % :5-9+
%    <c e gis bes dis'>-\markup { \override #'(baseline-skip . 2) \acAlt 
#"7" #"<9" #"<5" } % :5+9+

   <c e ges bes des'>-\markup { \override #'(baseline-skip . 2) \acAlt 
#"7" #">9" #">5" } % :9-5-
   <c e gis bes des'>-\markup { \override #'(baseline-skip . 2) \acAlt 
#"7" #">9" #"<5" } % :9-5+
   <c e ges bes dis'>-\markup { \override #'(baseline-skip . 2) \acAlt 
#"7" #"<9" #">5" } % :9+5-
   <c e gis bes dis'>-\markup { \override #'(baseline-skip . 2) \acAlt 
#"7" #"<9" #"<5" } % :9+5+

%   <c e gis des'>-\markup { \override #'(baseline-skip . 2) \acAlt #"7" 
#"<9" #">5" } % :9-.5+

% sustained chords
   <c d g>-\markup { \super "sus2" } % :sus2
   <c f g>-\markup { \super "sus" } % :sus4
   <c f g bes>-\markup { \super "7sus" }  % :sus4.7
   <c f g bes d'>-\markup { \super "9sus" }  % :sus4.7.9
   <c f g dis'>-\markup { \super "<9sus" }  % :sus4.9+
    <c f g bes d' a' >-\markup { \override #'(baseline-skip . 2) \acAlt 
#"" #"13" #"sus" } % :13sus4
% sans septième
    <c e g d'>-\markup { \super "add9" } % c1:3.5.9
   <c f g d'>-\markup { \override #'(baseline-skip . 2) \acAlt #"" 
#"sus" #"add9" } % c:3.5.9sus4
   <c e g d' aes' >-\markup { \override #'(baseline-skip . 2) \acAlt #"" 
#"add9" #">13" }
   %-\markup { \super "add9(>13)" } % c:3.5.9.13-

}

% variable needed to use chord exceptions
JazzChords = #(append (sequential-music-to-chord-exceptions 
JazzChordsList #t) ignatzekExceptions)

% modify the default ChordNames context
\layout {
   \context {
     \ChordNames
     chordRootNamer = #JazzChordNames    % update the chord names
     chordNameExceptions = #JazzChords    % update the chord exceptions
     %\override ChordName.font-name = #"lilyjazz-chord"  % use the 
custom font for displaying the chords
   }
}

   d4:min7  }

%    \set chordNameExceptions = #chExceptions
%   g:9-.13-
%      \unset chordNameExceptions
% e:min7  a: 7
% }

rightC = \relative c' {
   % En avant la musique !

leftC = \relative c {
   % En avant la musique !

\score {
   <<
     \chordsPart
     \pianoPart
        >>
   \header {
     title = "Niveau 3"
   }
   \layout { }
   \midi {
     \tempo 4=80
   } }

-- 
Vincent Gay
Envoyé depuis mon saxo-phone :)
https://myrealbook.vintherine.org/  -http://photos.vintherine.org/

---

From: Christophe Dubos <[email-masked]>
Date: Mon, 15 Nov 2021 18:09:57 +0000 (UTC)

Bonjour,Je ne trouve pas ce qui coince dans le code ci-dessus.
Merci pour vos retours.

    Le vendredi 12 novembre 2021 à 19:17:28 UTC+1, xtof pno <[email-masked]> a écrit :  

\version "2.18.2"
globalC = {
  \key c \major
  \numericTimeSignature
  \time 4/4 }
  
   chExceptionMusic = {
  %accord 7 b9 b13

\score {
  <<
    \chordsPart
    \pianoPart
       >>
  \header {
    title = "Niveau 3"
  }
  \layout { }
  \midi {
    \tempo 4=80
  } }

 
 Bonjour,

chExceptions = #(append

theMusic = \chordmode {

global = {
  \key c \major
  \time 4/4
}

right = \relative c'' {
  \global
  % En avant la musique !
  ges1 ees  a' d,
}

left = \relative c' {
  \global
  % En avant la musique !
  c,1 a' c, f,
}

\score {
  <<
    \new ChordNames{
      \theMusic
    }
    \new PianoStaff \with {
      instrumentName = "Piano"
    } <<

-- 
Martial Rameaux

---

From: Martial R <[email-masked]>
Date: Tue, 16 Nov 2021 00:04:09 +0100

après avoir bien galéré je constate qu'il faut écrire l'accord modèle en entier
1 3 5 7b 9b 13b

%--------------------
   chExceptionMusic = {
  %accord 7 b9 b13  <g b d' f' aes' ees''>
% mais en do c'est plus simple
  <c e g bes des' aes'>-\markup {
    \super "7"
    \fontsize #1 "(" \super {
      \fontsize #-1
      \column{
        \concat { \flat "9" }
        \raise #1  \concat { \flat "13" }
      }
    } \fontsize #1 ")"
  }
}
%--------------------------

http://lilybin.com/vjnzgr/1
p.s le caractère bémol "\flat" est différent de "b"

---

From: Martial R <[email-masked]>
Date: Wed, 17 Nov 2021 10:26:06 +0100

Bonjour à tous

les accords altérés sont  divers,
même principe les construire :

http://lilybin.com/wfr6mt/2

%%%%%%%%%%%%%%%%%%%%%%%%%%%
%\version
chExceptionMusic = {
  <c e g b>1-\markup { \super 7alt  }  %7iem augmenté
  <c e g bes des'>1-\markup { \super 7alt  }  %altéré
  <c e g bes dis'>1-\markup { \super 7alt  }  %altéré
}

chExceptions = #(append ;on pourait écrire accdExceptions
                  (sequential-music-to-chord-exceptions chExceptionMusic #t)
                  ignatzekExceptions)

ma-Musique-avec-des-accords-altere =  \chordmode {
  \set chordNameExceptions = #chExceptions
  c:7+  %7iem augmenté
  c:9-  %altéré accord de 7em
  c:9+  %altéré
  f:7+
  a,:9-
  d:9+
}

\score {
  \new StaffGroup <<
    \new ChordNames \ma-Musique-avec-des-accords-altere
    \new Voice \ma-Musique-avec-des-accords-altere
  \layout {  }
}
%%%%%%%%%%%%%%%%%%%%%%%%%%%

Le mar. 16 nov. 2021 à 22:35, xtof pno <[email-masked]> a écrit :
>
> Bravo et merci Martial,
> pas facile, je ne suis pas encore à l'aise, ni rapide, mais ça marche.
>
> A toutes fins utiles, y a-t-il un truc particulier pour noter un accord 7 altéré (7alt.) ?
> Ou est-ce le même principe ?
> Merci beaucoup pour ton accompagnement et tes recherches.
> Christophe
>
> Le mardi 16 novembre 2021 à 00:04:25 UTC+1, Martial R <[email-masked]> a écrit :
>
>

-- 
Martial Rameaux

---

From: xtof pno <[email-masked]>
Date: Wed, 17 Nov 2021 10:01:27 +0000 (UTC)

Bonjour Martial,C'est bien ça, si l'accord altéré en question n'est pas rigoureusement constitué 
des mêmes notes que l'accord modèle ça ne marche pas.Donc, c'est le même principe.Merci encore pour ton aide précieuse.
Cette étape est résolue.
Christophe J
   Le mercredi 17 novembre 2021 à 10:26:23 UTC+1, Martial R <[email-masked]> a écrit :  
 
 Bonjour à tous

\score {
  \new StaffGroup <<

-- 
Martial Rameaux