Subject: Changement de font au sein d'un markup

From: Vincent Gay <[email-masked]>
Date: Wed, 8 Sep 2021 17:33:21 +0200

Bonsoir,

dans mon bloc \paper j'ai :
   #(define fonts
     (set-global-fonts
     #:music "lilyjazz"
     #:brace "lilyjazz"
     #:roman "lilyjazz-text"
     #:sans "lilyjazz-chord"
     #:factor (/ staff-height pt 20)
   ))

au sein d'un markup j'aimerai utiliser lilyjazz-chord. J'ai essayé comme ça:

solos = \markup  \fill-line {
   \column { \line { \with-color #red \fontsize #2 { "Solos on " \sans 
\concat { "Fm"  \super "7" } } } }
}

mais je n'obtiens pas du tout la police escomptée. Où est l'erreur SVP ?

Merci d'avance

-- 
Vincent Gay
Envoyé depuis mon saxo-phone :)
http://blog.vintherine.org/ - http://photos.vintherine.org/

---

From: Martial R <[email-masked]>
Date: Wed, 8 Sep 2021 20:40:07 +0200

j'ai testé en remplaçant #:roman "lilyjazz-text"
par
#:roman "lilyjazz-chord"
ça fonctionne !

-- 
Martial Rameaux

---

From: Martial R <[email-masked]>
Date: Wed, 8 Sep 2021 21:04:51 +0200

mais ça devrait aussi marcher  avec #:roman "lilyjazz-text"

-- 
Martial Rameaux

---

From: Vincent Gay <[email-masked]>
Date: Wed, 8 Sep 2021 21:45:24 +0200

> j'ai testé en remplaçant #:roman "lilyjazz-text"

Merci Martial de t'être penché sur mon problème, toutefois j'ai aussi 
besoin de lilyjazz-text, c'est la police par défaut pour le reste des 
markups, jes titres etc...

---

From: Martial R <[email-masked]>
Date: Wed, 8 Sep 2021 23:34:58 +0200

bon j'ai tout réinstallés les otf dans le répertoire
 /lilypond/current/fonts/otf/
les fichiers ily dans mons répertoire includes

ça fonctionne

%%%%%%%%%%%%%%%%%%%%%ù
\include "jazzchords.ily"
\include "lilyjazz.ily"
\include "jazzextras.ily"

%au sein d'un markup j'aimerai utiliser lilyjazz-chord. J'ai essayé comme
ça:

solos = \markup  \fill-line {
   \column { \line { \with-color #red \fontsize #2 { "Solos on " \sans
\concat { "Fm"  \super "7" } } } }
}
{
   \new Staff { c'4(^\solos e')  }
}

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

-- 
Martial Rameaux

---

From: Martial R <[email-masked]>
Date: Wed, 8 Sep 2021 23:37:16 +0200

fichiers pour lilyjazz trouvé ici
https://github.com/OpenLilyPondFonts/lilyjazz/find/master

-- 
Martial Rameaux

---

From: Vincent Gay <[email-masked]>
Date: Thu, 9 Sep 2021 08:20:25 +0200

> les fichiers ily dans mons répertoire includes
Arf... faut que je change mes lunettes, c'est bien la bonne police. En 
fait ça a toujours marché mais avec le F bien droit je m'imaginait que 
s'en était une autre.

Désolé pour le bruit et merci encore.

---

From: Martial R <[email-masked]>
Date: Thu, 9 Sep 2021 09:13:11 +0200

Mince ce n'est pas donné l'opticien :-)
Pas de soucis,  j'en ai profité pour télécharger les polices lilyjazz plus
récentes.

Arf... faut que je change mes lunettes, c'est bien la bonne police.

-- 
Martial Rameaux