Subject: Plusieurs TrillSpan ne semblent pas s'enchaîner correctement [2.23]

From: fremoin <[email-masked]>
Date: Wed, 2 Jun 2021 22:14:27 -0700 (MST)

Bonjour,

Je souhaite enchaîner plusieurs trilles. La documentation (
http://lilypond.org/doc/v2.22/Documentation/notation/expressive-marks-as-lines.fr.html#trills
<http://lilypond.org/doc/v2.22/Documentation/notation/expressive-marks-as-lines.fr.html#trills> 
) précise « /Lorsque des trilles interviennent sur une succession de
hauteurs différentes, point n’est besoin d’expliciter la commande
\stopTrillSpan puisque l’apparition d’un nouveau trille interrompt de fait
celui qui le précédait /».

Dans les exemples ci-dessous :

- A  : conforme à la documentation, mais les trilles commencent après la fin
du span précédent (?)* et sont verticalement décalés ;
- B : rustine qui obtient l'effet souhaité, mais...
- C : ... qui ne marche plus si un autre voix contient (ici) des croches,
avec...
- D : une réaction différente selon que les hampes vont vers le haut ou vers
le bas (??)

%%%%%%%%%%%%%%%%%%%%
\version "2.23.2"

{ \mark "A"
  a1 \startTrillSpan 
  a1 \startTrillSpan  
  a'1 \startTrillSpan  
  a'1 \startTrillSpan  
  g'4 \stopTrillSpan r r2
}

{ \mark "B"
  a1*3/4 \startTrillSpan  s4
  a1*3/4 \startTrillSpan s4
  a'1*3/4 \startTrillSpan s4
  a'1 \startTrillSpan  
  g'4 \stopTrillSpan r r2
}

\score { 
  <<
    \new Staff { \mark "C" s1*2 \repeat unfold 8 { a'8 } }
    \new Staff
    {
      a1*3/4 \startTrillSpan s4
      a1*3/4 \startTrillSpan s4
      a'1*3/4 \startTrillSpan s4
      a'1 \startTrillSpan  
      g'4 \stopTrillSpan r r2
    } 
}

\score {
  <<
    \new Staff { \mark "D" s1 \repeat unfold 8 { a'8 } \repeat unfold 8 {
c''8 } }
    \new Staff
    {
      a1*3/4 \startTrillSpan s4
      a1*3/4 \startTrillSpan s4
      a'1*3/4 \startTrillSpan s4
      a'1 \startTrillSpan  
      g'4 \stopTrillSpan r r2
    }
}
%%%%%%%%%%%%%%%%%%%%

Comment obtenir un enchaînement de trilles sans décalage vertical ?

[*} Le compositeur souhaite la répétition du symbole de début de trille sur
chaque note.

Cordialement,
Frédéric

--
Sent from: http://lilypond-french-users.1298960.n2.nabble.com/

---

From: fgohier <[email-masked]>
Date: Wed, 2 Jun 2021 22:21:46 -0700 (MST)

Bonjour,

pour ma part, je partirais sur la création une seconde voix, exemple :

\score {
\new Staff
\relative c'  {
<< { s2.\startTrillSpan s8 s8\stopTrillSpan s1} \\ {\voiceOne c2 c2 c1} >>
  }
}

Frédéric

---

From: "F. Moinard" <[email-masked]>
Date: Thu, 3 Jun 2021 10:12:26 +0400

Bonjour

En effet ! Je n'y avais pas pensé, merci...

Cela dit, le décalage apparaît avec une autre portée :

%%%%%%%%%%
\version "2.23.2"

\score {
   <<
     \new Staff {  \repeat unfold 16 { a'8 } }
     \new Staff
     \relative c'  {
       << { s4.\startTrillSpan s8 s4. \startTrillSpan s8  \stopTrillSpan  }
          \\
          {\voiceOne c2 c2 c1  }
       >>
     }
   >>
}
%%%%%%%%%%

Frédéric

---

From: Jean Abou Samra <[email-masked]>
Date: Thu, 3 Jun 2021 20:52:52 +0200

Bonjour,

C'est un petit souci connu :

https://gitlab.com/lilypond/lilypond/-/issues/923

Une solution simple est :

{
   \override TrillSpanner.outside-staff-priority = ##f
   \mark "A"
   a1 \startTrillSpan
   a1 \startTrillSpan
   a'1 \startTrillSpan
   a'1 \startTrillSpan
   g'4 \stopTrillSpan r r2
}

Cordialement,
Jean

---

From: fremoin <[email-masked]>
Date: Fri, 4 Jun 2021 01:23:22 -0700 (MST)

Bonjour,

Ah mais absolument !
Je devrais penser plus efficacement à vérifier GitLab, en effet.

Merci !! :)
Frédéric