Subject: Font pour tablatures

From: Vincent Gay <[email-masked]>
Date: Fri, 2 Oct 2020 15:22:45 +0200

Bonjour à tous

j'utilise ordinairement les fonts lilyJazz avec dans le bloc paper

\paper {

  #(define fonts

    (set-global-fonts

    #:music "lilyjazz"

    #:brace "lilyjazz"

    #:roman "lilyjazz-text"

    #:sans "lilyjazz-chord"

    #:factor (/ staff-height pt 20)

  ))

}

malheureusement cela produit un résultat assez illisible pour les
tablatures.

Serait-il possible de revenir aux fonts par défaut pour une TabStaff,
sans toucher aux autres portées du \Score ?

Merci d'avance et bon week-end

-- 
Vincent Gay
Envoyé depuis mon saxo-phone :)
http://blog.vintherine.org/ - http://photos.vintherine.org/

---

From: Pierre Perol-Schneider <[email-masked]>
Date: Fri, 2 Oct 2020 16:35:40 +0200

Bonjour Vincent,
Un mini exemple avec un résultat illisible ?
Sinon, tu peux écrire :

%%%
\version "2.20.0"

music = { c' }

\paper {

  #(define fonts
    (set-global-fonts
    #:music "lilyjazz"
    #:brace "lilyjazz"
    #:roman "lilyjazz-text"
    #:sans "lilyjazz-chord"

\new GrandStaff <<
  \new Staff \with { \clef "G_8" } \music
  \new TabStaff \music

\layout {
  \context {
    \Staff
    \omit ClefModifier
  }
  \context {
    \TabStaff
    \override TabNoteHead.font-name = #"Arial Black"
  }
}
%%%

Cordialement,
Pierre

Le ven. 2 oct. 2020 à 15:23, Vincent Gay <[email-masked]> a écrit :

> Serait-il possible de revenir aux fonts par défaut pour une TabStaff, sans
> toucher aux autres portées du \Score ?
>
>
> Envoyé depuis mon saxo-phone :)http://blog.vintherine.org/ - http://photos.vintherine.org/
>
>

---

From: Vincent Gay <[email-masked]>
Date: Fri, 2 Oct 2020 17:48:02 +0200

>     \override TabNoteHead.font-name = #"Arial Black"

C'est parfait, merci