Subject: markup superposé à la barre de début de système

From: [email-masked]
Date: Fri, 30 Oct 2020 08:04:26 +0100 (CET)

Bonjour,

Je sais mettre un markup dans une portée, mais pas à cheval sur le début d'un système...Une idée pour lever cette interdiction ?

Voici mon exemple (le bloc de couleur refuse de dépasser la barre de mesure de départ de système):

\version "2.20.0"

floatMarkup = #(define-music-function (parser location posx posy) (number? number?)
                 #{
                   \once \override TextScript.outside-staff-priority = ##f
                   \once \override TextScript.X-offset = $posx
                   \once \override TextScript.Y-offset = $posy
                 #})

\new ChoirStaff \with {\omit Clef \omit TimeSignature  }
<<
{ \floatMarkup #'-5 #'1.1 c''1_\markup {
 \with-color #red  \filled-box #'(0 . 2) #'(-3.2 . 1) #0.1
}}
{c''1 }

---

From: martial <[email-masked]>
Date: Fri, 30 Oct 2020 02:27:52 -0700 (MST)

Bonjour, 

en tatonnant, bidouille quoi 

%---------------------

floatMarkup = #(define-music-function (parser location posx posy) (number?
number?)
                 #{
%score plutôt que staff
                   \once \override TextScript.outside-score-priority = ##f
                   \once \override TextScript.X-offset = $posx
                   \once \override TextScript.Y-offset = $posy
                 #})

\new ChoirStaff \with {\omit Clef \omit TimeSignature  }
<<
{ \floatMarkup #'-5 #'1.1 c''1_\markup { 
 %agrandissement du filled-box
 \with-color #red  \filled-box #'(0 . 2) #'(1 . -12) #0.1
}}
{c''1 }
%---------------------

-----
♫artial♪
--
Sent from: http://lilypond-french-users.1298960.n2.nabble.com/

---

From: Gilles Thibault <[email-masked]>
Date: Fri, 30 Oct 2020 11:04:49 +0100

> floatMarkup = #(define-music-function (parser location posx posy)

Bonjour. J'ai pas testé mais pour Lilypond 2.20.0, il n e devrait pas y 
avoir les paramètres parser et location, me semble t-il.
floatMarkup = #(define-music-function (posx posy) (number? number?)
    ...

-- 
Gilles

---

From: [email-masked]
Date: Fri, 30 Oct 2020 11:07:13 +0100 (CET)

Tiens, c'est étrange cela ne fonctionne pas chez moi : propriété "outside-score-priority" non trouvée.

----- Mail original -----
De: "martial" <[email-masked]>
À: [email-masked]
Envoyé: Vendredi 30 Octobre 2020 10:27:52
Objet: Re: markup superposé à la barre de début de système

Bonjour, 

%---------------------

%---------------------

-----
♫artial♪

---

From: martial <[email-masked]>
Date: Fri, 30 Oct 2020 03:09:13 -0700 (MST)

Gros bidouillage 
pour  3 systèmes 

%----------------

\version "2.20.0"
boxRed =\markup {
} 

floatMarkup = #(define-music-function (parser location posx posy) (number?
number?)
                 #{
                   %\once \override TextScript.outside-score-priority = ##t
                   \once \override TextScript.X-offset = $posx
                   \once \override TextScript.Y-offset = $posy
                 #})

\new ChoirStaff \with { \omit Clef \omit TimeSignature  }
<<
  {
    \floatMarkup #'-12 #'1.0 c''1_\boxRed \break
    \floatMarkup #'-25 #'1.0 c''_\boxRed  \break
    \floatMarkup #'-25 #'1.0 c''_\boxRed  \break
  }
  {
    c''1 \break
    c'' \break
    c'' \break
  }

%------------------------

-----
♫artial♪

---

From: [email-masked]
Date: Fri, 30 Oct 2020 11:13:21 +0100 (CET)

"Bonjour. J'ai pas testé mais pour Lilypond 2.20.0, il n e devrait pas y 
avoir les paramètres parser et location, me semble t-il.
floatMarkup = #(define-music-function (posx posy) (number? number?)
    ...
"

Si cela fonctionne, mais on voit toujours une partie de la barre de début de système :

http://lilybin.com/bhwrpy/1

---

From: Pierre Perol-Schneider <[email-masked]>
Date: Fri, 30 Oct 2020 11:22:06 +0100

Et en changeant le layer ?
C.f. http://lilybin.com/bhwrpy/2
Cordialement,
Pierre

---

From: [email-masked]
Date: Fri, 30 Oct 2020 11:29:34 +0100 (CET)

Oui c'est beaucoup plus élégant ! 
Merci !

----- Mail original -----
De: "Pierre Perol-Schneider" <[email-masked]>
À: "JoëlG" <[email-masked]>
Cc: "Gilles Thibault" <[email-masked]>, "lilypond-user-fr" <[email-masked]>, "lilypond-user-fr" <lilypond-user-fr-bounces+gillesth=[email-masked]>
Envoyé: Vendredi 30 Octobre 2020 11:22:06
Objet: Re: markup superposé à la barre de début de système

Le ven. 30 oct. 2020 à 11:14, < [email-masked] > a écrit :

---

From: martial <[email-masked]>
Date: Fri, 30 Oct 2020 03:50:58 -0700 (MST)

> "outside-score-priority" non trouvée.

Je suis version en 2.21.7

j'ai laissé 2.20.0 par flemme 

-----
♫artial♪

---

From: Valentin Villenave <[email-masked]>
Date: Fri, 30 Oct 2020 12:58:47 +0000

> Oui c'est beaucoup plus élégant !

Sinon j’avais quelque chose du genre :

%%%%%

highlightSystem =
#(define-music-function (color width) (color? number?)
   (define (combine grob)
     (let* ((stil (ly:system-start-delimiter::print grob))
            (yext (ly:stencil-extent stil Y))
            (xext (ly:stencil-extent stil X))
            (highlight (stencil-with-color
                        (ly:round-filled-box (cons 0 width) yext 0)
                        color)))
       (ly:make-stencil
        (ly:stencil-expr
         (ly:stencil-combine-at-edge
          stil X RIGHT highlight 0))
        xext yext)))
   #{
     \once \override Score.SystemStartBar.stencil = ##f
     \once \override Score.SystemStartBrace.stencil = $combine
     \once \override Score.SystemStartBracket.stencil = $combine
     \once \override Score.SystemStartSquare.stencil = $combine
   #})

\new ChoirStaff \with {\omit Clef \omit TimeSignature  }
<<
  {
    \highlightSystem #red #2 c''1
  }
  {c''1 }

%%%%

V.

---

From: [email-masked]
Date: Fri, 30 Oct 2020 14:12:34 +0100 (CET)

Alors là j'en reste baba...
Chapeau bas et 1000 mercis !

----- Mail original -----
De: "Valentin Villenave" <[email-masked]>
À: "joel gauvrit" <[email-masked]>
Cc: "Pierre Perol-Schneider" <[email-masked]>, "lilypond-user-fr" <[email-masked]>, "lilypond-user-fr" <lilypond-user-fr-bounces+gillesth=[email-masked]>
Envoyé: Vendredi 30 Octobre 2020 13:58:47
Objet: Re: markup superposé à la barre de début de système

%%%%%

highlightSystem =

%%%%

V.

---

From: martial <[email-masked]>
Date: Fri, 30 Oct 2020 06:13:53 -0700 (MST)

top ! 

-----
♫artial♪