Subject: Incipit et encore double barre !!

From: Jany Seytor <[email-masked]>
Date: Sun, 20 Sep 2020 18:30:59 +0000 (UTC)

Re bonjour !!

Je suppose que dans cette définition de l'incipit : 
incipit =
#(define-music-function (parser location incipit-music) (ly:music?)
  (_i "Output @var{incipit-music} before the main staff as an indication of
    its appearance in the original music.")
  #{
    \once \override Staff.InstrumentName.stencil =
      #(lambda (grob)
        (let* ((instrument-name (ly:grob-property grob 'long-text))
               (align-x (ly:grob-property grob 'self-alignment-X 0))
               (align-y (ly:grob-property grob 'self-alignment-Y 0)))
        (set! (ly:grob-property grob 'long-text)
          #{ \markup {
            \score
            {
              \new MensuralStaff \with {
                \override InstrumentName.self-alignment-X = #align-x
                \override InstrumentName.self-alignment-Y = #align-y
                instrumentName = #instrument-name
              }
              {
                $incipit-music
              }
              \layout {
                $(ly:grob-layout grob)
                indent-incipit-default = 15\mm
                line-width = #(primitive-eval
                  '(or (false-if-exception indent)
                    indent-incipit-default))
                indent = #(primitive-eval
                           '(or (false-if-exception (- line-width incipit-width))
                            (* 0.5 line-width)))
                ragged-right = ##f
                ragged-last = ##f
                system-count = 1
                \context {
                  \Score
                  \remove "Default_bar_line_engraver"
                }
              }
            }
            }
          #})
          (set! (ly:grob-property grob 'self-alignment-Y) #f)
          (set! (ly:grob-property grob 'self-alignment-X) RIGHT)
          (system-start-text::print grob)))
  #}
)trouvée dans le Lsr : http://lsr.di.unimi.it/LSR/Snippet?id=582

et correspondant à cette image : http://lsr.di.unimi.it/LSR/Search?q=incipit

il doit y avoir moyen de faire en sorte que la transcription moderne commence par une double barre de mesure et non par un crochet ?

C'était le cas dans le snippet de la version 2.18, et  dans certains cas la présentation me convient mieux.

En fait, je m'en sors en utilisant l'ancienne syntaxe, mais s'il y avait moyen de faire plus léger... et puis je comprendrais mieux l'écriture de cette fonction

Merci d'avance
Jany

---

From: Pierre Perol-Schneider <[email-masked]>
Date: Sun, 20 Sep 2020 21:17:59 +0200

Bonsoir Jany,
À voir, la commande \incipit en v2.20 :
http://lilypond.org/doc/v2.20/Documentation/notation/working-with-ancient-music_002d_002dscenarios-and-solutions.fr.html#incipits
Ce qui donne, par ex. :
\version "2.20.0"

discantus = {
  \set Staff.instrumentName = "Discantus"
  \override Staff.InstrumentName.self-alignment-X = #RIGHT
  \incipit {  \clef "neomensural-c1" \key f \major \time 2/2 c''1. }
  \fixed c' {
    \set Score.skipBars = ##t
    \hide Staff.BarLine
    \key g \major
    d'2. d'4 |
    b e' d'2 |
    c'4 e'4.( d'8 c' b |
    a4) b a2 |
    b4.( c'8 d'4) c'4 |
    \once \hide NoteHead
    c'1 |
    b\breve |
    \undo\hide Staff.BarLine
    \bar "|."
  }
}

discantusLyrics = \lyricmode {
  Ju -- bi -- la -- te De -- o,
  om -- nis ter -- ra, __ om-|
  "..."
  -us.
}

altus = {
  \set Staff.instrumentName = "Altus"
  \override Staff.InstrumentName.self-alignment-X = #RIGHT
  \incipit { \clef "neomensural-c3" \key f \major \time 2/2 r1 f'1. }
  \fixed c' {
    \key g \major
    \hide Staff.BarLine
    r2 g2. e4 fis g |
    a2 g4 e |
    fis g4.( fis16 e fis4) |
    g1 |
    \once \hide NoteHead
    g1 |
    g\breve |
    \undo\hide Staff.BarLine
    \bar "|."
  }
}

altusLyrics = \lyricmode {
  Ju -- bi -- la -- te
  De -- o, om -- nis ter -- ra,
  "..."
  -us.
}

tenor = {
  \set Staff.instrumentName = "Tenor"
  \override Staff.InstrumentName.self-alignment-X = #RIGHT
  \incipit { \clef "neomensural-c4" \key f \major \time 2/2 r\longa r\breve
r1 c'1. }
  {
    \clef "treble_8"
    \key g \major
    \hide Staff.BarLine
    R1 |
    R1 |
    R1 |
    % two measures
    r2 d'2. d'4 b e' |
    \once \hide NoteHead
    e'1 |
    d'\breve |
    \undo\hide Staff.BarLine
    \bar "|."
  }
}

tenorLyrics = \lyricmode {
  Ju -- bi -- la -- te
  "..."
  -us.
}

bassus = {
  \set Staff.instrumentName = "Bassus"
  \override Staff.InstrumentName.self-alignment-X = #RIGHT
  \incipit { \clef "mensural-f" \key f \major \time 2/2 r\maxima f1. }
  {
    \clef F
    \key g \major
    \hide Staff.BarLine
    R1 |
    R1 |
    R1 |
    R1 |
    g2. e4 |
    \once \hide NoteHead
    e1 |
    g\breve |
    \undo\hide Staff.BarLine
    \bar "|."
  }
}

bassusLyrics = \lyricmode {
  Ju -- bi-
  "..."
  -us.
}

\score {
  \new StaffGroup <<
    \new Staff <<
      \new Voice = Discantus \discantus
      \new Lyrics \lyricsto Discantus \discantusLyrics
    \new Staff <<
      \new Voice = Altus \altus
      \new Lyrics \lyricsto Altus \altusLyrics
    \new Staff <<
      \new Voice = Tenor \tenor
      \new Lyrics \lyricsto Tenor \tenorLyrics
    \new Staff <<
      \new Voice = Bassus \bassus
      \new Lyrics \lyricsto Bassus \bassusLyrics
  \layout {
    indent = 55
    incipit-width = 40
    system-count = 2
    \context {
      \StaffGroup
      systemStartDelimiter = #'SystemStartSquare
    }
  }
}

Cordialement,
Pierre

Le dim. 20 sept. 2020 à 20:31, Jany Seytor <[email-masked]> a écrit :

> )
> trouvée dans le Lsr : http://lsr.di.unimi.it/LSR/Snippet?id=582
>
> et correspondant à cette image :
> http://lsr.di.unimi.it/LSR/Search?q=incipit
>
> il doit y avoir moyen de faire en sorte que la transcription moderne
> commence par une double barre de mesure et non par un crochet ?
>
> En fait, je m'en sors en utilisant l'ancienne syntaxe, mais s'il y avait
> moyen de faire plus léger... et puis je comprendrais mieux l'écriture de
> cette fonction
>
> Merci d'avance
> Jany
>
>
>
>
>
>
>

---

From: Jany Seytor <[email-masked]>
Date: Sun, 20 Sep 2020 20:18:28 +0000 (UTC)

oui, ça marche avec SystemStartSquare, mais comment placer la SystemStartBar transformée en double barre ?

    Le dimanche 20 septembre 2020 à 21:18:12 UTC+2, Pierre Perol-Schneider <[email-masked]> a écrit :  
 
 Bonsoir Jany,À voir, la commande \incipit en v2.20 : http://lilypond.org/doc/v2.20/Documentation/notation/working-with-ancient-music_002d_002dscenarios-and-solutions.fr.html#incipitsCe qui donne, par ex. :\version "2.20.0"

discantus = {

altus = {

tenor = {
  \set Staff.instrumentName = "Tenor"
  \override Staff.InstrumentName.self-alignment-X = #RIGHT
  \incipit { \clef "neomensural-c4" \key f \major \time 2/2 r\longa r\breve r1 c'1. }
  {
    \clef "treble_8"
    \key g \major
    \hide Staff.BarLine
    R1 |
    R1 |
    R1 |
    % two measures
    r2 d'2. d'4 b e' |
    \once \hide NoteHead
    e'1 |
    d'\breve |
    \undo\hide Staff.BarLine
    \bar "|."
  }
}

bassus = {

\score {
  \new StaffGroup <<
    \new Staff <<
    >>
    >>
    >>
    >>
  >>
Cordialement,Pierre

Re bonjour !!

Merci d'avance
Jany