Subject: Redéfinition des percussions

From: Olivier Miakinen <[email-masked]>
Date: Sat, 4 May 2019 13:45:52 +0200

Bonjour,

Suite à mon interrogation et à la réponse de Pierre Perol-Schneider,
voici ma redéfinition des percussions au cas où cela pourrait aider
quelqu'un. Je n'ai redéfini que ce que je connais, et dans l'exemple
j'ai mis en gras ce dont je pense avoir le plus besoin.

<http://lilybin.com/52vhms/1>

\version "2.18.2"

#(define mydrums '(
                    (bassdrum default #f -3)
                    (snare default #f 1)
                    (sidestick cross #f 1)
                    (hihat cross #f 5)
                    (openhihat cross "open" 5)
                    (closedhihat cross "stopped" 5)
                    (halfopenhihat cross "halfopen" 5)
                    (pedalhihat cross #f -5)
                    (hightom default #f 4)
                    (himidtom default #f 3)
                    (lowmidtom default #f 2)
                    (lowtom default #f 0)
                    (highfloortom default #f -1)
                    (lowfloortom default #f -2)
                    (crashcymbal cross #f 6)
                    (splashcymbal cross #f 7)
                    (chinesecymbal cross #f 8)
                    (ridecymbal cross #f 4)
                    ))

\header {
  title = "redéfinition des percussions"
}

myBreak = { \bar " " \break }

drumAll = \drummode {
  \cadenzaOn

  bd  ^\markup { \center-align \bold "bassdrum: bd" }
  sn  ^\markup { \center-align \bold "snare: sn" }
  ss  ^\markup { \center-align "sidestick: ss" }
  \myBreak

  hh  ^\markup { \center-align \bold "hihat: hh" }
  hho ^\markup { \center-align \bold "openhihat: hho" }
  hhc ^\markup { \center-align "closedhihat: hhc" }
  hhho^\markup { \center-align "halfopenhihat: hhho" }
  hhp ^\markup { \center-align "pedalhihat: hhp" }
  \myBreak

  tomh ^\markup { \center-align "hightom: tomh" }
  tommh^\markup { \center-align \bold "himidtom: tommh" }
  tomml^\markup { \center-align \bold "lowmidtom: tomml" }
  toml ^\markup { \center-align "lowtom: toml" }
  tomfh^\markup { \center-align \bold "highfloortom: tomfh" }
  tomfl^\markup { \center-align "lowfloortom: tomfl" }
  \myBreak

  cymc ^\markup { \center-align \bold "crashcymbal: cymc" }
  cyms ^\markup { \center-align "splashcymbal: cyms" }
  cymch^\markup { \center-align "chinesecymbal: cymch" }
  cymr ^\markup { \center-align \bold "ridecymbal: cymr" }
  \myBreak

  %{
  cymca^\markup { \center-align "crashcymbala: cymca" }
  cymra^\markup { \center-align "ridecymbala: cymra" }
  cymcb^\markup { \center-align "crashcymbalb: cymcb" }
  cymrb^\markup { \center-align "ridecymbalb: cymrb" }
  rb   ^\markup { \center-align "ridebell: rb" }
  cb   ^\markup { \center-align "cowbell: cb" } \myBreak

  bohm^\markup { \center-align "mutehibongo: bohm" }
  boh ^\markup { \center-align "hibongo: boh" }
  boho^\markup { \center-align "openhibongo: boho" }
  bolm^\markup { \center-align "mutelobongo: bolm" }
  bol ^\markup { \center-align "lobongo: bol" }
  bolo^\markup { \center-align "openlobongo: bolo" } \myBreak

  cghm^\markup { \center-align "mutehiconga: cghm" }
  cglm^\markup { \center-align "muteloconga: cglm" }
  cgho^\markup { \center-align "openhiconga: cgho" }
  cgh ^\markup { \center-align "hiconga: cgh" }
  cglo^\markup { \center-align "openloconga: cglo" }
  cgl ^\markup { \center-align "loconga: cgl" } \myBreak

  timh^\markup { \center-align "hitimbale: timh" }
  timl^\markup { \center-align "lotimbale: timl" }
  agh ^\markup { \center-align "hiagogo: agh" }
  agl ^\markup { \center-align "loagogo: agl" } \myBreak

  ssh^\markup { \center-align "hisidestick: ssh" }
  ss ^\markup { \center-align "sidestick: ss" }
  ssl^\markup { \center-align "losidestick: ssl" } \myBreak

  guis^\markup { \center-align "shortguiro: guis" }
  guil^\markup { \center-align "longguiro: guil" }
  gui ^\markup { \center-align "guiro: gui" }
  cab ^\markup { \center-align "cabasa: cab" }
  mar ^\markup { \center-align "maracas: mar" } \myBreak

  whs^\markup { \center-align "shortwhistle: whs" }
  whl^\markup { \center-align "longwhistle: whl" } \myBreak

  hc  ^\markup { \center-align "handclap: hc" }
  tamb^\markup { \center-align "tambourine: tamb" }
  vibs^\markup { \center-align "vibraslap: vibs" }
  tt  ^\markup { \center-align "tamtam: tt"  } \myBreak

  cl ^\markup { \center-align "claves: cl" }
  wbh^\markup { \center-align "hiwoodblock: wbh" }
  wbl^\markup { \center-align "lowoodblock: wbl" } \myBreak

  cuim^\markup { \center-align "mutecuica: cuim" }
  cuio^\markup { \center-align "opencuica: cuio" }
  trim^\markup { \center-align "mutetriangle: trim" }
  tri ^\markup { \center-align "triangle: tri" }
  trio^\markup { \center-align "opentriangle: trio" } \myBreak

  ua^\markup { \center-align "oneup: ua" }
  ub^\markup { \center-align "twoup: ub" }
  uc^\markup { \center-align "threeup: uc" }
  ud^\markup { \center-align "fourup: ud" }
  ue^\markup { \center-align "fiveup: ue" } \myBreak

  da^\markup { \center-align "onedown: da" }
  db^\markup { \center-align "twodown: db" }
  dc^\markup { \center-align "threedown: dc" }
  dd^\markup { \center-align "fourdown: dd" }
  de^\markup { \center-align "fivedown: de" } \myBreak
  %}
}

\score {
  <<
    \new DrumStaff \with {
      \remove "Time_signature_engraver"
      \consists "Instrument_name_engraver"
      instrumentName = "défaut"
    } <<
      \new DrumVoice { \drumAll }
    \new DrumStaff \with {
      \remove "Time_signature_engraver"
      \consists "Instrument_name_engraver"
      instrumentName = "modifié"
    } <<
      \set DrumStaff.drumStyleTable = #(alist->hash-table mydrums)
      \new DrumVoice { \drumAll }
  \layout { }
}

---

From: Olivier Miakinen <[email-masked]>
Date: Sat, 4 May 2019 13:55:28 +0200

Post scriptum :

>                     (highfloortom default #f -1)

Il y a une certaine incohérence entre les « hi » et les « high » dans
ces définitions, et j'ai vérifié sur lilybin que c'était pareil en
2.19.48. Est-ce qu'il est prévu que cela change (ou que l'on puisse
utiliser indifféremment les deux graphies) ?

-- 
Olivier Miakinen

---

From: Valentin Villenave <[email-masked]>
Date: Sat, 4 May 2019 16:16:58 +0000

> utiliser indifféremment les deux graphies) ?

Bof, pas particulièrement. Cela a été évoqué cet été, et David a
commencé à soupirer quand on en est venu à se demander si "himidtom"
devrait plutôt s’écrire "highmidtom" ou "highmiddletom"…

V.

---

From: Olivier Miakinen <[email-masked]>
Date: Sat, 4 May 2019 18:38:22 +0200

Le 04/05/2019 18:16, Valentin Villenave m'a répondu :
> Bof, pas particulièrement.

À vrai dire je m'en doutais, et en fait c'est sans doute trop peu
utilisé pour que ça ait de l'importance. On utilise plutôt les
raccourcis hh, tomh, etc.

> Cela a été évoqué cet été, et David a

Haha... middle tom, à ne surtout pas confondre avec Tom Middleton !
<https://fr.wikipedia.org/wiki/Tom_Middleton>