Subject: "break beam"

From: filosophem <[email-masked]>
Date: Tue, 11 Dec 2018 01:30:56 -0700 (MST)

Bonjour à tous,

J'essaye d'écrire un exercice de batterie basé sur le moulin. Pour éviter un
long discours, voici le code :

up = \drummode {
  tomfl16 sn sn sn
  tomml16 sn sn sn
  tomfl16 sn sn sn
  tomml16 sn sn sn

  tomfl16 sn sn sn
  tomml16 sn sn sn
  tomfl16 sn sn sn
  tomml16 sn sn sn

  \break

  tomfl16 sn sn sn
  tomml16 sn sn sn
  tomfl16 sn sn sn
  tomml16 sn sn sn

  tomfl16 sn sn sn
  tomml16 sn sn sn
  tomfl16 sn sn sn
  tomml16 sn sn sn

  \break

  tomfl16 sn sn sn
  tomml16 sn sn sn
  tomfl16 sn sn sn
  tomml16 sn sn sn

  tomfl16 sn sn sn
  tomml16 sn sn sn
  tomfl16 sn sn sn
  tomml16 sn sn sn
}

down = \drummode {
  \override Beam.breakable = ##t
  bd8.[ hhp bd bd]
  hhp[ bd hhp hhp]

  bd[ hhp bd bd]
  hhp[ bd hhp hhp]

  bd[ hhp bd bd]
  hhp[ bd hhp hhp]

  bd[ hhp bd bd]
  hhp[ bd hhp hhp]
}

\score {
  \new DrumStaff
  <<
    \time 4/4
    \new DrumVoice { \voiceOne \up }
    \new DrumVoice { \voiceTwo \down }
  \layout { indent = 0
            ragged-right = ##f
  }
}

Le pdf me sort 2 lignes de 3 mesures. Je voudrais (pour la lisibilité) avoir
3 lignes de 2 mesures. Malgré de multiples tentatives, je n'arrive pas à
"couper" la voix 2 pour respecter les break de la voix 1. 

L'erreur remontée par Lilypond est la suivante:
"Avertissement : Un saut explicite a été outrepassé par un autre événement.
Positionnez quelques contrôles de mesure (bar check) pour vérifier."

Merci d'avance à tous pour votre aide

-----

"/home sweet /home"

Filosophem
--
Sent from: http://lilypond-french-users.1298960.n2.nabble.com/

---

From: Éditions IN NOMINE <[email-masked]>
Date: Tue, 11 Dec 2018 11:17:28 +0100

Salut !

Mmmm, c'est ta voix Down qui ne peut pas se découper toutes les 2
mesures... écrit comme cela.

Si tu ajoutes la voix :

misenepage = \drummode {
  \repeat unfold 2{s1*2 \break}
}

dans ton score, tu verras que ça fonctionne en commentant la voix down,
mais pas en commentant la voix up.

Il faut donc créer à la main des trous ainsi :

up = \drummode {
  tomfl16 sn sn sn
  tomml16 sn sn sn
  tomfl16 sn sn sn
  tomml16 sn sn sn

  tomfl16 sn sn sn
  tomml16 sn sn sn
  tomfl16 sn sn sn
  tomml16 sn sn sn

  \break

  tomfl16 sn sn sn
  tomml16 sn sn sn
  tomfl16 sn sn sn
  tomml16 sn sn sn

  tomfl16 sn sn sn
  tomml16 sn sn sn
  tomfl16 sn sn sn
  tomml16 sn sn sn

  \break

  tomfl16 sn sn sn
  tomml16 sn sn sn
  tomfl16 sn sn sn
  tomml16 sn sn sn

  tomfl16 sn sn sn
  tomml16 sn sn sn
  tomfl16 sn sn sn
  tomml16 sn sn sn
}

down = \drummode {
  hhp8. [ bd hhp hhp]

  bd8.[ hhp bd8.*1/3 s8 bd]
  hhp8.[ bd hhp hhp]

  bd8.[ hhp bd bd]
  hhp8.[ bd8.*1/3 s8 hhp8. hhp]

  bd8.[ hhp bd bd]
  hhp8.[ bd hhp hhp] s16
}

misenepage = \drummode {
  \repeat unfold 2{s1*2 \break}
}

\score {
  \new DrumStaff
  <<
    \time 4/4
    %\new DrumVoice { \voiceOne \up }
    \new DrumVoice { \voiceTwo \down }
    \new DrumVoice {\misenepage}
  >>
  \layout { indent = 0
            ragged-right = ##f
  }
}

A bientôt !

JMArc

Le 11/12/2018 à 09:30, filosophem a écrit :
> Bonjour � tous,
>
> J'essaye d'�crire un exercice de batterie bas� sur le moulin. Pour �viter un
> Le pdf me sort 2 lignes de 3 mesures. Je voudrais (pour la lisibilit�) avoir
> 3 lignes de 2 mesures. Malgr� de multiples tentatives, je n'arrive pas �
> L'erreur remont�e par Lilypond est la suivante:
> "Avertissement : Un saut explicite a �t� outrepass� par un autre �v�nement.
> Positionnez quelques contr�les de mesure (bar check) pour v�rifier."
>
> Merci d'avance � tous pour votre aide
>
>
>
> -----
>
> "/home sweet /home"
>
> Filosophem
> --
> _______________________________________________
> liste de diffusion lilypond-user-fr
> [email-masked]
> https://lists.gnu.org/mailman/listinfo/lilypond-user-fr
>

---

From: filosophem <[email-masked]>
Date: Tue, 11 Dec 2018 03:33:17 -0700 (MST)

Merci JMarc

C'est tout simplement bluffant et je n'y avais pas pensé

Affaire résolue !! 

-----

"/home sweet /home"

Filosophem

---

From: Éditions IN NOMINE <[email-masked]>
Date: Tue, 11 Dec 2018 11:40:17 +0100

De rien !

Après, ça reste du bricolage : je pense que des mécaniciens chevronnés
de Lilypond doivent avoir dans leur musette un moyen de faire faire cela
par Lilypond en automatique : avis aux expert.e.s !

Le 11/12/2018 à 11:33, filosophem a écrit :
> Merci JMarc
>
> C'est tout simplement bluffant et je n'y avais pas pens�
>
> Affaire r�solue !! 
>
>
>
>
>
> -----
>
> "/home sweet /home"
>
> Filosophem
> --

---

From: Pierre Perol-Schneider <[email-masked]>
Date: Tue, 11 Dec 2018 12:56:50 +0100

Bonjour Jean-Marc, Bonjour Sébastien,

Non, c'est plutôt malin. En revanche, "misenpage" est redondant avec la
voix 1, donc inutile.
Perso j'alignerai aussi les barres :

\version "2.18.2"

up = \drummode {
  \repeat unfold 4 {
    tomfl16 sn sn sn
    tomml16 sn sn sn
  }
  \break
    \repeat unfold 4 {
    tomfl16 sn sn sn
    tomml16 sn sn sn
  }
  \break
    \repeat unfold 4 {
    tomfl16 sn sn sn
    tomml16 sn sn sn
  }
}

down = \drummode {
  \override Beam.breakable = ##t
  \override Beam.positions = #'(-4.5 . -4.5)
  bd8.[ hhp bd bd]
  hhp8. [ bd hhp hhp]

  bd8.[ hhp bd bd]

  bd8.[ hhp bd bd]
  hhp8.[ bd hhp hhp] s16
  \revert Beam.positions
}

\score {
  \new DrumStaff
  <<
    \time 4/4
  \layout {
    indent = 0
  }
}

Cordialement,
Pierre

---

From: Valentin Villenave <[email-masked]>
Date: Tue, 11 Dec 2018 14:51:08 +0100

> par Lilypond en automatique : avis aux expert.e.s !

En l’occurrence, l’expert s’appelle David Nalesnik :
http://lsr.di.unimi.it/LSR/Item?u=1&id=838

Cordialement,
Valentin.