Subject: trop d'espace entre les systemes

From: Christian LE BARS <[email-masked]>
Date: Thu, 10 Nov 2016 17:44:11 +0100

bonjour,

voila j'ai une partition ou je trouve qu'il y a trop d'espace entre les
systèmes

comment puis- je les réduire;

ci dessous la partition:

\version "2.19.49"
\include "lilyjazz.ily"
%-------------------------------------------------
\header
{
   title = \markup { \fontsize #1 \bold\italic "tomorrow shall be my
dancing day" }
  composer =\markup { \italic "Traditionnel" } 
}
%----------------------------------------------
\paper
 {
  oddFooterMarkup = \markup { \fill-line { \fromproperty #'header:title  } }
  print-page-number = ##t
 }
%-----------------------------------------------
Global=
{
 \numericTimeSignature
 \set Score.markFormatter = #format-mark-box-alphabet
 \time 3/4
 \key g\major
 \partial 4
}
 %--------------------------------------
 %---------------------------------------
 LesAccords =
 \new ChordNames
  {
   \override ChordNames.ChordName.font-family = #'roman
   \override ChordNames . ChordName #'font-size = #1
   \set chordChanges = ##t
   \set Score.majorSevenSymbol = \markup {Maj7}
   \set chordNameSeparator = \markup { "/" }
   \set minorChordModifier = \markup{"-"}
   \chordmode
    {
     s4 g2. g2:9 d4/f g2. d:7
     c a:m7 g d
     g c:maj7/e a:m/c d
     c2:/e d4:/fis g2. a2:m7 d4:7/fis g2.   
    }
 }
 %---------------------------------
 CoupletA =
 \lyricmode
  {
   \override LyricText #'font-size = #1
   \override LyricText #'font-name = # "comics sans ms"
   to- mo- row shall be my dan- cing day
   i would my true love did so chance to
   see the leg- end of my play to call my true love to my dance
  }
%---------------------------------
 CoupletB =
 \lyricmode
  {
   \override LyricText #'font-size = #1
   \override LyricText #'font-name = # "comics sans ms"
    then was i born of a vir- gin pure
    of her i took flesh- ly sub- stance
    thus was i knit to man's na- ture
    to call my true love to my dance
  }
%---------------------------------
 CoupletC =
 \lyricmode
  {
   \override LyricText #'font-size = #1
   \override LyricText #'font-name = # "comics sans ms"
   in a man- ger laid and wrapped was
   so ve- ry poor this was my chance
   bet- wixt an ox and a silly poor ass
   to call my true love to my dance
  }
 %-----------------------------------
 LaVoix=
 \relative c'
  {
   \Global
   d4 g fis g a (b) c d (c) b a2 b4\break
   g (fis) g a (b) c d (c) b a2 b8 (c)\break
   d2 b4 c2 b4 a (g) a a2 d,4\break
   g2 a4 b(c) d c (b) a g2\bar"||"\pageBreak
 }
 %-----------------------------------
 LaMelodie =
  << %mise en parallèle la voix et les paroles
     \context Voice = voix
     \LaVoix
     \context Lyrics = coupletA\lyricsto voix  \CoupletA
     \context Lyrics = coupletB\lyricsto voix  \CoupletB
     \context Lyrics = coupletC\lyricsto voix  \CoupletC
%----------------------------------
 LaBasse =
 \relative c,
  {
   \new Staff
   \clef "bass_8"
   \Global
   s4
   g2 d'4 g4 d~d8 fis, g2 d'4~d8 d d2  c c4~c8 fis, a2 g4 d'4 g4~g d2
   g2 d4 e c e c a c d2 g4 e2 fis4 g2 d4 a2 fis4 g2
  }
  %---------------------------------------------
\score
{
   <<
    \LesAccords
    \LaMelodie
    \LaBasse
 \layout{}
  \header { piece = "Couplet" }
}
%-------------------------------------
%-----------------------------------------
 LaBasseA =
 \relative c
  {
   \clef bass
   s4 a2 g4 fis2 d'4 c2 d4  fis fis,2 a d4~d8 g d2 e2 fis4 g2 g4 a2 d,4 g,2.
  }
%------------------------------------
LesAccordsA =
 \new ChordNames
  {
   \override ChordNames.ChordName.font-family = #'roman
   \override ChordNames . ChordName #'font-size = #1
   \set chordChanges = ##t
   \set Score.majorSevenSymbol = \markup {Maj7}
   \set chordNameSeparator = \markup { "/" }
   \set minorChordModifier = \markup{"-"}
   \chordmode
    {
     s4 a2.:m7  d2:7/fis d4:7 c2.:maj7/g
     d:7/fis a2:m7 d4:7 d2.:7 c2:/e d4:/fis g2. a2:m7 d4:7 g2.
    }
}
%----------------------------------
\score
{
  <<
    \LesAccordsA
    <<
       \relative
        {
         \Global
         r4
         r2.  a'2  b8 (c) d2.~d2 b4 e2.(d2) r4 \break
         g4 f e d (c) b a (g) a g2.  
        }
      \addlyrics
       {
        \override LyricText #'font-size = #1
        \override LyricText #'font-name = # "comics sans ms"
         o my love my love this have i done for my true love
       }
     \relative
      {
       \Global
       b'4 a2 b8 (c) d2.b4 (g) b a2 b4 a2 b4 a2 d,4 g2 a4 b (c) d c (b)
a g2.
      }
    \addlyrics
      {
       \override LyricText #'font-size = #1
       \override LyricText #'font-name = # "comics sans ms"
       sing o my love o my love my love my love this have i done for my
true love
     }
  \new Staff\LaBasseA
  \layout
   { indent = 0\cm }
  \header { piece = "Refrain" }
}

Par avance merci

Pour vos conseils( j'ai pas su trouver dans la doc!)

christian

---

From: Philippe Neyrat <[email-masked]>
Date: Thu, 10 Nov 2016 21:21:50 +0100

Salut à tous,

Je sais pas si c'est très élégant, mais comme j'ai un book avec plein de 
bookparts différents, j'utilise dans chaque bloc paper une structure du 
style :

**************************************************************************

   \paper
   {
     indent = 0\cm
     ragged-right = ##f
     ragged-bottom = ##f
     ragged-last-bottom = ##f

     % Espace entre le bas de la marge haute et le milieu du premier système
     % s'il n'y a pas de titre ou de markup en haut de page
     top-system-spacing = #'((padding . 1)
                             (basic-distance . 6)
                             (minimum-distance . 4)
                             (stretchability . 0))

     % Espace entre le bas de la marge haute et le premier titre ou markup
     % s'il n'y a pas de système en haut de page
     top-markup-spacing = #'((padding . 1)
                             (basic-distance . 8)
                             (minimum-distance . 6)
                             (stretchability . 0))

     % Espace entre un titre ou un markup et le système qui le suit
     markup-system-spacing  = #'((padding . 1)
                                 (basic-distance . 12)
                                 (minimum-distance . 10)
                                 (stretchability . 12))

     % Espace entre deux titres ou markups
     markup-markup-spacing = #'((padding . 1)
                                (basic-distance . 4)
                                (minimum-distance . 2)
                                (stretchability . 0))

     % Espace entre un système et le titre ou le markup qui le suit
     score-markup-spacing  = #'((padding . 1)
                                (basic-distance . 18)
                                (minimum-distance . 16)
                                (stretchability . 12))

     % Espace entre le dernier système ou le dernier markup et le haut 
de la marge du bas
     last-bottom-spacing  = #'((padding . 1)
                               (basic-distance . 12)
                               (minimum-distance . 10)
                               (stretchability . 12))

   } % paper

**************************************************************************

Hope this helps...

Philippe

Le 10/11/2016 à 17:44, Christian LE BARS a écrit :
> _______________________________________________
> liste de diffusion lilypond-user-fr
> [email-masked]
> https://lists.gnu.org/mailman/listinfo/lilypond-user-fr
>

-- 
Propulsé par l'Association Sud-Ouest.org
Plateforme Libre d'hébergement mail à prix libre
     https://www.sud-ouest.org

---

From: Christian LE BARS <[email-masked]>
Date: Fri, 11 Nov 2016 17:46:29 +0100

bonsoir Philippe,

Merci pour ta réponse

Il y a de l'amélioration j'ai pris la fonction "/Espace entre système et
le titre ou le markup qui le suit"/

qu'il a fallut que j'inclus dans le "Layout" de mon dernier"Score"
 Il reste cependant un détail, Il y a trop de lignes d'espace entre les
deux scores.
 j'aurai aimé avoir qu'une seule ligne espace est- ce possible?

Ci dessous la partition corrigée:

\version "2.19.48"
#(set-global-staff-size 18) %taille des portées
\include "lilyjazz.ily"
   oddFooterMarkup = \markup { \fill-line { \fromproperty
#'header:title  } }
 Couplet =
   g2 a4 b(c) d c (b) a g2\bar"||"\break
     \context Lyrics = coupletA\lyricsto voix  \Couplet
%----------------------------------
 LaBasse =
 \relative c,
  {
   \new Staff
   \clef "bass_8"
   \Global
   s4
   g2 d'4 g4 d~d8 fis, g2 d'4~d8 d d2  c c4~c8 fis, a2 g4 d'4 g4~g d2
   g2 d4 e c e c a c d2 g4 e2 fis4 g2 d4 a2 fis4 g2
  }
% -------------------------------
\score
{
  <<
    \LesAccords
    \LaMelodie
    \LaBasse
  \layout
   { indent = 0\cm }
}
%---------------------------------------------
Solo=
\lyricmode
  {
   \override LyricText #'font-size = #1
   \override LyricText #'font-name = # "comics sans ms"
   o my love my love this have i done for my true love
}
%------------------------------------
Chorale=
\lyricmode
  {
   \override LyricText #'font-size = #1
   \override LyricText #'font-name = # "comics sans ms"
   sing o my love o my love my love my love this have i done for my true
love
}
%------------------------------------
LesAccordsA =
 \new ChordNames
  {
   \override ChordNames.ChordName.font-family = #'roman
   \override ChordNames . ChordName #'font-size = #1
   \set chordChanges = ##t
   \set Score.majorSevenSymbol = \markup {Maj7}
   \set chordNameSeparator = \markup { "/" }
   \set minorChordModifier = \markup{"-"}
   \chordmode
    {
     s4 a2.:m7  d2:7/fis d4:7 c2.:maj7/g
     d:7/fis a2:m7 d4:7 d2.:7 c2:/e d4:/fis g2. a2:m7 d4:7 g2.
    }
}
%-----------------------------------------
LaMelodieA =
\relative c'
{
  \Global
  \mark \markup {"Refrain"}
  r4
  r2.  a'2  b8 (c) d2.~d2 b4 e2.(d2) r4 \break
  g4 f e d (c) b a (g) a g2.
}
%------------------------------------------
LeChoeur =
\relative c''
{
 b4 a2 b8 c d2.b4 g b a2 b4 a2 b4 a2 d,4 g2 a4 b c d c b a g2. 
}
%-----------------------------------------
 LaBasseA =
 \relative c
  {
   \clef bass
   s4 a2 g4 fis2 d'4 c2 d4  fis fis,2 a d4~d8 g d2 e2 fis4 g2 g4 a2 d,4 g,2.
  }
 %-----------------------------------------
\score
{
  <<
    \LesAccordsA
     << %mise en parallèle la voix et les paroles
       \context Voice = voix
       \LaMelodieA
       \context Lyrics = Solo\lyricsto voix  \Solo
     \new Staff
     << %mise en parallèle la voix et les paroles
       \context Voice = voix
       \LeChoeur
       \context Lyrics = Chorale\lyricsto voix  \Chorale
    \new Staff\LaBasseA
  \layout
   {
    indent = 0\cm
    ragged-right = ##f
    ragged-bottom = ##f
    ragged-last-bottom = ##f
   score-markup-spacing  = #'(
                                               (padding . 1)
                                               (basic-distance . 18)
                                               (minimum-distance . 16)
                                               (stretchability . 12)
                                              )
   }
}
A+
Christian

---

From: Philippe Neyrat <[email-masked]>
Date: Tue, 15 Nov 2016 16:41:32 +0100

Heu, je sais pas trop, mais puisque c'est entre deux systèmes que tu 
veuilles moins d'espace (si j'ai bien compris), j'utiliserais plutôt 
system-system-spacing, avec la même syntaxe que les précédents.

Et en tâtonnant un peu, tu vas trouver les bonnes valeurs à appliquer.

Par exemple :

% Espace entre deux systèmes d'un même mouvement
system-system-spacing  = #'(
                              (padding . 1)
                              (basic-distance . 6)
                              (minimum-distance . 4)
                              (stretchability . 6)
                            )

Évidemment, la ligne qui va t'intéresser, c'est celle avec 
minimum-distance. Tu peux enlever les autres, Lilypond leur affecte des 
valeurs par défaut.

Chaque propriété d'espacement vertical concerne un type d'espacement 
soit entre markups, entre markups et systèmes, entre systèmes, en haut 
ou bas de page suivant qu'il y a un titre ou pas, etc. Là, il me semble 
bien que ce soit system-system-spacing qui te convienne.
Pour ma part, je tâtonne beaucoup avec tout ça, si d'autres peuvent 
apporter leurs lumières...

Hope this helps.

Philippe.

---

From: Philippe Neyrat <[email-masked]>
Date: Tue, 15 Nov 2016 16:44:00 +0100

Re !

Tout est là :

http://lilypond.org/doc/v2.18/Documentation/notation/flexible-vertical-spacing-paper-variables

Philippe