Subject: \tweak avec la basse chiffrée

From: JMarc <[email-masked]>
Date: Fri, 7 Oct 2016 05:10:53 -0700 (MST)

Bonjour à toute la troupe !

Dans le snippet suivant : 

J'aimerais pouvoir augmenter la taille du bémol du second chiffrage <6 _->.
J'ai essayé diverses formules de tweak dans le genre de celles utilisées
dans la doc, mais sans succès...

Un twix pour un bon tweak ! 
JMarc

-----
JMarc LEGRAND
Editions IN NOMINE
--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/tweak-avec-la-basse-chiffree-tp7584228.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

---

From: Pierre Perol-Schneider <[email-masked]>
Date: Fri, 7 Oct 2016 20:16:16 +0200

Bonjour Jean-Marc,

Exrait de.../current/scm/translation-functions.scm (voir ligne 30) :

\version "2.18.2"

#(define-public (new-bass-formatter-function figure event context)
  (let* ((fig (ly:event-property event 'figure))
         (fig-markup (if (number? figure)

                         ;; this is not very elegant, but center-aligning
                         ;; all digits is problematic with other markups,
                         ;; and shows problems in the (lack of) overshoot
                         ;; of feta-alphabet glyphs.
                         ((if (<= 10 figure)
                              (lambda (y) (make-translate-scaled-markup
                                           (cons -0.7 0) y))
                              identity)

                          (cond
                           ((eq? #t (ly:event-property event 'diminished))
                            (markup #:slashed-digit figure))
                           ((eq? #t (ly:event-property event
'augmented-slash))
                            (markup #:backslashed-digit figure))
                           (else (markup #:number (number->string figure
10)))))
                         #f))

         (alt (ly:event-property event 'alteration))
         (alt-markup
          (if (number? alt)
              (markup
               #:general-align Y DOWN #:fontsize
               (if (not (= alt DOUBLE-SHARP))
                   5 2) ;-2 2)  ;; <= fontsize defaults set here, : à
changer -2 pour 0 ou 1

               (alteration->text-accidental-markup alt))
              #f))

         (plus-markup (if (eq? #t (ly:event-property event 'augmented))
                          (markup #:number "+")
                          #f))

         (alt-dir (ly:context-property context
'figuredBassAlterationDirection))
         (plus-dir (ly:context-property context 'figuredBassPlusDirection)))

    (if (and (not fig-markup) alt-markup)
        (begin
          (set! fig-markup (markup #:left-align #:pad-around 0.3
alt-markup))
          (set! alt-markup #f)))

    ;; hmm, how to get figures centered between note, and
    ;; lone accidentals too?

    ;;    (if (markup? fig-markup)
    ;;  (set!
    ;;   fig-markup (markup #:translate (cons 1.0 0)
    ;;                      #:center-align fig-markup)))

    (if alt-markup
        (set! fig-markup
              (markup #:put-adjacent
                      X (if (number? alt-dir)
                            alt-dir
                            LEFT)
                      fig-markup
                      #:pad-x 0.2 alt-markup)))

    (if plus-markup
        (set! fig-markup
              (if fig-markup
                  (markup #:put-adjacent
                          X (if (number? plus-dir)
                                plus-dir
                                LEFT)
                          fig-markup
                          #:pad-x 0.2 plus-markup)
                  plus-markup)))

    (if (markup? fig-markup)
        (markup #:fontsize -2 fig-markup)
        empty-markup)))

bm = \markup\fontsize #2 \flat % <= autre possibilité

\figuremode {
  \set Score.figuredBassFormatter = #new-bass-formatter-function
  < 6 _- >
  < 6 \bm >
}

Cordialement,
Pierre

Le 7 octobre 2016 à 14:10, JMarc <[email-masked]> a écrit :

> View this message in context: http://lilypond-french-users.
> 1298960.n2.nabble.com/tweak-avec-la-basse-chiffree-tp7584228.html
> _______________________________________________
> liste de diffusion lilypond-user-fr
> [email-masked]
> https://lists.gnu.org/mailman/listinfo/lilypond-user-fr
>

---

From: JMarc <[email-masked]>
Date: Mon, 10 Oct 2016 00:15:16 -0700 (MST)

Grand merci Pierre !

D'abord, ça m'apprend à customiser les réglages par défaut de Lilypond + ça
fonctionne parfaitement !

En fait, j'utiliserai donc tout simplement ça : 

Grazie mille !
JMarc

-----
JMarc LEGRAND
Editions IN NOMINE
--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/tweak-avec-la-basse-chiffree-tp7584228p7584230.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.