Subject: image en arrière plan

From: achard free <[email-masked]>
Date: Thu, 7 Apr 2016 16:16:04 +0200

Bonjour à tous.
Est-il possible de mettre une image en arrière-plan d'une partition 
lilypond pour l'envoyer en fichier pdf (comme un filigrane à l'impression) ?
merci pour vos futures réponses.
jean-Pierre Achard

---

From: Pierre Perol-Schneider <[email-masked]>
Date: Thu, 7 Apr 2016 16:58:27 +0200

Bonjour Jean-Pierre,

Oui c'est possible en spécifiant une dimension nulle à l'image eps,
post-script ou au texte.
Ex :

\version "2.18.2"

\header {
  title = "Filigrane"
  tagline = ""
}

%% filigrane :
\markup \with-dimensions #'(0 . 0) #'(0 . 0) {
  \fontsize #23
  \with-color #yellow
  \rotate #45
  \translate #'(-10 . -70)
  "Filigrane"
}

\repeat unfold 40 { \relative c' { c4 d e f g a b c } }

Cordialement,
Pierre

Le 7 avril 2016 à 16:16, achard free <[email-masked]> a écrit :

> _______________________________________________
> liste de diffusion lilypond-user-fr
> [email-masked]
> https://lists.gnu.org/mailman/listinfo/lilypond-user-fr
>

---

From: achard free <[email-masked]>
Date: Thu, 7 Apr 2016 17:35:28 +0200

Merci,
c'est parfait.
Mais l'image n'est pas sur la deuxième page.
Comment fait-on ?
Jean-Pierre.

Le 07/04/2016 16:58, Pierre Perol-Schneider a écrit :
> Le 7 avril 2016 à 16:16, achard free <[email-masked] 
> <mailto:[email-masked]>> a écrit :
>
>     Bonjour à tous.
>     Est-il possible de mettre une image en arrière-plan d'une
>     partition lilypond pour l'envoyer en fichier pdf (comme un
>     filigrane à l'impression) ?
>     [email-masked] <mailto:[email-masked]>

---

From: Pierre Perol-Schneider <[email-masked]>
Date: Thu, 7 Apr 2016 20:16:43 +0200

Ah mé oui !! J'avais zoublié ça...
Je pense qu'il faut "simplement" intégrer le filigrane aux pieds de page.
Je dit "simplement" car après de nombreux essais infructueux j'ai googler
la question et trouvé la réponse ici:
http://www.lilypondforum.de/index.php?topic=1056.0*

Donc ça donne en v2.18 :

\version "2.18.2"

flg = \markup
  \with-dimensions #'(0 . 0) #'(0 . 0) {
    \override #'(layer . -5)
    \fontsize #22
    \with-color #yellow
    \rotate #45
    \translate #'(-60 . -70)
    "Filigrane"
  }

\header {
  title = "Filigrane"
  tagline = ""
  filigrane = \markup\flg
}

\paper {
        ragged-last-bottom = ##f
        bookTitleMarkup = \markup {
          \column {
            \bookTitleMarkup
            \fill-line {
              \fromproperty #'header:filigrane
            }
          }
        }
    oddHeaderMarkup = \markup
    \fill-line {
      %% force the header to take some space, otherwise the
      %% page layout becomes a complete mess.
      \null
      \center-column {
        \on-the-fly #not-first-page \fromproperty #'header:instrument
        \on-the-fly #not-first-page \fromproperty #'header:filigrane
      }
      \on-the-fly #print-page-number-check-first \fromproperty
#'page:page-number-string
    }
    evenHeaderMarkup = \markup
    \fill-line {
      \on-the-fly #print-page-number-check-first \fromproperty
#'page:page-number-string
      \center-column {
        \on-the-fly #not-first-page \fromproperty #'header:instrument
        \on-the-fly #not-first-page \fromproperty #'header:filigrane
      }
      \null
    }
}

%% test :
\score {
  \repeat unfold 200 { \relative c' { c4 d e f g a b c } }
}

Cordialement,
Pierre

---

From: achard free <[email-masked]>
Date: Thu, 7 Apr 2016 20:45:29 +0200

Merci Pierre. C'est OK.
Vive Lily.
Cordialement.
jean-Pierre.

Le 07/04/2016 20:16, Pierre Perol-Schneider a écrit :
> Je dit "simplement" car après de nombreux essais infructueux j'ai 
> googler la question et trouvé la réponse ici:
> Le 7 avril 2016 à 17:35, achard free <[email-masked] 
>>     Oui c'est possible en spécifiant une dimension nulle à l'image
>>     eps, post-script ou au texte.
>>     Ex :
>>
>>     \version "2.18.2"
>>
>>     \header {
>>       title = "Filigrane"
>>       tagline = ""
>>     }
>>
>>     %% filigrane :