Subject: Modification du rendu MIDI des blocs \chords

From: legoss <[email-masked]>
Date: Sat, 12 Mar 2016 08:34:43 -0700 (MST)

Bonjour à tous,

Voici mon code
%%%%%%%%%%
\version "2.18.2"
\score {
  <<
    \chords {
      c2 f2 c1
    }
    \relative c' {
      \time 4/4
      \key c\major c2 c2 c1
    }
    \addlyrics {
      \set stanza = "1. "
      bla bla bla
    }
  \layout { }
  \midi { 
    \context { 
      \Score
      tempoWholesPerMinute = #(ly:make-moment 120 4)
    } 
  } 
}
%%%%%%%%%%
Lilypond assigne, pour la partie \chords du rendu MIDI, un son piano et des
notes. Je cherche à modifier les deux, surtout les notes pour des
enchaînements d'accords plus cohérents.
Je caresse le doux espoir de pouvoir en retirer quelques nappes à exploiter
par ailleurs...
Quelqu'un a-t-il déjà regardé si c'était faisable? si oui, où est-ce que ça
se passe?

Merci pour votre aide
Cordialement,
Laurent

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/Modification-du-rendu-MIDI-des-blocs-chords-tp7583803.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

---

From: "Daniel Bernair" <[email-masked]>
Date: Wed, 16 Mar 2016 11:21:29 +0100

Voici ce que je fais quand je veux, pour le midi,  rendre les voix à 
différents instruments et les sons des instruments.
score {
  << %1
%%%%%%  \pointAndClickOff
        \new GrandStaff = "band" << %2
        \new Staff \with {midiInstrument = #"recorder" } << %3
        \set Staff.midiMinimumVolume = #0.6
          \set Staff.midiMaximumVolume = #0.7
        \new Voice = "flute" \Flute

      >> %3

       \new Staff \with {midiInstrument = #"viola" } << %3
       \set Staff.midiMinimumVolume = #0.4
          \set Staff.midiMaximumVolume = #0.5
        \new Voice = "viola" \Viola
             >> %3

    %%%%% \new Staff \with {midiInstrument = #"tenor sax" } << %3
      \new Staff \with {midiInstrument = #"trombone" } << %3
        \new Voice = "trombone" \Trombone
              >> %3
          >> %2
          \new ChoirStaff = "choeur" << %2
        \new Staff \with {midiInstrument = #"choir aahs" } << %3
        \new Voice = "sopun" \Sopranoun
        \new Lyrics \lyricsto "sopun" \SopUnParoles
        \new Lyrics \lyricsto "sopun" \SopUnParolespr

      >> %3

      \new Staff \with {midiInstrument = #"choir aahs" } << %3
        \new Voice = "altun" \Altoun
        \new Lyrics \lyricsto "altun" \AltUnParoles
        \new Lyrics \lyricsto "altun"  \AltUnParolespr
      >> %3

      %%%%% \new Staff \with {midiInstrument = #"tenor sax" } << %3
      \new Staff \with {midiInstrument = #"choir aahs" } << %3
        \new Voice = "tenor" \Tenor
        \new Lyrics \lyricsto "tenor"  \tenorvoix
        \new Lyrics \lyricsto "tenor"  \tenorvoixpr
      >> %3

      % {
      \new Staff \with {midiInstrument = #"choir aahs" } << %3
         \new Voice = "bass" \Basse
         \new Lyrics \lyricsto "bass" {\bassevoix}
       >> %3
       % }
     >> %2
   >> %1
\midi {
    \tempo 2. = 66
   }
  }
Ce n'est peut-être pas ce que vous cherchez mais c'est une piste.
Daniel Bernair
-----Message d'origine----- 
De : legoss
Date : samedi 12 mars 2016 16:34
À : [email-masked]
Objet : Modification du rendu MIDI des blocs \chords

Bonjour à tous,

Voici mon code
%%%%%%%%%%
\version "2.18.2"
\score {
  <<
    \chords {
      c2 f2 c1
    }
    \relative c' {
      \time 4/4
      \key c\major c2 c2 c1
    }
    \addlyrics {
      \set stanza = "1. "
      bla bla bla
    }
  \layout { }
  \midi {
    \context {
      \Score

Merci pour votre aide
Cordialement,
Laurent

--
View this message in context: 
http://lilypond-french-users.1298960.n2.nabble.com/Modification-du-rendu-MIDI-des-blocs-chords-tp7583803.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

_______________________________________________
liste de diffusion lilypond-user-fr
[email-masked]
https://lists.gnu.org/mailman/listinfo/lilypond-user-fr

---

From: legoss <[email-masked]>
Date: Wed, 16 Mar 2016 09:25:15 -0700 (MST)

Bonjour Daniel,

Merci pour ta réponse.
Malheureusement, elle ne répond pas à mon besoin.

Laurent

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/Modification-du-rendu-MIDI-des-blocs-chords-tp7583803p7583813.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.