Subject: double notation accord

From: Christian LE BARS <[email-masked]>
Date: Thu, 28 Jan 2016 17:06:14 +0100

bonjour,
voila je voudrais pouvoir noter sur une partition une variante d'accord
sur une portée . le PB c'est que les parenthèses se "promènent" un
peu.je ne veux pas me servir d'ossia
quelqu' un a t'il une solution ci joint mon code:\version "2.19.35"

LesAccordOssia =
{
  \new ChordNames
 {
   \mark \markup{(} e2 a g d\mark \markup{)}
 }
}
LesAccords=
{
  \new ChordNames
 {
  c1 f a b
 }
}
 LeChant =
 \relative c'
  { c4 g' d a' f a c e
  }
\score
{
  <<
    \LesAccordOssia
    \LesAccords
    \LeChant
  \layout {}
}

Par avance merci

---

From: Pierre Perol-Schneider <[email-masked]>
Date: Thu, 28 Jan 2016 17:16:36 +0100

Bonjour Christian,

La solution se trouve sur la LSR: http://lsr.di.unimi.it/LSR/Item?id=902

\version "2.19.35"

startParenthesis = {
  \once \override ParenthesesItem.stencils = #(lambda (grob)
        (let ((par-list (parentheses-item::calc-parenthesis-stencils grob)))
          (list (car par-list) point-stencil )))
}

endParenthesis = {
  \once \override ParenthesesItem.stencils = #(lambda (grob)
        (let ((par-list (parentheses-item::calc-parenthesis-stencils grob)))
          (list point-stencil (cadr par-list))))
}

LesAccordOssia = \new ChordNames {
  %\mark \markup{(} e2 a g d\mark \markup{)}
  \startParenthesis\parenthesize e2  a   g
  \endParenthesis\parenthesize d
}

LesAccords= \new ChordNames { c1 f a b }

LeChant = \relative c' { c4 g' d a' f a c e }

\score
{
  <<
    \LesAccordOssia
    \LesAccords
    \LeChant
  \layout {}
}

Cordialement,
Pierre

Le 28 janvier 2016 à 17:06, Christian LE BARS <[email-masked]> a
écrit :

> _______________________________________________
> liste de diffusion lilypond-user-fr
> [email-masked]
> https://lists.gnu.org/mailman/listinfo/lilypond-user-fr
>

---

From: Christian LE BARS <[email-masked]>
Date: Fri, 29 Jan 2016 07:12:40 +0100

bonjour Pierre,
Super!
merci beaucoup