Subject: Bizareries causées par \acciatura

From: Bernard Meylan <[email-masked]>
Date: Mon, 23 Mar 2015 02:13:48 -0700 (MST)

Bonjour à tous,

dans le code suivant,

\version "2.18.2"

#(set-global-staff-size 18)
%\pointAndClickOff

\header {
  title = \markup { \override #'(font-name . "RomandeADFNo2Std Regular")
  \fontsize #5 "Chanson de Vilja" }
  subtitle = \markup { \override #'(line-width . 10)
    \override #'(font-name . "RomandeADFNo2Std Regular")
    \center-column {
            \lower #2
            \fontsize #1 \line {La Veuve Joyeuse}
    }}
  
  composer = \markup { \override #'(font-name . "RomandeADFNo2Std Bold
Regular")
  \fontsize #2 "Franz Lehar" }
  tagline = ##f
}

\paper {
  line-width = 18.5 \cm
  ragged-last-bottom = ##f
  ragged-bottom = ##f
  top-margin = 1.5\cm
  bottom-margin = 1.5\cm
}

global = {
  \key g \major
  \time 2/4
  \tempo \markup { \override #'(font-name . "BerenisADFPro Bold") 
  \fontsize #3 "Allegro" }
}

sopranoVoice = \relative c' {
  \global
  \dynamicUp
  \autoBeamOff
  \grace {s16 s s s} 
  R2*3 r4 r8\fermata d8
  % 5
  \repeat volta 2 {
    b'4 a8 c b4 a8 c b4 e8. e16 d4. c8 b4 a8 c 
    % 10
    b4 fis8 a g4 fis8 g e4. e8 c'4 b8 c e4 d8 c
    % 15
    b4 a8. a16 g4. g8 g'4 fis8 e d4 b8 g c4 b8 a 
    % 20
    g2 g16 a g a b8 cis d4. fis,8 g16 a g a b8 cis d2 
    % 25
    fis4 e d g,16 a b c b4 a g2 \bar "||"
    % 29
    d4 g8 a b4 d8 e fis4 e8. d16 b2 a4 d8 b a4 d8 b 
    % 35
    e,4 fis8. d16 e2 d4 g8 a b4 g'8 g fis4 d8 b 
    % 40
    d2 fis,4 g8 a b4 e8. a,16 d2~d
    % 45
    R2*8 
    % 53
    d,4 g8 a b4 g'8\fermata g 
    % 55
    fis4 d8 b d2 a4 d8. b16 a4 b8.\fermata fis16
  }
  \alternative {
    {g2~g4 r R2*3 r4 r8\fermata d} 
    {g2}
  }
  r8 a b c d2 e4 \afterGrace g( b8) <<{b2~b~b\fermata} \\ {\parenthesize g~
\parenthesize g~ \parenthesize g}>> 
  \bar "|."
}

verseOneSopranoVoice = \lyricmode {
  \set stanza = "1."
  % Ajouter ici des paroles.
  
}

verseTwoSopranoVoice = \lyricmode {
  \set stanza = "2."
  % Ajouter ici des paroles.
  
}

soprano = \relative c' {
  \global
  \autoBeamOff
  \grace {s16 s s s}
  R2*44
  % 45
  d4 g8 a b4 d8 e fis4 e8. d16 b2 a4 d8 b a4 d8 b e,4 fis8. d16 e2
  % 53
  R2*12
  % 65 2.
  R2 e2 g a *~*~*\fermata
}

alto = \relative c' {
  \global
  \autoBeamOff
  \grace {s16 s s s}
  R2*44
  % 45
  d4 g8 a b4 d8 e fis4 e8. d16 b2 a4 d8 b a4 d8 b e,4 fis8. d16 e2
  % 53
  R2*12
  % 65 2.
  R2 <c' e>2 *   <g b>~<g b>~<g b>\fermata

}

tenor = \relative c' {
  \global
  \autoBeamOff
  \grace {s16 s s s}
  s2*44
  % 45
  s2*2 b4 b8. b16 b2 s2*4
  
}

bass = \relative c {
  \global
  \autoBeamOff
  \grace {s16 s s s}
  R2*44
  % 45
  d4 g8 a b4 d8 d,\rest g4 g8. g16
  
}

verseOneChoir = \lyricmode {
  \set stanza = "1."
  % Ajouter ici des paroles.
  
}

verseTwoChoir = \lyricmode {
  \set stanza = "2."
  % Ajouter ici des paroles.
  
}

right = \relative c'' {
  \global
  \acciaccatura {g'16 a b c} 
  d-.[ d-. d-. d-.] d8-. c-. \acciaccatura {d,16 e fis g a} b8.(\(-> g16)
d8. b16 
  d a'\) a-. a-. a8 \tuplet 3/2 8 {a16( b a} g8) r <g b d g>-> 
  
}

left = \relative c {
  \global
  \grace {s16 s s s} 
  g8 <d' g b> d, <d' fis c'> g,8 <d' g b> g,8 <d' g b> a <d fis c'> d <fis
c'> <g b> r <g, d' g> r\fermata
  
}

sopranoVoicePart = \new Staff \with {
  instrumentName = "Soprano"
} { \sopranoVoice }
\addlyrics { \verseOneSopranoVoice }
\addlyrics { \verseTwoSopranoVoice }

choirPart = \new ChoirStaff <<
  \new Staff \with {
    instrumentName = "Soprano"
  } \new Voice = "soprano" \soprano
  \new Lyrics \with {
    \override VerticalAxisGroup #'staff-affinity = #CENTER
  } \lyricsto "soprano" \verseOneChoir
  \new Lyrics \with {
    \override VerticalAxisGroup #'staff-affinity = #CENTER
  } \lyricsto "soprano" \verseTwoChoir
  \new Staff \with {
    instrumentName = "Alto"
  } \new Voice = "alto" \alto
  \new Lyrics \with {
    \override VerticalAxisGroup #'staff-affinity = #CENTER
  } \lyricsto "alto" \verseOneChoir
  \new Lyrics \with {
    \override VerticalAxisGroup #'staff-affinity = #CENTER
  } \lyricsto "alto" \verseTwoChoir
  \new Staff \with {
    instrumentName = \markup \center-column { "Ténor" "Basse" }
  } <<
    \clef bass
    \new Voice = "tenor" { \voiceOne \tenor }
    \new Voice = "bass" { \voiceTwo \bass }

pianoPart = \new PianoStaff \with {
  instrumentName = "Piano"
} <<
  \new Staff = "right" \right
  \new Staff = "left" { \clef bass \left }

\score {
  <<
    \sopranoVoicePart
    \choirPart
    \pianoPart
  \layout {
    \context {
      \Lyrics
      \override LyricText #'font-name = #"RomandeADFNo2Std Bold"
      \override LyricText #'font-size = #'1
    }
    \context {
      \Score
      \override StaffSymbol #'thickness = #1.75
      \override BarNumber #'break-align-symbols = #'(clef)
      \override BarNumber #'self-alignment-X = #2
      \override BarNumber #'font-name = #"Berenis ADF Med Bold Italic"
      \override BarNumber #'padding = #2.0
    }
  }
}

le fait d'introduire les petites notes à la main droite du piano met le
boxon: d'abord, impossible d'éliminer la clé de fa sur la portée
Ténor/Basse, ensuite au moment de chanter ensemble, les hampes de ces deux
voix se calent vers le bas, ce qui alerte Lily qui me dit: 

/Avertissement : trop d'empilements de notes se chevauchent. On fera au
mieux./

Le fait d'éliminer ces petites notes et leurs équivalents invisibles dans
les autres portées résoud le problème.

Je n'ai pas testé avec la dernière version de LilyPond... une solution?

-----
Cordialement

Bernard
--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/Bizareries-causees-par-acciatura-tp7582582.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

---

From: Christophe Pochon <[email-masked]>
Date: Mon, 23 Mar 2015 11:04:42 +0100

Salut,

Dans les voix de soprano et alto, tu as mis des * qui ne plaisent pas trop
à Lilypond. J'ai dû les supprimer pour pouvoir compiler ton code.

Concernant la clef de fa sur la portée ténor/basse, c'est parce que tu as
mis un "\clef bass" dans la création du Staff. Je l'ai supprimé d'ici et
ajouté dans la voix de ténor, juste après \global et c'est tout bon.

Je n'ai pas le message d'erreur que tu as à propos de notes qui se
chevauchent. Je suis en 2.19.15

Bonne journée,

Christophe

Christophe Pochon
http://www.christophe-pochon.com

Le 23 mars 2015 10:13, Bernard Meylan <[email-masked]> a écrit :

> View this message in context:
> http://lilypond-french-users.1298960.n2.nabble.com/Bizareries-causees-par-acciatura-tp7582582.html
> _______________________________________________
> liste de diffusion lilypond-user-fr
> [email-masked]
> https://lists.gnu.org/mailman/listinfo/lilypond-user-fr
>