Subject: Diagrammes d'accords à ma sauce

From: "[email-masked]" <[email-masked]>
Date: Thu, 3 Apr 2014 14:42:17 +0200

Bonjour à tous,

Je cherche à obtenir des diagrammes d'accords à ma sauce, comme dans le
petit exemple suivant.

\version "2.17.29"

}
\header {
  title = "Titre"
}

global = {
  \key g \major
  \time 4/4
  \tempo 4=100
}

chordNames = \chordmode {
  \global
  \powerChords
  g1 d2
}

melody = \relative c'' {
  \global
  g2^\markup {
   
    \override #'(fret-diagram-details . (
                                         (label-dir . -1)
                                         (finger-code . in-dot)
                                         (mute-string . "X")
                                         (open-string . "O")
                                         (orientation . portrait)
                                         (barre-type . none)
                                         (dot-radius . 0.5)
                                         (dot-color . white)
                                         (xo-font-magnification . 0.4)
                                         (xo-padding . 0.3))) {
                                           \fret-diagram-verbose
#'((mute 6)
                                                                   
(mute 5)
                                                                   
(mute 4)
                                                                   
(open 3 1)
                                                                   
(open 2  3)
                                                                   
(place-fret 1 3 1)
                                                                   
(barre 0 0 0 ))
    }
  } g4 b b^\markup {
   
    \override #'(fret-diagram-details . (
                                         (label-dir . -1)
                                         (finger-code . in-dot)
                                         (mute-string . "X")
                                         (open-string . "O")
                                         (orientation . portrait)
                                         (barre-type . none)
                                         (dot-radius . 0.5)
                                         (dot-color . white)
                                         (xo-font-magnification . 0.4)
                                         (xo-padding . 0.3))) {
                                           \fret-diagram-verbose
#'((mute 6)
                                                                   
(mute 5)
                                                                   
(open 4)
                                                                   
(place-fret 3 2 3)
                                                                   
(place-fret 2 3 1)
                                                                   
(place-fret 1 2 5)
                                                                    )
    }
  }
 
}

verseI = \lyricmode {
  À la
}

classicalGuitar = \relative c' {
  \global
  <g g,>2
 
}

leadSheetPart = <<
  \new ChordNames \chordNames
  \new Staff { \melody }
  \addlyrics { \verseI }

classicalGuitarPart = \new StaffGroup \with {
  \consists "Instrument_name_engraver"
  instrumentName = "Guitare"
} <<
  \new Staff \with {
    midiInstrument = "acoustic guitar (nylon)"
  } { \clef "treble_8" \classicalGuitar }
  \new TabStaff \with {
    stringTunings = #guitar-tuning
  } \classicalGuitar

\score {
  <<
    \leadSheetPart
    \classicalGuitarPart
  \layout { }
  \midi { }
}

Je voudrais n'avoir à déclarer les détails de dessin des diagrammes
qu'une fois.
J'aimerai aussi définir mes propres accords de base dans un catalogue
utilisable pour différentes partitions.
Je ne sais pas trop comment m'y prendre.

Quelqu'un aurait-il des pistes?

Merci beaucoup!

-- 
Harpo

---

From: Pierre Perol-Schneider <[email-masked]>
Date: Thu, 3 Apr 2014 15:57:50 +0200

Le 3 avril 2014 14:42, [email-masked] <[email-masked]> a

> Bonjour à tous,

Bonjour Harpo,

> qu'une fois.

%%%%%%%%%%%%%%%%%%%%%
mySol = \markup {

(label-dir . -1)

(finger-code . in-dot)

(mute-string . "X")

(open-string . "O")

(orientation . portrait)

(barre-type . none)

(dot-radius . 0.5)

(dot-color . white)

(xo-padding . 0.3))) {

\fret-diagram-verbose #'(

(mute 6)

(mute 5)

(mute 4)

(open 3 1)

(open 2 3)

(place-fret 1 3 1)

(barre 0 0 0 ))

}

}

 myRe = \markup {

(label-dir . -1)

(finger-code . in-dot)

(mute-string . "X")

(open-string . "O")

(orientation . portrait)

(barre-type . none)

(dot-radius . 0.5)

(dot-color . white)

(xo-padding . 0.3))) {

\fret-diagram-verbose #'(

(mute 6)

(mute 5)

(open 4)

(place-fret 3 2 3)

(place-fret 2 3 1)

(place-fret 1 2 5))

}

}

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

puis :

melody = \relative c'' {

\global

g2^\mySol g4 b b^\myRe

}

> Je ne sais pas trop comment m'y prendre.

Il faut créer un fichier mesAccords.ly contenant les définitions perso de
tes accords (mySol, myRe, etc.) puis ajouter en début de chaque partition :

\include "mesAccords.ly"

Cordialement,
~Pierre

---

From: Schneidy <[email-masked]>
Date: Sat, 5 Apr 2014 11:45:43 -0700 (PDT)

Si je peux me permettre, l’utilisation des grilles en \markup me paraît bien
compliquée.
Pourquoi ne pas utiliser le \FretBoards mis à ta disposition ?
Cela donnerait (j'ai gardé tes doigtés même s'ils m'échappent un peu) :

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
\version "2.17.29"

global = {
  \key g \major
  \time 4/4
  \tempo 4=100
}

\storePredefinedDiagram #default-fret-table \chordmode { d }
                        #guitar-tuning
                        #"x;x;o;2-3;3-2;2-5;"
                        
\storePredefinedDiagram #default-fret-table \chordmode { g }
                        #guitar-tuning
                        #"x;x;x;o;o;3-1;"                     

melody = \relative c'' {
\global
g2 g4 b b

}

verseI = \lyricmode {
  À la
}

} 

\score {
  <<
    <<
      \new ChordNames \chordNames
      \new FretBoards 
      \with {
        \override FretBoard.fret-diagram-details.label-dir = #LEFT
        \override FretBoard.fret-diagram-details.finger-code = #'in-dot
        \override FretBoard.fret-diagram-details.mute-string = "X"
        \override FretBoard.fret-diagram-details.open-string = "O"
        \override FretBoard.fret-diagram-details.orientation = #'normal
        \override FretBoard.fret-diagram-details.barre-type = #'none
        \override FretBoard.fret-diagram-details.dot-radius = #0.5
        \override FretBoard.fret-diagram-details.dot-color = #'white
        \override FretBoard.fret-diagram-details.xo-font-magnification =
#0.4
        \override FretBoard.fret-diagram-details.xo-padding = #0.3
      }
      \chordNames
      \new Staff { \melody }
      \addlyrics { \verseI }
    \new StaffGroup 
    \with {
      \consists "Instrument_name_engraver"
      instrumentName = "Guitare"
    } 
    <<
      \new Staff 
      \with { midiInstrument = "acoustic guitar (nylon)" } 
      { 
        \clef "treble_8" 
        \classicalGuitar 
      }
      \new TabStaff 
      \with { stringTunings = #guitar-tuning }
      \classicalGuitar
  \layout { }
  \midi { }
}
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

Cordialement,
~Pierre

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/Diagrammes-d-accords-a-ma-sauce-tp7581089p7581118.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

---

From: "[email-masked]" <[email-masked]>
Date: Sat, 12 Apr 2014 15:06:52 +0200

Merci Pierre,

Cela va tout à fait dans le sens de ce que cherche.

-- 
Harpo

On 05/04/2014 20:45, Schneidy wrote:
> global =
>   \tempo 40
> chordNames =chordmode {
> melody =relative c'' {
> verseI =lyricmode {
> classicalGuitar =relative c' {
>   \global
>   <g g,>2
>
> } 
>
> \score {
>   <<
>     <<
>         \override FretBoard.fret-diagram-details.label-dir =LEFT
>         \override FretBoard.fret-diagram-details.finger-code ='in-dot
>         \override FretBoard.fret-diagram-details.mute-string =X"
>         \override FretBoard.fret-diagram-details.open-string =O"
>         \override FretBoard.fret-diagram-details.orientation ='normal
>         \override FretBoard.fret-diagram-details.barre-type ='none
>         \override FretBoard.fret-diagram-details.dot-radius =0.5
>         \override FretBoard.fret-diagram-details.dot-color ='white
>         \override FretBoard.fret-diagram-details.xo-font-magnification #0.4
>         \override FretBoard.fret-diagram-details.xo-padding =0.3
>       }
>       \chordNames
>       \new Staff { \melody }
>       \addlyrics { \verseI }
>     >>
>     \new StaffGroup 
>     \with {
>       instrumentName =Guitare"
>       \with { midiInstrument =acoustic guitar (nylon)" } 
>       { 
>         \clef "treble_8" 
>         \classicalGuitar 
>       }
>       \new TabStaff 
>       \with { stringTunings =guitar-tuning }
>       \classicalGuitar
>     >>
>   >>
>   \layout { }
>   \midi { }
> }

---

From: "[email-masked]" <[email-masked]>
Date: Sat, 12 Apr 2014 15:20:48 +0200

J'oubliais d'expliquer un peu mes doigtés un peu bizarre.
Je détourne les indications de doigté pour montrer les degrés dans
l'accord. C'est pour moi une information bien plus utile.
Je ne parviens pas à différencier un degré b3 d'un 3, mais c'est déjà
mieux que rien.
J'aimerai aussi pouvoir différencier davantage encore, en ayant un
cercle plus grand pour le degré 1, voire même associer une couleur à
chaque degré.

On peut rêver, non?

:)
Bonne journée et merci encore,

-- 
Harpo