Subject: étrange disparition des strokeFinger et stringNumber

From: Eluze <[email-masked]>
Date: Fri, 2 Nov 2012 08:51:26 -0700 (PDT)

music = \new Voice = music { \relative { c4 d8 d8 <e g>4 <f a> g f <e g> <d
f> c b a b <c e g c>1} } % <-----
musicWithFinger = \addFingering \music
            #"012345           % mes 1
              xxxx '1-2''3-4'  % mes 2
              -1+2-3+4         % mes 3
              1234             % mes 4
              "
musicWithFingerAndStringAndStroke = \addStrokeFinger \addStringNumber
\addFingering \music  % <-----
            #"012345           % mes 1                                                     
              xxxx '1-2''3-4'  % mes 2                                                     
              -1+2-3+4         % mes 3                                                     
              1234             % mes 4
              "
            #"5656"                                                                        
% <-----
            #"12345"                                                                       
% <-----

lyrtext = \lyricmode { un deux trois qua -- tre }                                          
% <-----

avec le code ci-dessous quelques stringNumbers ainsi que les strokeFingers
disparaissent:

\score {<<
  % \new Staff \with { instrumentName = \markup \center-column {
"original""music" }}             % <-----
             % \music                                                                            
% <-----
  \new Staff \with { instrumentName = \markup \center-column
{"music""with""fingerings"}}        
             % \musicWithFinger                                                                 
% <-----
             \musicWithFingerAndStringAndStroke                                                 
% <-----
  \new Lyrics \lyricsto music \lyrtext                                                          
% <-----
>>}

en rajoutant un staff tout semble en ordre:

\score {<<
  \new Staff \with { instrumentName = \markup \center-column {
"original""music" }}             
             \music                                                                             
  \new Staff \with { instrumentName = \markup \center-column
{"music""with""fingerings"}}        
             % \musicWithFinger                                                                 
% <-----
             \musicWithFingerAndStringAndStroke                                                 
% <-----
  \new Lyrics \lyricsto music \lyrtext                                                          
% <-----
>>}

que faut-il faire? (j'ai utilisé les définitions scheme publiées dans le LSR
et j'ai marqué toutes les lignes changées)

Eluze

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/etrange-disparition-des-strokeFinger-et-stringNumber-tp7578622.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

---

From: Gilles <[email-masked]>
Date: Fri, 02 Nov 2012 21:08:44 +0100

> avec le code ci-dessous quelques stringNumbers ainsi que les  
Je ne peux pas expliquer pourquoi, mais je peux simplement dire que ça n'a  
rien à voir avec fingering.ly
(Pour ceux qui se demandent de quoi on parle
   http://lsr.dsi.unimi.it/LSR/Item?id=768
)

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
\version "2.16.0"
music = \new Voice = "music" {
     c'4\rightHandFinger #1 \5-0
       d'8\rightHandFinger #2 \6-1 d'\rightHandFinger #3 \5-2
       < e'\rightHandFinger #4 \6-3 g'-4 >4
       < f'-5 a' > |
     g' f' < e' g'-\tweak #'text #"1-2" -0 >
        < d'-\tweak #'text #"3-4" -0 f'_1 > |
     c'^2 b_3 a^4 b-1 |
     < c'-2 e'-3 g'-4 c'' >1
   }
lyrtext = \lyricmode { un deux trois qua -- tre }

\markup "\\music sans Lyrics"
   \music
\markup "\\music avec Lyrics"
   \score {<<
     \new Staff \music
     \new Lyrics \lyricsto music \lyrtext
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

-- 
Gilles

---

From: Eluze <[email-masked]>
Date: Fri, 2 Nov 2012 16:03:03 -0700 (PDT)

Gilles THIBAULT wrote
> Le Fri, 02 Nov 2012 16:51:26 +0100, Eluze &lt;

> EluzeW@

> &gt; a écrit:

en effet, pardon d'avoir soupçonné le /fingering.ly/ et surtout merci pour
l'exemple en LilyPond  cru qui semble dénoncer un bug!

je me hâte de le rapporter sur la liste bug!

Eluze

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/etrange-disparition-des-strokeFinger-et-stringNumber-tp7578622p7578625.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

---

From: Eluze <[email-masked]>
Date: Fri, 2 Nov 2012 16:27:33 -0700 (PDT)

Eluze wrote
> je me hâte de le rapporter sur la liste bug!

et voilà - réduit pour être svelte:
http://lilypond.1069038.n5.nabble.com/lyrics-with-music-disturbs-fingering-stroke-fingering-or-string-numbering-tp135727.html

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/etrange-disparition-des-strokeFinger-et-stringNumber-tp7578622p7578626.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

---

From: Eluze <[email-masked]>
Date: Sat, 3 Nov 2012 08:57:54 -0700 (PDT)

je crois que la cause est toute simple: il faut mettre les indication pour
StrokeFinger et StringNumber dans un accord (< … >)

quelqu'un connaitrait-il une méthode qui transforme chaque note suivie d'une
indication /main droite/ ou /numéro de corde/?

merci d'avance!
Eluze

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/etrange-disparition-des-strokeFinger-et-stringNumber-tp7578622p7578627.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.