Subject: Acciaccatura en début de portée

From: flup <[email-masked]>
Date: Tue, 5 Jun 2012 21:43:43 -0700 (PDT)

Bonjour,

Dans l'exemple suivant, l'ajout d'une acciaccatura en début de système donne
un résultat pour le moins surprenant.

Sans acciaccatura :
http://lilypond-french-users.1298960.n2.nabble.com/file/n7578096/Capture_d%E2%80%99%C3%A9cran_2012-06-06_%C3%A0_06.37.08.jpg 

Avec :
http://lilypond-french-users.1298960.n2.nabble.com/file/n7578096/Capture_d%E2%80%99%C3%A9cran_2012-06-06_%C3%A0_06.37.29.jpg 

Pour régler le problème, j'ai dû mettre une acciaccatura dans la portée qui
n'a aucune note dans la mesure concernée, sous la forme \acciaccatura s8

http://lilypond-french-users.1298960.n2.nabble.com/file/n7578096/Capture_d%E2%80%99%C3%A9cran_2012-06-06_%C3%A0_06.38.14.jpg 

Est-ce normal ? Ou un bug ?

Voici le code utilisé :

%%%%%%%%%%%
\version "2.14.2"

PartPOneVoiceOne =  \relative d'' {
    \clef "treble" \key g \major \time 2/4 
    \acciaccatura s8 R2 | % 2 AJOUT ACCIACCATURA SILENCIEUSE
    d4 \f e16 ( [ f16 ) e16 d16 ] | % 3
    
    \bar "|."
    }

PartPTwoVoiceOne =  \relative cis''' {
    \clef "treble" \key g \major \time 2/4 | % 1
    \acciaccatura { cis8 } 
    <d, g d'>2 \f ^\fermata | % 2
    R2  \bar "|."
    }

PartPTwoVoiceFive =  \relative cis {
    \clef "bass" \key g \major \time 2/4 
    \acciaccatura { cis8 } 
    <g d'>2
    ^\fermata | % 2
    R2 \bar "|."
    }

% The score definition
\score {
    <<
        \new Staff <<
            \context Staff << 
                \context Voice = "PartPOneVoiceOne" { \PartPOneVoiceOne }
        \new PianoStaff <<
            \context Staff = "1" << 
                \context Voice = "PartPTwoVoiceOne" { \voiceOne
\PartPTwoVoiceOne }
                >> \context Staff = "2" <<
                \context Voice = "PartPTwoVoiceFive" { \PartPTwoVoiceFive }
        
    \layout {}

    }
%%%%%%%%%%%%

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/Acciaccatura-en-debut-de-portee-tp7578096.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

---

From: Christophe Pochon <[email-masked]>
Date: Wed, 6 Jun 2012 08:24:04 +0200

Bonjour,

C'est en effet mentionné dans la doc sous "Problèmes connus et
avertissements" ici  :
http://lilypond.org/doc/v2.14/Documentation/notation/special-rhythmic-concerns#grace-notes

Christophe Pochon
http://www.christophe-pochon.com

Le 6 juin 2012 06:43, flup <[email-masked]> a écrit :

> View this message in context:
> http://lilypond-french-users.1298960.n2.nabble.com/Acciaccatura-en-debut-de-portee-tp7578096.html
> _______________________________________________
> liste de diffusion lilypond-user-fr
> [email-masked]
> https://lists.gnu.org/mailman/listinfo/lilypond-user-fr
>