Subject: Re: Notation française de la viole de gambe

From: Loïc A. Chahine <[email-masked]>
Date: Sun, 3 Jun 2012 06:00:29 -0700 (PDT)

Bonjour à tous,
Depuis la nouvelle version (2.15.39), je n’avais pas réutilisé… et ça ne
fonctionne plus ! Et je ne sais pas pourquoi…

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/Notation-francaise-de-la-viole-de-gambe-tp6987729p7578083.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

---

From: Eluze <[email-masked]>
Date: Sun, 3 Jun 2012 07:30:34 -0700 (PDT)

Loïc A. Chahine wrote
> fonctionne plus ! Et je ne sais pas pourquoi…

convert-ly?!

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/Notation-francaise-de-la-viole-de-gambe-tp6987729p7578084.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

---

From: Loïc Chahine <[email-masked]>
Date: Sun, 3 Jun 2012 22:03:04 +0200

>> fonctionne plus ! Et je ne sais pas pourquoi…
C’est des fonctions, je doute que convert-ly réécrive les fonctions avec 
les changements arcaniques ;)

---

From: Eluze <[email-masked]>
Date: Sun, 3 Jun 2012 13:26:27 -0700 (PDT)

Loïc A. Chahine wrote
> les changements arcaniques ;)

on peut essayer tout de même!
Eluze

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/Notation-francaise-de-la-viole-de-gambe-tp6987729p7578087.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

---

From: Loïc Chahine <[email-masked]>
Date: Sun, 3 Jun 2012 22:38:17 +0200

> on peut essayer tout de même!
C’est fait. Il ne dit même pas un petit message pour dire qu’il a pas su 
“moderniser”… et ça ne fonctionne toujours pas ;-)

---

From: Eluze <[email-masked]>
Date: Sun, 3 Jun 2012 14:46:07 -0700 (PDT)

Loïc A. Chahine wrote
> “moderniser”… et ça ne fonctionne toujours pas ;-)

en tout cas il ôte quelques $ (où vont-ils?)

malheureusement le résultat n'est pas ce qu'on attend - à vrai dire je ne
comprends pas ce qui se passe et n'ayant aucune connaissance de scheme je
rends le problème aux experts!

souris!

Eluze

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/Notation-francaise-de-la-viole-de-gambe-tp6987729p7578090.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

---

From: Bertrand Bordage <[email-masked]>
Date: Sun, 3 Jun 2012 23:57:25 +0200

Salut !

Il faut supprimer un $ avant nb-pts dans la fonction corde.
Cela résout le problème des points, mais pas les autres ornements.
Je ne comprends pas encore bien pourquoi cela ne fonctionne pas, mais c'est
dû à ce changement :
http://git.savannah.gnu.org/gitweb/?p=lilypond.git;a=commit;h=bab44018918beed5d01350fa6c4fed7dfffcf19c

J'essaie de comprendre ce que David Kastrup a fait...

À dans quelques minutes j'espère,
Bertrand

---

From: Bertrand Bordage <[email-masked]>
Date: Mon, 4 Jun 2012 00:11:09 +0200

Bonne nouvelle !  C'était facile.  En fait, David a supprimé une bidouille
de LilyPond, qui faisait que chaque note, même individuelle, était un
accord d'une note.  Ce qui était passablement idiot.

La nouvelle fonction add-vdg-ornament est donc (avec les changements en
gras) :

#(define (add-vdg-ornament music rotation size glyph-name)
 (if
  (equal? (ly:music-property music 'name) 'NoteEvent)
    (set! (ly:music-property music 'articulations)
          (append (ly:music-property music 'articulations)
                  (list
                   (let ((obj (make-music 'FingeringEvent)))
                     (set! (ly:music-property obj 'tweaks)
                           (acons 'X-extent (lambda (grob)
                             (ly:stencil-extent
                               (grob-interpret-markup grob
                                 glyph-name)
                               X))
                           (acons 'stencil (lambda (grob)
                              (grob-interpret-markup grob
                                (markup
                                  #:rotate rotation
                                  #:fontsize size
                                  glyph-name)))
                              (ly:music-property obj 'tweaks))))
                     obj))))
  music))

Chez moi ça marche impec' avec cela (plus la modification dont j'ai parlé
dans le précédent mail).

À bientôt !
Bertrand

---

From: Eluze <[email-masked]>
Date: Sun, 3 Jun 2012 16:06:48 -0700 (PDT)

Bertrand Bordage wrote
> La nouvelle fonction add-vdg-ornament est donc (avec les changements en

dommage que les gras ont maigri - ça m'aurait intéressé!

mais merci quand' même, ça fonctionne!

Eluze

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/Notation-francaise-de-la-viole-de-gambe-tp6987729p7578093.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.