Subject: Grace Note Thickness

From: Pierre Perol-Schneider <[email-masked]>
Date: Wed, 23 May 2012 14:23:35 +0200

Hi Groups,

few months ago Thoms Morley (found thanks too Google) sent this code, wiche
works fine :

\version "2.14.2"
%\version "2.15.20"

music = \relative c' {
        \grace { d,16 [des] } c4
}
\score {
        <<
        \new Staff { \clef "G_8" \music}
        \new TabStaff {
                \tabFullNotation
                %\revert TabVoice.Flag #'transparent % comment in with "2.15.20"
                \music
        }
        \layout {
                \context {
                        \TabVoice
                        graceSettings = #`((Voice Stem length-fraction .5)
                                           (Voice TabNoteHead font-size -4)
                                           (Voice Beam beam-thickness 0.1))
                }
         }
}

Now I would like to understand this :

1)

\version "2.15.39"

music = \relative c' {
        \grace { d,16 [des] } c4
}
\score {
        <<
        \new Staff { \clef "G_8" \music}
        \new TabStaff {
                \tabFullNotation
                \revert TabVoice.Flag #'transparent
                \music
        }
        \layout {
                \context {
                        \Score
                        graceSettings = #`((Voice Stem length-fraction .5)
                                           (Voice TabNoteHead font-size -4)
                                           (Voice Beam beam-thickness 0.1))
                }
         }
}

affect both staff and tabstaff grace notes (see *3.png)
BUT, when thickness is increased :

\version "2.15.39"

music = \relative c' {
        \grace { d,16 [des] } c4
}
\score {
        <<
        \new Staff { \clef "G_8" \music}
        \new TabStaff {
                \tabFullNotation
                \revert TabVoice.Flag #'transparent
                \music
        }
        \layout {
                \context {
                        \Score
                        graceSettings = #`((Voice Stem length-fraction .5)
                                           (Voice TabNoteHead font-size -4)
                                           (Voice Beam beam-thickness 0.45))
                }
         }
}

affect ONLY tabstaff grace notes.  (see *4.png)

2) if I change, for example, *(beam-thickness . 0.48)* to *(beam-thickness
. 0.58)* in the define-grobs.scm file this DOES NOT affect grace
notes.  (see *5.png)

Thanks in advance
Pierre

---

From: Pierre Perol-Schneider <[email-masked]>
Date: Wed, 23 May 2012 14:37:18 +0200

Please forget question 1), my mistake.
Infact, for some reason beams appears thicker in tabstaff.
But what about question 2) ?

2012/5/23 Pierre Perol-Schneider <[email-masked]>

> Hi Groups,
>
> few months ago Thoms Morley (found thanks too Google) sent this code,
> wiche works fine :
>
> \version "2.14.2"
> %\version "2.15.20"
>
> music = \relative c' {
>         \grace { d,16 [des] } c4
> }
> \score {
>         <<

---

From: Pierre Perol-Schneider <[email-masked]>
Date: Wed, 23 May 2012 15:54:28 +0200

> BTW, what do you intend at all?

In the last LilyPond
Report<http://news.lilynet.net/?The-LilyPond-Report-26&lang=en> ,
the comparison of Breitkopf and the "airy" Lilypond outpout, according to
Janek, is something that I agree 100% for quite a long time.
What I would like to do is, as a 1st step, to raise the beam thickness up
to #.55~59.

2012/5/23 Thomas Morley <[email-masked]>

> 2012/5/23 Pierre Perol-Schneider <[email-masked]>:
> > Hi Groups,
> >
> wiche
> (...)
> Of course, you changed the context to \Score
>
> (...)
> Can't confirm. All grace-notes _are_ affected, but in a different
> degree. I added
> (Voice Beam length-fraction 1.5) to make this effect more visible:
>
> \version "2.15.38"
>
> music = \relative c' {
>        \grace { d,16 [des] } c8 d e f
> }
> \score {
>        <<
>                                            (Voice Beam length-fraction 1.5)
>                                           (Voice Beam beam-thickness 0.5))
>                 }
>         }
> }
>
> >
> > 2) if I change, for example, (beam-thickness . 0.48) to (beam-thickness .
> > 0.58) in the define-grobs.scm file this DOES NOT affect grace
> notes.  (see
> > *5.png)
>
> In graceSettings (Voice Beam beam-thickness 0.5) overrides other
> alterations of beam-thickness (using an override in the file or
> changing the value in define-grobs.scm), but only for grace-notes.
>
> BTW, what do you intend at all?
>
> Regards,
>  Harm
>

---

From: Pierre Perol-Schneider <[email-masked]>
Date: Wed, 23 May 2012 15:56:01 +0200

See *airy.png*

> In the last LilyPond Report<http://news.lilynet.net/?The-LilyPond-Report-26&lang=en> ,

---

From: Pierre Perol-Schneider <[email-masked]>
Date: Wed, 23 May 2012 22:08:20 +0200

Dear Thomas,

I've followed your instruction and when I code :

\version "2.15.39"

{
  \clef "treble_8"
  \time 3/8
  \stemUp
  e'4. | %2
  \slurDown
  \appoggiatura { b'32 [ c'' b' ais' ] } b'8 [ c'' b'16 \glissando e'' ] |
%2
}

this works fine (see first staff enclosed).

Problem comes with the polyphony :

\version "2.15.39"

{
  \new Staff
  <<
  \new Voice = "first"
    {  \voiceOne
        \clef "treble_8"
        \time 3/8
        \stemUp
        e'4. | %2
        \slurDown
        \appoggiatura { b'32 [ c'' b' ais' ] } b'8 [ c'' b'16 \glissando
e'' ] | %2
    }
  \new Voice= "second"
    {  \voiceTwo s2. }
}

( see second staff)  beam-thickness does not apply on grace notes ...

---

From: Pierre Perol-Schneider <[email-masked]>
Date: Thu, 24 May 2012 10:39:34 +0200

> I'm not aware I gave you any instructions. :)

I just ment that I've change the beam-thickness in the graceSettings file.
Sorry for the missunderstanding and for my poor english. :S

Pierre

> I'm not aware I gave you any instructions. :)
>
> Well, I see the problem, but I'm too tired to have any useful idea.
> Perhaps tomorrow.
>
> Cheers,
>  Harm
>