Subject: Fwd: Experimental Web-based Lilypond Editor

From: "[email-masked]" <[email-masked]>
Date: Wed, 1 Feb 2012 11:37:55 +0100

Bonjour,

Je vous transmets un mail que je viens de recevoir sur la liste internationale à propos d'un nouveau site qui permet de créer et de visualiser des partitions LilyPond.  Je l'ai essayé avec une partition simple et c'est très efficace.   A diffuser largement !
http://lily.sytes.net

Cordialement,
~Mike

Begin forwarded message:

> From: trevordixon <[email-masked]>
> Subject: Experimental Web-based Lilypond Editor
> Date: February 1, 2012 10:51:46 AM GMT+01:00
> To: [email-masked]
> 
> I've been working on something I think the LilyPond community may find very useful: a web-based editor. Before you check it out, keep in mind that it's at a pre-alpha stage. It's likely that certain things won't work as expected, and it will probably crash and be down at times. I've only tested it in Chrome 15 and Firefox 9. It should work in Internet Explorer 9 or 10, but will almost certainly not work in IE8 or earlier.
> 
> Saving will create a new URL that you can share with others. If they save, it will be saved as a new revision, preserving your original.
> 
> This could be useful for:
> 
> Posting example code that you'd like others to look at and mess with.
> Quick projects when you don't have access to your regular development environment.
> Perhaps as your main editor someday.
> Future features might include:
> 
> Ability to open and save to your hard drive.
> Ability to open and save to Dropbox.
> Open to suggestions.
> See it at: http://lily.sytes.net
> 
> Let me know how it works for you!
> 
> 
> View this message in context: Experimental Web-based Lilypond Editor
> Sent from the Gnu - Lilypond - User mailing list archive at Nabble.com.
> _______________________________________________
> lilypond-user mailing list
> [email-masked]
> https://lists.gnu.org/mailman/listinfo/lilypond-user

---

From: legoss <[email-masked]>
Date: Thu, 2 Feb 2012 04:08:12 -0800 (PST)

Ça me rappelle les "petits commencements" avec 
http://www.weblily.net/web/guest/home weblily ...
C'est aussi avec de telles initiatives que Lilypond fera de plus en plus
d'émules. Pas encore vraiment testé, mais par avance, Bravo !

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/Fwd-Experimental-Web-based-Lilypond-Editor-tp7242683p7246717.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

---

From: Calixte <[email-masked]>
Date: Sat, 4 Feb 2012 03:33:13 -0800 (PST)

Bonjour,

j’essaye en vain de formuler mon message en anglais, mais devant la
difficulté que j’ai à le faire, je le poste en français, si quelqu'un veut
bien le poster sur la liste anglophone… :)
On peut en parler ici, mais il y a plus de réaction sur la liste anglophone
!

« Il serait intéressant de combiner certains fichier Mutopia avec cet
éditeur en ligne, notamment les mélodies et lieder, pour transposer
facilement une partition de façon automatique » sans être obligé de
copier/coller la source, de taper la commande \transpose, etc. Peut-être
serait-il envisageable de créer une interface simplifiée pour ce cas précis
?
J’utilise Mutopia principalement pour ça d’ailleurs, et de cette façon je
pourrais faire partager à mes amis chanteurs qui ne sont pas forcément à
l’aise avec l’installation et l’utilisation de Lilypond (ou d’informatique
en général).

J’espère avoir été clair, merci !
Calixte.

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/Fwd-Experimental-Web-based-Lilypond-Editor-tp7242683p7253879.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

---

From: Martial <[email-masked]>
Date: Sat, 04 Feb 2012 14:35:58 +0100

Bonjour

Extra  !
ça va me permettre de montrer en ligne simplement  comment c'est bien 
beau et  facile LilyPond

-- 
Martial

---

From: legoss <[email-masked]>
Date: Sat, 4 Feb 2012 11:43:26 -0800 (PST)

C'est clair, ça peut être une sacrée vitrine pour la Belle, pour convaincre
les indécis.
Et hop ! un lien dans ma signature mail.
Bon, il y aura toujours des irréductibles... quoique le fait d'avoir le
rendu en vis-à-vis décrispera certainement quelques-uns des inconditionnels
du wysiwyg. Très bonne initiative donc.
C'est sobre, fonctionnel et à mon sens très pratique.
Il manquerait un raccourci vers la doc et un assistant de création de
partition. Ça serait "tip top ma biche" pour les fois ou je bosse sur des
ordis qui ne sont pas à moi. 

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/Fwd-Experimental-Web-based-Lilypond-Editor-tp7242683p7254702.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

---

From: Dean Herington <[email-masked]>
Date: Sun, 5 Feb 2012 23:16:04 -0500

[As a courtesy to a poster of a message to the 
French-speaking Lilypond list, I'm offering my 
humble translation.]

Hello,

I've tried in vain to write my message in 
English, but given the difficulty I've had, I'm 
posting in French, hoping that someone will post 
it to the English-speaking list...
We could discuss it here [on the French-speaking 
list], but there's more response on the 
English-speaking list!

It would be interesting to combine some of the 
Mutopia files with this online editor, especially 
melodies and songs, to make it easy to transpose 
these scores automatically without having to 
copy/paste the source code, add the \transpose 
command, etc.  Maybe a simple interface could be 
created for this specific purpose?

I use Mutopia mainly for this purpose, and with 
this feature I would be able to share [the 
transposed scores] with my singer friends who 
aren't comfortable installing and using Lilypond 
(or with computers in general).

I hope I've been clear.  Thanks!
Calixte

At 3:33 AM -0800 2/4/12, Calixte wrote:
>Bonjour,
>
>j'essaye en vain de formuler mon message en anglais, mais devant la
>difficulté que j'ai à le faire, je le poste en français, si quelqu'un veut
>bien le poster sur la liste anglophoneŠ :)
>J'utilise Mutopia principalement pour ça d'ailleurs, et de cette façon je
>l'aise avec l'installation et l'utilisation de Lilypond (ou d'informatique
>en général).
>
>J'espère avoir été clair, merci !
>Calixte.
>
>--
>View this message in context: 
>http://lilypond-french-users.1298960.n2.nabble.com/Fwd-Experimental-Web-based-Lilypond-Editor-tp7242683p7253879.html
>liste de diffusion lilypond-user-fr
>[email-masked]
>https://lists.gnu.org/mailman/listinfo/lilypond-user-fr

---

From: Calixte <[email-masked]>
Date: Mon, 6 Feb 2012 01:21:20 -0800 (PST)

Thanks a lot!
I posted your translation on the english-speaking list and mutopia-list too.

Merci beaucoup !
J’ai posté la traduction sur la liste anglophone, et sur la liste Mutopia

Calixte.

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/Fwd-Experimental-Web-based-Lilypond-Editor-tp7242683p7258041.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

---

From: Jean-Christophe D <[email-masked]>
Date: Mon, 6 Feb 2012 15:05:58 -0800 (PST)

[email-masked] wrote
> http://lily.sytes.net

Bonsoir,

J'obtiens tout pleins d'erreurs "...ubuntu..." dans le quart droite-bas.
(malheureusement le texte n'est pas sélectionnable)
Firefox 10.0 \ winXP...

Jean-Christophe

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/Fwd-Experimental-Web-based-Lilypond-Editor-tp7242683p7260254.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

---

From: Jean-Christophe D <[email-masked]>
Date: Mon, 6 Feb 2012 15:11:36 -0800 (PST)

Jean-Christophe D wrote
> (malheureusement le texte n'est pas sélectionnable)

Dééésolé! ça marche impeccable, simple erreur de ma part... (j'ai testé en
italiano directement, oublié de changer le \relative c') 

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/Fwd-Experimental-Web-based-Lilypond-Editor-tp7242683p7260278.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

---

From: legoss <[email-masked]>
Date: Wed, 29 Feb 2012 05:34:42 -0800 (PST)

Il semble que la page ne soit plus accessible...

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/Fwd-Experimental-Web-based-Lilypond-Editor-tp7242683p7329224.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

---

From: bameylan <[email-masked]>
Date: Wed, 29 Feb 2012 06:55:23 -0800 (PST)

legoss wrote
> Il semble que la page ne soit plus accessible...

... 502 Bad Gateway

Un trou noir... 

Bernard

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/Fwd-Experimental-Web-based-Lilypond-Editor-tp7242683p7329455.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.