Subject: chords grid

From: douwen elo <[email-masked]>
Date: Thu, 24 Nov 2011 22:14:55 +0100

hi everyone

i now use the following code for having some grids

i guesse that i can transpose them easily with the instruction \transpose

so, that is much more interessant as typing theses chords in an usual text editor

for the lines i will superpose it into my text/vectorial editor

now my question is :

how to put two chords in a single case ?

it is very frequent for improvisation ot have somethign like that :

C  |  D/F7  |  G  |  Am

the "D/F7" indicatves that half the time of a case it is D and the other half is F7

in Lilypond i can indicate d:/f that means chord D with bass note F, but that could be convenient for having D for half and F for other half of the case
now how could i have D/F7 ? because Lily will not accept d:/f:7

Sacha

--- my code (=Xavier's code that i have just lighted) -----

accords = \chordmode {
c:     f:/g    f:m7/c  cis:m7  b:	b:	b:	b:	\break
a:      b       a       a       b:	b:	b:	b:	\break
a:      a       e:m7+   b:9     b:	b:	b:	b:	\break
d:maj   r       a:      b:      b:	b:	b:	b:	\break
a:      d:7     r       aes:m6  b:	b:	b:	b:	\break
bes:7+  c:6     cis:m   d:m9    b:	b:	b:	b:	\break
}
\version "2.15.19"

\paper {
  #(set-paper-size "a4" 'landscape)
  indent = 0
  system-system-spacing = #'((padding . 0)
                             (basic-distance . 0)
                             (minimum-distance . 0)
                             (stretchability . 0))
	left-margin = 0
	right-margin = 0
	top-margin = 0
	bottom-margin = 0
	check-consistency
}

\layout {
  \context {
    \Score
    \accepts "LineUp"
    \accepts "LineDown"
    \remove "Bar_number_engraver"
    proportionalNotationDuration = #(ly:make-moment 1 8)
   % \override SpacingSpanner #'strict-note-spacing = ##t
  }
  \context {
    \ChordNames
    % french chords
    chordRootNamer = #(chord-name->italian-markup #t)
    chordPrefixSpacer = #0.4
   % \consists "Bar_engraver"
    \consists "Double_percent_repeat_engraver"
    \consists "Percent_repeat_engraver"
    \consists "Slash_repeat_engraver"
    \override BarLine #'bar-extent = #'(-3 . 3)
    \override ChordName #'font-name = #'"Apple Chancery"
    \override ChordName #'font-size = #1
    \override ChordName #'Y-extent = #'(-3 . 3)
 %   \override VerticalAxisGroup #'nonstaff-relatedstaff-spacing #'padding = #0
  %  \override VerticalAxisGroup #'nonstaff-nonstaff-spacing #'padding = #0
  }
}

\score {
  <<
 \new ChordNames {
      \accords
    }

}
\markup {"ambitus :"}
\new Staff {c' d''}

---

From: JeanPi <[email-masked]>
Date: Sun, 27 Nov 2011 08:05:24 -0800 (PST)

Bonjour,

Je suppose que tu parles aussi français car ici c'est Lilipond French Users
;)

Cela fait un moment que je cherche a faire des grilles avec lilypond et j'ai
trouvé une solution.
La notation avec une barre oblique prête a confusions (accords avec basse
différente) et je pense qu'un affichage avec un espacement proportionnel est
suffisant dans la majorité des cas. Quelques annotations rythmiques sous la
grille peuvent aider a expliciter.

Bref j'ai fait ça:

%------------------------
\version "2.14.0"

\paper {
	indent = 0
	system-system-spacing #'basic-distance = #20
}

structure = {
	\key e \major
	\mark \markup \box "test"
	s1 * 4 \break
	\bar "|:" s1 * 2 \bar ":|" s1 * 2
}

accords = \chordmode {|
	c2	c2:7 	r8 f4.	f2:m	c2:7 f:7 c1:7 |
	c1 f c2 f2 g1
}

rythme = { 
	\stemDown
	b8 b16 b16 b4 b4. r8 r8 b4. b2 b2 b2 b1 
	s1 s1 s1 s1
}

\layout {
	\context { \Score 
	\context { \ChordNames
		
		\override ChordName #'font-name = #"Deja Vu Sans" 
		\override ChordName #'font-size = #5
		
		noChordSymbol = #(make-simple-markup "-")
		\override BarLine #'bar-extent = #'(-2 . 5)
		\consists "Bar_engraver"
		\override VerticalAxisGroup #'nonstaff-relatedstaff-spacing #'padding = #0
	}
	\context { \RhythmicStaff
		\override NoteHead #'style = #'slash
		\override NoteHead #'font-size = #-2
		\remove "Time_signature_engraver"
		\remove "Bar_engraver"
	}
}

\score {
	<< 
		\new RhythmicStaff \with {
			\override VerticalAxisGroup #'staff-affinity = #DOWN
		} \structure
		\new ChordNames \accords
		\new RhythmicStaff \rythme
	\layout {}
}
%------------------------
Un peu d'analyse devrait permettre d'adapter a tes désirs.

Cordialement

-----
Lily Pond et le Jazz 
--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/chords-grid-tp7029465p7036540.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.