Subject: paroles additives centrées

From: moebius <[email-masked]>
Date: Sat, 13 Nov 2010 22:07:32 +0100

Bonsoir,

J'utilise un truc adapté à mes besoins pour écrire les autres strophes 
d'une chanson après la musique.
J'ai conservé le snipset d'origine, bien que les "hspace" me paraissent 
parfois douteux, leur commentaire (que j'ai conservé) parlant, à leur 
sujet,  alternativement d'espacement horizontal et d'espacement vertical 
(!?).
Pour l'espacement horizontal, je me sers de lignes vides ; c'est un peu 
empirique mais ça marche...

Mais mon propos n'est pas là ; en fait, j'aimerais que les paroles, au 
lieu d'être justifiées à gauche, se retrouvent centrées à l'intérieur de 
chaque strophe. J'ai bien essayé de placer, de ci de là, quelques 
"\center-align", mais les résultats n'ont guère été probants.

Mes remerciements aux courageux,

cordialement,

---

From: Valentin Villenave <[email-masked]>
Date: Sat, 13 Nov 2010 22:20:51 +0100

2010/11/13 moebius <[email-masked]>:
> J'utilise un truc adapté à mes besoins pour écrire les autres strophes d'une
> chanson après la musique.
> parfois douteux, leur commentaire (que j'ai conservé) parlant, à leur sujet,
>  alternativement d'espacement horizontal et d'espacement vertical (!?).

Sans exemple de code, difficile de vous aider...

> Mais mon propos n'est pas là ; en fait, j'aimerais que les paroles, au lieu
> d'être justifiées à gauche, se retrouvent centrées à l'intérieur de chaque
> strophe. J'ai bien essayé de placer, de ci de là, quelques "\center-align",
> mais les résultats n'ont guère été probants.

Et ça ?
\center-column {
   \line { ma première ligne }
   \line { ma deuxième ligne beaucoup plus longue }
}

Cordialement,
V. Villenave.

---

From: moebius <[email-masked]>
Date: Sun, 14 Nov 2010 09:18:18 +0100

La fatigue : le copié DOIT être suivi d'un collé, c'est la règle !

Très bien le \center-column, merci beaucoup.

Je mets, ci-dessous,  mon original et, à la suite, le même modifié.

cordialement,

\markup { \line { \column { "   " "   " "   " } } } % un peu d'espace à 
la fin des notes
\markup {
   \fill-line  {
     \hspace #0.2 % moves the column off the left margin;
         % can be removed if space on the page is tight
      \center-column {
       \line  {
         \center-column  { \bold "3."
           "Oh! Jemmy, should my father hear you"
           "We will be ruined for sure I fear"
           "He'd sent a cuel press gang for you"
           "And separate you and I my dear"
           " "
           " "
         }
       }

       \hspace #0.1 % adds vertical spacing between verses
       \line {
         \center-column { \bold "4."
           "Her father chanced to overhear them"
           "And for a press gang sent straight away"
           "Against this young man  gave information"
           "And sent him sailing o'er the sea"
         }
       }
     }
     \hspace #0.1  % adds horizontal spacing between columns;
         % if they are still too close, add more " " pairs
         % until the result looks good
      \center-column {
       \line {
         \center-column { \bold "5."
           "Oh! Cruel father, pay down my fortune"
           "Five hundred pounds are due you know"
           "And I will cross the briny ocean"
           "To find my true love I will go"
           " "
           " "
         }
       }
       \hspace #0.1 % adds vertical spacing between verses
       \line {
         \center-column { \bold "6."
           "Jemmy's the man I do admire"
           "He is the one I do adore"
           "And if I can't have my heart's desire"
           "I will go single for evermore"
           " " " " " "
         }
       }
     }
   \hspace #0.1 % gives some extra space on the right margin;
       % can be removed if page space is tight

     }

   }
\markup {
   \fill-line {
     %  \hspace #0.1 % moves the column off the left margin;
         % can be removed if space on the page is tight
      \center-column {
       \line {
         \center-column { \bold "7."
           "Awake, awake, you drowsy sleeper"
           "Awake, awake, it's break of day"
           "I am not sleeping, I'll rest no longer"
           "Until we land in Americay"

         }
       }
     }
   }
}

%--le même modifié : --------%

\markup { \line { \column { "   " "   " "   " } } } % un peu d'espace à 
la fin des notes
\markup {
   \fill-line  {
     \hspace #0.2 % moves the column off the left margin;
         % can be removed if space on the page is tight
      \center-column {
       \line  {
         \center-column  { \bold "3."
           "Oh! Jemmy, should my father hear you"
           "We will be ruined for sure I fear"
           "He'd sent a cuel press gang for you"
           "And separate you and I my dear"
           " "
           " "
         }
       }

       \hspace #0.1 % adds vertical spacing between verses
       \line {
         \center-column { \bold "4."
           "Her father chanced to overhear them"
           "And for a press gang sent straight away"
           "Against this young man  gave information"
           "And sent him sailing o'er the sea"
         }
       }
     }
     \hspace #0.1  % adds horizontal spacing between columns;
         % if they are still too close, add more " " pairs
         % until the result looks good
      \center-column {
       \line {
         \center-column { \bold "5."
           "Oh! Cruel father, pay down my fortune"
           "Five hundred pounds are due you know"
           "And I will cross the briny ocean"
           "To find my true love I will go"
           " "
           " "
         }
       }
       \hspace #0.1 % adds vertical spacing between verses
       \line {
         \center-column { \bold "6."
           "Jemmy's the man I do admire"
           "He is the one I do adore"
           "And if I can't have my heart's desire"
           "I will go single for evermore"
           " " " " " "
         }
       }
     }
   \hspace #0.1 % gives some extra space on the right margin;
       % can be removed if page space is tight

     }

   }
\markup {
   \fill-line {
     %  \hspace #0.1 % moves the column off the left margin;
         % can be removed if space on the page is tight
      \center-column {
       \line {
         \center-column { \bold "7."
           "Awake, awake, you drowsy sleeper"
           "Awake, awake, it's break of day"
           "I am not sleeping, I'll rest no longer"
           "Until we land in Americay"

         }
       }
     }
   }
}

Le 13/11/2010 22:20, Valentin Villenave a écrit :
> 2010/11/13 moebius<[email-masked]>: