Subject: Relecture de la préface + introduction

From: Damien Heurtebise <[email-masked]>
Date: Thu, 4 Dec 2008 10:52:10 -0800 (PST)

http://n2.nabble.com/file/n1614804/LilyPond_fr_introduction.itely
LilyPond_fr_introduction.itely 

Bonsoir,
J'ai relu la préface et l'intro de la documentation. Dans la préface,
vraiment peu de choses à dire, sinon deux redondances qui pourraient être
évitées :

 ligne 41 :
"d'autres jours ... on continue... jour après jour". Euh !!! Un peu lourd,
non ? En français, on dirait plutôt : "on continue... coûte que coûte" ou
"vaille que vaille".

ligne 47 :
"notre logiciel est véritablement utile aux gens." Bin, on se doute qu'il
est utile aux gens et pas aux arbres. Le motif de satisfaction, c'est que le
logiciel soit utile, tout court. Les gens, il en sera question dans la
phrase suivante, pour dire ce qu'ils en font.

Pour l'intro, quelques petites corrections, vraiment minimes. J'en ai saisi
quelques-unes directement sur le fichier ".itely" (corrections d'accent, le
"u" de langage etc.). Et en voici trois autres que je n'ai pas saisies mais
que je suggère : 

ligne 253 :
"LilyPond représente notre effort pour apporter l'excellence graphique de la
gravure à la main à l'ère de l'ordinateur" : je préfèrerais "LilyPond est le
fruit de nos efforts pour restaurer l'excellence graphique de la gravure à
la main à l'ère de l'ordinateur".

ligne 274 : 
"Si LilyPond arrive à résoudre la plupart des situations correctement" : en
français, on ne résoud pas une situation mais un problème. Il vaudrait mieux
écrire : "Si LilyPond arrive à se sortir correctement de la plupart des
situations". Et à la phrase suivante : "Les autres problèmes peuvent être
résolus à la main."

ligne 576 :
"Le graveur de hampe est notifié de chaque tête de note qui survient."
Bizarre. J'aimerais mieux "est prévenu" ou "est averti".

ligne 934 :
"Nombre d'utilisateurs n'ont jamais touché à Scheme." Je verrais plutôt la
phrase au présent (comme en anglais), pour signifier que ce chapitre est
facultatif.

Et pour finir, un mystère : "l'état de la traduction de la documentation"
sur le site de LilyPond indique que la traduction de l'intro n'était pas à
jour. Pourtant, en comparant avec 
http://git.savannah.gnu.org/gitweb/?p=lilypond.git;a=blob;f=Documentation/fr/user/introduction.itely;h=00eb1f1bfd5f97d35cc14fc88676523590d21678;hb=HEAD
ceci , je n'ai pas vu de différence de texte. S'il y en a une, elle doit
être minime et m'a échappé. 

Bonne soirée.

Damien
-- 
View this message in context: http://n2.nabble.com/Relecture-de-la-pr%C3%A9face-%2B-introduction-tp1614804p1614804.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

---

From: John Mandereau <[email-masked]>
Date: Wed, 31 Dec 2008 02:16:38 +0100

Bonjour Damien,
Le jeudi 04 décembre 2008 à 10:52 -0800, Damien Heurtebise a écrit :
> J'ai relu la préface et l'intro de la documentation.

Merci, j'ai appliqué tes changements et commentaires, qui devraient
apparaître dans la version 2.12.1 ou 2.12.2.

>  Dans la préface,
> non ?

En effet :-)

>  En français, on dirait plutôt : "on continue... coûte que coûte" ou
> "vaille que vaille".

D'accord pour "coûte que coûte".  J'ai aussi reformulé avec une tournure
plus française "en jouer semble naturel" -> "il semble naturel d'en
jouer" juste au-dessus.

> phrase suivante, pour dire ce qu'ils en font.

J'ai reformulé cette phrase et tout le paragraphe suivant en
"Notre principale motivation vient sans doute de l'utilité réelle de
notre logiciel.  En flânant sur Internet, nous trouvons beaucoup de
gens qui utilisent LilyPond pour réaliser d'impressionnantes
partitions : c'est incroyable, mais en même temps très flatteur."

> "u" de langage etc.).

J'ai fait un patch avec

diff -u introduction.itely LilyPond_fr_introduction.itely >introduction.itely.patch

que j'ai examiné dans mon éditeur de texte préféré, j'ai appliqué tous
les changements sauf les introductions de tabulations et d'espaces en
fin de ligne.  Les caractères de tabulation sont proscrits pour
l'indentation des codes sources dans LilyPond, car il n'y a pas de
standard reconnu donnant la valeur en espaces d'un caractère de
tabulation.

>  Et en voici trois autres que je n'ai pas saisies mais
> que je suggère : 
> 
> ligne 253 :

Vendu.

> situations".

J'ai mis "Si LilyPond arrive à traiter la plupart"...

>  Et à la phrase suivante : "Les autres problèmes peuvent être
> résolus à la main."

"Les problèmes restants"...

> Bizarre. J'aimerais mieux "est prévenu" ou "est averti".

J'ai mis "est informé".

> phrase au présent (comme en anglais), pour signifier que ce chapitre est

D'accord.

> être minime et m'a échappé. 

Il est très difficile de voir certaines différences "à l'œil nu", c'est
pour cela que nous avons le Différencescope (tm) également appelé
check-translation, décrit dans le fichier des sources
Documentation/TRANSLATION, qui montre les changements dans la
documentation en anglais.  Pour l'introduction en français, cela donne
le fichier en pièce jointe... avis aux amateurs !

Je profite de l'occasion pour annoncer que je ne plus garantir ma
participation aux traductions et relectures en français pour les 6 mois
à venir : par manque de temps, je ne répondrai plus aux remarques,
propositions et amélirations de traduction que sous forme de patches à
appliquer, c'est-à-dire obtenus avec

diff -u anciens_fichier nouveaux_fichier

ou

diff -ur répertoire_anciens_fichiers répertoire_nouveaux_fichiers

ou patches produits avec Git.  Les commentaires dans des courriels sont
intéressants et parfois ne peuvent remplacer un patch, mais prennent du
temps à traiter ; comme je n'ai plus assez de temps pour y répondre en
une dizaine de jours, je laisse à tout volontaire le soin de le faire et
de produire un patch ou appliquer directement les modifications sur le
dépôt Git des sources.  Par contre, je suis prêt à former les
traducteurs aux aspects techniques (format source de la documentation,
système de contrôle de version Git et autres), c'est d'ailleurs mon rôle
de coordinateur des traductions.  À propos, nous devrions nommer un chef
(coordinateur si vous préférez) des traductions francophones de
LilyPond, poste qui n'existait pas mais qui nous fait défaut aujourd'hui
vu le développement récent de la communauté autour de cette liste ; il
s'agit entre autres de motiver les contributions à la documentation en
français (pas forcément en termes de traduction), de s'assurer qu'une
suite est donnée à toute suggestion constructive...  j'enverrai une
offre d'emploi pour préciser ça l'année prochaine. (Ah au fait, l'emploi
en question est bénévole, comme toutes les contributions actuelles à
LilyPond !)

Damien, comme tu a déjà fourni un travail de traduction assez important,
je te propose de récupérer si tu ne l'as pas déjà fait les sources de
LilyPond avec Git, en suivant les instructions sur
http://git.sv.gnu.org/gitweb/?p=lilypond.git;a=blob_plain;f=Documentation%2FTRANSLATION;hb=lilypond%2Ftranslation

Si la création de tes propres révisions avec "git commit" et les
potentielles résolutions de conflits t'ennuient, tu peux dans un premier
temps suivre l'évolution des sources dans Git/Lily sans toucher aux
fichiers, quitte à les copier en dehors du répertoire des sources et
appeler la commande diff manuellement pour faire des patches ; des
indications sont données sur
http://lilypondwiki.tuxfamily.org/index.php?title=Translations_HOWTO#Local_patches

Au fait j'ai mis à jour la feuille de route des traductions en français
http://lilypondwiki.tuxfamily.org/index.php?title=Fr:Aide_sur_la_traduction_du_site_web

Salutations lilyesques et à l'année prochaine
John
/usr/bin/python ../buildscripts/check_translation.py --no-color fr/user/introduction.itely
diff --git a/Documentation/user/introduction.itely b/Documentation/user/introduction.itely
index 7a7db27..a27db04 100644
--- a/Documentation/user/introduction.itely
+++ b/Documentation/user/introduction.itely
@@ -7,7 +7,7 @@
     version that you are working on.  See TRANSLATION for details.
 @end ignore
 
-@c \version "2.11.51"
+@c \version "2.12.0"
 
 @node Introduction
 @chapter Introduction
@@ -16,8 +16,8 @@ This chapter introduces readers to LilyPond and the
 documentation.
 
 @menu
-* Background::                  
-* About the documentation::     
+* Background::
+* About the documentation::
 @end menu

@@ -28,17 +28,23 @@ This section covers the overall goals and architecture of
 LilyPond.
 
 @menu
-* Engraving::                   
-* Automated engraving::         
-* What symbols to engrave?::    
-* Music representation::        
-* Example applications::        
+* Engraving::
+* Automated engraving::
+* What symbols to engrave?::
+* Music representation::
+* Example applications::
 @end menu

 @node Engraving
 @unnumberedsubsec Engraving
 
+@cindex engraving
+@cindex typography, music
+@cindex music typography
+@cindex plate engraving
+@cindex music engraving
+
 The art of music typography is called @emph{(plate) engraving}.
 The term derives from the traditional process of music printing.
 Just a few decades ago, sheet music was made by cutting and
@@ -188,6 +194,7 @@ music = {
 
 @cindex regular rhythms
 @cindex regular spacing
+@cindex spacing, regular
 
 Each bar in the fragment only uses notes that are played in a
 constant rhythm.  The spacing should reflect that.  Unfortunately,
@@ -201,7 +208,6 @@ of the notes.  The upper two measures are printed with this
 correction, the lower two measures without, forming
 down-stem/@/up-stem clumps of notes.
 
-@cindex typography
 
 Musicians are usually more absorbed with performing than with
 studying the looks of a piece of music, so nitpicking about
@@ -241,6 +247,9 @@ to see and love to play from.
 @node Automated engraving
 @unnumberedsubsec Automated engraving
 
+@cindex engraving, automated
+@cindex automated engraving
+
 How do we go about implementing typography?  If craftsmen need
 over ten years to become true masters, how could we simple hackers
 ever write a program to take over their jobs?
@@ -278,6 +287,8 @@ music notation works.
 
 @end itemize
 
+@cindex Scheme programming language
+
 These problems have been addressed by integrating an interpreter
 for the Scheme programming language and rewriting parts of
 LilyPond in Scheme.  The current formatting architecture is built
@@ -304,6 +315,10 @@ chord has all directions up (right).
 }
 @end lilypond
 
+@cindex score formatting
+@cindex formatting a score
+@cindex formatting rules
+
 @noindent
 The process of formatting a score consists of reading and writing
 the variables of graphical objects.  Some variables have a preset
@@ -346,34 +361,33 @@ changed during the music fragment.
          (pos (ly:grob-property grob 'staff-position)))
     (if (memq 'note-head-interface interfaces)
         (begin
-          (ly:grob-set-property! grob 'stencil ly:text-interface::print)
-          (ly:grob-set-property! grob 'font-family 'roman)
-          (ly:grob-set-property! grob 'text
-            (make-raise-markup -0.5
-              (case pos
-                ((-5) (make-simple-markup "m"))
-                ((-3) (make-simple-markup "c "))
-                ((-2) (make-smaller-markup (make-bold-markup "2")))
-                (else (make-simple-markup "bla")))))))))
+          (ly:grob-set-property! grob 'stencil
+            (grob-interpret-markup grob
+              (make-lower-markup 0.5
+                (case pos
+                  ((-5) "m")
+                  ((-3) "c ")
+                  ((-2) (make-smaller-markup (make-bold-markup "2")))
+                  (else "bla")))))))))
 
 \new Voice \relative c' {
-   \stemUp
-   \set autoBeaming = ##f
-   \time 2/4
-   <d f g>4
-   \once \override NoteHead #'stencil = #ly:note-head::brew-ez-stencil
-   \once \override NoteHead #'font-size = #-7
-   \once \override NoteHead #'font-family = #'sans
-   \once \override NoteHead #'font-series = #'bold
-   <d f g>
-   \once \override NoteHead #'style = #'cross
-   <d f g>
-   \applyOutput #'Voice #mc-squared
-   <d f g>
-   <<
-      { d8[ es-( fis^^ g] fis2-) }
-      \repeat unfold 5 { \applyOutput #'Voice #mc-squared s8 }
-   >>
+  \stemUp
+  \set autoBeaming = ##f
+  \time 2/4
+  <d f g>4
+  \once \override NoteHead #'stencil = #ly:note-head::brew-ez-stencil
+  \once \override NoteHead #'font-size = #-7
+  \once \override NoteHead #'font-family = #'sans
+  \once \override NoteHead #'font-series = #'bold
+  <d f g>4
+  \once \override NoteHead #'style = #'cross
+  <d f g>4
+  \applyOutput #'Voice #mc-squared
+  <d f g>4
+  <<
+    { d8[ es-( fis^^ g] fis2-) }
+    \repeat unfold 5 { \applyOutput #'Voice #mc-squared s8 }
+  >>
 }
 @end lilypond
 
@@ -383,6 +397,8 @@ changed during the music fragment.
 
 @cindex engraving
 @cindex typography
+@cindex engraver
+@cindex plug-in
 
 The formatting process decides where to place symbols.  However,
 this can only be done once it is decided @emph{what} symbols
@@ -539,6 +555,10 @@ signature, and key signature, we get a complete piece of notation.
 \score { \topVoice }
 @end lilypond
 
+@cindex polyphony
+@cindex engraving multiple voices
+@cindex contexts
+
 This system works well for monophonic music, but what about
 polyphony?  In polyphonic notation, many voices can share a staff.
 
@@ -557,10 +577,11 @@ context contains more than one Voice context.  Similarly, multiple
 Staff contexts can be put into a single Score context.  The Score
 context is the top level notation context.
 
-@seealso
 
+@seealso
 Internals Reference: @rinternals{Contexts}.
 
+
 @lilypond[quote,ragged-right]
 \include "engraver-example.ily"
 \score {
@@ -575,6 +596,9 @@ Internals Reference: @rinternals{Contexts}.
 @node Music representation
 @unnumberedsubsec Music representation
 
+@cindex syntax
+@cindex recursive structures
+
 Ideally, the input format for any high-level formatting system is
 an abstract description of the content.  In this case, that would
 be the music itself.  This poses a formidable problem: how can we
@@ -671,6 +695,9 @@ the source code.
 @node Example applications
 @unnumberedsubsec Example applications
 
+@cindex simple examples
+@cindex examples, simple
+
 We have written LilyPond as an experiment of how to condense the
 art of music engraving into a computer program.  Thanks to all
 that hard work, the program can now be used to perform useful
@@ -689,8 +716,12 @@ By adding chord names and lyrics we obtain a lead sheet.
 @lilypond[quote,ragged-right]
 <<
    \chords { c2 c f2 c }
-   \new Staff \relative c' { \time 2/4 c4 c g'4 g a4 a g2 }
-   \new Lyrics \lyricmode { twin4 kle twin kle lit tle star2 }
+   \new Staff
+   \relative c' {
+     \time 2/4
+     c4 c g' g a a g2
+   }
+   \addlyrics { twin -- kle twin -- kle lit -- tle star }
 @end lilypond
 
@@ -712,7 +743,7 @@ following example combines some more exotic constructs.
       << {
         \revert Stem #'direction
         \change Staff = down
-        \set subdivideBeams = ##t	     
+        \set subdivideBeams = ##t
         g16.[
           \change Staff = up
           c'''32
@@ -743,7 +774,7 @@ following example combines some more exotic constructs.
       \override Beam  #'thickness = #0.3
       \override Stem  #'thickness = #4.0
       g'16[ b16 fis16 g16]
-      << \makeClusters { 
+      << \makeClusters {
         as16 <as b>
         <g b>
         <g cis>
@@ -788,6 +819,13 @@ makes it easy to mix music and text in documents.
 
 This section explains the different portions of the documentation.
 
+@cindex Learning Manual
+@cindex Music Glossary
+@cindex Notation Reference
+@cindex Application Usage
+@cindex Snippet List
+@cindex Internals Reference
+
 @c leave these lines wrapping around.  It's some texinfo 4.12 thing. -gp
 @c This is actually a limitation of texi2html. -jm
 @menu
@@ -804,6 +842,8 @@ This section explains the different portions of the documentation.
 @node About the Learning Manual
 @unnumberedsubsec About the Learning Manual
 
+@cindex Learning Manual
+
 This book explains how to begin learning LilyPond, as well as
 explaining some key concepts in easy terms.  You should read these
 chapters in a linear fashion.
@@ -863,6 +903,7 @@ all.
 @node About the Music Glossary
 @unnumberedsubsec About the Music Glossary
 
+@cindex Music Glossary
 @cindex idiom
 @cindex jargon
 @cindex terminology
@@ -879,6 +920,11 @@ it is highly advisable to consult the glossary.
 @node About the Notation Reference
 @unnumberedsubsec About the Notation Reference
 
+@cindex Notation Reference
+@cindex appendices
+@cindex reference charts
+@cindex charts, reference
+
 This book explains all the LilyPond commands which produce
 notation.  It assumes that readers are familiar with the concepts
 in the Learning Manual.
@@ -951,6 +997,9 @@ a complete index.
 @node About the Application Usage
 @unnumberedsubsec About the Application Usage
 
+@cindex Application Usage
+@cindex integrating LilyPond with other programs
+
 This book explains how to execute the programs and how to integrate
 LilyPond notation with other programs.
 
@@ -992,6 +1041,8 @@ formats to the @code{.ly} format.
 
 @cindex snippets
 @cindex LSR
+@cindex Snippet List
+@cindex LilyPond Snippet Repository
 
 @rlsrnamed{Top,LilyPond Snippet List}: this shows a
 selected set of LilyPond snippets from the
@@ -1011,6 +1062,8 @@ also linked from the @strong{See also} portion.
 @node About the Internals Reference
 @unnumberedsubsec About the Internals Reference
 
+@cindex Internals Reference
+
 @rinternalsnamed{Top,Internals Reference}: this is a set
 of heavily cross linked HTML pages which document the nitty-gritty
 details of each and every LilyPond class, object, and function.