Subject: MAJ doc master

From: Jean-Charles <[email-masked]>
Date: Tue, 27 Feb 2007 14:10:38 +0100

Bonjour,

Petites mises à jour.

Petites questions en vrac concernant le script check-translation :

Pour éviter de faire ressortir les fichiers non encore traduits mais 
modifiés, j'ai vu dans /make/doclang-targets.make la ligne

find $(outdir) -name '*.html' | xargs grep -L 'UNTRANSLATED NODE: IGNORE ME'

Cependant Graham a remplacé bon nombre d'occurrences de "xx" par @q{xx} 
ou @amp{xx}. Ces fichiers sont cependant traités :

index 35cf314..bc92313 100644
--- a/Documentation/user/converters.itely
+++ b/Documentation/user/converters.itely
@@ -96,7 +96,7 @@ Show summary of usage.
  @item -k, --key=@var{acc}[:@var{minor}]
  Set default key.  @math{@var{acc} > 0} sets number of sharps;
  @math{@var{acc} < 0} sets number of flats.  A minor key is indicated by
-":1".
+@samp{:1}.

  @item -o, --output=@var{file}

Serait-il possible de les exclure du traitement, sauf en ce qui pourrait 
concerner une refonte du type ajout de noeud, section... comme  pour 
changing-defaults.itely

-* \set vs. \override::
+* Using Scheme code instead of \tweak::
+* \set vs. \override::

J'ai donc pour l'instant modifié le « committish » des fichiers /fr/ en 
cause.

@+
Jean-Charles
From 1c3004d6410c1c18b99c6ec47fc82835da22239a Mon Sep 17 00:00:00 2001
From: Jean-Charles <[email-masked]>
Date: Tue, 27 Feb 2007 13:26:05 +0100
Subject: [PATCH] French updates

---
 Documentation/fr/user/advanced-notation.itely     |    2 +-
 Documentation/fr/user/changing-defaults.itely     |   10 ++++++++--
 Documentation/fr/user/programming-interface.itely |    2 +-
 Documentation/fr/user/spacing.itely               |    2 +-
 Documentation/fr/user/templates.itely             |    2 +-
 Documentation/fr/user/tutorial.itely              |    2 +-
 Documentation/fr/user/tweaks.itely                |    2 +-
 Documentation/fr/user/working.itely               |    6 +++---
 8 files changed, 17 insertions(+), 11 deletions(-)

diff --git a/Documentation/fr/user/advanced-notation.itely b/Documentation/fr/user/advanced-notation.itely
index adec14d..20d1171 100644
--- a/Documentation/fr/user/advanced-notation.itely
+++ b/Documentation/fr/user/advanced-notation.itely
@@ -1,7 +1,7 @@
 @c -*- coding: utf-8; mode: texinfo; documentlanguage: fr -*-
 @c This file is part of lilypond.tely
 @ignore
-    Translation of GIT committish: d56aa8181857c5feabf303ae88e716eba069f0a9
+    Translation of GIT committish: 884968f3b77f345f327857f1df17e114adad877f

     When revising a translation, copy the HEAD committish of the
diff --git a/Documentation/fr/user/changing-defaults.itely b/Documentation/fr/user/changing-defaults.itely
index dc92c26..1bbf936 100644
--- a/Documentation/fr/user/changing-defaults.itely
+++ b/Documentation/fr/user/changing-defaults.itely
@@ -1,7 +1,7 @@
 @c -*- coding: utf-8; mode: texinfo; documentlanguage: fr -*-
 @c This file is part of lilypond.tely
 @ignore
-    Translation of GIT committish: d56aa8181857c5feabf303ae88e716eba069f0a9
+    Translation of GIT committish: 884968f3b77f345f327857f1df17e114adad877f

     When revising a translation, copy the HEAD committish of the
@@ -104,6 +104,7 @@ UNTRANSLATED NODE: IGNORE ME
 * Layout interfaces::
 * Determining the grob property::
 * Objects connected to the input::
+* Using Scheme code instead of \tweak:: 
 * \set vs. \override::
 * Difficult tweaks::
 @end menu 
@@ -132,8 +133,13 @@ UNTRANSLATED NODE: IGNORE ME
 
 UNTRANSLATED NODE: IGNORE ME
 
+@node Using Scheme code instead of \tweak
+@subsection Using Scheme code instead of @code{\tweak}
+
+UNTRANSLATED NODE: IGNORE ME
+
 @node \set vs. \override
-@subsection \set vs. \override
+@subsection @code{\set} vs. @code{\override}
 
 UNTRANSLATED NODE: IGNORE ME
 
diff --git a/Documentation/fr/user/programming-interface.itely b/Documentation/fr/user/programming-interface.itely
index 98f9e31..ad8103b 100644
--- a/Documentation/fr/user/programming-interface.itely
+++ b/Documentation/fr/user/programming-interface.itely
@@ -1,7 +1,7 @@
 @c -*- coding: utf-8; mode: texinfo; documentlanguage: fr -*-
 @c This file is part of lilypond.tely
 @ignore
-    Translation of GIT committish: d56aa8181857c5feabf303ae88e716eba069f0a9
+    Translation of GIT committish: 884968f3b77f345f327857f1df17e114adad877f

     When revising a translation, copy the HEAD committish of the
diff --git a/Documentation/fr/user/spacing.itely b/Documentation/fr/user/spacing.itely
index dff7d2b..6fb6ae2 100644
--- a/Documentation/fr/user/spacing.itely
+++ b/Documentation/fr/user/spacing.itely
@@ -1,7 +1,7 @@
 @c -*- coding: utf-8; mode: texinfo; documentlanguage: fr -*-
 @c This file is part of lilypond.tely
 @ignore
-    Translation of GIT committish: d56aa8181857c5feabf303ae88e716eba069f0a9
+    Translation of GIT committish: 884968f3b77f345f327857f1df17e114adad877f

     When revising a translation, copy the HEAD committish of the
diff --git a/Documentation/fr/user/templates.itely b/Documentation/fr/user/templates.itely
index 6098dc8..a9c50ea 100644
--- a/Documentation/fr/user/templates.itely
+++ b/Documentation/fr/user/templates.itely
@@ -1,7 +1,7 @@
 @c -*- coding: utf-8; mode: texinfo; documentlanguage: fr -*-
 @c This file is part of lilypond.tely
 @ignore
-    Translation of GIT committish: d56aa8181857c5feabf303ae88e716eba069f0a9
+    Translation of GIT committish: 884968f3b77f345f327857f1df17e114adad877f

     When revising a translation, copy the HEAD committish of the
diff --git a/Documentation/fr/user/tutorial.itely b/Documentation/fr/user/tutorial.itely
index 6141f36..2ad97cf 100644
--- a/Documentation/fr/user/tutorial.itely
+++ b/Documentation/fr/user/tutorial.itely
@@ -1,7 +1,7 @@
 @c -*- coding: utf-8; mode: texinfo; documentlanguage: fr -*-
 @c This file is part of lilypond.tely
 @ignore
-   Translation of GIT committish: b40f25ec7472b855483b5eb9126747bfb9487fe1
+   Translation of GIT committish: 884968f3b77f345f327857f1df17e114adad877f
 
    When revising a translation, copy the HEAD committish of the
    version that you are working on.  See TRANSLATION for details.
diff --git a/Documentation/fr/user/tweaks.itely b/Documentation/fr/user/tweaks.itely
index 50c2086..582f6d6 100644
--- a/Documentation/fr/user/tweaks.itely
+++ b/Documentation/fr/user/tweaks.itely
@@ -1,7 +1,7 @@
 @c -*- coding: utf-8; mode: texinfo; documentlanguage: fr -*-
 @c This file is part of lilypond.tely
 @ignore
-    Translation of GIT committish: d56aa8181857c5feabf303ae88e716eba069f0a9
+    Translation of GIT committish: 884968f3b77f345f327857f1df17e114adad877f

     When revising a translation, copy the HEAD committish of the
diff --git a/Documentation/fr/user/working.itely b/Documentation/fr/user/working.itely
index 6864acb..cf7f6bb 100644
--- a/Documentation/fr/user/working.itely
+++ b/Documentation/fr/user/working.itely
@@ -1,7 +1,7 @@
 @c -*- coding: utf-8; mode: texinfo; documentlanguage: fr -*-
 @c This file is part of lilypond.tely
 @ignore
-   Translation of GIT committish: b40f25ec7472b855483b5eb9126747bfb9487fe1
+   Translation of GIT committish: 884968f3b77f345f327857f1df17e114adad877f
 
    When revising a translation, copy the HEAD committish of the
    version that you are working on.  See TRANSLATION for details.
@@ -382,7 +382,7 @@ est peu visible, c'est pourquoi nous allons l'épaissir et le
 rapprocher des têtes de notes.  Déplaçons l'indication métronomique
 au-dessus de la clef, au lieu de la laisser au-dessus de la première
 note.  Et pour finir, mon professeur de composition déteste les
-chiffrages de mesure en "C", nous allons donc le transformer en "4/4".
+chiffrages de mesure en @q{C}, nous allons donc le transformer en @q{4/4}.
 
 Cependant, ne changez pas le fichier @file{musique.ly}.  Remplacez le
 fichier @file{definitions.ly} par ceci :
@@ -448,7 +448,7 @@ tempoMark = #(define-music-function (parser location markp) (string?)
 
 C'est encore mieux !  Mais supposons maintenant que je veuille publier
 cette pièce.  Mon professeur de composition n'aime pas les chiffrages
-de mesure en "C", mais moi je les aime bien.  Copions l'actuel
+de mesure en @q{C}, mais moi je les aime bien.  Copions l'actuel
 @file{definitions.ly} dans le fichier @file{publication-web.ly}, et
 modifions ce dernier.  Puisque la musique est destinée à produire un
 fichier PDF affiché sur écran, nous allons aussi augmenter la taille
-- 
1.5.0

---

From: John Mandereau <[email-masked]>
Date: Tue, 27 Feb 2007 23:47:47 +0100

Bonsoir Jean-Charles !

> find $(outdir) -name '*.html' | xargs grep -L 'UNTRANSLATED NODE: IGNORE ME'

La ligne que tu as vue concerne la création de liens
titi/tutu/toto.fr.html vers fr/titi/tutu/toto.html, afin d'intégrer les
traductions (le répertoire fr/ n'est pas examiné lors de la collecte des
fichiers dans <racine_sources>/out-www/{on/off}line-root)

> ou @amp{xx}.

C'est surtout Werner qui s'en est occupé.

>  Ces fichiers sont cependant traités :

> +* Using Scheme code instead of \tweak::

Il est possible de les exclure du traitement, mais je préfère que les
traducteurs reçoivent des fausses alertes plutôt qu'ils ratent des mises
à jour importantes telles que les changements de node et de section.

> J'ai donc pour l'instant modifié le « committish » des fichiers /fr/ en 

C'est inutile depuis le week-end dernier, j'ai fait un script qui met à
jour les squelettes .itely : à partir du répertoire Documentation,
essaye

    make ISOLANG=fr skeleton-update

C'est magique, non ? :-)

À part ça, je voulais vraiment traduire le pied de page de la
documentation pour 2.10.20 et 2.11.20, je croyais y être arrivé mais un
bogue s'est glissé quelque part au dernier moment :-(  En fait ça marche
quand je compile chez moi mais apparemment pas avec GUB.

-- 
John Mandereau <[email-masked]>

---

From: Jean-Charles <[email-masked]>
Date: Wed, 28 Feb 2007 22:09:12 +0100

Le 27.02.2007 23:47, John Mandereau disait :
>> [...]
Autrement dit, une forme de « copie/redirection » à l'usage du grand
créateur (make ou make-web)? Le fichier (source texinfo) qui a été
traduit et réside dans fr/titi/tutu/  sera compilé lors de la génération
de la documentation atterrira dans le « bouquin » avec un suffixe
supplémentaire (fr) à côté de son homologue en VO, sauf s'il contient le
« panneau indicateur » en question.

> C'est surtout Werner qui s'en est occupé.

J'avais zappé le fil...
>>  [...]
> Il est possible de les exclure du traitement, mais je préfèreque les

Tout à fait d'accord pour tout ce qui concerne le contenant ou sa
structure. Il est aussi vrai que ces /fausses/ alertes permettent de
se rendre compte que même une fois traduite, l'information originelle
n'est pas figée... C'est juste un peu gênant quand cela prend 200 lignes
d'emacs ; mais la parade existe :
étant donné que chaque fichier mouvementé apparaît sur deux lignes sous
la forme
   --- a/Documentation/user/basic-notation.itely
   +++ b/Documentation/user/basic-notation.itely

il suffit de rechercher l'occurrence suivante de « --- » en faisant
C-s --- pour aller au prochain fichier.

>     make ISOLANG=fr skeleton-update
Tout à fait remarquable, mais, je pense, à ne faire qu'en fin de
procédure de mise à jour.

> quand je compile chez moi mais apparemment pas avec GUB.

Je viens de tester, et le résultat est négatif pour 2.10.20 et en master.

Bon courage...

@+
Jean-Charles