Subject: test MAJ avec git

From: Jean-Charles <[email-masked]>
Date: Sat, 06 Jan 2007 22:55:59 +0100

Bonsoir à tous,

J'ai un peu joué avec ces « nouvelles manières ».
Le résultat me semble assez bon. Cela m'a pris pas mal de temps, dans la 
mesure où beaucoup de fichiers en VO ont été modifiés (apposition de " 
dans de nombreuses balises html). J'ai d'ailleurs remarqué que ceux-ci 
ne comportent pas de "commitish".

J'en ai profité pour résumer mes actions dans le « gitrux » joint, que 
je demande à John de bien vouloir commenter et corriger si besoin.

@+
Jean-Charles
====================
CRÉER UN DÉPOT LOCAL

mkdir dépôt ; cd dépôt 
git init-db
git fetch git://git.sv.gnu.org/soft.git/ branche:branche
    où branche:branche signifie 
       nom de la branche d'origine
       séparateur (:)
       nom de la copie locale de la branche
git checkout -b mabranche branche
    où mabranche représente un alias pour le travail personnel sur le
    dépôt local. De ce fait, je laisse la copie locale intacte.

======================================
METTRE À JOUR LA COPIE LOCALE DU DÉPÔT

git pull git://git.sv.gnu.org/soft.git/ branche:branche

=========================================
AJOUT D'UN FICHIER INEXISTANT JUSQU'ALORS

git add LE_FICHIER_NOUVEAU

=========================================
AU RAYON MAINTENANCE DU SITE LILYPOND.ORG

1- Je mets à jour ma copie locale du dépôt, afin de prendre en compte
les changements apportés par les collègues, avant de m'y coller.

git pull git://git.sv.gnu.org/lilypond.git/ web/master:web/master

2- Je vérifie que mes traductions déjà en ligne correspondent bien à
la version originale ; j'aime pas les films sous-titrés.

cd GIT/web/ ; emacs&
M-X compile
make LANG=fr check-translation
     => me détaille tout ce qui n'est pas synchrone, comme :

diff --git a/site/about/automated-engraving/input-format.html b/site/about/automated-engraving/input-format.html
index 3f314ef..4e6af1d 100644
--- a/site/about/automated-engraving/input-format.html
+++ b/site/about/automated-engraving/input-format.html
@@ -30,7 +30,7 @@ typable, e.g.,
   c'4 d'8
 </pre>
 Are a quarter note C1 and eighth note D1, as in this example:
-<p align=center>
+<p align="center">
 <img src="@[email-masked]">
 <p>

LE FICHIER /site/about/automated-engraving/input-format.html A ÉTÉ
MODIFIÉ À PARTIR DE LA LIGNE 30. À MOI DE METTRE À JOUR LE FICHIER
/fr/about/automated-engraving/input-format.html. 

JE L'OUVRE : 
   C-x C-f /fr/about/automated-engraving/input-format.html.

J'AFFICHE LES ACCENTS AU LIEU DES CODES HTML POUR MES YEUX :
   M-x html-accents

JE RECHERCHE UNE LIGNE VERS LA LIGNE 30 QUI CORRESPONDE À UNE VERSION
FRANÇAISE. C'EST LA 31 :
c'4 d'8
</pre>
sont un do noire et un ré croche, comme dans cet exemple&nbsp;:
</p>

J'APPORTE LA MODIFICATION : double quote là où il faut

J'ENCODE LES ACCENTS EN HTML AVANT DE SAUVEGARDER :
M-x accents-html
C-x C-s

J'OUVRE UNE CONSOLE ET GÉNÈRE LE NUMÉRO DE RÉVISION, QUE JE VAIS
RECOPIER DANS /fr/about/automated-engraving/input-format.html.

[jcharles@localhost web]$ git-rev-parse web/master
78aeb69f041a646876af8d863d34eeecf505f39b

JE COPIE LA LIGNE RETOURNÉE DANS LE "Scratch" D'EMACS SURTOUT
S'IL Y A PLUSIEURS FICHIERS MOUVEMENTÉS
ET J'ENREGISTRE LE FICHIER AVEC SON NUMÉRO DE RÉVISION :
  C-x C-s

ET LE FERME :
  C-x k

JE VÉRIFIE QUE PERSONNE N'EST PASSÉ ENTRE TEMPS :
   M-X compile
   make LANG=fr check-translation
QUI ME RENVOIE :

cd /home/jcharles/GIT/web/
make LANG=fr check-translation
python scripts/check-translation.py fr/about/automated-engraving/benchmarking.html fr/about/automated-engraving/conclusion.html fr/about/automated-engraving/divide-and-conquer.html fr/about/automated-engraving/engraving.html fr/about/automated-engraving/formatting-architecture.html fr/about/automated-engraving/implementing-notation.html fr/about/automated-engraving/implementing-typography.html fr/about/automated-engraving/index.html fr/about/automated-engraving/input-format.html fr/about/automated-engraving/introduction.html fr/about/automated-engraving/problem-statement.html fr/about/automated-engraving/schubert.html fr/about/automated-engraving/scoring-esthetics.html fr/about/automated-engraving/software.html fr/about/automated-engraving/typography-features.html fr/about/browser-language.html fr/about/faq.html fr/about/features.html fr/about/index.html fr/about/name.html fr/about/pubs.html fr/about/thanks.html fr/documentation.html fr/index.html fr/install/cygwin.html fr/install/getting-started.html fr/install/index.html fr/install/macos.html fr/install/using.html fr/sponsor/index.html fr/sponsor/natura.html fr/sponsor/options.html fr/switch/advantages.html fr/switch/howto.html fr/switch/index.html fr/switch/new-notation.html fr/switch/testimonials.html fr/switch/tour.html

Compilation finished at Sat Jan  6 22:17:34

JE CONSIDÈRE QUE C'EST BON.
   M-x git-status
   Select directory: ~/GIT/web/
QUI ME RENVOIE :
Directory:  ~/GIT/web/
Branch:     myweb
Head:       78d7ba7aa4

     Modified     fr/about/automated-engraving/benchmarking.html
     Modified     fr/about/automated-engraving/conclusion.html
     Modified     fr/about/automated-engraving/divide-and-conquer.html
     Modified     fr/about/automated-engraving/engraving.html
     Modified     fr/about/automated-engraving/formatting-architecture.html
     Modified     fr/about/automated-engraving/implementing-notation.html
     Modified     fr/about/automated-engraving/implementing-typography.html
     Modified     fr/about/automated-engraving/index.html
     Modified     fr/about/automated-engraving/input-format.html
     Modified     fr/about/automated-engraving/introduction.html
     Modified     fr/about/automated-engraving/problem-statement.html
     Modified     fr/about/automated-engraving/schubert.html
     Modified     fr/about/automated-engraving/scoring-esthetics.html
     Modified     fr/about/automated-engraving/software.html
     Modified     fr/about/automated-engraving/typography-features.html
     Modified     fr/about/features.html
     Modified     fr/about/name.html
     Modified     fr/about/thanks.html
     Modified     fr/install/getting-started.html
     Modified     fr/install/index.html
     Modified     fr/sponsor/index.html
     Modified     fr/sponsor/options.html
     Modified     fr/switch/howto.html

JE SOUMETS MES MODIFICATIONS PERSONNELLES ÀU DÉPÔT LOCAL :
DANS LA CONSOLE
  git-commit -m 'French updates' -a

PUIS GÉNÈRE LE PATCH
  git format-patch web/master

C'EST TOUT POUR AUJOURD'HUI
JE RÉDIGE MON MESSAGE À LINTENTION DE LA LISTE DEVEL.

From 78d7ba7aa4ede2957391ebcea5c65260f108fd25 Mon Sep 17 00:00:00 2001
From: Jean-Charles <jcharles@localhost.(none)>
Date: Sat, 6 Jan 2007 17:34:54 +0100
Subject: [PATCH] README typos

---
 README |   10 +++++-----
 1 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/README b/README
index a1d0c17..e72ef64 100644
--- a/README
+++ b/README
@@ -40,7 +40,7 @@ hexadecimal digits which acts as the internal unique identifier for
 this commit.
 
 This README tries to explain most of git commands needed for
-translationg the web site.  However, you are invited to read further
+translating the web site.  However, you are invited to read further
 documentation to make git more familiar to you; for instance, take a
 look at http://git.or.cz/gitwiki/, especially GitDocumentation
 (follow the links from this page) and GitGlossary.
@@ -154,7 +154,7 @@ translation.
 * TRANSLATION HINTS
 
 To translate a page, open the HTML source file with a plain text
-editor and translate all plain text, leaving markup and URLs in tact.
+editor and translate all plain text, leaving markup and URLs intact.
 Tracking changes is much easier, that way.
 
 The best choice for non-destructive editing of HTML source is probably
@@ -246,7 +246,7 @@ bar/baz.html.  Fix it and verify with
 
     git diff bar/baz.html
 
-that all is fine.  This command is also useful is there are too many
+that all is fine.  This command is also useful if there are too many
 changes and you want to see changes only for bar/baz.html.

@@ -289,7 +289,7 @@ present in the revision you worked from, plus all files you added),
 where changes can also mean that the file was removed.  (Still, the
 untracked files, and the ignored files, listed in .gitignore, are not
 concerned by the commit.)  If you prefer to commit files separately,
-do not use '-a', but give the files you want to commit as arguments.
+do not use '-a', but give the files you want to commit as argument.
 
 For example, if you want to commit a German translation update and
 there are no other changes in your working tree, do
@@ -366,7 +366,7 @@ check-translation doesn't falsely complain?
 
 First make the changes in the English pages (i.e. in site/) and commit
 them, then update translation for our language as usual, except
-that.if you have no Git push access, you have to wait that your
+that if you have no Git push access, you have to wait that your
 changes are committed before updating the committishes in translated
 files.
 
-- 
1.4.4.3

From 78c7d001093105d9eaad373a35c171b6de0a74f2 Mon Sep 17 00:00:00 2001
From: Jean-Charles <[email-masked]>
Date: Sat, 6 Jan 2007 22:39:24 +0100
Subject: [PATCH] French updates

---
 TRANSLATION                                        |    2 +-
 fr/about/automated-engraving/benchmarking.html     |   12 +--
 fr/about/automated-engraving/conclusion.html       |    2 +-
 .../automated-engraving/divide-and-conquer.html    |    2 +-
 fr/about/automated-engraving/engraving.html        |    2 +-
 .../formatting-architecture.html                   |    3 +-
 .../automated-engraving/implementing-notation.html |    2 +-
 .../implementing-typography.html                   |    2 +-
 fr/about/automated-engraving/index.html            |    8 +-
 fr/about/automated-engraving/input-format.html     |    3 +-
 fr/about/automated-engraving/introduction.html     |    2 +-
 .../automated-engraving/problem-statement.html     |    2 +-
 fr/about/automated-engraving/schubert.html         |    2 +-
 .../automated-engraving/scoring-esthetics.html     |    2 +-
 fr/about/automated-engraving/software.html         |    2 +-
 .../automated-engraving/typography-features.html   |    2 +-
 fr/about/features.html                             |   11 ++-
 fr/about/name.html                                 |    2 +-
 fr/about/thanks.html                               |    2 +-
 fr/install/getting-started.html                    |    8 +--
 fr/install/index.html                              |    8 +-
 fr/sponsor/index.html                              |    2 +-
 fr/sponsor/options.html                            |  110 ++++++++++++++-----
 fr/switch/howto.html                               |    2 +-
 24 files changed, 121 insertions(+), 74 deletions(-)

diff --git a/TRANSLATION b/TRANSLATION
index e884d07..6f430f0 100644
--- a/TRANSLATION
+++ b/TRANSLATION
@@ -48,7 +48,7 @@ Priorities:  1. delivery, 2. later, 3. optional, 4. not to be translated*)
     need a revision or should be removed before considering a
     translation.
 
-WORD COUNTS FOR CATEROGIES
+WORD COUNTS FOR CATEGORIES
 
 LANG=C wc --words $(grep ^1 TRANSLATION | cut -d ' ' -f 2 | sed 's@^@site/@')
   210 site/about/index.html
diff --git a/fr/about/automated-engraving/benchmarking.html b/fr/about/automated-engraving/benchmarking.html
index 1731bf1..37e4671 100644
--- a/fr/about/automated-engraving/benchmarking.html
+++ b/fr/about/automated-engraving/benchmarking.html
@@ -1,5 +1,5 @@
 <!--
-    Translation of GIT Committish: c72fd2fa225611379417a78fc8b1e537f1e6c9f0
+    Translation of GIT Committish: 78aeb69f041a646876af8d863d34eeecf505f39b
 
     When revising a translation, copy the HEAD committish of the
     version that you are working on.  Use
@@ -28,20 +28,14 @@ programme, en terme de qualit&eacute;, s'&eacute;tablissent par rapport &agrave;
 Voici des extraits compar&eacute;s d'une m&ecirc;me pi&egrave;ce. En haut l'&eacute;dition de
 r&eacute;f&eacute;rence (B&auml;renreiter BA 350), en bas ce que LilyPond 1.4 a
 g&eacute;n&eacute;r&eacute;&nbsp;:
-</p>
 
 <p align="center">
 <img src="@[email-masked]">
-</p>
-
 <p align="center">
 B&auml;renreiter
-</p>
 
 <p align="center">
 <img src="@[email-masked]">
-</p>
-
 <p align="center">
 LilyPond 1.4
 </p>
@@ -50,14 +44,12 @@ LilyPond 1.4
 La sortie LilyPond est certes lisible, et acceptable pour beaucoup de gens.
 Cependant, une comparaison minutieuse avec une &eacute;dition grav&eacute;e &agrave; la main
 r&eacute;v&egrave;le de nombreuses erreurs de formatage&nbsp;:
-</p>
 
 <p align="center">
 <img src="@[email-masked]">
+<p align="center">
 </p>
 
-<!--<p align="center">-->
-
 <ul>
 <li>De nombreux symboles &eacute;taient d&eacute;s&eacute;quilibr&eacute;s. Le trille en particulier
 &eacute;tait trop grand.</li>
diff --git a/fr/about/automated-engraving/conclusion.html b/fr/about/automated-engraving/conclusion.html
index 67c98df..ad4684e 100644
--- a/fr/about/automated-engraving/conclusion.html
+++ b/fr/about/automated-engraving/conclusion.html
@@ -1,5 +1,5 @@
 <!--
-    Translation of GIT Committish: c72fd2fa225611379417a78fc8b1e537f1e6c9f0
+    Translation of GIT Committish: 78aeb69f041a646876af8d863d34eeecf505f39b
 
     When revising a translation, copy the HEAD committish of the
     version that you are working on.  Use
diff --git a/fr/about/automated-engraving/divide-and-conquer.html b/fr/about/automated-engraving/divide-and-conquer.html
index 866e870..20c2063 100644
--- a/fr/about/automated-engraving/divide-and-conquer.html
+++ b/fr/about/automated-engraving/divide-and-conquer.html
@@ -1,5 +1,5 @@
 <!--
-    Translation of GIT Committish: c72fd2fa225611379417a78fc8b1e537f1e6c9f0
+    Translation of GIT Committish: 78aeb69f041a646876af8d863d34eeecf505f39b
 
     When revising a translation, copy the HEAD committish of the
     version that you are working on.  Use
diff --git a/fr/about/automated-engraving/engraving.html b/fr/about/automated-engraving/engraving.html
index 4fcdba2..147086f 100644
--- a/fr/about/automated-engraving/engraving.html
+++ b/fr/about/automated-engraving/engraving.html
@@ -1,5 +1,5 @@
 <!--
-    Translation of GIT Committish: c72fd2fa225611379417a78fc8b1e537f1e6c9f0
+    Translation of GIT Committish: 78aeb69f041a646876af8d863d34eeecf505f39b
 
     When revising a translation, copy the HEAD committish of the
     version that you are working on.  Use
diff --git a/fr/about/automated-engraving/formatting-architecture.html b/fr/about/automated-engraving/formatting-architecture.html
index 96d0c9d..2a1f6d9 100644
--- a/fr/about/automated-engraving/formatting-architecture.html
+++ b/fr/about/automated-engraving/formatting-architecture.html
@@ -1,5 +1,6 @@
 <!--
-    Translation of GIT Committish: c72fd2fa225611379417a78fc8b1e537f1e6c9f0
+    Translation of GIT Committish: 78aeb69f041a646876af8d863d34eeecf505f39b
+
 
     When revising a translation, copy the HEAD committish of the
     version that you are working on.  Use
diff --git a/fr/about/automated-engraving/implementing-notation.html b/fr/about/automated-engraving/implementing-notation.html
index 3906c0c..758421f 100644
--- a/fr/about/automated-engraving/implementing-notation.html
+++ b/fr/about/automated-engraving/implementing-notation.html
@@ -1,5 +1,5 @@
 <!--
-    Translation of GIT Committish: c72fd2fa225611379417a78fc8b1e537f1e6c9f0
+    Translation of GIT Committish: 78aeb69f041a646876af8d863d34eeecf505f39b
 
     When revising a translation, copy the HEAD committish of the
     version that you are working on.  Use
diff --git a/fr/about/automated-engraving/implementing-typography.html b/fr/about/automated-engraving/implementing-typography.html
index 624460a..b6b59ee 100644
--- a/fr/about/automated-engraving/implementing-typography.html
+++ b/fr/about/automated-engraving/implementing-typography.html
@@ -1,5 +1,5 @@
 <!--
-    Translation of GIT Committish: c72fd2fa225611379417a78fc8b1e537f1e6c9f0
+    Translation of GIT Committish: 78aeb69f041a646876af8d863d34eeecf505f39b
 
     When revising a translation, copy the HEAD committish of the
     version that you are working on.  Use
diff --git a/fr/about/automated-engraving/index.html b/fr/about/automated-engraving/index.html
index 4c08645..c146552 100644
--- a/fr/about/automated-engraving/index.html
+++ b/fr/about/automated-engraving/index.html
@@ -1,18 +1,18 @@
 <!--
-    Translation of GIT Committish: c72fd2fa225611379417a78fc8b1e537f1e6c9f0
+    Translation of GIT Committish: 78aeb69f041a646876af8d863d34eeecf505f39b
 
     When revising a translation, copy the HEAD committish of the
     version that you are working on.  Use
 
-      git-rev-list HEAD | head -1
+    git-rev-list HEAD | head -1
 
     to discover that.
 !-->

 <!-- hmm, the one big page is too big, but it was really inviting to
-    read.  this is not.  maybe just scrap this menu and introduction
-    to index?  !-->
+     read.  this is not.  maybe just scrap this menu and introduction
+     to index?  !-->
 
 <h1>&ldquo;L'obsession du papier encr&eacute;&rdquo;</h1>
 <a name="index"></a>
diff --git a/fr/about/automated-engraving/input-format.html b/fr/about/automated-engraving/input-format.html
index 33a2ecf..bdfd62a 100644
--- a/fr/about/automated-engraving/input-format.html
+++ b/fr/about/automated-engraving/input-format.html
@@ -1,5 +1,5 @@
 <!--
-    Translation of GIT Committish: c72fd2fa225611379417a78fc8b1e537f1e6c9f0
+    Translation of GIT Committish: 78aeb69f041a646876af8d863d34eeecf505f39b
 
     When revising a translation, copy the HEAD committish of the
     version that you are working on.  Use
@@ -31,7 +31,6 @@ puisqu'elle peut &ecirc;tre facilement tap&eacute;e au clavier&nbsp;:
   c'4 d'8
 </pre>
 sont un do noire et un r&eacute; croche, comme dans cet exemple&nbsp;:
-</p>
 
 <p align="center">
 <img src="@[email-masked]">
diff --git a/fr/about/automated-engraving/introduction.html b/fr/about/automated-engraving/introduction.html
index 9974df6..d42da72 100644
--- a/fr/about/automated-engraving/introduction.html
+++ b/fr/about/automated-engraving/introduction.html
@@ -1,5 +1,5 @@
 <!--
-    Translation of GIT Committish: c72fd2fa225611379417a78fc8b1e537f1e6c9f0
+    Translation of GIT Committish: 78aeb69f041a646876af8d863d34eeecf505f39b
 
     When revising a translation, copy the HEAD committish of the
     version that you are working on.  Use
diff --git a/fr/about/automated-engraving/problem-statement.html b/fr/about/automated-engraving/problem-statement.html
index 7aa0547..a95df49 100644
--- a/fr/about/automated-engraving/problem-statement.html
+++ b/fr/about/automated-engraving/problem-statement.html
@@ -1,5 +1,5 @@
 <!--
-    Translation of GIT Committish: c72fd2fa225611379417a78fc8b1e537f1e6c9f0
+    Translation of GIT Committish: 78aeb69f041a646876af8d863d34eeecf505f39b
 
     When revising a translation, copy the HEAD committish of the
     version that you are working on.  Use
diff --git a/fr/about/automated-engraving/schubert.html b/fr/about/automated-engraving/schubert.html
index 5ba949b..646d1b4 100644
--- a/fr/about/automated-engraving/schubert.html
+++ b/fr/about/automated-engraving/schubert.html
@@ -1,5 +1,5 @@
 <!--
-    Translation of GIT Committish: c72fd2fa225611379417a78fc8b1e537f1e6c9f0
+    Translation of GIT Committish: 78aeb69f041a646876af8d863d34eeecf505f39b
 
     When revising a translation, copy the HEAD committish of the
     version that you are working on.  Use
diff --git a/fr/about/automated-engraving/scoring-esthetics.html b/fr/about/automated-engraving/scoring-esthetics.html
index 998c46e..2aa4106 100644
--- a/fr/about/automated-engraving/scoring-esthetics.html
+++ b/fr/about/automated-engraving/scoring-esthetics.html
@@ -1,5 +1,5 @@
 <!--
-    Translation of GIT Committish: c72fd2fa225611379417a78fc8b1e537f1e6c9f0
+    Translation of GIT Committish: 78aeb69f041a646876af8d863d34eeecf505f39b
 
     When revising a translation, copy the HEAD committish of the
     version that you are working on.  Use
diff --git a/fr/about/automated-engraving/software.html b/fr/about/automated-engraving/software.html
index e6bbeda..9c9ef21 100644
--- a/fr/about/automated-engraving/software.html
+++ b/fr/about/automated-engraving/software.html
@@ -1,5 +1,5 @@
 <!--
-    Translation of GIT Committish: c72fd2fa225611379417a78fc8b1e537f1e6c9f0
+    Translation of GIT Committish: 78aeb69f041a646876af8d863d34eeecf505f39b
 
     When revising a translation, copy the HEAD committish of the
     version that you are working on.  Use
diff --git a/fr/about/automated-engraving/typography-features.html b/fr/about/automated-engraving/typography-features.html
index 17bbff1..33a28ce 100644
--- a/fr/about/automated-engraving/typography-features.html
+++ b/fr/about/automated-engraving/typography-features.html
@@ -1,5 +1,5 @@
 <!--
-    Translation of GIT Committish: c72fd2fa225611379417a78fc8b1e537f1e6c9f0
+    Translation of GIT Committish: 78aeb69f041a646876af8d863d34eeecf505f39b
 
     When revising a translation, copy the HEAD committish of the
     version that you are working on.  Use
diff --git a/fr/about/features.html b/fr/about/features.html
index f2af9f7..83ab21d 100644
--- a/fr/about/features.html
+++ b/fr/about/features.html
@@ -1,5 +1,5 @@
 <!--
-    Translation of GIT Committish: 1b01f2cbe54744b151da765163d4ffba842ee28e
+    Translation of GIT Committish: 78aeb69f041a646876af8d863d34eeecf505f39b
 
     When revising a translation, copy the HEAD committish of the
     version that you are working on.  Use
@@ -163,4 +163,13 @@ r&eacute;gression</a>.
     <a href="http://www.recordare.com/xml.html">Music XML</a>,
     <a href="http://nwc2ly.sourceforge.net">Noteworthy Composer</a>.
   </li>
+  <li>
+    &Eacute;diteurs comprenant un support pour LilyPond&nbsp;:
+     <a
+     href="http://git.sv.gnu.org/gitweb/?p=lilypond.git;a=tree;f=elisp">Emacs</a>
+     <a
+     href="http://git.sv.gnu.org/gitweb/?p=lilypond.git;a=tree;f=vim">Vim</a>,
+     <a href="http://www.jedit.org">JEdit</a>,
+     <a href="http://www.chris-lamb.co.uk/blog/2006/04/03/lilypond-and-latex-plugin-for-wordpress/">WordPress</a>.
+   </li>
 </ul>
diff --git a/fr/about/name.html b/fr/about/name.html
index b706647..ccec1c0 100644
--- a/fr/about/name.html
+++ b/fr/about/name.html
@@ -1,5 +1,5 @@
 <!--
-    Translation of GIT Committish: c72fd2fa225611379417a78fc8b1e537f1e6c9f0
+    Translation of GIT Committish: 78aeb69f041a646876af8d863d34eeecf505f39b
 
     When revising a translation, copy the HEAD committish of the
     version that you are working on.  Use
diff --git a/fr/about/thanks.html b/fr/about/thanks.html
index a399384..9c5fa9e 100644
--- a/fr/about/thanks.html
+++ b/fr/about/thanks.html
@@ -1,5 +1,5 @@
 <!--
-    Translation of GIT Committish: 370051a3935b18bd3f24173a13175ef5c92ec923
+    Translation of GIT Committish: 78aeb69f041a646876af8d863d34eeecf505f39b
 
     When revising a translation, copy the HEAD committish of the
     version that you are working on.  Use
diff --git a/fr/install/getting-started.html b/fr/install/getting-started.html
index a1bb035..982fa6e 100644
--- a/fr/install/getting-started.html
+++ b/fr/install/getting-started.html
@@ -1,5 +1,5 @@
 <!--
-    Translation of GIT Committish: c72fd2fa225611379417a78fc8b1e537f1e6c9f0
+    Translation of GIT Committish: 78aeb69f041a646876af8d863d34eeecf505f39b
 
     When revising a translation, copy the HEAD committish of the
     version that you are working on.  Use
@@ -72,11 +72,6 @@
 	}
       </pre>
     </blockquote>
-    
-    <strong>NOTE&nbsp;:</strong> Avec LilyPond 2.2 et pr&eacute;c&eacute;dents, encadrez
-    l'exemple ci-dessus avec les blocs
-    <code>\notes{}</code> <em>et</em> <code>\score{}</code>.
-    
   </li>
   <li>Enregistrez le fichier sous <tt>test.ly</tt>. Quittez l'&eacute;diteur.
   <li>Ex&eacute;cutez
@@ -89,7 +84,6 @@
     Si tout va bien, vous devriez voir
     <blockquote>
       <pre>
-	DVI output `test.dvi'...
 	PS output to `test.ps'...
 	PDF output to `test.pdf'...
       </pre>
diff --git a/fr/install/index.html b/fr/install/index.html
index 542a543..b569824 100644
--- a/fr/install/index.html
+++ b/fr/install/index.html
@@ -1,13 +1,13 @@
 <!--
-    Translation of GIT Committish: c72fd2fa225611379417a78fc8b1e537f1e6c9f0
+    Translation of GIT Committish: 78aeb69f041a646876af8d863d34eeecf505f39b
 
     When revising a translation, copy the HEAD committish of the
     version that you are working on.  Use
 
-      git-rev-list HEAD | head -1
+    git-rev-list HEAD | head -1
 
     to discover that.
-!-->
+    !-->
 
 <h1>Installer LilyPond</h1>
 
@@ -40,7 +40,7 @@
 </table>
 
 <h2>T&eacute;l&eacute;charger LilyPond 2.11 &mdash;
-branche de développement</h2>
+branche de d&eacute;veloppement</h2>
 
 <a name="2.11"></a>
 <table width="100%" border="0" rules="rows" cellpadding="3">
diff --git a/fr/sponsor/index.html b/fr/sponsor/index.html
index e8f6f5e..4c55af1 100644
--- a/fr/sponsor/index.html
+++ b/fr/sponsor/index.html
@@ -1,5 +1,5 @@
 <!--
-    Translation of GIT Committish: a04557829bbe3d4a2dbdf1ac2d56af89bf5bc0c5
+    Translation of GIT Committish: 78aeb69f041a646876af8d863d34eeecf505f39b
 
     When revising a translation, copy the HEAD committish of the
     version that you are working on.  Use
diff --git a/fr/sponsor/options.html b/fr/sponsor/options.html
index 9e40be0..88a3e61 100644
--- a/fr/sponsor/options.html
+++ b/fr/sponsor/options.html
@@ -1,10 +1,10 @@
 <!--
-    Translation of GIT Committish: a04557829bbe3d4a2dbdf1ac2d56af89bf5bc0c5
+    Translation of GIT Committish: 78aeb69f041a646876af8d863d34eeecf505f39b
 
     When revising a translation, copy the HEAD committish of the
     version that you are working on.  Use
 
-      git-rev-list HEAD | head -1
+    git-rev-list HEAD | head -1
 
     to discover that.
 !-->
@@ -42,8 +42,8 @@ style="padding-right: 8px;"><p>
  <h2>Vous avez trouv&eacute; un <em>bogue</em>&nbsp;?</h2>
   <a href="http://lilypond-design.com/">Demandez-nous</a> de le corriger&nbsp;!
 
-Notre exp&eacute;rience nous permet de corriger un bogue en quelques jours
-ou m&ecirc;me quelques heures. <a
+Notre exp&eacute;rience nous permet de corriger un bogue en quelques jours,
+voire m&ecirc;me quelques heures. <a
 href="http://lilypond-design.com/sponsor/">En savoir plus...</a> </div>
 
 <br><br>
@@ -55,40 +55,92 @@ href="http://lilypond-design.com/sponsor/">En savoir plus...</a> </div>

 <h2>
-Vous <em>appr&eacute;ciez LilyPond</em>&nbsp;?  </h2>
-
-Faites un don&nbsp;! Nous sugg&eacute;rons la somme de 25 euros.
-Vous pouvez l'envoyer par
-
-<blockquote>
-<form action="https://www.paypal.com/cgi-bin/webscr" method="post">
-<input type="hidden" name="cmd" value="_xclick"/>
-<input type="hidden" name="business" value="[email-masked]"/>
-<input type="hidden" name="item_name" value="LilyPond donation"/>
-<input type="hidden" name="currency_code" value="EUR">
-<input type="hidden" name="item_number" value="2006"/>
-<input type="image"
-src="http://images.paypal.com/images/x-click-but02.gif" name="submit" alt="Make payments with PayPal - it's fast, free and secure!"/>
-</form>
-</blockquote>
- &agrave;
-<blockquote>
-<tt>[email-masked]</tt>
-</blockquote>
+LilyPond repose <em>principalement</em> sur les &eacute;paules de b&eacute;n&eacute;voles
+acharn&eacute;s&nbsp;!</h2>
+
+<p>
+Depuis sa gen&egrave;se et jusqu'&agrave; fin 2005, LilyPond reposait &agrave; 100&nbsp;%
+sur le b&eacute;n&eacute;volat. Jan et Han-Wen ont alors calcul&eacute; avoir fourni &agrave; eux
+seuls l'&eacute;quivalent de neuf ann&eacute;es de travail depuis qu'ils s'&eacute;taient
+lanc&eacute;s dans le d&eacute;veloppement de LilyPond en octobre 1996. Ceci sans
+tenir compte la participation de <a
+href="@DOC@latest/Documentation/topdocs/AUTHORS.html">nombreux
+contributeurs</a>, certains depuis le tout d&eacute;but.
+</p>
+
+<p>
+En 2005--2006, Han-Wen s'est consacr&eacute; aux demandes de fonctionnalit&eacute;s 
+sponsoris&eacute;es. Cette p&eacute;riode a <a
+href="http://lilypond.org/vc/gub.darcs">r&eacute;volutionn&eacute;</a> le <a
+href="@[email-masked]/Documentation/topdocs/NEWS.html">d&eacute;veloppement</a> de
+LilyPond. Elle a aussi r&eacute;v&eacute;l&eacute; qu'il &eacute;tait encore trop t&ocirc;t pour fonder
+une entreprise ayant pour objet le d&eacute;veloppement de LilyPond.
+</p>
+
+<p>
+Ainsi, LilyPond est tout d'abord un projet d'amateurs, dans le bon
+sens du terme : il est fait avec passion.
+</p>
+
+<div style="overflow: auto">
+ 
+<h2>LilyPond reste un projet des <em>plus</em> </em> professionels&nbsp;!</h2>
+
+<p>
+Alors que la p&eacute;riode de sponsorisation des fonctionnalit&eacute;s touche &agrave; sa 
+fin, le rythme du d&eacute;veloppement va naturellement se ralentir.
 
-<em>Ne nous envoyez pas de ch&egrave;ques&nbsp;: leur encaissement nous co&ucirc;te environ
-25 euros.</em>
+Han-Wen et Jan ont tous deux un emploi de programmeur. Han-Wen
+travaille &agrave; temps complet pour Google, et le temps partiel de Jan chez
+Atos Origin ne lui laisse qu'un jour par semaine &agrave; consacrer &agrave;
+LilyPond.
+</p>
+
+<p>
+Cependant le caract&egrave;re professionnel ne se substitue pas &agrave; la qualit&eacute;.
+Comme le dit Han-Wen, <blockquote>
+ Lily est de loin le projet le plus <em>professionnel</em> sur lequel
+ j'ai travaill&eacute; au cours de ma carri&egrave;re de programmeur informatique,
+ en terme d'envergure et de qualit&eacute;.
+</blockquote>
+</p>
+<div style="overflow: auto">
+<img src="@IMAGES@/cello-blonde-flickr-sillygwailo.jpeg" align="right" width="300">
+ 
+<h2>Vous <em>appr&eacute;ciez LilyPond</em>&nbsp;?</h2>
+
+Faites un don&nbsp;! Nous sugg&eacute;rons la somme de 25 euros. Vous pouvez l'envoyer par 
+ <blockquote>
+    <form action="https://www.paypal.com/cgi-bin/webscr" method="post">
+      <input type="hidden" name="cmd" value="_xclick"/>
+      <input type="hidden" name="business" value="[email-masked]"/>
+      <input type="hidden" name="item_name" value="LilyPond donation"/>
+      <input type="hidden" name="currency_code" value="EUR">
+      <input type="hidden" name="item_number" value="2006"/>
+      <input type="image"
+	     src="http://images.paypal.com/images/x-click-but02.gif"
+ name="submit" alt="Make payments with PayPal - it's fast, free and secure!"/>
+    </form>
+  </blockquote>
+  &agrave;
+  <blockquote>
+    <tt>[email-masked]</tt>
+  </blockquote>
+ 
+ 
+<em>Ne nous envoyez pas de ch&egrave;ques&nbsp;: leur encaissement nous co&ucirc;te
+environ 25 euros.</em>.
 
 </div>
 
 <p align="right">
 &laquo;&nbsp;Mais <a href="natura.html">je suis vraiment pauvre</a>&nbsp;&raquo;
+</p>
 
 <br><br>
 
-
-
-<em><font size="-1"> Cr&eacute;dits images&nbsp;: outils&nbsp;: <a
+<em>
+<font size="-1"> Cr&eacute;dits images&nbsp;: outils&nbsp;: <a
 href="http://www.flickr.com/photos/sus/">.susanne</a> (flickr.com), visage
 &agrave; l'insecte&nbsp;: <a href="http://openphoto.net/user/profile.html?user_id=973">Jan
 Teunis</a> (openphoto.net), violoncelliste&nbsp;: <a
diff --git a/fr/switch/howto.html b/fr/switch/howto.html
index 83a9c71..a5f5f0c 100644
--- a/fr/switch/howto.html
+++ b/fr/switch/howto.html
@@ -1,5 +1,5 @@
 <!--
-    Translation of GIT Committish: c72fd2fa225611379417a78fc8b1e537f1e6c9f0
+    Translation of GIT Committish: 78aeb69f041a646876af8d863d34eeecf505f39b
 
     When revising a translation, copy the HEAD committish of the
     version that you are working on.  Use
-- 
1.4.4.3

---

From: John Mandereau <[email-masked]>
Date: Sun, 07 Jan 2007 01:06:35 +0100

> ne comportent pas de "commitish".

Apparemment, "make check-translation" donnait beaucoup de fausses
alertes, par l'exemple dans les pages de l'essai.

> je demande à John de bien vouloir commenter et corriger si besoin.

Je n'ai rien à rajouter. Ce document serait très utile aux autres
traducteurs, une fois traduit en anglais et mis sur
http://lilypondwiki.tuxfamily.org ; le README est déjà assez chargé, je
ne veux pas ajouter des instructions aussi détaillées, qui aboutiraient
à un README de 2000 lignes. Ceal n'empêche pas que tes instructions
détaillées ont un grand intérêt, notamment pour initier à Emacs.

Au sujet de la mise à jour des traductions, as-tu remarqué ligne 52 dans
site/sponsor/options.html :

<!-- DRAFT: do not translate !-->

???

Ce n'est pas grave, maintenant que c'est fait on ne va pas l'enlever :-)

Bravo pour ce travail conséquent et d'une grande propreté technique !

J'ai appliqué tous tes patches, fait les toutes dernières mises à jour
de traduction et aussi quelques corrections dans sponsor/options. Tu me
diras ce que tu en penses.. pour cela (je crois que c'est dans le
README) mets à jour les sources avec git-pull, puis reagrde avec
"git-log -p" ou gitk mes modifications.

Bonne nuit ;-)
-- 
John Mandereau <[email-masked]>