Subject: Re: tuplets brackets

From: Ludovic Sardain <[email-masked]>
Date: Thu, 5 Jan 2006 15:07:20 +0100

I send you an example of what I tried. I use lilypond 2.7.8:

\version "2.7.8"

global = {

	\key f \minor

	\time 4/4
	\set tupletSpannerDuration = #(ly:make-moment 1 4)
	\override TupletBracket  #'bracket-visibility = #'if-no-beam

}

pianoDroite = \relative c'' {
	\global
	\times 2/3 {<g c ees g>8\p c, des ees f fis g a b c d dis-.} |
}

pianoGauche = \relative c {
	\global
	\clef bass
	<g g'>4 <ees' g c>8. <ees g c>16 <d g b>4 r |
}

\score {<<
		\context PianoStaff = "piano" <<
			\context Staff = upper \pianoDroite
			\context Staff = lower \pianoGauche

}

2006/1/5, Mats Bengtsson <[email-masked]>:
> Clearly it works in the Regressions test example you refer to, so if you
> need
> more help I recommend you to send a (small but complete) example of what
> you tried yourself, to the mailing list. Also, tell what LilyPond
> version you use.
>
>    /Mats
>
> Ludovic Sardain wrote:
>
> >Hello,
> >
> >I'd like to remove the tuplets brackets on a score, and I just don't
> >find in the documentation nor in the list's archives how to do that. I
> >thought that I found something in the page
> >http://www.lilypond.org/doc/v2.6/input/regression/collated-files.html
> >but the command "\override TupletBracket  #'bracket-visibility =
> >#'if-no-beam" does'nt seem to work.
> >Thanks for helping me
> >
> >Ludovic
> >
> >
> >_______________________________________________
> >lilypond-user mailing list
> >[email-masked]
> >http://lists.gnu.org/mailman/listinfo/lilypond-user
> >
> >
>
> --
> =============================================
>         Mats Bengtsson
>         Signal Processing
>         Signals, Sensors and Systems
>         Royal Institute of Technology
>         SE-100 44  STOCKHOLM
>         Sweden
>         Phone: (+46) 8 790 8463
>         Fax:   (+46) 8 790 7260
>         Email: [email-masked]
>         WWW: http://www.s3.kth.se/~mabe
> =============================================
>
>

---

From: Ludovic Sardain <[email-masked]>
Date: Thu, 5 Jan 2006 16:25:15 +0100

Thank you very much. I now use the version 2.7.19, and it works.

Thanks again

Ludovic

2006/1/5, Mats Bengtsson <[email-masked]>:
> Your example works well with the latest stable version, 2.6.5,
> maybe it's a bug in your particular version.
>
> Actually, the default seems to be that the brackets are not printed
> when there is a beam of the same lenght as the triplet, so in your
> example you get exactly the same result also without this setting.
> The if-no-beam setting only differs from the default layout if you
> for example beam 6 triplets together.
>
>   /Mats
>
> Ludovic Sardain wrote:
>